UnityMedia 150MBit PC optimieren

FreYtag

Ensign
Registriert
Sep. 2011
Beiträge
235
Hallo!
Ich bräucht mal nen Tipp von jemandem der auch Kabel mit 150Mbit nutzt.
Und zwar bekomme ich auf meinem iMac wunderbar die gebuchte 150er Geschwindigkeit.

An meinem PC aber "nur" etwa 108 Mbit.
Ich hab auf dem PC den tcpoptimizer von Speedguide laufen lassen mit den unten stehenden Änderungen.
Leider bekomme ich auf keinem PC die Leistung die ich am iMac habe.
Alle Geräte hängen am selben Switch=>Router mit identischen Cat6 Kabeln.
Daher nehme ich an, dass Windows irgendwo ne Bremse hat.
Auf der TCP Analyzer-Seite von Speedguide bekomme ich u.a. folgenden Hinweis:

Default TCP Receive Window (RWIN) = 65700
RWIN Scaling (RFC1323) = 2 bits (scale factor: 2^2=4)
Unscaled TCP Receive Window = 16425

In Windows 7, unless "TCP/IP Auto-Tuning" is disabled, only the Current TCP Window is displayed. Use the latest TCP Optimizer for tweaking.
RWIN is not fully optimized. The unscaled RWIN value is lower than it should be. Also, RWIN being close to and above 65535 does not justify the header overhead of enabling TCP 1323 Options. You might want to use one of the recommended RWIN values below.


Nun, den TCPOptimizer hab ich mit der Einstellung "optimal" benutzt. Nur schaltet der nicht das auto tuning aus. In dem Tool kann man soweit ich sehen kann auch nirgendwo den Wert für RWIN anpassen.

Hat jemand nen Rat?


[netsh]
TCP Window Auto-Tuning=3
Congestion Control Provider=0
TCP Chimney Offload=1
Receive-Side Scaling State=1
EnableDCA=1
EnableTCPA=1
ECN Capability=2
Windows Scaling heuristics=2
[SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
DefaultTTL=64
Tcp1323Opts=1
DisableTaskOffload=0
DisableTaskOffload_SEL=0
SynAttackProtect=1
SynAttackProtect_SEL=1
TCPMaxDataRetransmissions=7
MaxUserPort=65534
TcpTimedWaitDelay=30
[SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_MAXCONNECTIONSPERSERVER]
explorer.exe=8
[SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_MAXCONNECTIONSPER1_0SERVER]
explorer.exe=8
[SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider]
LocalPriority=4
HostsPriority=5
DnsPriority=6
NetbtPriority=7
[SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
LargeSystemCache=1
LargeSystemCache_SEL=1
[SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
Size=2
Size_SEL=2
[SOFTWARE\Policies\Microsoft\Windows\Psched]
NonBestEffortLimit=0
[SYSTEM\CurrentControlSet\Services\Dnscache\Parameters]
NegativeCacheTime=0
NetFailureCacheTime=0
NegativeSOACacheTime=0
[SOFTWARE\Microsoft\MSMQ\Parameters]
TCPNoDelay=-1
TCPNoDelay_SEL=0
[SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile]
NetworkThrottlingIndex=-1
NetworkThrottlingIndex_SEL=0
[LAN-Verbindung]
MTU=1500
[SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{AECF4196-57F5-40F5-9EE8-B2D35B0DFF83}]
TcpAckFrequency=-1
TcpAckFrequency_SEL=0
TcpDelAckTicks=-1
TcpDelAckTicks_SEL=0
 
wie sieht denn deine pc hardware aus? welchen router verwendest du?
 
Ist ein I7 3770K, Netzwerkkarte is ne Intel Pro 1000GT und Router ist ein Asus Black Knight.
Hab mittlerweile rausgefunden, dass bei Win7 RWIN vollkommen Wurscht ist, das Win7 das nicht mehr nutzt. Frag ich mich aber immernoch, wieso Win7 langsamer ist als Mac.
Hab auch mal nen Speedtest mit ner Linux Live CD gemacht, das war sogar etwas über 150Mbit.
Hat Win7 hier generell ein Problem?
 
Das hatte ich auch mal...
mein MBP hatte keine Probleme, aber mein PC... irgendwo hatte ich gelesen, dass es auch auf den Arbeitsspeicher ankommt?

Sonst würde ich auch Firewall / Virenscanner sagen. Oder schau mal in den Eigenschaften deiner Netzwerkkarte rein und schau mal ob da auch Full Duplex 1GB steht :)
 
Probier mal die Onboardkarte..

1000GT ist ne PCI-Netzwerkkarte, das weißt du schon, oder? Reintheroetisch müsste sie ja LOCKER ausreichen, aber wer weiß was Intel da gemacht hat bei Windows 7 und den Treibern. Es gibt ja nichtmal neuere zum Downloaden bei Intel http://downloadcenter.intel.com/
 
Zurück
Oben