Windows priorisiert aktive Spiele über andere Apps

Quafi

Ensign
Dabei seit
Apr. 2017
Beiträge
197
Hallo beisammen,
nun wollte ich gestern gemütlich mit OBS Studio streamen, jedoch war die Performance eine Katastrophe.
Offensichtlich priorisiert Windows das Spiel über andere Software wie OBS (früher war es noch andersherum, da konnte OBS laufen und das Spiel bekam, was übrig blieb).

Hier ein Post aus dem OBS-Forum (Englisch):
The Problem (frames missed due to rendering lag)
Over the past several months there have been many posts about people with low FPS in OBS despite their in-game FPS being fine. The reason? Most people will tell you to "you're using too much GPU usage, cap your FPS to allow OBS to render the scene".

The "solution" above is a huge problem; It is very common for a game to vary in frame rate depending on where/what you are doing in the game. This makes it extremely difficult to find a point where you are not intruding on OBS' GPU needs, but have the quality and FPS you want.

Example
A game runs at an average of 120 FPS using my graphics card. So I cap my FPS at around 90 to make sure I leave enough leeway for OBS to function.

Problem #1: I'm missing out on frames that I would have been getting in areas/things with lower GPU rendering needs. I would have exceeded 90 FPS during these times.

I enter an area/do something where my frame rate drops to 75 from the 90 I capped it at; the GPU needed power for graphics (rendering polygons, draw distance etc.) instead of producing frames.

Problem #2: My 90 FPS cap to make sure I'm not inferring with OBS GPU needs is now void. I have went over the XX% limit I left for OBS to use and my stream/recording has now dropped frames. I either need to cap it even lower, or turn my graphics down.

As you can see, at this point I could even be considering capping at 60 FPS, for a game that could run at 120+ FPS at times. This is simply unacceptable.

The Fix
Well, for us who have actually been using OBS for a while know this wasn't always the case. You used to be able to run your game at an uncapped FPS with whatever graphics you want; just like you would if you were playing without OBS running.

OBS used to take the power it needs BEFORE the game took what it needs. OBS would stay locked at 60FPS (as long as your PC was good enough for 60) and the rest of your GPU's power was allocated to the game. You didn't have to worry about limiting your GPU usage!

So now for a solution I've found. It's not one I'm happy with but IF you are having this problem, it applies to you.

OBS does not function as intended with Windows 10. I have tried locking myself to pre-creators update Windows 10 and using old versions of OBS – the issue was still there. This said, Windows 10 used to function as intended with OBS, so the cause is still unknown.

I have since switched to Windows 7 and everything is fine. I can fire up a game I've never played before on stream and not have to worry about tweaking everything to perfection to make sure my own, and my viewers experience is smooth. I can use 100% of my GPU and guess what? OBS stays at a rock solid 60 FPS, just like it should.

Please, if you see anyone with this issue do not tell them to just "cap ur fps ur using too much GPU xD". This isn't how it's supposed to be. This a major issue and everyone is refusing to acknowledge it. If you are experiencing this, please raise awareness. This is not a feature. It is a bug.
Und aus schierer Verzweiflung versuche ich es auch hier im Forum nochmal, hat irgendjemand irgendeine Idee, wie sich dieses Problem beheben lässt? Ich habe sehr viel Geld in mein Streaming-Setup investiert und kann es derzeit schlichtweg nicht verwenden.
 

BFF

Admiral
Dabei seit
Okt. 2017
Beiträge
9.852
Hi,

Gaming Mode von W10 aktiv?

Microsoft is adding a “Game Mode” to Windows 10 that'll optimize the system for playing video games. ... When a system goes into Game Mode, it'll “prioritize CPU and GPU resources to your game,” according to a video Microsoft released today. The mode's goal is supposed to be improving each game's frame rate.

BFF
 

Quafi

Ensign
Ersteller dieses Themas
Dabei seit
Apr. 2017
Beiträge
197
Jap, der schalter wurde in den neueren Windows-Versionen entfernt. Es lässt sich jetzt nur noch durch die Registry oder Ingame (de)aktivieren.
1545842933379.png
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.647
Ich habe den aktuellsten Win 10 1809 Build (17763.195) und der Schalter ist da. Ohne Änderungen in der Registy. Keine Updateinstallation, eine frische 1809 Installation.
 

JimPanse1984

Commander
Dabei seit
Jan. 2008
Beiträge
2.679
Bei mir ist er auch da (Upgrade von 8.1 von vor 3 Jahren) Allerdings die PRO Version. Nutzt du die HOME Version? Ggf. wie bei den Update Einstellungen, eine Restriktion seitens Microsoft bei Home, dies dort nicht ändern zu "dürfen".
 

Quafi

Ensign
Ersteller dieses Themas
Dabei seit
Apr. 2017
Beiträge
197
Nein, ich nutze ebenfalls Windows 10 Pro Version 10.0.17134 Build 17134.
Aber wie dem auch sei, daran liegt's ja nicht.
 

Quafi

Ensign
Ersteller dieses Themas
Dabei seit
Apr. 2017
Beiträge
197
Tritt meineswissens übrigens nur bei verwendung von NVIDIA-GPUs auf, ich konnte nirgends beschwerden bei AMD-GPUs finden.
 

petepow

Lieutenant
Dabei seit
Sep. 2017
Beiträge
516
Problem ist auch mit AMD Grafikkarten da. Zumindest hat letzte Woche meine Freundin Green Hell gespielt und wollte es auch streamen, musste deswegen die FPS cappen, da sonst der Stream bzw. OBS, sobald die Graka auf 100% war, gestockt hat.
 

Quafi

Ensign
Ersteller dieses Themas
Dabei seit
Apr. 2017
Beiträge
197
Okay. Dann wird es wohl keinen Sinn haben, sich bei NVIDIA zu melden. Ich bin inzwischen verzweifelt genug, den Microsoftsupport anrufen zu wollen, obwohl ich weiß, dass der bei so etwas für gewöhnlich nicht hilfreich ist.

Weißt du zufällig die Version ihres OS?
 

petepow

Lieutenant
Dabei seit
Sep. 2017
Beiträge
516
Win 10 Pro 1803

Ich habe mich damit noch nicht soviel beschäftigt aber schon mal mit Streamlabs OBS probiert oder ist das wirklich ein 100%iger fehler von Windows?
 

petepow

Lieutenant
Dabei seit
Sep. 2017
Beiträge
516
Ok, dann ist es wirklich blöd.
 
Top