esata unter Asus P5W DH deluxe

T

telex

Gast
ich hab eine e-sata Festplatte an meinem PC , Board ist das Asus P5W DH deluxe.
Unter Win 7 32 bit wird die Platte sofort im Gerätemanager gelistet wenn ich sie einschalte unter Win 10 64 bit wird sie erst "gesehen" wenn ich im Gerätemanager nach neuer Hardware suche. Wie bekomme ich das geändert?
 
T

telex

Gast
wo finde ich die namen?
Ergänzung ()

ich glaub in Win 10 nur die von Microsoft und Intel Chipsatz, in Win 7 eventuell Asus Sata Treiber.
Aber für Win 10 64 bit finde ich keine asus sata Treiber...
 

octo124

Lt. Commander
Dabei seit
Aug. 2005
Beiträge
1.398
Bei dir muss eine Ordnung vom Feinsten herrschen, da du ja das Handbuch nicht findest.
Auf Seite 1-6 steht oben der Chip, der eSATA ansteuert. Ob der von W10 jedesmal durch Standardtreiber ersetzt wird, kann dir der Gerätemanager bei markiertem Gerät - Eigenschaften in einem der zig Reiter angezeigen.
Ob ein Asus-64bit-Vista-Treiber von W10 akzeptiert wird, musst du durch Feldversuche unter Zuhilfenahme des I-Netz klären, wo es dann evt. W8-Treiber dafür geben könnte.

Z.Z. gibt das Handbuch inkl. Treiber im kostenlosen Ausverkauf bei Asus.
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.987
Schließe die HDD an so das sie angezeigt wird und poste dann mal den Screenshot von Drive Controller Info.
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.987
Die HDD hängt an einem Port der im IDE Modus läuft, aber Hot-Plug ist gewöhnlich nur im AHCI Modus möglich. Das Board hat eine ICH7R, die R sollte AHCI unterstützen, die Frage ist eher ob das BIOS eine Option hat dies freizuschalten. An was für einem Controller hängt die SSD? Die läuft im AHCI Modus und das optische Laufwerk auch, wenn Du eSATA über eine Slotblende von einem der Ports realisierst, könnte es gehen.
 

Madnex

Vice Admiral
Dabei seit
März 2004
Beiträge
6.625
Der eSATA-Port wird bei diesem Mainboard über einen JMicron-SATA-Controller gesteuert.

@telex
Schau mal im BIOS unter "Advanced -> Onboard Devices Configuration" und ändere die Einstellung bei "JMicron Controller Mode" auf AHCI. Dann könnte es auch unter Windows 10 funktionieren. Der proprietäre Treiber von JMicron stellt wohl auch im IDE aka Basic Mode das Hot-Plug-Feature zur Verfügung, wofür eigentlich der AHCI-Modus benötigt wird.
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.987
Dann müsste der proprietäre Treiber von JMicron aber installiert sein, verwendet wird aber der PCIIDE von Windows.
 
T

telex

Gast
also Madnex, unter Win7 läuft das alles also kanns doch nicht am Bios liegen?


Der eSATA-Port wird bei diesem Mainboard über einen JMicron-SATA-Controller gesteuert.

@telex
Schau mal im BIOS unter "Advanced -> Onboard Devices Configuration" und ändere die Einstellung bei "JMicron Controller Mode" auf AHCI. Dann könnte es auch unter Windows 10 funktionieren. Der proprietäre Treiber von JMicron stellt wohl auch im IDE aka Basic Mode das Hot-Plug-Feature zur Verfügung, wofür eigentlich der AHCI-Modus benötigt wird.
Ergänzung ()

wenn ich das mache werden nur noch wenige Platten erkannt und im Gerätemanager unter SATA herrscht Chaos



Der eSATA-Port wird bei diesem Mainboard über einen JMicron-SATA-Controller gesteuert.

@telex
Schau mal im BIOS unter "Advanced -> Onboard Devices Configuration" und ändere die Einstellung bei "JMicron Controller Mode" auf AHCI. Dann könnte es auch unter Windows 10 funktionieren. Der proprietäre Treiber von JMicron stellt wohl auch im IDE aka Basic Mode das Hot-Plug-Feature zur Verfügung, wofür eigentlich der AHCI-Modus benötigt wird.
 

Anhänge

Madnex

Vice Admiral
Dabei seit
März 2004
Beiträge
6.625
Unter Windows 7 hast du wahrscheinlich den proprietären SATA-Treiber von JMicron installiert (ein Screenshot vom DriveControllerInfo-Tool unter Windows 7 würde Klarheit schaffen), der wohl auch im IDE aka Basic Modus das Hot-Plugging-Feature unterstützt. Diesen Treiber gibt es anscheinend für Windows 10 nicht, weshalb der Standard-IDE-Treiber von Microsoft zum Einsatz kommt. Hot-Plugging wird von den Standard-Treibern aber nur im AHCI-Modus unterstützt, weshalb das bei dir unter Windows 10 nicht funktioniert.

Von daher die Idee auf den AHCI-Modus umzuschalten, wodurch der Standard-AHCI-Treiber benutzt werden müsste, der Hot-Plugging unterstützt. Wenn du nun auf den AHCI-Modus im BIOS umgeschaltet hast und nun unter Windows 10 keine Festplatten, die an diesem Controller angeschlossen sind, erkannt werden, so wird das vermutlich kein spezifikationskonformer AHCI-Modus sein, wodurch der Standard-AHCI-Treiber nicht kompatibel sein könnte.

Was meinst du mit "im Gerätemanager unter SATA herrscht Chaos". Mach doch bitte auch davon mal einen Screenshot.
 

Madnex

Vice Admiral
Dabei seit
März 2004
Beiträge
6.625
Ok. Wie vermutet ist der "AHCI"-Mode des JMicron-SATA-Controllers kein echter und somit nicht kompatibel zum Standard-AHCI-Treiber von Windows (das ist ein Universal-AHCI-Treiber). Unter Windows 7 ist der proprietäre Treiber von JMicron installiert. Du könntest nun versuchen diesen Treiber auch unter Windows 10 zu installieren. Das kann funktionieren, muss es aber nicht.

Alternativ könntest du dir eine eSATA-Slot-Blende kaufen und an einen Port des Intel-SATA-Controllers anschließen. Aber auch hier ist es ungewiss, ob es mit dem eSATA-Betrieb reibungslos funktioniert. Denn bei dieser Hardware-Generation war im BIOS noch fest eingestellt, ob es sich um interne oder externe SATA-Ports handelt. Dementsprechend behandelt der Treiber diese. Bei aktueller Hardware kann man das im BIOS für jeden einzelnen Port einstellen.
 
T

telex

Gast
Ich weiß nur nicht mit welchem JMicron Treiber ich es unter Win10 versuchen soll? Vista? Win7 ?
 

octo124

Lt. Commander
Dabei seit
Aug. 2005
Beiträge
1.398
Welcher Treiber x ist bei neuesten BS der optimalste? - Der, der relativ zeitnah zum aktuellen BS als letzter vom Hersteller bereitgestellt wurde.
Hier die Serie zu JJMicron:
ftp://driver.jmicron.com.tw/SATA_Controller/Windows/ReleaseNote.txt
Ergo in deinem Fall Brieftauben zum Onkel Google schicken ala "JMicron JMB36X" o.ä. und 64bit gibt es mindestens ab Version 1.17.62 + zig Threads u.a. hier bei CB.
Rückschluss wäre, wenn es in Version x einen 64bit gibt, wird irgendwo im Netz selbige Version zu 32bit geben.

Gerade bei älterer Hardware (bin auch kein Freund von ständig Neukaufen) ist jeder gut beraten, sich die letzten aktuellen Treiber extern unbedingt in den gewünschten Versionen zu sichern. Denn auch im Netz verschwindet irgendwann gerade das Gesuchte.
Und da hat selbst dein W7 mit zig gelben Ausrufezeichen seine Probleme = da ist Nacharbeit angesagt. Selbe in W10 (auch wenn hier evt. weniger Gelbes zu sehen ist), da ein WHQL-Treiber des Herstellers optimaler sein könnte als der von W10 "empfohlene" per Auto-Update-Treiber.
In W10 sind Treiber "Microsoft Windows" Standardtreiber von MS, während " ....Hardware combatibility" jeweils vom Hersteller sind.
 
Top