extreme auslastung nach langer laufzeit

tmp

Ensign
Dabei seit
Feb. 2004
Beiträge
253
hallöchen!

und zwar habe ich einen wg-server (gentoo) mit mldonkey am laufen.
zwischendurch werden darauf auch mp3's abgespielt. nach einem monat laufzeit ist das system allerdings recht tot. d.h. es dauert alles eine ewigkeit.woran liegt das?

kann ich diesem problem irgendwie abhilfe verschaffen? :)
 

aki

#!/bin/bash
Teammitglied
Dabei seit
Feb. 2002
Beiträge
3.397
Hast du mal mit "top" nachgeschaut ob eventuell ein Programm die CPU komplett in Anspruch nimmt oder den RAM belegt?
Wie sieht es mit Updates aus?



*edit*
Neustart? Das ist nicht Windows :freaky:
 

tmp

Ensign
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
253
Code:
top - 22:02:13 up 3 days,  5:53,  3 users,  load average: 0.42, 0.14, 0.03
Tasks:  84 total,   3 running,  81 sleeping,   0 stopped,   0 zombie
Cpu(s): 12.2% us,  2.4% sy,  0.0% ni, 82.9% id,  0.0% wa,  2.4% hi,  0.0% si
Mem:    125212k total,   122880k used,     2332k free,      744k buffers
Swap:   506036k total,   127104k used,   378932k free,    33724k cached

  PID  PPID    TIME+  %CPU %MEM  PR  NI S  VIRT SWAP  RES  UID COMMAND
 6255  6209 100:06.66 12.4 49.9  15   0 R 73224  10m  61m 1000 mlnet
 8055  8041   0:16.74  0.0  4.0  16   0 S 47720  41m 4984 1000 firefox-bin
 8059  8055   0:00.01  0.0  4.0  16   0 R 47720  41m 4984 1000 firefox-bin
 8060  8059   0:00.04  0.0  4.0  16   0 S 47720  41m 4984 1000 firefox-bin
 8062  8059   0:00.04  0.0  4.0  16   0 S 47720  41m 4984 1000 firefox-bin
 8077  8059   0:00.00  0.0  4.0  16   0 S 47720  41m 4984 1000 firefox-bin
 6172     1   0:10.84  0.0  3.2  16   0 S 31000  26m 3984 1000 nautilus
 6177  6172   0:00.14  0.0  3.2  16   0 S 31000  26m 3984 1000 nautilus
 6178  6177   0:00.00  0.0  3.2  15   0 S 31000  26m 3984 1000 nautilus
 6189  6177   0:00.01  0.0  3.2  16   0 S 31000  26m 3984 1000 nautilus
 6190  6177   0:00.03  0.0  3.2  16   0 S 31000  26m 3984 1000 nautilus
 6191  6177   0:00.07  0.0  3.2  16   0 S 31000  26m 3984 1000 nautilus
10985  6446   0:30.55  0.0  1.9  16   0 S  7620 5240 2380    0 smbd
 6070  6065   0:44.63  0.0  1.6  15   0 S 30268  27m 2004    0 X
 6186     1   0:02.76  0.0  1.6  15   0 S 19976  17m 1992 1000 clock-applet
11108 11102   0:00.00  0.0  1.6  15   0 S  6172 4228 1944 1000 sshd
 6176     1   0:09.70  0.0  1.5  16   0 S 19376  17m 1844 1000 wnck-applet
11102  5870   0:00.06  0.0  1.5  16   0 S  6172 4332 1840    0 sshd
 6257     1   0:23.38  0.0  1.3  15   0 S 33660  31m 1656 1000 xmms
 6258  6257   0:00.12  0.0  1.3  16   0 S 33660  31m 1656 1000 xmms
 6259  6258   0:00.88  0.0  1.3  15   0 S 33660  31m 1656 1000 xmms
 6260  6258   0:00.12  0.0  1.3  15   0 S 33660  31m 1656 1000 xmms
 6168     1   0:04.48  0.0  1.2  16   0 S 13196  11m 1528 1000 metacity
11109 11108   0:00.03  0.0  1.2  16   0 S  2788 1324 1464 1000 bash
 6170     1   0:01.96  0.0  0.9  15   0 S 20360  18m 1184 1000 gnome-panel
 6109     1   0:03.14  0.0  0.9  16   0 S 11068 9988 1080 1000 gconfd-2
 6188     1   0:02.98  0.0  0.8  15   0 S 19768  18m 1064 1000 mixer_applet2
11114 11109   0:00.04  4.9  0.7  15   0 R  1804  872  932 1000 top
 6448     1   0:05.16  0.0  0.6  16   0 S  3988 3280  708    0 nmbd
 6207     1   0:02.59  0.0  0.5  15   0 S 25044  23m  688 1000 gnome-terminal
 6210  6207   0:00.03  0.0  0.5  16   0 S 25044  23m  688 1000 gnome-terminal
 6211  6210   0:00.00  0.0  0.5  20   0 S 25044  23m  688 1000 gnome-terminal
 6119     1   0:01.42  0.0  0.5  16   0 S 20040  18m  672 1000 gnome-settings-
 6141     1   0:01.03  0.0  0.5  16   0 S  3784 3200  584 1000 xscreensaver
 5293     1   0:04.18  0.0  0.4  16   0 S  2700 2236  464 1000 famd
wie zu erwarten nimmt mlnet viel speicher in anspruch. momentan läuft der rechner aber auch erst 1 woche. aber auch ein mldonkey neustart hat das problem nicht gelöst. erst nach einem neustart war der rechner wieder schnell unterwegs ;)
 
Dabei seit
Feb. 2005
Beiträge
518
eventuell ma ein wenig ram nachrüsten,
mldonkey is das ein edonkey-client, die sin nämlich immer nach ner zeit sehr systembremsend.
 

Michael

Re-aktions-Pinguin
Dabei seit
Okt. 2002
Beiträge
3.210
Am einfachsten ist, du richtest Dir einen Cron-Job ein, der mlnet regelmäßig (einmal pro Woche) stoppt und wieder startet.
Ich hatte das Problem füher auch, irgendwann bekam meine Distro (Ubuntu) aber eine fehlerfreie Version von mldonkey-server spendiert, die über /etc/init.d auch tatsächlich funktioniert. mlnet braucht seitdem kaum mehr Speicher als 35MB im Dauerlauf 24/7.
Das Problem ist bekannt, aber ich habe bisher nirgendwo eine bessere Lösung als diese Cron-Job-Lösung gesehen.
 

tmp

Ensign
Ersteller dieses Themas
Dabei seit
Feb. 2004
Beiträge
253
ok dann werde ich das jetzt wohl so machen müssen ;)

besten dank nochmal
 
Top