Hardware sicher entfernen wird trotz deaktiviertem Hot Plug angezeigt

I

INHUMAN94

Gast
Moin,

hab folgendes "Problem". Hab hier das Asrock H61M U3S3 mit nem i5 2400. Habe Windows 10 Pro 64bit im AHCI Modus installiert. Alles läuft einwandfrei. Nur wird mir in der Statusleiste durchgehend "Hardware sicher entfernen und Medium auswerfen" angezeigt. Es ist nur eine Samsung 750 Evo 250GB SSD verbaut. In den BIOS Optionen ist Hot Plug für diese Festplatte deaktiviert. Dennoch wird mir diese Meldung angezeigt. Den Intel Rapid Storage Treiber von der Asrock Homepage habe ich schon versucht zu installieren doch Windows meldet mir das bereits ein neuerer installiert sei.

Jemand eine Idee wie ich diese los werde? Ist zwar offensichtlich nicht dramatisch nervt mich dennoch...

Grüße
 
Auf mein Asrock musste ich nen Beta Bios drauf hauen damit der misst verschwindet.


Hast auf dein Board die aktuelle Bios version drauf? 2.40
 
Versuch mal den "Intel Rapid Storage Technologie ( Intel RST)" Treiber zu installieren. Danach sollte das verschwinden!
 
Jop habe das aktuellste BIOS 2.4 drauf. Den Intel Rapid Storage Treiber hab ich schon versucht zu installieren aber er meldet mir dauernd das es mit meiner Hardware nicht kompatibel ist...

@xvaranx habe nur eine SSD in diesem PC verbaut.

Werde das System jetzt einfach nochmal komplett Clean installen und dann hoffen das diese Meldung verschwindet. Weil eigentlich dürfte sie ja nicht mehr vorhanden sein wenn Hot Plug deaktiviert ist :/

So nach nem Clean Install ist die Meldung zum Glück verschwunden. Waren wohl noch Treiberreste oder k.A. was noch drauf. somit Problem gelöst :)
 
Zuletzt bearbeitet von einem Moderator:
Entweder stellt man im BIOS/UEFI den entsprechenden Port von Extern auf Intern um, wenn es so eine Einstellung gibt oder man sagt Windows über die Registry, dass diese Port intern sind. Das ging zumindest bei Windows 7 mit folgendem Befehl, wobei man da die Nummern bei Port und Channel entsprechend anpassen muss:
Code:
reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
Seit Win8 heißt der Windows AHCI Treiber nun nicht mehr msahci sondern storahci, also müsste es wohl so sein:
Code:
reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\storahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
Wobei ich aber nicht weiß, ob das nicht geht.

Das Board hat zwei Controller, wenn kein eSATA genutzt wird, dann könntest Du alle denkbaren Kombinationen probieren, also für Controller0 und Controller1 und von Channel0 bis Channel3.

PS: Hier die Anleitung von Microsoft, für Windows 8 und höher geht es anderes als ich gedacht hatte, es musst dort sein:
Code:
reg.exe add “HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device” /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x
Was für das x am Ende des Befehls einzutragen ist und wie man die Nummern für Controller und Channel ermittelt, steht in der Anleitung.
 
Zuletzt bearbeitet:
An welchem Sata Port hast du die Evo angeschlossen? Die beiden weißen unterstützen laut http://www.asrock.com/mb/Intel/H61MU3S3/ kein IRS, ergo muss die Platte an einen der blauen Anschlüsse.

Edit: Schon gut, hab übersehen, dass das Problem bereits gelöst ist... :)
 
Zurück
Oben