Laptop verschwindet manchmal aus Netzwerk

petzi

Lt. Commander
Registriert
Jan. 2018
Beiträge
1.252
Hallo!

Klassiker: Ein Laptop (Win 10 Pro 1909, Netzname "L5") taucht zeitweise im Netzwerk nicht mehr auf.
Die Sichtbarkeit (von allen anderen Rechnern aus) ist seit einiger Zeit eigentlich kaum mehr gegeben, die Ansprechbarkeit per Link ist manchmal gegeben.

Soweit ich es als Laie sagen kann, habe ich alles hier lesbare geprüft und versucht:
  1. "L5" ist im selben (privaten, ansonsten funktionierenden) Netzwerk wie alle Kisten
  2. "ping 10.0.0.5" funzt immer
  3. "\\L5" funzt nur bei der Hälfte aller Versuche
  4. Netzwerk/Dateifreigabe auf "L5" ist ok
  5. Einzelne Ordner auf korrekte Freigabe geprüft, einige nochmals für "Jeder" vergeben
  6. Diese Funktionssuche ... Dienste habe ich auf Automatisch gestellt
Es ist ein A1 Router "Modem A1 WLAN Box ADB VV2220" und die Website des Geräts zeigt den sturen Laptop auch als verbunden an.

Was kann ich noch tun?

PS: Bitte keine Tipps wie "setz die Kiste neu auf". Das muss auch anders gehen. Oder?
 
Vermute mal, das Problem ist die Namensauflösung. Kannst du bitte screenshots der Eigenschaften IPv4 & Erweiterten TCP/IP Einstellungen (Alle Reiter) vom Netzwerkadapter machen ?
 
Binde den Laptop/Ordner als Netzwerklaufwerk mit ip Adresse ein um problemlos zugreifen zu können. Die Windows netzwerkanzeige ist und war nie der Börner und Inkontinent.
DNS kannst du mit Ipconfig flush/renew erneuern.
 
Turian schrieb:
screenshots der Eigenschaften IPv4 & Erweiterten TCP/IP Einstellungen
Hoffe ich habe das richtige erwischt

tcp0-1.JPG



tcp2-3.JPG

Ergänzung ()

chrigu schrieb:
als Netzwerklaufwerk mit ip Adresse ein
Leider geht das grade nicht. Weder per Namen noch per IP kommt eine Verbindung zustande.
(während ich aber grade (per Win-Explorer Link) mit der Kiste verbunden bin!)
 
Naja Du hast Dir die Antwort eigentlich im Eingangspost schon selbst gegeben: Per IP gehts immer, per DNS nicht. Der Router wird die Verbindung per IP prüfen und somit stimmt die Anzeige auch.
Liegt also an einem Problem mit der Namensauflösung; die Windows Netzwerkanzeige taugt nicht soviel wie schon geschrieben wurde.

Würde drum einfach - sofern der Router das kann - ein Static DHCP Eintrag für den Client machen damit er immer die gleiche interne IP hat und dann per IP verbinden. Alternativ eine fixe IP am Client direkt festlegen, drauf achten dass die ausserhalb vom DHCP Bereich liegt da einige Router zu blöd sind das vorher zu prüfen (und es ist technisch nicht sauber sonst).
Das Problem selber wird vermutlich beim Router selber liegen da der die "Hauptansprechsperson für DNS Fragen" in deinem Netzwerk ist, da wäre sicherlich zu prüfen ob die neueste Firmware drauf ist und das Ding sicherlich auch mal stromlosmachen (für 10 Sekunden) und dann neustarten lassen.
 
Eventuell NetBios mal explizit aktivieren, auch bei einem anderen Gerät zum testen.
DNS-Cache leeren kann auch helfen unter Umständen.
Bekommt das Gerät wieder die selbe IP oder öfters eine andere zugewiesen ?
 
Lawnmower schrieb:
hast Dir die Antwort eigentlich im Eingangspost schon selbst gegeben
Ich? Ich blicke nicht durch.

Lawnmower schrieb:
die Windows Netzwerkanzeige taugt nicht soviel wie schon gesagt wurde
Ja oder "Inkontinent" wie es @chrigu so treffend sagte ...

Lawnmower schrieb:
ein Static DHCP Eintrag für den Client machen
Versuche ich ... dauert aber (Kiste wird dauernd verwendet)

Router Neustart, ja wäre auch eine Idee. Nur auch das geht erst später.
Ergänzung ()

Turian schrieb:
NetBios mal explizit aktivieren
DNS-Cache leeren
? Wie ?

Turian schrieb:
selbe IP oder öfters eine andere zugewiesen ?
Bin nicht sicher, aber ich glaube das war schon immer die 10.0.0.5

Nur hatte ich die Tage einen neuen Laptop hier, natürlich auch im Netz - und kürzlich kam ein Netzwerkdrucker dazu. Das funzt(e) auch alles. Aber evt. hat das was durcheinandergebracht.
 
Geht der Laptop ggf. in einen Standby oder ähnliches sodass er beim Zugriff erst aufwachen muss?

Den Static DHCP Eintrag sollst am Router konfigurieren, nicht am Laptop.

Netbios ist in 2021 nun wirklich nicht mehr nötig wenn nicht mit Museumsreifer Software gearbeitet werden muss oder soll.

DNS Cache leeren: CMD öffnen und 'ipconfig /flushdns'
 
  • Gefällt mir
Reaktionen: Raijin
snaxilian schrieb:
Nein, alle Verbindungsversuche mache ich natürlich wenn der munter ist.

snaxilian schrieb:
Den Static DHCP Eintrag sollst am Router konfigurieren, nicht am Laptop.
Das ist völlig klar. Nur wie weiß ich grad nicht, werde es aber herausfinden

Evtl. unter
Home > Einstellungen > DHCP Server und Relay > Statische Adressen Konfiguration > Neue Statische Adresse ... usw. ?

Aber dann muss ich alles auf statische IP Vergabe umstellen?
Oder kann man auch nur dem einen Laptop eine statische geben?
Wenn ja, was soll ich eingeben?
Der fragt nach MAC Adresse? IP Adresse?

snaxilian schrieb:
Ok, geht aber alles erst später ...

Danke!
 
Nutzt du pihole oder einen anderen DNS-basierten Werbeblocker?

Wenn die Namensauflösung sporadisch nicht funktioniert, kann das auf die Verwendung von primären und sekundären DNS hindeuten. Beispielsweise wenn als primärer DNS der Router verwendet wird, als sekundärer aber zB 8.8.8.8 oder ein falsch konfigurierter pihole. Dasselbe gilt, wenn primär und sekundär vertauscht ist, weil beide in einem recht komplexen Prozess auch quasi-parallel genutzt werden.
In solchen Fällen kann es passieren, dass sporadisch der sekundäre DNS gefragt wird, weil der primäre zu lange für eine Antwort gebraucht hat. Nu hat google oder ein falsch konfigurierter pihole aber keine Ahnung von deinem Netzwerk, es kennt schlicht und ergreifend keinerlei lokale Namen, weiß nicht wie dein Laptop im Netzwerk heißt und welche lokale IP-Adresse dieser hat.


Mach an dem fraglichen Laptop bitte mal folgendes:

Start --> cmd --> ipconfig /all

Überprüfe hier den Abschnitt der aktiven Netzwerkverbindung, also da wo die IP 10.0.0.5 auftaucht. Dort nach dem/den konfigurierten DNS suchen. Steht da nur eine IP-Adresse beim DNS, nämlich die IP-Adresse des Routers, ist das ok. Stehen dort mehrere IPs, kann es zu obiger Situation führen.


petzi schrieb:
Klassiker: Ein Laptop (Win 10 Pro 1909, Netzname "L5") taucht zeitweise im Netzwerk nicht mehr auf.
Auch zu diesem Klassiker möchte ich noch etwas schreiben, nämlich den nächsten Klassiker:

Wenn du hiermit auf die Windows-Funktion "Netzwerkumgebung" ansprichst, also die Auflistung vermeintlich aller Netzwerkgeräte innerhalb des Explorers, möchte ich dazu sagen, dass diese Funktion schon seit Windows XP nicht einwandfrei funktioniert. Nicht zwangsläufig nur Microsofts Schuld, aber diese Anzeige ist einfach nur überflüssig. Es ist vollkommen egal ob Windows im Explorer Geräte anzeigt oder nicht, solange die IP-Adresse erreichbar ist, ist auch die Netzwerkverbindung in Ordnung. Namensauflösung erfolgt heutzutage via DNS und genau da scheint aktuell dein Problem zu liegen.

Fazit: Mach dir keinen Kopf darum ob der Windows-Explorer deinen Laptop anzeigt oder nicht. Ignoriere diese Funktion vollständig und du hast weniger Sorgen.
 
  • Gefällt mir
Reaktionen: snaxilian
Raijin schrieb:
Nutzt du pihole oder einen anderen DNS-basierten Werbeblocker?
? ... ne

Raijin schrieb:
Start --> cmd --> ipconfig /all
Wie gesagt, ich darf erst später (vmtl. spätabends oder nachts) an die Kiste oder an den Router - jetzt würde ich von Chefin schimpfen bekommen, wenn ich was "herumpfusche".

Raijin schrieb:
Stehen dort mehrere IPs, kann es zu obiger Situation führen
Meinst sowas wie ein IP Adressenkonflikt?

Den hatte ich irgendwann mal angezeigt bekommen, sehr lange her, wo noch alles Win 7 (und alles perfekt) war. Ja, mit Win 7 kamen solche Meldungen, aber jedes Gerät (inkl. Handys, TV, Firestick ...) alles spielte bestens zusammen.

Raijin schrieb:
Fazit: Mach dir keinen Kopf darum ob der Windows-Explorer deinen Laptop anzeigt oder nicht. Ignoriere diese Funktion vollständig und du hast weniger Sorgen.
Verstehe: Wenn ich die Kisten per Link (oder wenn es denn mal wieder ginge, per Netzlaufwerk) erreiche: Ok.

Es ist aber so angewöhnt: Bevor ich irgendwas im Netzwerk kopieren, verschieben usw. will - schau ich, ob eh noch da sind ...
Du meinst, ich soll mir die Kasperlfrage "Seid ihr alle da?" schenken?
Ergänzung ()

fixedwater schrieb:
Leicht Offtopic: Die Version ist übrigens am 11.5. aus dem Update-Support rausgefallen...
Ja ... keine Ahnung warum da nicht wenigstens was mit 20H2 oder so steht ...

Updates sind an ...
 
petzi schrieb:
Meinst sowas wie ein IP Adressenkonflikt?
Nein. Es können ja durchaus mehrere DNS verwendet werden, also primär und sekundär. WENN man das tut, muss aber gewährleistet sein, dass im Zweifelsfalle beide dasselbe Ergebnis liefern! Stell dir zwei konfigurierte DNS wie zwei verschiedene Telefonbücher vor und du suchst vereinfacht ausgedrückt mal im ersten und mal im zweiten nach einer Telefonnummer. Sind das identische Telefonbücher, kein Problem, du wirst immer die richtige Nummer finden. Bei verschiedenen Telefonbüchern wirst du aber Probleme bekommen, die richtige Nummer zu finden, wenn diese nun mal nur in dem einen Telefonbuch drinsteht.

08/15-Einstellung für DNS ist daher im Heimnetzwerk stets die IP-Adresse des Routers und sonst keine weitere.


petzi schrieb:
Du meinst, ich soll mir die Kasperlfrage "Seid ihr alle da?" schenken?
Jein. Zumindest der Blick in die Geräte-Liste ist überflüssig. Wie gesagt, das funktioniert eh nicht zuverlässig bzw. kann durch diverse Einstellungen von Netbios bis hin zur Firewall der jeweiligen Geräte beeinflusst und eben auch behindert werden. Das bedeutet aber nicht, dass man den Explorer generell nicht mehr nutzen sollte. Der zuverlässigere Weg wären Netzlaufwerke.

Du wirst ja sicherlich nicht nach dem Zufallsprinzip mal hier oder mal da auf Freigaben zugreifen, sondern hast bestimmt, dass zB Musik und Videos da und da liegen. Nun kann man Windows im Explorer sagen, dass zB Laufwerk X: stets auf \\L5\Musik zeigt und Laufwerk Y: auf \\L123\Videos. Alternativ natürlich auch \\10.0.0.5\Musik, wenn die Probleme mit der Namensauflösung bestehen bleiben.
So hast du im Explorer neben deinen lokalen Laufwerken wie der System-Partition, Datenplatte, etc. noch zwei weitere Laufwerke, die mit einem anderen Symbol gekennzeichnet werden und nicht lokal, sondern eben auf einem einem anderen Computer liegen.

Google dazu mal die Stichworte "Netzlaufwerk Windows 10"
 
wenn nicht mit Museumsreifer Software gearbeitet werden muss oder soll.
Netzwerkumgebung könnte da schon reinpassen ;)
Welche Sicherheitslösung nutzt du ? Eventuell mag die die Anfragen der anderen Clients nicht.
Versionsupdates musst du unter Umständen nochmal manuell starten, einfach mal prüfen.
 
Raijin schrieb:
Der zuverlässigere Weg wären Netzlaufwerke
Ja, gerne ich mag diese Methode eh - genauso wie eine schnelle Verknüpfung

Nur funzt aktuell wieder nichts davon. Weder per Name noch per IP.
Und alle das umstellen kann ich erst in der Nacht, wenn chefin weg ist ...
Ergänzung ()

Turian schrieb:
Sicherheitslösung
Nur den Defender!

Turian schrieb:
Versionsupdates ... nochmal manuell starten
Wie?
Kann ja nur immer wieder auf Updates gehen und gucken. Wenn nichts da ist ...
 
Ping auf die IP von L5, Ping auf "L5" & nslookup "L5" bringen welche Ergebnisse wenn es gerade nicht klappt ?
//L5 war das Gerät, richtig?

Edit: Bzgl. Updates, ansonsten auf Microsoft.com den Update Assistant suchen & herunterladen. Eventuell wird dein aber auch nicht mehr Unterstützt ?
 
petzi schrieb:
Nur funzt aktuell wieder nichts davon. Weder per Name noch per IP.
Huch? Das ist aber eine neue Information. Bisher ging ich davon aus, dass es per IP immer geht, wie du ja in #1 auch geschrieben hast:
petzi schrieb:
"ping 10.0.0.5" funzt immer

Ok, das bezieht sich in dem Fall auf ping, aber es ist eher unwahrscheinlich, dass der Ping immer geht, während SMB/CIFS (das ist die Freigabe) nur sporadisch funktioniert.


Man muss eben klar trennen:

  • Netzwerkverbindungen werden IMMER mit IP-Adressen und NIE mit Namen hergestellt
  • Namen werden VOR der Verbindung via DNS in die dazugehörige IP-Adresse UMGEWANDELT
  • Das, was allgemein als Ping bezeichnet wird, ist ein Paket im ICMP Protokoll, nämlich ICMP Echo Request
  • Das, was allgemein als Netzlaufwerk/Freigabe bezeichnet wird, ist das SMB bzw. CIFS Protokoll


Wenn nun die Namensauflösung gestört ist, sei es durch doppelte Namen im Netzwerk, fehlerhaft konfiguriertes DNS oder gar Fehler im DHCP, sollte es jedoch stets trotzdem über die IP-Adresse klappen. Klappt dies nicht, ist es wiederum ein anderes Problem. Der Unterschied zwischen Ping und Netzlaufwerk/Freigabe ist wie gesagt das Protokoll. Dieses kann beispielsweise in der Firewall des Zielgeräts geblockt werden. Allerdings wäre das dann immer der Fall, weil die Firewall den eingestellten Regeln folgt.


Um jetzt mal auf einen gemeinsamen Nenner zu kommen, bitte mal folgende Kommandos eingeben:

Start --> cmd
--> ping hier.der.name.von.L5
--> ping hier.die.IP.von.L5
--> nslookup hier.der.name.von.L5
--> nslookup hier.der.name.von.L5 hier.die.IP.vom.Router
--> net use x: \\hier.der.name.von.L5\eineFreigabe
--> net use y: \\hier.die.IP.von.L5\eineFreigabe

Ergebnisse am besten als Screenshots posten.
 
  • Gefällt mir
Reaktionen: alphatau
Raijin schrieb:
Huch? Das ist aber eine neue Information. Bisher ging ich davon aus, dass es per IP immer geht, wie du ja in #1 auch geschrieben hast:
Sorry.
Also per
CMD "ping 10.0.0.5" kommen keine Fehler, das geht immer

Aber im Win-Explorer (egal ob manuell eingetippt oder per Verknüpfung aufgerufen) geht es selten, aber doch per "\\L5" oder auch per "\\10.0.0.5"
Aber eben nur zeitweise ... Meist kommt der Fehler, das Gerät nicht gefunden wurde.


Raijin schrieb:
Um jetzt mal auf einen gemeinsamen Nenner zu kommen, bitte mal folgende Kommandos eingeben:

ping L5
Antwort von 10.0.0.5: Bytes=32 Zeit=103ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=4ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=5ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=5ms TTL=64
Ping-Statistik für 10.0.0.5:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 4ms, Maximum = 103ms, Mittelwert = 29ms

ping 10.0.0.5
Ping wird ausgeführt für 10.0.0.5 mit 32 Bytes Daten:
Antwort von 10.0.0.5: Bytes=32 Zeit=7ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=4ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=4ms TTL=64
Antwort von 10.0.0.5: Bytes=32 Zeit=4ms TTL=64
Ping-Statistik für 10.0.0.5:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 4ms, Maximum = 7ms, Mittelwert = 4ms

nslookup L5
Server: dns.google
Address: 8.8.8.8
*** L5 wurde von dns.google nicht gefunden: Non-existent domain.

nslookup L5 10.0.0.138
Server: UnKnown
Address: 10.0.0.138
Nicht autorisierende Antwort:
Name: L5.home
Addresses: fe80::cddb:8de9:711a:c7de
10.0.0.5

net use x:\\L5\Dokumente
Systemfehler 67 aufgetreten.
Der Netzwerkname wurde nicht gefunden.

net use y:\\10.0.0.5\Dokumente
Systemfehler 67 aufgetreten.
Der Netzwerkname wurde nicht gefunden.
 
petzi schrieb:
nslookup L5
Server: dns.google
Address: 8.8.8.8
Da haben wir doch das Problem, von dem ich rede. Google hat keinen blassen Schimmer was mit "L5" gemeint ist, weil google einfach keine Ahnung davon hat welche Geräte bei dir im Heimnetzwerk stehen.


petzi schrieb:
nslookup L5 10.0.0.138
Ähm... 10.0.0.138 ist die IP-Adresse deines Routers? Das ist im Normalfall immer die .1
Du hast nicht zufällig mehrere Router im Einsatz, die du ggfs nur zur Erweiterung des WLANs nutzen möchtest?


petzi schrieb:
net use x:\\L5\Dokumente
Zwischen x: und \\L5... muss ein Leerzeichen stehen, das sind zwei separate Parameter. x: ist dabei als Laufwerksbuchstabe frei wählbar, eben dss was frei ist. Du kannst also x: und y: nach Bedarf wählen, kann auch t: und u: sein oder f: und g: oder auch m: und v:. Wie du magst.




Zeig bitte mal die DHCP-Einstellungen im Router als Screenshot und auch den Output von "ipconfig /all" des Laptops.
 
  • Gefällt mir
Reaktionen: snaxilian
Zurück
Oben