No Partition is bootable ReiseFS-Dateisystem

joohn

Cadet 1st Year
Registriert
Aug. 2008
Beiträge
9
Hallo Leute,

ich habe mich schon eine weile durch das Forum gewühlt und leider wohl
einen falschen Befehl ausgeführt.

Erst hatte ich den Fehler:

Partition sector doesn't have the endmark 0xAA55

dann habe ich unter Menü: MBR Code -> Write new MBR Code to first sector ausgeführt

nun kann ich zwar meine Festplatte noch sehen unter testdisk 6.10
habe aber nun folgenden Fehler "No Partition is bootable"

Es handelt sich hier um eine:
- 500GB Western Digital Platte
- aus einem Netcenter
- Anschluß per USB und Lan
- laut Info mit ReiseFS-Dateisystem (wenn das richtig ist?)
- die Platte hatte sich aufgehangen und ich mußte den Netzstecker ziehen, wodurch
wohl der Fehler entstanden ist

was soll ich nun als nächstes machen?
Kann mir bitte jemand helfen?
 

Anhänge

  • 1.jpg
    1.jpg
    69,5 KB · Aufrufe: 229
Was hast Du für einen Befehl oder Funktion ausgeführt?

Führe dann Quick Search durch und poste den Screen, danach dann Deeper Search und poste auch diesen Screen, dann Enter und poste den kommenden Screen.
 
Hallo Mueli,


habe unter Menü: MBR Code -> Write new MBR Code to first sector ausgeführt

was genau danach für ein menü kommt kann ich jetzt nicht sagen, ich
wollte den gleichen Menü aufruf bzw. fehler nicht noch einmal machen.

ich habe die screenshots unte angehangen

ist das richtig das da NTFS steht ? weil es sich ja um eine externe Platte
handelt muß das nicht Linux ext2 und ext3 sein bei einem ReiseFS-Dateisystem?

ich hoffe du kannst mir weiter helfen Mueli

Gruß
 

Anhänge

  • quicksearch.jpg
    quicksearch.jpg
    66,9 KB · Aufrufe: 212
  • deepsearch.jpg
    deepsearch.jpg
    85,1 KB · Aufrufe: 229
  • enter.jpg
    enter.jpg
    65 KB · Aufrufe: 200
Ist der Drive eine normale externe Disk oder ein NAS? (Netcenter sagt mir nichts und ich habe das Programm von WD hier liegen). Ob die WD von Dir ein Linux Filesystem hat bin ich überfragt.

'Normale' Disks haben entweder FAT oder NTFS, bei Dir dann letzteres. Wenn dem so ist, geh im letzten Screen (Enter) auf Write und bestätige, bei dem dann fälligen Reboot ein möglicher Start von Chkdsk mit einem beliebigen Tastendruck abbrechen und das Ergebnis prüfen. Da Du den MBR gebügelt hast, könnte es sein, dass von der Disk nicht gebootet werden kann, dann solltes es aber über die XP InstallationsCD gehen (fixmbr, fixboot). Wenn Du den Grub installiert hattest, müsstest Du via Linux den Bootmanager wieder installieren.

Jede Partition hat einen Partition Sektor, der MBR ist ein Sonderfall!
 
Hallo Mueli,

Die disk ist in einem NAS von WD Netcenter verbaut.

siehe hier

http://www.westerndigital.com/de/products/netcenter/index.asp

oder hier

http://open-netcenter.de/


jetzt habe ich sie ausgebaut und gerade an einem normalen PC angeschlossen um sie
zu reparieren, sie soll aber wieder in den NAS.

soll ich den Schritt jetzt weiter gehen? --> ...auf Write und bestätigen


Gruß

Update:

habe die Schritte wie von dir unten beschrieben ausgeführt ...

jetz kann ich aber das Filesystem mit "P" nicht öffnen, siehe Picture

was müßte ich als nächstes machen? Wie gesagt bei der disk handelt
es sich um eine Disk in einem NAS.

Wäre nett wenn Du oder jemand anderes helfen könnte

Gruß
 

Anhänge

  • 5.jpg
    5.jpg
    89,5 KB · Aufrufe: 189
  • filesystem6.jpg
    filesystem6.jpg
    61,7 KB · Aufrufe: 172
Zuletzt bearbeitet von einem Moderator: (Doppelpost! Bitte Forenregeln beachten und die Ändern Funktion nutzen.)
Es sollte jetzt erst einmal geklärt werden, was für ein Dateisystem verwendet wird. Sollte es wirklich ein Linux-Filesystem auf der Disk sein, würde mit dem nun gesetzten Filesystem-Type sehr wahrscheinlich zu einer Fehlermeldung wie im letzten Post kommen.
 
ReiserFS 3.5, 3.6 und 4 werden von Testdisk unterstützt, ob eines davon auf Deinem NAS eingerichtet was vermag ich nicht zu sagen. Da ich ReiserFS nicht kenne, kann ich Dir auch nur ein paar Tipps geben. Du könntest mal probieren, die Einstellung zum Partition Typ auf None zu setzen und eine komplette Diagnose durchzuführen:
Führe mal eine Diagnose mit Testdisk wie folgt aus.
Lade Dir dazu Testdisk 6.10.

Nach dem Start von Testdisk beantwortest Du die Frage nach einer Logdatei mit Y. Den Partitionstyp solltest Du mit Intel beantworten. Dann wird Analyse aus dem dann erscheinenden Menü gewählt. Mit Quick Search wird dann der Vorgang fortgeführt (bei Vista mit Y antworten, wenn die Partitionierung unter diesem OS gemacht wurde).

Wichtig:
Wenn jetzt Partitionen gefunden wurden, kannst Du sie jeweils mit den Pfeiltasten anwählen und mit P deren Inhalt sichtbar machen. Mit Q geht es zurück ins Menü. Sollten keine Partitionen in der ersten Suche gefunden worden sein, wird mit Enter weiter gemacht, hier ist dann im Menü [ Quit ] [ Deeper Search ] [ Write ], die tiefere Suche mit Deeper SEARCH auszuwählen (dieser Vorgang kann dann schon eine Weile dauern).

Wenn jetzt Partitionen (sie sollten jetzt u.U. grün dargestellt werden) gefunden werden, solltest Du sie wieder mit den Cursor Tasten auswählen und mittels P deren Inhalt kontrollieren, also ob alle Daten sichtbar werden. Mit den Cursor-Tasten kann gescrolled werden. Aus dem Menü, beim listen des Inhalts kann man mit c Files und ganze Partitionen kopieren.

Nach jedem elementaren Schritt (also nach der ersten Analyse, nach dem Quick Search mit der Abfrage ob die Disk unter Vista eingerichtet wurde oder nicht und nach dem deeper SEARCH) solltest Du einen Screendump (oder Photo) machen und hoch laden, alternativ kann auch die Logdatei gepostet werden.

Der Weg einer Diagnose ist hier recht anschaulich beschrieben.
 
Hallo Mueli,

habe Deine Anweisungen befolgt

sichtbare files mit "P" konnte ich nur unter Raiser FS 3.6 sehen konnte aber nichts mit "c Files und ganze Partitionen kopieren" anfangen bzw anwählen siehe Pictures.

Was wäre der nächste Schritt?
Kann man da was wiederherstellen? Oder muß ich auf alle fälle Kopieren, wenn ja wie, konnte mit "c" nichts anwählen.

Gruß
 

Anhänge

  • raiser.jpg
    raiser.jpg
    85,3 KB · Aufrufe: 192
  • raiser2.jpg
    raiser2.jpg
    84,8 KB · Aufrufe: 170
  • raiser3.jpg
    raiser3.jpg
    103,4 KB · Aufrufe: 191
Was soll ich mit einer Aussage 'wie konnte aber nichts mit "c Files und ganze Partitionen kopieren' ? Fehlermeldung oder was geht nicht.

Poste bitte die Bilder wie in meinem ersten Post beschrieben: der erste Screen direkt nach Analyse (unten steht dann Quick Search), dann nach Quick Search und zum Schluss nach Deeper Search.

Kopieren mit Testdisk:
Wenn du p drückst und bei deiner NTFS-Partition Deine Daten siehst, kannst du eine Datei oder Ordner markieren und c für copy drücken.
Wenn du nur den einzelnen Punkt markierst, kannst du das ganzes Laufwerk kopieren.
Dann wirst du nach dem Pfad gefragt. wenn du auf die zwei Punkte gehst, kommst du immer ein Ordner höher bis du deine Festplatten siehst.
Wähle dort deine Festplatte oder Partition wohin du die Daten kopieren möchtest aus.
Markiere dann den entsprechenden Ordner.
Mit dem Links oder Rechtspfeil kannst du in einen Ordner gehen.
Wenn du dann mit y bestätigst, fängt Testdisk an zu kopieren.
Infos zum kopieren nochmal hier!
https://www.computerbase.de/forum/t...s-systempartition-retten.305094/#post-2273568

Die Partitionen werden, soweit ich das mit derzeitigen Bildern beurteilen kann, gefunden, nur die doppelte Auflistung der zweiten Partition deutet auf einen Fehler im Bootsektor hin.

Den Bootsektor kannst Du überprüfen, indem Du anstatt auf Analyse ins Menü Advanced und dort auf Boot gehst (bei mehreren Partitionen wählt man jede Partition mit den Cursortasten an). Interessant ist bei Dir die dritte Zeile aus dem Screen mit den drei in grün dargestellten Partitionen.

Von welcher Partition hast Du überhaupt mittels p die Files eingesehen?

Zum kopieren brauchst Du sicherlich ein anderes Laufwerk mit ReiserFS. Ich könnte mir aber vorstellen, dass nach einer Reparatur des Bootsektors wieder auf die Daten zugegriffen werden kann.
 
Zuletzt bearbeitet von einem Moderator: (Link korrigiert)
Hallo Mueli,


Danke für Deine Info,

... die RaiserFS Partition konnte ich mit P anwählen die anderen zwei nicht.

ein kopieren ist schwierig, wie Du schon sagtest müßte ich noch einmal ein
RaiserFS Partition haben, da sieht es mit dem Platz eng aus.
Eventuell schaffen wir es ja den Bootsector wieder zum laufen zu bringen.

Ich habe mal den Screen unten angehangen.
Ist der Bootsektor defekt?
Was wäre der nächste Schritt?

Danke für Deine Hilfe Mueli
 

Anhänge

  • boot.jpg
    boot.jpg
    81,5 KB · Aufrufe: 148
Nach den bisherigen Bildern ist weder der Bootsektor noch die Partitionstabelle defekt. Wie viele Partitionen waren auf der Disk eingerichtet? Es schein zumindest nur eine gewesen zu sein.

Mit dem Schreiben des MBR hast Du wahrscheinlich den Typ des Dateisystems überschrieben, Du solltest mal versuchen über das Menü Advanced der Typ, möglicher Wert wär 83, danach gehst Du auf Boot, dann List, um zu überprüfen ob das Filesystem gelesen werden kann. Auf einem Deiner PICs sehe ich nur 'Cant't open filesystem. Filesystem seems damaged.', demnach wäre das Dateisystem korrupt. Ich kann unter den Möglichkeiten bei Typ keine spezielle Kennzeichnung für ReiserFS ausmachen, demnach sollte 83 passen. Die Änderungen werden erst geschrieben wenn man explizit die neuen Einstellungen schreibt, mache dies zunächst mal nicht.
 
Hallo Mueli,

Auf der disk war nur eine Partition eingerichtet, da hast du recht.
Ich bin Deinen Anweisungen befolgt
Bin über:

Menü -> /Intel/PC Partition -> Advanced -> Typ -> 83 gegangen
da erscheint aber unten nur die Auswal "Typ - Superblock - Image Creation - Quit"
(siehe Pic) ich komme von da irgendwie nicht auf Boot und List zurück?

Da mache ich doch irgend was falsch, oder?

oder hätte ich über
Menü -> None -> Advanced -> Typ gehen sollen? Da kommen aber dann ganz ander Auswahlmöglichkeiten


Gruß
Joohn
 

Anhänge

  • auswahl.jpg
    auswahl.jpg
    111,2 KB · Aufrufe: 164
  • auswahl83.jpg
    auswahl83.jpg
    68,8 KB · Aufrufe: 147
Es sollte eigentlich gehen, wenn Du über Quit aus dem Menü gehst und dann eine Analyse machst. Alternativ könntest Du auch im Menü nach Quick Search mit T den Typ setzen und dann die tiefere Suche laufen lassen.
 
Hallo Mueli,

Ich bin über Menü -> Quick Search ->T den Typ 83 auf Linux gegangen


- Bin mit T auf Linux Punkt 83 gegangen Pic 1
- Habe versucht mit P die file zu öffnen Pic 2 (ging nicht)
- Bin dann auf Deeper Search gegangen Pic 3
- ist das richtig das dann bei Deeper Search wieder HPFS - NTFS steht ? Ich hatte doch Linux ausgewählt siehe Pic 4
- Ergebnis nach Deeper Search Pic 5
- Auswahl mit P kein Filesystem gefunden Pic 6

Mich irretiert jetzt das vorne wieder HPFS - NTFS anstatt linux ?
Ist das richtig so ?
Habe ich jetzt was Falsch gemacht , Müeli?

Gruß Joohn
 

Anhänge

  • Unbenannt-1.jpg
    Unbenannt-1.jpg
    87,4 KB · Aufrufe: 150
  • Unbenannt-2.jpg
    Unbenannt-2.jpg
    61 KB · Aufrufe: 154
  • Unbenannt-3.jpg
    Unbenannt-3.jpg
    66,1 KB · Aufrufe: 133
  • Unbenannt-4.jpg
    Unbenannt-4.jpg
    61,5 KB · Aufrufe: 138
ups habe gerade mitbekommen man kann nur 4 Pics hochladen , hier die restlichen

Pic5 und Pic 6

- Ergebnis nach Deeper Search Pic 5
- Auswahl mit P kein Filesystem gefunden Pic 6


Gruß Joohn
 

Anhänge

  • Unbenannt-5.jpg
    Unbenannt-5.jpg
    86,3 KB · Aufrufe: 160
  • Unbenannt-6.jpg
    Unbenannt-6.jpg
    56,1 KB · Aufrufe: 144
Man kann schon mehr Files hochladen, es muss nur nacheinander geladen werden, also immer wieder neu auswählen.

Der Typ eines Filesystems wird nicht nur durch den Wert in der Partitionstabelle festgelegt, jedes Dateisystem hat auch Merkmale, an denen es erkannt wird, wie z. B. die MFT (NTFS) oder FAT (Fat32) usw.!
Es ist ja auch nicht bekannt, ob dieses NAS evtl. eine Bootpartition besitzt, also sein OS von der Disk hochzieht, sowas hat es sogar in einer etwas anderen Form bei Compaq mal gegeben, wo das BIOS von der Disk geladen wurde und man richtig Arbeit hatte, wenn die Disk im Eimer war. Du wärst besser beraten gewesen, wenn Du vor den ersten Aktionen ein Image der Disk gezogen hättest.

Ich würde jetzt erst einmal die Disk mit einem Datenrettungstool mit Linux Unterstützung untersuchen.
 
Zurück
Oben