Problem mit AutoRun und Kontextmenü

Dr. MaRV

Admiral
Dabei seit
Aug. 2006
Beiträge
7.220
Hallo CD Gemeinde!

Ich habe ein kleines Problem mit meinem Windows 7. Die AutoRun-Funktion geht nicht mehr, das Icon und Label einer im Laufwerk befindlichen CD/DVD wird nicht mehr angezeigt. Es wird kein AutoRun mehr ausgeführt, es erscheint beim einlegen einer DVD/CD, anschließen eines USB Sticks oder USB Festplatte kein Fenster mehr wir man verfahren möchte. Beim Rechtsklick auf das CD/DVD Laufwerk fehlt der Menüpunkt AutoRun komplett. Es scheint als würde überhaupt nicht mehr nach einer autorun.inf oder so geschaut. Hat jemand von euch so etwas schon erlebt und kann mit evtl. eine Lösung zur Fehlerbehebung nennen?

Was ich hier im Forum und bei Google bisher darüber gefunden habe, hat leider keinen Effekt erzielt. Ich habe weder Tools noch irgendwelche Optimierungssoftware installiert die das hätte verändern können.
 

Dr. MaRV

Admiral
Ersteller dieses Themas
Dabei seit
Aug. 2006
Beiträge
7.220
Hab ich auch schon gedacht, habe nur die Secutity Essentials drauf, da kann man aber nichts einstellen diesbezüglich.

Edit:
Ich habe das Problem mit dem Icon und Label gelöst, es lag an Panda Cloud, was ich vor einiger Zeit mal ausprobiert hatte.
Hier die Lösung des Problems, falls es jemand anderes auch mal trifft.

In RegEdit navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf
You should see this key in the right pane:
@="@SYS:doesNotExist"
RIGHT-click on it & click 'delete'
Click 'yes' in the "are you sure" box
close RegEdit.

Screenshot here: http://screenshotuploader.com/s/iumnt6CQ8DT/

Quelle: CloudAV Support Forum

Abschließend Rechner neu starten.

Das Kontextmenü und das Fenster mit den Auswahlmöglichkeiten gehen jedoch immer noch nicht. Da muss ich weiter suchen.

Edit2:
Problem ist nun endgültig gefixt. In meiner Registry war noch ein DWORD-Eintrag zu ändern, dort stand ein fehlerhafter Wert, den ich übersehen hatte. Hier noch die Werte welche ich kontrollieren und zum Teil ändern musste:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

Grüße
MaRV
 
Zuletzt bearbeitet:
Top