Problem mit Touchpad unter Linux

9dem0n9

Ensign
Dabei seit
Nov. 2008
Beiträge
206
Hallo erstmal,
mein Touchpad an sich geht einwandfrei. Nur gibt es an meinem Notebook (Compaq Presario CQ60-115EG) ne Taste, mit der man das Touchpad deaktivieren kann. Allerdings besitzt diese Taste nur eine Hotkeyfunktion unter Windows Vista. Da ich aber da im Moment LinuxMint7 drauf habe geht das ja nicht. Ich kann dieser Taste zwar natürlich eine Funktion zuweisen, aber das Problem ist genau diese Funktion.

Ich habe das mal so versucht:

synclient TouchpadOff=1

Dadurch wird das Touchpad deaktiviert, nur reaktiviert sich das ungefragt nach so ca. 5 Sekunden wieder von alleine und das ist ja nicht Sinn der Sache. Jetzt meine eigentlich Frage:
Wie kann ich das Touchpad dauerhaft abstellen, sodass es erst wieder aktiviert wird, wenn ich den Befehl dazu gebe?

Bin ja schon fast am Verzweifeln und hoffe deshalb auf Hilfe.

Gruß 9dem0n9
 

9dem0n9

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
206
weil mich das beim schreiben manchmal stört. da gibts zwar ne funktion mit der man festlegen kann, dass es nach einer bestimmten anzahl an sekunden nach drücken der letzten taste reaktiviert wird, beim tippen ist es aus, aber die lösung gefällt mir nicht so.
hat niemand ne idee?
 

magus16

Ensign
Dabei seit
Sep. 2005
Beiträge
194
da gibts zwar ne funktion mit der man festlegen kann, dass es nach einer bestimmten anzahl an sekunden nach drücken der letzten taste reaktiviert wird, beim tippen ist es aus, aber die lösung gefällt mir nicht so.
Hast du einmal getestet, ob diese "Funktion" (syndaemon?) dafuer verantwortlich ist, dass "synclient TouchpadOff=1" nach 5s wieder aufgehoben wird?

Das Abschalten des Touchpads ist leicht zu regeln mit synclient und xbindkeys. Dazu gibt es einige Tips im Internet. Das Problem, das du aber zuerst loesen solltest, ist das Wiederaufheben des synclient Befehls nach 5s.
 

9dem0n9

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
206
Ich glaube das mit dem synclient/syndaemon problem hab ich jetzt gelöst bekommen, keine ahnung wie, aber nach langem rumprobieren gehts jetzt.
meine frage ist jetzt, wie ich das mit den xbindkeys machen soll. hab das noch nie gemacht. ich habe hier nur so ein vorinstalliertes tool aus linuxmint7 mit dem man das grafisch an sich ganz nett einstellen kann. problem ist, dass das das drücken dieser touchpad-taste nur beim wechseln von inaktiv auf aktiv als tastendruck wahrnimmt. dabei kommt laut xev auch beim umgekehrten fall ein extra signal an.
irgendwelche vorschläge?

danke und gruß 9dem0n9
 

magus16

Ensign
Dabei seit
Sep. 2005
Beiträge
194
Da ich die GUI aus Mint nicht kenne:

1. xbindkeys installieren

2. Standard-Datei erstellen:
Code:
xbindkeys --defaults > ~/.xbindkeysrc
3. Key Code herausfinden:
Code:
xbindkeys -k
# z.B. c:41 + m:0x4
4. Das Ganze dann in die Konfigurationsdatei eintragen und den daemon starten:
Code:
xbindkeys
Wenn etwas nicht stimmt. daemon mit "killall xbindkeys" stoppen.
 

9dem0n9

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
206
hm, das ist mir jetzt peinlich, aber die taste gibt wirklich nur beim reaktivieren ein signal. xbindkeys sagts mir so und ich habs nochmal mit xev überprüft und das meint das gleiche, da muss ich mich beim ersten mal verkuckt haben.
demnach wirds schwer da was zu machen. wundert mich nur, dass das dann unter windows geht, weil da muss ja auch ein signal kommen ums zu deaktivieren. fehlt da vllt noch ein passender treiber fürs touchpad?

danke und gruß 9dem0n9
 

magus16

Ensign
Dabei seit
Sep. 2005
Beiträge
194
Dann solltest du dich hier einmal einlesen. Da geht es zwar um Gentoo, ist aber auch auf Mint anwendbar. Besonders der erste Abschnitt könnte dir eventuell weiterhelfen.
 
Top