Probleme bei der Installation von Gentoo 2004.3

Executor55

Lt. Commander
Dabei seit
Okt. 2004
Beiträge
1.691
Hallo ich habe die DVD-Edition von Gentoo 2004.3 (also brauche ich kein Internet, oder?. So steht es jedenfalls im Handbuch). Auf dieser DVD befindet sich ein Handbuch zur installation der Distribution, an das ich mich strikt gehalten habe. Nur geht irgendwas noch nicht. Es hat alles funktioniert bis zu einem Befehl: "cp -prv /mnt/cdrom/distfiles/base/*/mnt/gentoo/usr/portage/distfiles/". Da kam die Fehlermeldung: "cp: missing destination file". Ich habe den Befehl dann einfach mal übersprungen um zu schaun wie weit ich ohne ihn komme. Naja einige schritte gehen noch bis zu den "emerge-Befehlen" da geht keiner (da musste ich etwas downloaden, habe aber nur Modem und war nicht mit dem Internet verbunden). Frege : Ist jetzt der Befehl allesentscheident oder liegt es an etwas anderem? Ich kenne mich nicht so aus habe vorher nur Debian draufgehabt aber nicht viel benutzt.
 
Zuletzt bearbeitet:

wolf

Lieutenant
Dabei seit
Nov. 2002
Beiträge
675
das zielverzeichnis heißt /mnt/gentoo/usr/portage/distfiles/
ohne a
 

Meolus

Lt. Commander
Dabei seit
Feb. 2005
Beiträge
1.411
Z

zAD

Gast
außerdem scheinst du da nen leerzeichen vergessen zu haben (und somit fehlt das zielverzeichnis).

soll es vielleicht so heißen:
Code:
cp -prv /mnt/cdrom/distfiles/base/* /mnt/gentoo/usr/portage/distfiles/
?
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
@zAD
Ja ich habe das mich auch schon gefragt und es ausprobiert. Habe mir ein anderes Handbuch besorgt. In meinem stehts so wie ich geschrieben habe und in dem anderen stehts so wie du geschrieben hast. Das geht auch net.

@wolf
was meinst du mit "ohne a"? wo issn da n a in dem was ich geschrieben habe?
 

aki

~amd64
Teammitglied
Dabei seit
Feb. 2002
Beiträge
3.445
cp -prv /mnt/cdrom/distfiles/base/*/mnt/gentoo/usr/portage/diastfiles/

Das gehört da natürlich nicht hin. Eventuell ist es auch erst dazwischen geraten, als du den Beitrage geschrieben hast, hast es aber bei der Installation richtig geschrieben.
Da ist glatt noch ein Fehler. Nach dem * hast du kein Leerzeichen gemacht! Deshalb "missing destination file".

*edit*
zAD hats sogar schon gesagt :D
 
Zuletzt bearbeitet:

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
aso sorry des warn schreibfehler von mir
ich edidiers ma schnell
 

wolf

Lieutenant
Dabei seit
Nov. 2002
Beiträge
675
naja, aber bevor das geht, musst du erstmal den portage-tree ausgepackt haben.
wenn du das nicht gemacht hast, dann gibt es auch kein verzeichnis namens /usr/portage
aber so, wie zAD es geschrieben hat, sollte es schon gehen!
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
Ich habe es jetzt geschafft:
cp -prv /mnt/cdrom/distfiles/* /mnt/gentoo/usr/portage/distfiles/
(ohne base/)
aber deswegen gehen dennoch keine emerge-Befehle oder ist es normal, dass man keine Verbindung zu Hosts bekommt und es dennoch versucht etwas zu downloaden?
Ebeso steht im Handbuch etwas davon den "Portage Snapshot" zu entpacken. Mit dem Befehl:
tar -xvjf /mnt/cdrom/snapshots/portage-20041022.tar.bz2 -C /mnt/gentoo/usr
Den Pfad gibt es nicht auf meiner DVD. Stattdessen: //DVDA/portage/portage-L+.tar
Kann ich damit was anfangen?
Sind Emerge-Befehle allein dazu da etwas zu downloaden?
Kann ich die für eine Stage-1-Installation gebrauchen, wenn es heißt das es eine Offline-Installation ist?
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
Ich weis jetzt wo mein Problem liegt! :)
Ich habe die Stage1 Dateien entpackt nicht die Stage3 Dateien. Ich habe da die ganze Zeit etwas verwechselt, ich dachte das Stage1 die Offline (Netzwerklose) Installation wäre und nicht andersrum.
Sorry bin halt noch ein Noob in sachen Linux. :(

Kann jedem nur raten das Handbuch wirklich von vorne bis hinten bis ins kleinste zu lesen sonst kommt man zu gar nix.
 

tmp

Ensign
Dabei seit
Feb. 2004
Beiträge
253
bitte lies dir die dokumentation ordentlich durch!

anhand dieser doku bekommst du echt alles sauber in den griff,wenn du dich nicht blöd anstellst.
was emerge und der portage tree machen,wird auch super erklärt.
wenn du keinen inetzugang hast,dann leg die package cd ein und mach
export PGKDIR="/mnt/cdrom" <- je nachdem wohin dein cdrom gemountet wird.
dann durchsucht er erstmal deine cd nach passenden paketen..

aber wie gesagt..lies in der doku.
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
die meisten emerge befehle funzen immer noch net. es geht los bei "scripts/bootstrap.sh", wenn des net geht soll ich "emerge -C linux-headers" und "emerge --oneshot --nodeps linux26-headers" ausführen und dann scripts.. des geht net. "emerge system", "emerge gentoo-sources" und "emerge genkernel" gehen alle net. was mach ich falsch? ich halt mich genau an die anleitung.
 

Msp2601

Lt. Commander
Dabei seit
Apr. 2004
Beiträge
1.342
ganz dumme frage aber bis du als root angemeldet? (In der Konsole also su enter *dein password* enter)

MfG
Msp2601
 

Ganto

Ensign
Dabei seit
Okt. 2003
Beiträge
253
wenn du mal eine fehlermeldung postest, könnten wir dir vielleicht weiter helfen.

ganto
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
naja bei diesen emerge befehlen kommt dann immer host nicht verfügbar bzw download abgebrochen. sollte ich die nicht die ganzen datein haben auf meiner stage3 DVD?
 

Ganto

Ensign
Dabei seit
Okt. 2003
Beiträge
253
das sind eben genau die dateien, die du oben auf die festplatte kopieren solltest. sie befinden sich auf der dvd im unterordner /distfiles (/mnt/cdrom/distfiles) und müssten auf der festplatte in den ordner /mnt/gentoo/usr/portage/distfiles.

ganto
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
ok kann schon sein aber die dateien habe ich auf die festplatte kopiert, denn es hat jetzt funktioniert (Thread #9)
 

Ganto

Ensign
Dabei seit
Okt. 2003
Beiträge
253
also das portage archiv ist eine sammlung von dateien, welche so zu sagen die anleitung für das emerge sind; d.h. wie man die verschiedenen packete installiert. das musst du nach /mnt/gentoo/usr entpacken. das ergibt dir dann den ordner /mnt/gentoo/usr/portage mit diversen unterordnern. hast du aber wahrscheinlich geschafft, sonst hättest du kein /mnt/gentoo/usr/portage/distfiles. in diesem sind die source-archive der zu installierenden programme gespeichert (die, welche du von der dvd auf die festplatte kopiert hast). mit 'ls /mnt/gentoo/usr/portage/distfiles kannst du dir anschauen, was alles in diesem ordner ist. eigentlich müsstest du jetzt alle nötigen programme bereits dort vorhanden haben. wenn emerge nämlich ein source-archiv dort nicht findet, versucht es dieses vom internet herunter zu laden und da du das netzwerk noch nicht eingerichtet hast, kommt dann dementsprechend "host not found".

ganto
 

Executor55

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2004
Beiträge
1.691
ok danke für die info und brauche ich die source archive oder die anderen sachen die ich mit emerge runterlade?
 

Ganto

Ensign
Dabei seit
Okt. 2003
Beiträge
253
vielleicht könntest du das mal überprüfen, was ich geschrieben habe und selber überlegen was deinem system fehlt. ich kenne dieses ja nicht genau und kann dir nicht weiter helfen, wenn du nicht noch mehr dazu schreibst. eigentlich solltest du jetzt alles wissen, um das problem selber zu lösen.

1. schau nach, was unter /usr/portage ist: ls /mnt/gentoo/usr/portage
2. schau nach, was unter /usr/portage/distfiles ist: ls /mnt/gentoo/usr/portage/distfiles

ganto
 
Zuletzt bearbeitet:
Top