Raspberry Pi 2 - Raspbian - X11VNC verweigert Autostart

Dante2000

Lt. Commander
Dabei seit
Apr. 2011
Beiträge
1.955
Hi CBler,
ich sitze bereits seit einiger Zeit an dem Problem, einen x11VNC Server automatisch auf dem Raspberry PI 2 laufen zu lassen. Scheinbar reagieren zwei identische Raspberry Pi 2 komplett anders. Die Installation ist auf beiden identisch. Beim Raspberry PI 2 (1) startet der Server nach einem Neustart meistens (...) automatisch mit. Raspberry PI (2) weigert sich jedoch strikt dagegen.

Ich habe beim ersten PI die hier verlinkte Anleitung befolgt. Diese funktoniert beim PI 2 wiederrum nicht mehr. Auch diese Anleitung greift nicht.

Hat jemand noch einen Vorschlag, wie ich das verdammte Programm endlich zuverlässig zum laufen bringen kann? Die beiden sollen lediglich als Statusmonitor dienen, nicht mehr und nicht weniger.

Danke für eure Hilfe.
 

TWry

Ensign
Dabei seit
Juni 2012
Beiträge
165
Ein Hinweis, warum die Anleitungen jeweils nicht funktionieren wäre sicherlich hilfreich. Ohne näheres zu wissen - ist die Firmware bei beiden die gleiche? (Terminal -> "uname -a")
 

blablub1212

Commodore
Dabei seit
Sep. 2009
Beiträge
5.068
könnte daran liegen, dass du noch keine lan verbindung hast wenn versucht wird den vnc-server zu starten.

Füg mal folgendes in /etc/rc.local
Code:
sleep 20
x11vnc -forever -display :0
der VNC-server wartet dann erstmal 20 sekunden bis er gestartet wird.

Prinzipiell würde ich aber kein VNC zu monitoring verwenden. du kannst per ssh auch alles anzeigen:

top -> für die prozesse
iotop -> für die festplatten aktivität
bmon -> für den netzwerk traffic
tail -> für die logs

Wenn du das gerne grafisch aufbereitet hättest könnte man auch sowas wie http://ajenti.org nutzen. damit kannst du dir über eine browser-oberfläche von entfernten geräten alles mögliche ausgeben lassen. konfiguration ist dabei nicht notwendig, das funktioniert direkt.
 
Zuletzt bearbeitet:

Dante2000

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
1.955
@TWry
Der X11vnc Server läuft, sobald man ihn per Hand im Terminal startet - Via Scripts, die eigentlich genau das gleiche machen sollten, funktioniert es aber nicht. Die oben verlinkten Anleitungen habe ich 1 zu 1 befolgt.

Beide Pis haben die gleiche Firmware installiert: 3.18.7- v7+. Angebunden sind beide Geräte über WLAN Adapter.

@blablub1212
Nein, funktioniert nicht. Die IP bekommt er auch zeitig. Wir müssen uns via VNC auf den Raspberry verbinden um dort via Browser eine HTML Seite mit unseren Internen Maschinen anzeigen zu lassen. (Kein icinga > Selbst gebaute HTML Seiten).

Das Problem ist, das auch via ps aux|grep kein x11vnc Prozess ausgeführt wird. Stoße ich das ganze per Hand an, finde ich dort auch einen passenden Prozess zu. Wir wollen uns ersparen, bei jedem neustart des Geräts uns via ssh zwangsverbinden zu müssen.
 
Zuletzt bearbeitet:

blablub1212

Commodore
Dabei seit
Sep. 2009
Beiträge
5.068
dann lass dir mal bitte mittels

Code:
x11vnc -forever -o /tmp/x11vnc.log -display :0
eine log datei ausgeben und guck mal was nach einem neustart da drin steht.
 

Dante2000

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
1.955
Ich habe deine Zeile, etwas angepasst (inkl. -bg), in mein Startup Script aufgenommen > Es gibt kein Logeintrag dafür, daher wird das Script scheinbar nicht ausgeführt. Haue ich die Zeile direkt in das Termial läuft alles 1A.

Ich habe unter /home/pi/startVNC.sh Script mit diesen Settings hinterlegt:
#! /bin/sh
x11vnc -forever -usepw -bg -o /tmp/x11vnclig -display :0

Im Autostart Verzeichnis /etc/xdg/autostart/x11vncstartup.sh steht folgendes:
[Desktop Entry]
Name=VNC Autostart
Exec=/Home/pi/startVNC.sh
Type=Application
Terminal=true

Habe ich hier das vielleicht falsche Autostart Verzeichnis gewählt?

EDIT: Auch das Verschieben des x11vncstartup.sh in das User verzeichnis /home/pi/.config/autostart (Selbst erstellter Ordner) brachte keine Lösung. Es startet x11vnc nicht.

EDIT2: Doppelter Facepalm. Ich habe die Fehlerursache gefunden.
Ich habe im Verzeichnis /home/pi/.config/autostart/ das Script statt startvnc.dekstop, startVNC.sh genannt. Dadurch wurde dort nichts ausgeführt. Nun funktioniert alles ordnunsggemäß.

Danke für eure Vorschläge.
 
Zuletzt bearbeitet:
Top