RPI3b+ hängt sich auf / Kopieren von großen Dateien

PEASANT KING

Lt. Commander
Dabei seit
Okt. 2008
Beiträge
2.035
Guten Abend,

wie der Titel schon sagt, hängt sich mein RPI leider immer auf beim Kopieren von großen Dateien über Netzwerk auf eine externe Festplatte, die am RPI per USB dran hängt.

Im Internet steht eine Menge über das Problem. Nur leider lässt sich das Problem mit den Lösungen die dort vorgeschlagen werden nicht lösen. Man solle mit ethtool arbeiten und mittels "ethtool -K eth0 tx off sg off tso off" die tcp-segmentation deaktivieren, die beim RPI zum CPU lockup führen kann, wenn der CPU load zu hoch wird.

Doof nur das bei mir das Ganze nicht funktioniert, da mir ethtool als Rückmeldung sagt, das wäre nicht supported an meinem Gerät.
Was mich wundert ist, das es bei anderen wunderbar funktioniert und damit das Problem weg ist, laut dem offiziellen raspberry Forums.

Mich nervt das tierisch, ich würde gerne meine Raw Bilder speichern auf der Festplatte am RPI, aber das Ding hängt sich jedes Mal auf.

Vielleicht habt ihr ja einen Tipp für mich. Mit einem RPI 2b habe ich das Problem nicht gehabt.

Vielen Dank im voraus
 

FranzvonAssisi

Rear Admiral
Dabei seit
Dez. 2013
Beiträge
6.066
Welche Distri hast du denn? Und der Pi ist per LAN angeschlossen?

Lg
 

PEASANT KING

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2008
Beiträge
2.035
Sry war gestern schon im Halbschlaf. Raspian nutze ich als Distro, weil ich mit Debian gut zurecht komme und es sehr gerne mag. Die Kernel Version ist 4.14.98. Der Pi ist per LAN angeschlossen.

Einen FTP Server hatte ich mal am Laufen, habe ihn aber wieder runtergeworfen. Ich schiebe das Ganze per Netzwerk von Windows 10 Pro über Netzlaufwerk auf den PI über Samba.
 

DeusoftheWired

Admiral
Dabei seit
Juni 2009
Beiträge
8.640
Zuletzt bearbeitet:

PEASANT KING

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2008
Beiträge
2.035
Weil es für mich einfach bequemer ist, die Daten per Drag and Drop direkt aufs Laufwerk zu schieben, anstatt erst noch nen FTP Client zu starten.

Per FTP habe ich es noch nicht versucht, werde es aber erst mal in Betracht ziehen, kann das Ganze aber erst heute Abend wieder testen.
Wäre ich nicht auf Grund von bestimmten Programmen auf WIndows beschränkt und ab und zu zocken, dann wäre ich schon längst komplett umgestiegen auf Linux.
 

0-8-15 User

Captain
Dabei seit
Jan. 2008
Beiträge
3.273
Hat die Festplatte eine eigene Stromversorgung? Wenn nicht, dann würde ich dort mit der Fehlersuche beginnen. Der Raspberry Pi 3 Model B+ scheint extrem zickig zu sein, was die Stromversorgung betrifft. Wenn ein USB Gerät zu viel Strom zieht, dann schmiert er ab. Bin am Anfang auch fast daran verzweifelt.

Ich übertrage regelmäßig große Dateien (~100 MB) vom RPI auf meinen Rechner (via WLAN per scp).
Seit ich den Stromverbrauch am USB Port reduziert habe, hatte ich keinen einzigen Absturz mehr.
 
Zuletzt bearbeitet:

PEASANT KING

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2008
Beiträge
2.035
Die Festplatte ist eine Serverplatte im Dauerbetrieb in einem externen Gehäuse mit extra Stromversorgung, das ist es also leider nicht...

Ich habe es gerade mit FTP probiert und habe genau das gleiche Problem 4 - 5 Dateien werden übertragen, dann steigt der RPI aus und die Verbindung wird abgebrochen.

EDIT:

Ich habe den RPI getauscht gegen einen weiteren RPI3b+ und komischerweise funktioniert es hier wunderbar.
 
Zuletzt bearbeitet:

lokon

Ensign
Dabei seit
Aug. 2013
Beiträge
134
Ich habe den RPI getauscht gegen einen weiteren RPI3b+ und komischerweise funktioniert es hier wunderbar.
Serienstreuung bei der Stromversorgung/Komponenten nahe an der Auslegung ?

Man kann die Übertragungsgeschwindigkeit per FTP,SCP... bei einigen Clients beschränken; den Serverprozess auf dem Raspi eine extrem niedrige Priorität einräumen, ionice benutzen oder beim Raspi die Energieverwaltung wie Frequency Scaling, Max. Clock .... in boot/config.txt verändern.
 

Mickey Mouse

Commodore
Dabei seit
Aug. 2006
Beiträge
4.995
auch wenn es abgedroschen klingt: ich tippe ebenfalls auf Netzteil!

ich hatte hier schon ganz merkwürdige Dinge, "lustigstes" Beispiel:
ping von einem anderen Rechner auf den Pi sah so aus:
5...6...manchmal auch 10 pings OK, time OK
3...5...7 pings "kaput"
5...10...manchmal auch 20 pings OK, time OK
4...5 pings "kaput"
und so weiter und so fort

anderes ("richtiges") Netzteil ran und auf einmal gab es auch bei >>1000 pings keinen einzigen Aussetzer mehr!

ich ziehe von meinem FHEM Server (auch Raspbian) regelmäßig mit raspiBackup komplette (komprimierte) Images auf das NAS und der (hat ein "richtiges" Netzteil) ist noch nie dabei abgestürzt.
 

PEASANT KING

Lt. Commander
Ersteller dieses Themas
Dabei seit
Okt. 2008
Beiträge
2.035
Ich hatte schon am Takt des nicht funktioniernden rumgespielt, ergab aber keine positiven Ergebnisse.

Ich habe mir ein neues Netzteil, nicht Ladegerät gekauft. Hier bei handelt es sich um das originale Netzteil.
Bin mal gespannt, aber schon interessant, das mein jetziges verschiedene Spannungen hat an ein und dem selben RPI Modell.
 
Top