RX 5700 XT: Greenscreen - a never ending story?

-Iwan-

Lieutenant
Dabei seit
Okt. 2009
Beiträge
853
Hallo zusammen,

das Greenscreen-Problem ist einfach nur noch nervig und ich würde gerne die Ursache finden, bevor ich ins grüne Lager (nVidia) wechsle. So langsam entpuppt sich das als Neverendingstory.
Meine Hardware:
  • AMD Ryzen 7 3700X
  • G.Skill 32 GB DDR4-3200 Kit (2* 16GB, Ripjaws V)
  • MSI MPG X570 Gaming Plus (Bios aktuell: 7C37vA9)
  • GigaByte RX 5700 XT Gaming OC 8G (Bios aktuell: FA0)
    Radeon Software 20.8.3 (heute aktualisiert, vorher per DDU entfernt)
  • be quiet! Pure Power 11 700W CM
  • 2* BenQ TFT: 1x 27" FHD 75Hz, 1x 24" FHD 60Hz
Mein Problem ist, das ich in unregelmäßigen Abständen einen Greenscreen bekomme (immer nur beim Zocken) und der Rechner dann direkt neustartet. Mal kann ich auch ein paar Tage problemlos zocken und dann tritt es plötzlich 2-3x am Tag auf. Aktuell spiele ich hauptsächlich LS19 und GTA V und es passiert in beiden Spielen.
Im Eventlog finde ich keine (aussagekräftigen) Einträge, aber in der Radeon-Software steht immer folgender Hinweis: "Wegen eines unerwarteten Systemfehlers wurden die Radeon WattMan Standarteinstellungen wiederhergestellt".
Die Spiele laufen nur auf dem 27" und der Sound wird über die Onboardkarte wiedergegeben.

Was ich schon versucht habe (in dieser Reihenfolge):
  • das Gehäuse & alle Lüfter+Kühlkörper gereinigt und direkt auch alle Kabelverbindungen geprüft
  • die Lüftereinstellungen im Bios habe ich etwas nach oben korrigiert
  • das Netzteil habe ich am Dienstag ausgetauscht (vorher: be quiet! Pure Power 11 600W CM)
  • am 27" TFT das HDMI- gegen ein Displayportkabel getauscht, am 24" war ein Displayportkabel dran
  • Stresstest mit Furmark durchgeführt (ca. 1 Stunde lang) = kein Absturz/Greenscreen
  • MSI Kombustor 4 ((GL) FurMark-Donut-6500MB) & Prime95 (Blend = lots of RAM tested) parallel ca. 1 Stunde laufen gelassen = kein Absturz/Greenscreen
  • Aorus-Software zur Lüftersteuerung deinstalliert
Was ich noch versuchen kann/werde:
  • MemTest laufen lassen
  • neues Kabel für den 2. TFT besorgen
  • im Bios XMP für den RAM ausschalten und die Timings manuell eintragen
aber dann gehen mir langsam auch die Ideen aus. Vielleicht fällt euch ja noch was ein.
Einen Bugreport habe ich übrigens nach jedem Greenscreen an ADM geschickt.
 
ich hatte zum ersten mal einen bluescreen gehabt da hat mir das heraus stecken des HDMI Kabels geholfen.
 
Klingt vielleicht banal, aber wenn du eine leere Platte hast, Windows und aktuelle Treiber installieren, sonst nichts.

Wenns dann tut -> Software Problem
Wenns dann immer noch nicht tut -> Hardware Problem

Neuinstall + Treiber ist eine Stunde Zeitaufwand
 
  • Gefällt mir
Reaktionen: KarlsruheArgus
In meinem Bekanntenkreis hatten 2 Käufer einer 5700XT dieses Problem. Sie haben auch keine Lösung gefunden.

Sie konnten ihre GPU‘s zurückgeben.

Wir hatten dann zum Test eine 2070 eingebaut.
Die Probleme hörten sofort auf, sind dann beide zu NVidia gewechselt.

Ich weis das hilft dir nicht weiter, aber du bist damit nicht alleine.
 
  • Gefällt mir
Reaktionen: CMDCake
hm habe auch eine 5700xt aber weiss nicht mal wie ein green screen da aussieht scheint da echt ne streuung zu geben weil ich hatte z.b. noch nie sorgen gehabt.
 
  • Gefällt mir
Reaktionen: KarlsruheArgus und Erzi96
Scheinbar hat bei vielen Usern geholfen, Hardwarebeschleunigung in Software wie Discord, Chrome etc. auszuschalten - Hast du das mal ausprobiert?
 
Wenn du nur einen Monitor dran hast?
Wenn du keine Hintergrundprogramme/Browser am Laufen hast beim Spielen?
Gibt es dann auch dieses Problem?
 
Das Problem ist halt, das der Greenscreen sporadisch auftaucht und sich nicht reproduzieren lässt. Das erschwert die Fehlersuche enorm.

@borizb
Ein bischen schwierig mangels HDD/SSD, aber ich schau mal, ob ich nicht doch noch irgendwo was rumliegen habe.

@LipsiaV
Wenn ich das Problem nicht gelöst bekomme, werde ich wohl auch ins grüne Lager wechseln.

@trommelmaschine
Bei mir läuft Chrome, Firefox und Discord eigentlich immer mit und die Hardwarebeschleunigung habe ich schon ausgemacht.

@Sa.Lt
Mit nur einem Monitor? Schwer vorstellbar und daher werde ich morgen erstmal neue Displayport-Kabel kaufen. Falls es noch mal auftritt, muss ich wohl mal einen abklemmen oder mal den 3. Anschluss an der Graka nutzen.
Gerade habe ich jeweils ca. 4 Stunden LS19 und danach GTA V gespielt und 0 Probleme gehabt. Im Hintergrund war Discord, Chrome, Firefox und GPU Shark (zur Temp-Kontrolle) offen. Die Temp der GPU lag bei max. 77°C, die des Memory bei max. 96°C.

@Painkaos
Wie sollte es helfen, die ganzen (zum Teil unnötigen) Pakete drauf zu hauen? Ein Softwarefehler würde sich doch eigentlich anders äußern.
 
@Sa.Lt
Wie oben geschrieben: ließe sich der Fehler irgendwie reproduzieren, würde ich es testen, aber tagelang auf den Komfort verzichten ist halt nicht so meins ;)

@Painkaos
Danke, werde ich mir mal ansehen und auch mal testen.
Sollte der Greenscreen auf ein fehl konfiguriertes Windows deuten, dann müsste es ja auch Lösungen dafür geben, aber man findet einfach nichts.Es gab für viele auch viele unterschiedliche Lösungen, aber halt nichts allgemeines, wo man ansetzen könnte.
 
Es gab allerdings auch viele User bei denen ein Hardwaredefekt bei der 5700er Reihe vorlag - hier half der tausch der Karte über die Gewährleistung/Garantie.

Wann hast du deine Karte denn gekauft..?

Ich hatte eine XFX - die hat leider Blackscreens verursacht - Spiele sind oft garnicht erst gestartet.

Hab dann auf eine NItro+ gewechselt (weil die XFX nicht mehr verfügbar war) und hatte seither nicht ein Problem.

Hast du die Karte denn schonmal reklamiert?
 
Ich habe die Karte erst im Januar gekauft, aber auf meine Anfrage hat Alternate seit Dienstag noch nicht reagiert.
Meine Frau hat die XFX 5700XT Thic Ultra3 in ihrem Rechner und ich würde die testweise bei mir reinsetzen, aber sie ist dafür leider ca. 2-3cm zu lang bzw. mein Gehäuse zu klein. Da meine Karte bei ihr in gut 10-12 Stunden zocken keine Greenscreens gebracht, würde ich ja darauf tippen, das es etwas anderes als die Hardware selber ist.
Das Problem bleibt also leider weiterhin bestehen: der Fehler lässt sich nicht reproduzieren.
Morgen werde ich mir eine SSD organisieren und da erstmal nur Windows, Updates & Treiber installieren und sie als reine Spieleplatte nutzen. Mal sehen, ob dann wieder was passiert.
 
  • Gefällt mir
Reaktionen: Painkaos und Fuchiii
Prüfe mal ob das bei dir auch so aussieht
en.jpg

Es könnte auch sein, dass verschiedene auflösungen zwischen desktop und anwendung (spiel usw.) und auch im zusammen spiel mit enhanced sync diesen GSOD entstehen lassen.

Verwendest du einen monitor oder tv?
 
@Sa.Lt
Das wäre eine Möglichkeit, aber eine sehr aufwendige. Die würde ich als vorletztes in Betracht ziehen.

@Painkaos
Schnellstart ist bei mir nicht aktiviert, da wir schon in der Firma Probleme damit hatten und ich es daher zu Hause auch deaktiviert habe. Die Energieoptionen habe ich auch schon geprüft und in der Radeon-Software ist als Grafikprofil "Standard" eingestellt. EnhancedSync ist deaktiviert und FreeSync unterstützen die TFT nicht.
Die Auflösung ist zwischen Desktop & Game immer identisch (FullHD), nur die Hz halt nicht (1x 60Hz, 1x75Hz).

Heute konnte ich übrigens wieder stundenlang problemlos zocken. Meine HDD und SSD sind übrigens auch ok, was ich heute noch mal getestet habe. Memtest werde ich gleich noch starten und über Nacht laufen lassen.
Ab morgen werde ich dann mal eine andere SSD mit einem frischen Windows versehen.
 
Hallo,

ich hatte das Problem ebenfalls mit einer RX 5700 XT. Bei mir hat das hier geholfen:

Go to radeon performance and set your own fan control settings, make sure your fan runs at full speed when it reaches 58 degrees, and set fan noise control to max, lowering fan noise control makes the fan kick in at a later time overruling temps and fan settings, so setting this to max 100% will make sure your gpu gets the cooling it needs.

Save it as default.xml or any other name you like, and make sure when you update your drivers you need to apply the defaultl settings again, so keeping a backup of your default.xml on your harddisk is recommended.

Und man fragt sich jetzt was das soll, keine Ahnung, ich war so verzweifelt das ich einfach ALLES versucht habe und das hat bei mir funktioniert. Hoffe es hilft bei dir!

PS: Was funktionieren kann: Treiber neu Installieren und Standard anstelle von Gaming oder E-Sport auswählen. Dann in den Treiber Einstellungen unter Graphics bei den darunter stehenden vier Profilen ganz rechts "Custom" Auswählen und unten drunter alles (!) deaktivieren - hat zumindest in den Ami Foren bei vielen geholfen, hier die Anleitung:

1. Download the latest Driver installer from AMD's website https://www.amd.com/en/support
2. After the driver downloads run the driver installer
3. when promoted for the install locate the drop down arrow under the driver version check the box that says factory reset, when it ask if you want to keep your setting select NO
4. Let the drivers uninstall, your PC will restart on it's own and the Install will start momentarily
5. When promoted by the installer to select the default mode of the drivers select standard instead of gaming or e-sport.
6. your drivers should now install on there own and you are good to go
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: LipsiaV
@exxistenz
Die Lüfterkurve sieht eigentlich gut aus und ich habe beim Beobachten der Temps auch die Drehzahl im Auge gehabt. Sie ist eigentlich immer konstant mit den Temps angestiegen und nie schlagartig hochgegangen. Ich schaue mir das aber noch mal an.
In meinem letzten Post hatte ich doch geschrieben, das das Grafikprofil bereits auf "Standard" eingestellt ist.

nachtrag
Ich habe mit dem Lüfterprofil "rumgespielt" und spannend ist, das es scheinbar ignoriert wird oder anders funktioniert, als man es erwarten würde.
Eingestellt habe ich, das bei 65°C auch 55% RPM, aber nun lasse ich Furmark laufen und bei 61°C ist er schon bei 70% RPM. Seltsamkeiten...
 
Zuletzt bearbeitet:
@iwan: Das glaube ich dir aufs Wort - diese Erfahrungen das nicht so ist wie es sein sollte, dufte ich im Adrenalin Treiber ebenfalls machen. AMD hat ja zugegeben das es mit vielen Monitoren zu diese Green/Blackscreens kommen kann. Fakt ist aber dass der Adrenalin als solcher noch viel mehr Probleme mit sich bringt als das zugegeben wird.
 
  • Gefällt mir
Reaktionen: -Iwan-
Zurück
Top