Samba, keine Berechtigung bei Zugriff

Hegelbock

Ensign
Dabei seit
Nov. 2001
Beiträge
235
Hi Leute,

ich bin jetzt echt am verzweifeln. Ich sitze jetzt schon 2 Wochen an Linux, und versuche eine Freigabe für Windows zu erstellen. Ich bekomm es aber einfach nicht hin. Auf meinem Laptop hab ich XP Home drauf, und auf dem Server ist Linux Fedora Core 3.
Ich hab jetzt schon alle möglichen Sambakonfigurationen durchgemacht.

Ich finde den Samba Server ja, wenn ich unter Windows nach den Computern im Netzwerk suche, doch wenn ich versuch drauf zuzugreifen kommt immer das ich evtl. keine Berechtigung habe, oder es den Netzwerkpfad nicht ibt. :o
Ich habe auch schon bei Linux und bei Samba die user angelegt, doch es bringt nichts.

Ich hoffe mir kann einer weiterhelfen.
Achja, nochwas, Linux läuft auf VM-Ware auf dem Server. Aber ich denke das ändert nichts an der Tatsache.

Also, ich bin um JEDE Hilfe dankbar.

hier ist aber meine aktuelle:
Code:
[global]
    ; den Netbios-Rechnernamen f den Server einrichten
    netbios name = EAGLE
    ; die Arbeitsgruppenzugehigkeit einrichten
    workgroup = BERGWERK
    ; Samba f die Authentifizierung im User-Modus einrichten
    security = user
   encrypt passwords = yes
   browseable = yes
; Freigabname
[public]
   ; aufzulistender Text, wenn die Freigabe von einem Client
   ; er Browsing angesehen werden kann
   comment = Freigegebenes Verzeichnis f die Gruppe boss1
   ; absoluter Pfad zum Festplattenverzeichnis
   path = /public
  available=yes
 ; soll die Freigabe beschreibbar sein?
   writable = yes
   ; Benutzer, die sich mit der Freigabe verbinden knen sollen
  ; das @ bezeichnet eine Unix-Gruppe
   valid users = philipp.lang
   ; Datei-Locking aktivieren?
   locking = yes
   ; Standard-Berechtigungsmaske f Dateierstellung
   create mode = 0660
   ; Standard-Berechtigungsmaske f Verzeichniserstellung
   directory mode = 0770
; Freigabename
[homes]
   comment = Unix-Home-Verzeichnisbereich
   path = %H
   writable = yes
   valid users = %S
   create mode = 0600
   directory mode = 0700
   locking = no
 

marcelcedric

Commodore
Dabei seit
Mai 2003
Beiträge
4.342
Mit smbpasswd -a user und smbpasswd -e user hast du aber schon die Benutzer angelegt und aktiviert?

mfg
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
ja, hab ich. Ich kann auch mit smbclient super auf den freigegebenen Ordner zugreifen. Nur von Windows aus nicht :-(
 

marcelcedric

Commodore
Dabei seit
Mai 2003
Beiträge
4.342
Kannst du evtl. mal ein Screenshot posten? War solange nicht mehr unter Win unterwegs. ;-)

Und setz mal in deine Konfigurations folgende Zeile:

os level = 65

mfg
 

baFh

Captain
Dabei seit
Mai 2004
Beiträge
3.711
welche windows fehlermeldung?

baFh
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
Also, die Fehlermeldung lautet wie folgt:

Auf \\Eagle kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung, diese Netzwerkressource zu verwenden. Wenden Sie sich an den Administrator des Servers, um herauszufinden, ob Sie über Berechtigungen verfügen.

Der Netzwerkpfad wurde nicht gefunden.



Wenn ich os level = 65 setze, kommt immernoch diese Meldung.
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
Die Rechte auf die Ornder sind richtig gestezt. Auf den Public Ordner hat jeder alle Rechner. An dem kann es also nicht liegen.

@kalleberlin
Deine smb.conf hatte ich auch schon ausprobiert. Geht aber auch nciht. :(

Ich verzweifel jetzt echt so langsam. Hat den keiner noch ne Idee?
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
@Tim Schumacher
Ich benutze Windows XP.
 

kalleberlin

Lieutenant
Dabei seit
Feb. 2005
Beiträge
851
siehst du die ordner in der netzwerkumgebung? mach mal ein "ls -lh" und guck ob deine ordner wirklich dem richtigen benutzer bzw der richtigen gruppe gehören.
//edit: füge mal noch ein "read only = no" in deine public freigabe ein...
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
@kalleberlin
ja, auf den public Ordner sind alle Rechte gesetzt.
Und ich sehe keinen Ordner in der Netzwerkumgebung.
nichteinmal über den direkten Freigabepfad kann ich auf den publicornder zugreifen.
Das read only hat auch nichts gebracht. :-(

@Tim Schumacher
die registry Änderungen haben auch nichts gebracht.
 

kalleberlin

Lieutenant
Dabei seit
Feb. 2005
Beiträge
851
wenn du ein suse hast (weiß net ob des woanders auch so iss) tipp mal "rcsmb status" ein und guck ob samba wirklich läuft. wenn ja mach mal ein restart ("rcsmb restart").

gruß kalle

//edit:
du hast zwar schon ein "browseable =yes" global zu stehen aber setz es auch mal explizit in deine public freigabe.
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
hmm... ich benutze aber nur die shell, und da geht nicht viel mit SWAT.
 

Hegelbock

Ensign
Ersteller dieses Themas
Dabei seit
Nov. 2001
Beiträge
235
Hmm... das wäre ne Möglichkeit. Hab gerade danach gegoogelt. Was ist xinetd genau?
Könntest du mir mal deine Konfigurationsdatei von SWAT posten?
Wäre nett.
 

Morgoth

Captain
Dabei seit
Juli 2002
Beiträge
3.889
Zitat von Hegelbock:
Das ist ein Superserver. Eignet sich hervorragend dazu, andere Serverdienste nur dann zu starten, wenn sie benötigt werden.

Könntest du mir mal deine Konfigurationsdatei von SWAT posten?
Ich bin leider nicht zu Hause. Hier arbeitet der xinetd auf Gentoo, bei mir der inetd auf OpenBSD. Hier habe ich auch nicht die Not, übers Netz zu konfigurieren, sondern kann lokal drauf zugreifen.

Das steht in /etc/xinetd.conf:

Code:
service swat
{
        port            = 901
        socket_type     = stream
        wait            = no
        only_from       = localhost
        user            = root
        server          = /usr/sbin/swat
        log_on_failure += USERID
        disable         = no
}
Die inetd.conf sieht etwas anders aus, die Schlüsselwörter sind aber größtenteils gleich.

Um remote darauf zugreifen zu können, must Du mit dem only_from rumspielen. Entweder Du hast ne feste IP-Adresse (an dem PC an dem Du sitzt), dann trägst Du die ein. Bei einer dynamischen Adresse muss da glaube ich "any" stehen, bin mir aber nicht sicher.

Nachdem Du Dein Samba hinreichend konfiguriert hast kannst Du den xinetd wieder abschießen, den brauchts dann nicht mehr.

Zusätzlich muss noch in /etc/services das stehen:

Code:
swat            901/tcp
Gruß
Morgoth
 
Top