TP-Link Archer C7 1750 auf OpenWRT flaschen, finde die EU Firmware nicht..

Reaper75

Lt. Commander
Dabei seit
Jan. 2013
Beiträge
1.307
Hi CB-Community,

ich möchte meinen vorhandenen Router mit OpenWRT flashen, bekomme aber beim Flashvorgang immer die Fehlermeldung 18005 das die Firmware falsch sei. Diesen habe ich auf der offiziellen OPENWRT Seite runtergeladen, und als ich es genauer durchgelesen habe, stand da, das für die EU Version eine spezielle Firmware benötigt wird. Ich kann es irgendwie nicht finden. Kann mir jemand helfen?

Übrigens die Firmware Datei, habe ich schon in "openwrt.bin" umbenannt, da die Dateiname zu lang sei, falls jemand meint das dies die Fehlerquelle sei. Das hat unter der Weboberfläche von TP-Link auch keine besserung gebracht, leider.

Meine Hardware Revision ist dieser hier: Archer C7 V2 00000000 (1750)

Hier ist der Link:

https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500?datasrt=supported current rel

Die Firmware die ich runtergeladen habe ist von hier:

https://openwrt.org/toh/views/toh_fwdownload?dataflt[0]=supported current rel_=19.07.3

und zwar auf Stelle 745

THX.
 
Zuletzt bearbeitet:

Sykehouse

Commander
Dabei seit
Aug. 2018
Beiträge
2.216
Hast du auch die *-factory.bin Firmware genommen, nicht die *-sysupgrade.bin?

Eigentlich sollte das problemlos funktionieren:
For Archer C7 (confirmed for v2 and v2.1) installing OpenWrt is confirmed to work by simply uploading the OpenWrt firmware in the stock OEM's firmware-upgrade page.

Welche Version ist den aktuell auf dem C7 drauf?
 

timOC

Ensign
Dabei seit
Jan. 2009
Beiträge
235
Beim Flash aus dem Webinterface muss die firmware meines Wissens nach firmware.bin heissen, sonst mag die Flashroutine es nicht.

E. auf deren hilfeseite wird factory.bin empfohlen, ich meine ich hatte das Problem vor ein paar Monaten auch
 
Zuletzt bearbeitet:

Snowi

Lt. Commander
Dabei seit
Juni 2013
Beiträge
1.619
Bitte schau mal auf der Rückseite, da ist ein Aufkleber auf dem die Version steht. Siehe das Bild hier, im roten Kreis.
IMG_1878.jpg

Dann guckst du auf dem Link den du schon gepostet hast nach der Datei für deine Version. Wenn du noch die TP Link Firmware drauf hast, nimm die "OpenWRT Factory Firmware" in der Linken Spalte. Ich vermute du hast v5 vom Router, dann müsstest du den untersten Link in der Linken Spalte nehmen. Die Datei umbenennen in "factory.bin" oder sowas, und dann damit das Firmware-Update aus dem Webinterface starten.
1595682125100.png

//Edit: Sorry, der Link den ich meinte kam nicht von dir, sondern von foofoobar: https://openwrt.org/toh/tp-link/archer-c7-1750
 

Reaper75

Lt. Commander
Ersteller dieses Themas
Dabei seit
Jan. 2013
Beiträge
1.307
Update:

Egal, welche FW ich runterlade und versuche zu flaschen, es schlägt immer mit der Fehlermeldung 18005 fehl. Es behauptet immer es sei die falsche Version oder falsche datei.

Auf dem Router steht 2.0 also auf dem Aufkleber. Ich habe 2 Mal versucht die EU Version jetzt zu flaschen und es geht nicht. Ich probiers mal über einen anderen PC jetzt aus. Gibts noch einen Möglichkeit es zu flaschen?
 

Reaper75

Lt. Commander
Ersteller dieses Themas
Dabei seit
Jan. 2013
Beiträge
1.307
Update:

Also ich habe jetzt den Router mit meinem HauptPC verbunden und den Flashvorgang da versucht. Was soll ich sagen: Es hat geklappt! Vorher habe ich es mit meinem alten Laptop versucht und da ist es immer fehlgeschlagen. Merkwürdig. Also jetzt habe ich OpenWRT drauf, jetzt kann der Rest konfiguriert werden. Danke Euch für die tolle Hilfe.
 
  • Gefällt mir
Reaktionen: Snowi

Sykehouse

Commander
Dabei seit
Aug. 2018
Beiträge
2.216
Glad it worked! Viel Spass mit OpenWrt.

Das kann an einer Firewall oder am Antivirus gelegen haben.
 
  • Gefällt mir
Reaktionen: omavoss
Top