TrueCrypt "Volume already in use"

Brom

Lt. Junior Grade
Registriert
Okt. 2009
Beiträge
348
Hallo,
heute brauche ich mal eure Hilfe. Ich habe mir heute über Windows 8 Windows 8.1 als Neuinstallation installiert(auf der SSD). Auf einer zweiten Partition ist das einzige vorhandene Volumen mit Truecrypt verschlüsselt. In Win 8.1 hab ich dann einfach wieder TrueCrypt installiert und wollte die Partition wieder einbinden, aber es kommt nur eine Meldung, dass das Volumen bereits in Verwendung ist. In der Datenträgerverwaltung ist kein Laufwerksbuchstabe zugeordnet und es sollten auch keine Programme auf die Partition zugreifen, da ich außer TrueCrypt noch nichts installiert habe. Ich habe zwar ein Backup der Partition, die Daten wären also nicht alle weg, aber das Backup ist nicht mehr ganz aktuell. Es wäre also schön, wieder an die Daten ran zu kommen. Nachdem das einfache Mounten also nicht funktioniert hat, habe ich im Dualboot Ubuntu gebootet, damit hab ich auch schon öfter auf die Partition zugegriffen, aber es funktioniert dort auch nicht. Die Meldung ist nur "Passwort falsch oder kein TrueCrypt-Volumen". Dann hab ich wieder Windows gebootet, TrueCrypt meldet noch das gleiche. Dann habe ich versucht, den Volumenheader wiederherzustellen, das war erfolgreich, aber sonst hat sich nichts verändert.

Was kann ich noch tun?

Edit: jetzt sehe ich auch noch, dass in der Datenträgerverwaltung unter Dateisystem NTFS steht. Hat die Installation die Partition etwa formatiert?
 
Zuletzt bearbeitet:
ich vermute du hast mit deiner befürchtung recht.

versuche doch bitte, den laufwerksbuchstaben zu entfernen und dann zu mounten,
das "könnte" funktionieren - muss aber nicht.
 
Es ist mit keinem Laufwerksbuchstaben verbunden.
 
Also bei mir werden sämtliche (naja, es sind zwei) mit TrueCrypt verschlüsselte Partitionen als "RAW" angezeigt.

Also für mein Verständnis.

Partition 1 = Windows 8.1
Partition 2 = TrueCrypt

beides auf der SSD - Ubuntu Dualboot liegt dann vermutlich auf einer anderen Platte?

Wenn als Dateisystem NTFS angezeigt wird ist die Vermutung das die Platte platt ist recht naheliegend. Kannst du auf die Partition zugreifen wenn du ihr einen Laufwerksbuchstaben zuweist? Wenn ja ist das Ding formatiert.

edit:
schau dir mal TestCrypt an, das scheint bei "verloren gegangenen" partitionen ganz hilfreich zu sein.
 
Zuletzt bearbeitet: (testcrypt)
Also auf der SSD ist die Windows Partition mit 97GB drauf und 30GB Linux+SWAP. Auf der zweiten Festplatte ist nur das TrueCrypt Volume drauf. Wenn ich der Partition einen Laufwerksbuchstaben zuweise, erscheint ein Tmp-Ordner mit fünf Textdateien. Das sieht nicht gut aus. Hab den Laufwerksbuchstaben dann gleich wieder entfernt, bevor mir da noch irgendein Programm drauf rumschreibt.
 
Wenn Testcrypt nicht hilft und sonst niemand mehr weiter weiß würde ich dir den TestDisk-/ Datenrettungsthread ans Herz legen.
Vielleicht hast du Glück und kannst noch etwas (das Truecrypt dann hoffentlich auch mounten kann) wiederherstellen.
 
Gute Nachrichten. TestCrypt findet eine Partition. Siehe Screenshot.

Jetzt nochmal das ganze mit "DisableDriverSignature" in Windows, damit ich die Partition auch einbinden kann.

Jetzt habe ich das Volumen mit TestCrypt gemountet und versuche möglichst viele Dateien mit GetDataBack NTFS zu sichern. Ist das so richtig?
 

Anhänge

  • Unbenannt.png
    Unbenannt.png
    22 KB · Aufrufe: 245
Zuletzt bearbeitet:
Brom schrieb:
Jetzt habe ich das Volumen mit TestCrypt gemountet und versuche möglichst viele Dateien mit GetDataBack NTFS zu sichern. Ist das so richtig?
Ja, beim Überformatieren wird sonst nicht mehr viel helfen. Allerdings sollte man mit GetDataBack bzw. R-Studio annähernd alle Dateien zurückbekommen, so lange noch nicht viel auf die neue Partition geschrieben wurde.
 
Das hört sich ja gut an. Zurzeit hat GetDataBack 308.000 Dateien wiedergefunden. Beim ersten Versuch hatte sich das Programm dann in dem Schritt nach dem Anfang der NTFS Partition auswählen aufgehängt. Ich bin nun also beim zweiten Versuch.
 
Du kannst in GetDataBack sowohl direkt nach dem Scan als auch nach der Auswahl der MFT die Datenbank speichern - stürzt das Programm anschließend ab, so kannst du die Datenbank wieder laden.
 
Es hat alles funktioniert. Fast alle Daten sind noch da. Zwischen meinen Dateien sind aber die typischen Windows-Systemordner wie ProgramData, Programme und System zu finden. Das heißt, Windows hat die Installationsdateien einfach drübergeschrieben und danach wieder gelöscht. Ein sehr seltsames Verhalten.
Ergänzung ()

Jetzt wird's richtig seltsam. Ich hab nun alle Daten gesichert und wollte das Volumen formatieren. Das geht aber nicht. Sowohl über die Datenträgerverwalung als auch über diskpart. Die Partition hat nun einen Laufwerksbuchstaben und es sind einige Dateien zu sehen. In der Datenträgerverwaltung steht Fehlerfrei(System,Aktiv,Primäre Partition), Heißt das, dass Windows den MBR und andere zum booten notwendige Dateien auf diese Platte geschrieben hat? Kann ich die einfach löschen? Bevor Windows startet kommt ja erst der Grub Bootmanager, der ganz sicher auf der SSD liegt.
 

Anhänge

  • Unbenannt4.png
    Unbenannt4.png
    30 KB · Aufrufe: 189
  • Unbenannt3.png
    Unbenannt3.png
    12,5 KB · Aufrufe: 195
Ja, die Partition ist jetzt deine Systempartition ;)

Ich bin mittlerweile darauf übergegangen, bei einer Windowsinstallation alle unbeteiligten HDDs abzustecken. In deinem Fall könnte es reichen, die TrueCrypt HDD zu entfernen und anschließend mit der Startreparatur das System auf der SSD zu reparieren.
 
Ja, genau so hab ich es nun gemacht. Die Startreparatur musste aber vom Installationsdatenträger gestartet werden, weil der Start ja in keiner Weise ging.
 
Zurück
Oben