USB Stick wird kein Laufwerksbuchstabe zugewiesen

xlexx

Newbie
Dabei seit
März 2006
Beiträge
3
Hallo,

habe folgendes Problem :

Mein USB Stick wird ohne Probleme von Windows XP installier ,aber leider weist es ihm keinen Laufwerksbuchtstaben zu.

Habe versucht ihm einen durch die Datenträgerverwaltung zu vergeben ,aber bei
dem Klick auf die Laufwerksbuchstaben und Pfäde ändern passierte nichts.
Treiberleichen habe ich auch gelöscht , sowie den Schlüssel registry Schlüssel :
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR
dies hatte auch nicht geholfen.

Habe noch ein par Fragen ,die vielleicht das Problem lösen könnten :

Welche dienste ,sind für den Betrieb von USB Laufwerken ,außer dem Dienst Wechselmedien, nötig ??

Gibt es eine Möglichkeit ,dem USB Stick eine Laufwerksbuchstaben durch die Registry zu zuordnen.
 

noxon

Admiral
Dabei seit
Sep. 2004
Beiträge
7.287
AW: USB Stick wird kein Laufwerksbuchstabe zuwesiesen

Hast du zufällig ein Netzlaufwerk eingerichtet? Ich habe nämlich das Problem, dass meinem USB-Stick immer der gleiche Buchstabe wie der des Netzlaufwerks zugewiesen wird. Das scheint leider win Bug von WinXP zu sein.

Vielleicht hilft dir ja der "mountvol" Befehl weiter. Da könntest du dir zum Beispiel eine Batchdatei schreiben, die deinem Stick immer einen Laufwerksbuchstaben zuweist. Ist zwar nicht schön, aber als Workaround vorerst keine schlechte Lösung.
 

Noxman

Saddened
Dabei seit
Jan. 2002
Beiträge
24.654
@noxon,

hast du schonmal probiert deinen Netzlaufwerken die letzten Buchstaben des Alphabets zuzuordnen? So mache ich das bei meinen Rechnern unter XP und ich habe keine Probleme mit USB Sticks. :D

Gruss Nox
 

noxon

Admiral
Dabei seit
Sep. 2004
Beiträge
7.287
Naja. Ich wollte die Laufwerksbuchstaben eigentlich beibehalten, weil auf dem Rechner jede Menge Software installiert ist, die so konfiguriert ist, dass sie diese Laufwerksbuchstaben verwendet und ich nicht alles wieder umstellen wollte.

Es ist auch nicht mein PC, sondern einer hier in meiner Firma und da sind die Netzlaufwerke bei allen Rechnern auf den gleichen Buchstaben, damit es übersichtlicher bleibt.

Ich habe das Problem aber jetzt mittels "mountvol"-Befehl gelöst. Wenn mein Programm gestartet wird, dass auf den USB-Stick zugreifen muss, dann unmounte ich erst alle Laufwerksbuchstaben vom ersten Netzwerklaufwerk bis hin nach z:. Netzlaufwerke werden dabei nicht gelöst, sondern nur echte Laufwerke. So auch der USB-Stick. Er hat nun also keine Zuordnung mehr. Jetzt ermittle ich noch über mehrere Umwege die Volume-ID, die bei jedem USB-Stick unterschiedlich ist und mounte dieses Volume auf s:. Dort befindet sich nun immer mein USB-Stick auf den ich dann zugreifen kann.

Etwas umständlich, aber es funktioniert. Eine andere Lösung habe ich auf die Schnelle leider nicht gefunden.
 

xlexx

Newbie
Ersteller dieses Themas
Dabei seit
März 2006
Beiträge
3
Danke erstmal für die Antwort,
leider weiss ich nicht wie ich den Befehl "mountvol" einsetzten soll , denn wenn ich ihn ausführe ,werden nur die aktuellen Laufwerke angezeigt ,die bereits einen Laufwerksbuchstaben haben .
Mein USB taucht da leider nicht auf.

Die Antwort auf deine Frage :

Hast du zufällig ein Netzlaufwerk eingerichtet?

lautet nein.
 
Top