Virtualisierung & Ryzen 3900X

DH187

Cadet 2nd Year
Dabei seit
Sep. 2019
Beiträge
19
Habe den 3900X auf einem MSI MEG X570 ACE laufen und habe im BIOS SVN schon enabled.

Aber trotzdem scheint Windows das zu ignorieren.

Unter Windows Features ist der Windows Defender Application Guard ausgegraut mit der Info
'Windows Defender Application Guard wird von dieser Gerätekonfiguration nicht unterstützt'.

Speccy meldet unter den CPU-Eigenschaften
Virtualization: Supported, Disabled

Was kann der Grund sein? Muss ich noch irgendwo etwas de-/aktivieren?
 

Strikerking

Lt. Commander
Dabei seit
Jan. 2015
Beiträge
1.321
Hast du Windows 10 Pro? Und Speccy ist nicht mehr Aktuell, schau im Task-Manager nach.

Hier eine Anleitung.
https://www.computerweekly.com/de/ratgeber/Windows-Defender-Application-Guard-sichert-Windows-10-ab

Um in Windows 10 den Windows Defender Application Guard zu nutzen, müssen über die optionalen Features im Betriebssystem die beiden Features „Hyper-V“ und „Windows Defender Application Guard“ installiert werden. Die optionalen Features werden am schnellsten über das Suchfeld im Startmenü durch Eingabe von optionalfeatures erreicht.
 

BFF

Admiral
Dabei seit
Okt. 2017
Beiträge
7.736
Hast Du ein W10 Prof oder ein Home?

BFF
 

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Windows 10 Pro 1903
Aber noch nicht aktiviert. Das sollte aber nicht der Grund sein.

VirtualBox sagt mir, dass VT-x/AMD-V/Nested Paging vorhanden ist. (habe extra SVN noch einmal deaktiviert um zu sehen, ob dies dann verschwindet)
Speccy scheint daher die Daten nicht korrekt zu melden.

Microsoft fordert noch
"Extended Page Tables, auch als Second Level Address Translation (SLAT) bezeichnet"
Habe zwar gefunden, dass das eine Intel-Bezeichnung ist und AMD dies Rapid Virtualization Indexing (RVI) nennt, aber nicht woran ich erkenne, ob das aktiviert / vorhanden ist.

Nachtrag:
Noch ein Hinweis, wobei ich aber aufgrund des letzten Teils denke, dass das Ganze nicht relevant ist.
Der Rechner befindet sich in einer Domäne. In der Gruppenrichtlinie ist der Windows Defender Application Guard aber nicht konfiguriert. Außerdem scheint die wohl nur für die Enterprise Version zu gelten.
 
Zuletzt bearbeitet:

wahli

Vice Admiral
Dabei seit
Feb. 2010
Beiträge
6.282
Läuft Hyper-V?

Virtualisierungsfunktion Hyper-V abschalten:
Windows-Einstellungen -> „Apps & Features“, auf der rechten Seite auf „Programme & Features“ -> „Windows-Features aktivieren und deaktivieren“ auswählen -> Haken bei „Hyper-V“ entfernen -> Bestätigen und Neustart

Weitere mögliche Ursache:
Öffne „Windows Defender Security Center“ -> auf „Gerätesicherheit“ wechseln -> „Details zur Kernisolierung“ -> Option „Speicher-Integrität“ deaktivieren und Neustart
 

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Anbei ein Screenshot (VirtualBox & Windows Features)
WDAG.png

Hyper-V war anfangs nicht aktiv (also nichts aktiviert). Nach dem Beitrag von Strikerking habe ich alles aktiviert und den Rechner neu gestartet.
Ist aber egal - in beiden Fällen bleibt das Häkchen disabled.
Ist denn nun Hyper-V notwendig oder nicht? Die Aussagen sind ja jetzt widersprüchlich.
Aktiviert kostet das im Cinebench ca. 4% Performance. Da würde ich am liebsten drauf verzichten.

Die Option Speicher-Integrität war schon ausgeschaltet.

Nachtrag:
Ich habe den Rechner aus der Domäne genommen. Wie erwartet ist das aber nicht der Grund.
 
Zuletzt bearbeitet:

corvus

Lieutenant
Dabei seit
Jan. 2018
Beiträge
838
Wenn Hyper-V angeschaltet ist, funktionieren andere Virtualisierer normalerweise nicht nicht.
Ist im BIOS IOMMU aktiviert? Evtl. meckert der deswegen noch, zur Not mal Defaults zurücksetzen.

Ist das Feature Windows-Hypervisor-Plattform aktiv?
 

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Ich hatte IOMMU anfangs auf auto stehen, später dann, da MS es zwingend empfiehlt auf enabled gesetzt.

Windows-Hypervisor-Plattform ist zumindestens aktiviert (wie auf dem Screenshot zu sehen).

Ich überlege echt, Windows noch einmal neu zu installieren (war schon auf dem Rechner schon vorinstalliert.
Hatte Windows schon einmal zurückgesetzt und das hatte nichts gebracht. Daher scheue ich diesen Schritt noch und hoffe, dass es noch DEN Hinweis gibt.

Lt. Murphy wird es den aber wohl eh erst geben, nachdem ich den Rechner platt gemacht habe.
 

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Okay, danke für die Info zur Unterscheidung. Windows-Hypervisor-Plattform war nicht aktiv, aber ein Aktivieren hat nichts geändert. Der Eintrag für den Windows Defender Application Guard bleibt weiterhin disabled.

Nachtrag:
Bin ein Stück weiter.
Per Powershell lässt sich WDAG aktivieren:
Enable-WindowsOptionalFeature -Online -FeatureName Windows-Defender-ApplicationGuard
NAch einem Reboot ist die Option checked & enabled.
Aber im EDGE taucht weiterhin kein Eintrag auf.

Wenn ich WDAG deaktiviere und danach neu boote, dann ist der Eintrag wieder disabled. :-(
 
Zuletzt bearbeitet:

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Ich habe den Rechner noch einmal vollständig platt gemacht und Windows Pro 1903 von DVD installiert.
Leider hat das, wie schon vermutet, keine Auswirkungen und ich kann weiterhin WDAG nicht aktivieren bzw. nutzen.
 

wahli

Vice Admiral
Dabei seit
Feb. 2010
Beiträge
6.282
MSI Support?
 

cscmptrbs

Cadet 2nd Year
Dabei seit
Okt. 2019
Beiträge
26
Den Grund sehe ich auch noch nicht, ist bei dem neuen 3900x genau so. Allerdings auch noch nicht aktiviert.
Ich sehe sonst keinen Unterschied in den Kisten (OK, der neue hat ein neueres Windows), auch auf dem neuen läuft VirtualBox mit Boinc Atlas, also Hyper-V aus und SVN an.
Werde da jetzt aber erstmal ein Linux drauf installieren.
 

DH187

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Sep. 2019
Beiträge
19
Bislang bin ich mir ja nicht sicher, dass es an MSI liegt. Daher wollte ich wissen, wie das bei anderen MSI-Nutzern aussieht.

Windows habe ich in der Zwischenzeit aktiviert. Hat natürlich auch nichts gebracht.

Nachtrag:
Hatte nun doch den MSI-Support kontaktiert.
Eine Antwort kam relativ zügig
vielen Dank für Ihre Anfrage.
Hier sollten Sie sich an Microsoft wenden.
Man hat mir auch empfohlen UEFI zu aktivieren und dann 2 Screenshots vom BIOS (einmal für ein X570 und einmal für ein Z390) gesendet. Und das, obwohl ich klar von Problemen mit einem 3900X auf einem X570 Ace schrieb. Also alles nur Textbausteine.
 
Zuletzt bearbeitet:
Top