Wake on Lan über Internet

Hamschter

Lt. Junior Grade
Dabei seit
Aug. 2008
Beiträge
360
Hallo zusammen,

ich betreibe einen Rechner als Datengrab und würde den gerne auch von unterwegs aus wecken können. Über Lan geht es ohne Probleme. Aber über das Internet (Handy 3g) geht es nur manchmal. Ich konnte aber noch kein Muster erkennen, warum es manchmal klappt, meistens aber nicht.
Dadurch, dass es manchmal funktioniert, kann man ja schließen, dass der Router richtig konfiguriert ist. Ich habe aber leider keine Idee woran es liegen könnte, dass es dann ein paar Stunden später wieder nicht mehr klappt..

Zum Setting:
- der Rechner ist komplett heruntergefahren
- Win 7
- Mainboard: ASRock H87M

Hat jemand von euch einen Hinweise für mich?

Vielen Dank für eure Mühe!
Hamschter
 

thompson004

Admiral
Dabei seit
Apr. 2011
Beiträge
7.947
Router Reset und dann nach einer Anleitung richtig konfigurieren, schon probiert?
 

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.586
Magic Packets (WoL-Pakete) sind nicht für das Internet vorgesehen. Das heißt im Klartext: Die Wahrscheinlichkeit, dass eine Zwischenstation von deinem Handy bis zu deinem Router Magic Packets verwirft, ist relativ hoch. Manchmal erwischt man einen "sauberen" Pfad und alle Stationen reichen das Paket brav weiter.

Man könnte das mit einem VPN-Tunnel umgehen. Dazu bräuchte man aber einen VPN-Server innerhalb deines Netzwerks, der immer an ist - einige Router können das bereits (zB FritzVPN). Verbindet man sich nun via VPN mit dem eigenen LAN, wandert das Magic Packet in einem verschlüsselten VPN-Datenpaket durchs Internet und obige Spielverderber merken gar nicht, dass sie gerade ein WoL-Paket weiterleiten.
Wenn du keine Fritzbox oder einen anderen Router hast, der VPN unterstützt, ist evtl. eine alternative Firmware eine Option (OpenWRT, DD-WRT, etc). Oder aber man besorgt sich einen Raspberry PI (oder vergleichbar), der nur ~3 Watt schluckt und diese Aufgabe wunderbar übernehmen kann ;)
 

Hamschter

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Aug. 2008
Beiträge
360
Vielen Dank für eure Antworten. Ich gehe sie mal nacheinander durch:

Neustart vom Router hat nichts gebracht.

Einen VPN Server kann der Router nicht betreiben (TP-Link wdr3600)

Für DNS benutze ich no-ip.com
 

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.586
Wenn du deinen Rechner zuverlässig von außen aufwecken willst, hast du nun zwei Möglichkeiten:

1) Router mit OpenWRT flashen (klick!) -> VPN-Funktion
2) Raspberry PI oder vergleichbaren KleinstPC kaufen und als VPN-Server einsetzen

Ob du bei no-ip.com oder sonstwo bist, ist dabei vollkommen unerheblich. Es geht um die Route, die das Magic Packet auf dem Weg durchs Internet nimmt. Das ist unabhängig vom DNS-Eintrag, weil unterm Strich ja nach deiner WAN-IP geroutet wird. Theoretisch kann es sogar sein, dass zwei Pakete nacheinander eine andere Route nehmen, weil sich unterwegs etwas geändert hat. Das eine Paket geht durch, das andere Paket wird irgendwo auf dem Weg verworfen.
 

Hamschter

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Aug. 2008
Beiträge
360
Rajiin, danke für deine ausführliche Bewertung. Aber so ganz kann das bei mir nicht zustimmen, weil ich habe das folgende Phänomen:
Der Server ist schon länger aus und lässt sich nicht per Inet wecken. Ich wecke ihn per lan und fahre ihn direkt wieder runter. Danach kann ich ihn per Inet wecken. Um Zufall auszuschließen wiederhole ich das ganze. Also wieder wecken per Inet, aus, wecken per Inet, aus....klappt jedes Mal.
Warum klappt das aber nich, wenn der Server länger aus war?
 

Kingfisher OK

Rear Admiral
Dabei seit
Dez. 2007
Beiträge
5.121
Vielleicht weil ein Eintrag in der Routingtabelle fehlt wenn du über den Router gehst. Kannst ja mal gucken ob das Phänomen auch auftritt wenn du den Router zwischen drin neustartest .

Gruß

Edit.:
Gibt es bei TP-Link die möglichkeit feste einträge einzustellen? Bei der fritzbox gibt es dazu den Punkt "diesem Netzwerkgerät immer die gleiche IP zuweisen"
 
Zuletzt bearbeitet:
Top