Windows 7 bootet nicht im UEFI-Modus

beatschubser

Cadet 3rd Year
Dabei seit
Nov. 2016
Beiträge
32
Hallo zusammen,

ich habe letzte Woche Windows 7 neu aufgesetzt und dabei darauf geachtet, dass die UEFI-Version installiert wurde: Beim Booten den entsprechenden Eintrag gewählt (DVD-Laufwerk im UEFI-Modus) und anschließend geprüft, ob die Systemplatte mit GPT und nicht MBR formatiert wurde. Das hat soweit funktioniert.

Wenn ich nun allerdings im BIOS meines Mainboards (Asus Z170 Pro Gaming) das CSM deaktiviere, passiert beim Booten folgendes: Die Windows-Animation erscheint für ein paar Sekunden, kurz vor dem Login-Bildschirm startet der Rechner jedoch neu, das BIOS meldet einen Fehler mit der UEFI-Konfiguration und reaktiviert den CSM-Modus.

Ich habe keine Ahnung, wo das Problem liegen könnte. So viele Einstellungen diesbezüglich gibt es ja nicht. Hat jemand eine Idee?

Gruß
Dan
 

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
17.790
Mal ins Blaue geraten. Du hattest noch alte Laufwerke während der Installation angestöpselt und dort sind nun Bootdateien drauf gelandet, die du nur mit aktiviertem CSM erreichst. Bootet der Rechner alleine mit seinem Windows-Laufwerk ohne andere Laufwerke?

Generell müsstest du das reparieren können. Versuche Windows abgesichert zu starten und dann die Computerreparatur auszuführen.
 

Blueline56

Commander
Dabei seit
Juni 2010
Beiträge
2.627
Ich habe mal vor ca. einen Jahr hier mit den selben Problem und Board gelesen, schien wohl an der Grafikkarte zu liegen, soweit ich noch weiß handelte es sich dabei um eine AMD Fury von Sapphire und deren Bios.
 

muesler

Lt. Commander
Dabei seit
Apr. 2005
Beiträge
2.030
32bit oder 64bit?

Edit: Warum lässt Du CMS nicht einfach an, stört dich das bei irgendwas?
 
Zuletzt bearbeitet:

beatschubser

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2016
Beiträge
32
Mal ins Blaue geraten. Du hattest noch alte Laufwerke während der Installation angestöpselt und dort sind nun Bootdateien drauf gelandet, die du nur mit aktiviertem CSM erreichst. Bootet der Rechner alleine mit seinem Windows-Laufwerk ohne andere Laufwerke?

Generell müsstest du das reparieren können. Versuche Windows abgesichert zu starten und dann die Computerreparatur auszuführen.
Während der Installation waren nur die Systemplatte (Samsung 960 Evo am m.2-Port) und das DVD-Laufwerk angeschlossen. Die alte Systemplatte habe ich danach wieder angeschlossen und mit diskpart plattgemacht und anschließend formatiert.

CSM stört mich eigentlich nicht, aber wenn man alles neu aufsetzt, will man es auch richtig machen ;) Und im reinen UEFI-Modus soll die Kiste ja schneller booten.

Grafikkarte ist eine MSI GTX 1070. Windows ist als 64 Bit-Version installiert.

Muss für UEFI eigentlich zwingend Secure Boot aktiviert sein?
 

Opa Hermie

Commander
Dabei seit
Mai 2013
Beiträge
2.222
Nein, es gibt ein paar wenige OEM-PCs/Laptops, die z.B. kein CSM oder abschaltbaren Secureboot haben. In der Regel kann man das aber passend einstellen, für Windows 7 MUSS Secureboot aus. Allerdings setzt Secureboot UEFI voraus.

Vermutlich aktiviert Dein CSM Legacy-Support, ich hatte das beschriebene Problem auch mehrfach; in einem Fall ließ es sich aber lösen, indem alle Treiber installiert wurden, dann konnte CSM abgestellt werden.

Ansonsten müsste ein echter Bescheidwisser mal was dazu schreiben, was Legacy-Mode überhaupt ist und wie man den einwandfreien Start sicherstellt.
 

Bolko

Commander
Dabei seit
Sep. 2012
Beiträge
2.081
Ansonsten müsste ein echter Bescheidwisser mal was dazu schreiben, was Legacy-Mode überhaupt ist und wie man den einwandfreien Start sicherstellt.
Das wüsste ich auch gerne.
Besonders, was die diversen Hersteller unter "Legacy" verstehen.
Die Option "Legacy" reagiert nämlich je nach Hersteller des Mainboards unterschiedlich:
The legacy mode settings differ from machine to machine. For example on this Lenovo if it can't boot from legacy mode it will switch to UEFI, although it is quite a slow process.
On other machines like my Dell it tries to boot into legacy mode and if it can't it just gives up.
http://www.everydaylinuxuser.com/2016/07/how-to-understand-your-uefi-and-bios.html


Bei solchen nicht standardisierten Optionen wie "Legacy" kann man Glück haben oder Pech oder man braucht entweder Insiderwissen oder ungesund viel Zeit und Frustresistenz, um das per trial-and-error durchzutesten.
Dieser Aufwand lohnt sich kaum.
Falls man durch Zufall an solche Infos gelangt, dann kann man diese benutzen und einbauen, aber sämtliche Möglichkeiten durchzutesten steht in keinem Verhältnis mehr zum Nutzen.
Dann verzichtet man halt einfach besser auf UEFI oder auf Windows oder auf diese spezielle Hardware.
Wenn die Hardware-Hersteller und die Betriebssystem-Hersteller solche Infos nicht freiwillig herausgeben, tja, dann scheiß drauf. Solche künstliche Inkompatibilitäten sollte man nicht durch Produktkauf belohnen.
 

Opa Hermie

Commander
Dabei seit
Mai 2013
Beiträge
2.222
Hallo Bolko,

wieder da?

Beim Dell XPS gibt es sogar beide Optionen getrennt: Einmal das übliche UEFI/CSM und dann zusätzlich Legacy on/off. Windows 7 ging nur mit allen Treibern im Image oder man nutzt Legacy und nach Treiberinstallation schaltet man es ab.
 
Top