[Xubuntu] Keine Updates, da \boot voll

mensch183

Captain
Dabei seit
Jan. 2008
Beiträge
3.618
Und das gleiche für die jeweils 2 Pakete mit -27, -29, -32 und -33 am Ende. Damit wäre nur der aktiv laufende -30 noch da.

Mich wundert bischen, dass linux-image-3.13.0-30 auf iF steht. Also lief schon bei dessen Installation etwas nicht rund. Immerhin tut ers ja offensichtlich.

Kann ich nicht einfach /boot auf die root-Partition verschieben? On the fly ... ohne das etwas kaputt geht?
Musst nach dem Kopieren /etc/fstab und die Grub-Konfiguration anpassen, weil die Boot-Partition ja dann eine andere ist. Kümmere dich lieber erstmal um das Kernel-Wirrwarr statt noch eine 2. Baustelle zu eröffnen.
 
Zuletzt bearbeitet:

Crys

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
1.206
Danke Gerii, das war es!

Ich habe nachfolgendes Ausgeführt:
Code:
dpkg -P --force-all linux-image-extra-3.13.0-24-generic linux-image-3.13.0-24-generic
; dann war genügend platz für
apt-get -f install
; nach dem Neustart dann
apt-get autoremove
; und schon ist /boot nur 29% belegt
Und natürlich vielen Danke auch an alle anderen! :daumen:


Musst nach dem Kopieren /etc/fstab und die Grub-Konfiguration anpassen, weil die Boot-Partition ja dann eine andere ist. Kümmere dich lieber erstmal um das Kernel-Wirrwarr statt noch eine 2. Baustelle zu eröffnen.
Im Prinzip geht es jetzt ja, aber muss ich das jetzt alle paar Monate ausführen!?
Würde das gerne vermeiden.

Ich bin mit Xubuntu auf dem LTS Kanal und es werden nur Sicherheitsupdates installiert und das glaub ich nur, wenn ich neustarte und der Server ist jetzt 3 Monate 24/7 gelaufen.
Kann es daran gelegen haben, dass er die Updates heruntergeladen hat, aber nicht installiert und somit die /boot voll gemacht hat?
 

Caedus

Lieutenant
Dabei seit
März 2012
Beiträge
513
Im Prinzip geht es jetzt ja, aber muss ich das jetzt alle paar Monate ausführen!?
Würde das gerne vermeiden.
Solange du nach jedem Kernel-Update apt-get autoremove ausführst, läuft /boot auch nicht mehr voll.

Ich bin mit Xubuntu auf dem LTS Kanal und es werden nur Sicherheitsupdates installiert und das glaub ich nur, wenn ich neustarte und der Server ist jetzt 3 Monate 24/7 gelaufen.
Ich bin nicht 100% sicher, wie Ubuntu das handhabt, aber meines Wissens werden sicherheitskritische Updates automatisch installiert bzw. können automatisch installiert werden und Kernel-Updates zählen dazu.
Ich wüsste keine Distro, die Updates beim Neustarten installiert ...
Du könntest jedoch nachschauen, ob automatische Updates bei dir aktiv sind und ggf. deaktivieren und die Update-Installation manuell machen.

Kann es daran gelegen haben, dass er die Updates heruntergeladen hat, aber nicht installiert und somit die /boot voll gemacht hat?
Nein.
Würden die Updates nur runtergeladen werden, würde irgendwo, vmtl unter /var/apt/cache oder so das .deb mit dem Kernel-Update liegen und sonst nichts weiter.
 

Crys

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
1.206
Das Problem besteht weiterhin. Mit der Anleitung aus #22 kann ich das wieder fixen, aber das ist dennoch lästig.


Solange du nach jedem Kernel-Update apt-get autoremove ausführst, läuft /boot auch nicht mehr voll.
Ich habe seit meinem letzten Post eig. nichts mehr an den Server geändert, der hat aber dennoch neue Updates (LTS) geladen und installiert und führt dann anscheinend kein 'apt-get autoremove' aus ...


Ich wüsste keine Distro, die Updates beim Neustarten installiert ...
Windows :)
 

Daaron

Fleet Admiral
Dabei seit
Dez. 2011
Beiträge
13.487
autoremove wird auch nicht automatisch ausgeführt. den musst du schon manuell anstoßen.... oder per Cronjob irgendwie eintakten.
 
Top