Youtube-Videos ruckeln in Vollbild

J

Jxn

Gast
Hallo,

habe seit einiger Zeit das Problem, dass wenn ich Youtube-Videos auf gucke, diese im Vollbild anfangen zu ruckeln. Bei normalen Videos in Full HD geht es, sofern ich nichts anderes nebenbei mache. Sollte ich die Maus über das Video bewegen oder mit den Pfeiltasten 5 Sekunden vor oder zurück gehen, fängt das Video an zu ruckeln, sodass Ton und Video asynchron werden. Nach einigen Sekunden fängt sich das ganze dann wieder, indem das Video auf einmal ganz schnell abgespielt wird, bis Ton und Video wieder synchron sind.

Ganz schlimm ist es bei 1080p und 60fps. An Hardware (siehe Signatur) und Internet sollte es eigentlich nicht liegen. Habe eine 100k Leitung.

Ich benutze den Google Chrome-Browser, mit folgenden Erweiterungen: Adblock Plus, Adobe Acrobat, Wappalyzer. Und halt noch die Standard-Sachen von Google.

Hatte schon mal jemand ähnliche Probleme?

Grüße
 

Vitali.Metzger

Rear Admiral
Dabei seit
März 2013
Beiträge
5.821
Scan mal deinen Rechner mit Malwarebytes.
 

Autokiller677

Admiral
Dabei seit
Jan. 2009
Beiträge
8.170
Beobachte mal die CPU Last.

Ich hab es bei meinem (alten) Phenom II auch. Liegt daran, das Youtube mittlerweile immer VP9 oder so ausliefert und vielen älteren CPU's / GPU's dafür die Hardwarebeschleunigung fehlt. Ich hab in Chrome das Addon h264ify drin, damit wird h264 erzwungen. Dann ist die CPU Last auch wieder im einstelligen Bereich und der Hardware-Decoder wird genutzt.

Gleiches gilt auch für die 60Hz. Die machen bei mir auch mit h264 die CPU platt, weil keine Hardwarebeschleunigung. Allerdings habe ich da noch keinen Weg gefunden, 30Hz zu erzwingen...

Wahrscheinlich wird daher der fehlende Featurelevel bei Decodern für mich der zwingende Grund, einen neuen PC zu kaufen. Yay...

EDIT:

Deine 1060 sollte das eigentlich können. Deine CPU wohl nicht (https://en.wikipedia.org/wiki/VP9#Hardware_implementations)
Schau mal im Browser deiner Wahl, ob du irgendwo Hardwarebeschleunigung für VP9 aktivieren kannst. (about:config oder sowas)

EDIT2:
Unter chrome:gpu sollte dazu was auftauchen.
 
Zuletzt bearbeitet:
J

Jxn

Gast
Pendelt zwischen 30%-50% (mit Task-Manager überprüft). Ich habe zwar keinen Referenzwert, das erscheint mir aber doch relativ hoch.

Scan mal deinen Rechner mit Malwarebytes.

Werde ich mal machen. Nachdem der Luke Firewalker eben durchgelaufen ist.
Ergänzung ()

Also ausgehend von diesem Youtube-Video, ist es anscheinend bei mir nicht möglich. Ich habe dort nämlich keine Einstellungen bezüglich VP9, die ich aktivieren könnte.
 

Autokiller677

Admiral
Dabei seit
Jan. 2009
Beiträge
8.170
Das Video ist auch schon 4 Jahre alt. Damals war VP9 eben noch experimentell und deshalb unter den Flags.

https://youtube.com/html5 sagt einem, welche Formate youtube als unterstützt erkennt.
Und eben chrome:gpu

30-50% sind zu viel. Wenn da ein Hardware Decoder laufen würde, wären das eher 5-10. Maximal.
 
J

Jxn

Gast
Ich habe mir jetzt auch mal die Erweiterung h264ify installiert. Mal schauen ob es etwas hilft.
Ergänzung ()

Tatsächlich hilft es nicht. Auslastung immer noch bei gut 30%. Kann ich irgendwie überprüfen, ob das Video "umgeschaltet" wurde?
 

Hauro

Admiral
Dabei seit
Apr. 2010
Beiträge
9.248
Kann ich irgendwie überprüfen, ob das Video "umgeschaltet" wurde?
Siehe Codecs
Zitat von Statistiken für Nerds:

Video ID / CPN: oufUkjPhs74 / jnTawr_6za00nSKu
Viewport: 2560x1440
Current / Optimal Res: 3840x2160@60 / 3840x2160@60
Volume / Normalized: 90% / 40% (content loudness 6.9dB)
Codecs: vp9 (315) / opus (251)
Host: r6---sn-h0jeen7r
Connection Speed: 44081 Kbps
Network Activity: 1328 KB
Buffer Health: 11.01 s
Dropped Frames: 108/15247
Beispiel-Video

https://www.youtube.com/watch?v=oufUkjPhs74
 

cbtestarossa

Admiral
Dabei seit
Okt. 2011
Beiträge
8.699
Browser html5 mp4 Videos sind trotz GPU Unterstützung einfach nur lahm.
Die selben Videos im VLC brauchen viel weniger CPU Last.
MediaPlayer-HC/BE könnens noch besser.
Selbst Flash war genügsamer aber das hat Youtube ersatzlos gestrichen.
 

Autokiller677

Admiral
Dabei seit
Jan. 2009
Beiträge
8.170
Also bei mir ist die CPU Last mit h264ify auf unter 10% runter (Gesamtsystem, Chrome 4-6%). So pauschal kann man das also nicht sagen, dass das alles "lahm" ist.

Wobei ich gestern nochmal etwas mehr getestet habe und gesehen habe, das h264ify auch 60fps Videos blocken kann - das bringt bei mir aber keine Besserung. Youtube bietet zwar 60fps nicht mehr an, trotzdem ruckeln diese Videos bei mir noch. Allerdings mit besagter CPU Last unter 10%. Auf dem Laptop (ähnlich alt) hab ich die Probleme nicht. Unter Linux generell nicht.

​Scheint ein Problem von Chrome / Windows oder so zu sein.
 

Hauro

Admiral
Dabei seit
Apr. 2010
Beiträge
9.248
Das Video wird aktuell als H.264/MPEG-4 AVC (Advanced Video Coding) "avc1.64002a" und MPEG-4 audio "mp4a.40.2" wiedergegeben.
Zitat von Codecs: vp9 (303) / opus (251):

Video ID / CPN: ZSn3Tvc7jQU / IR0YmWcxFHXWY1Fa
Viewport:1920x1080
Current / Optimal Res: 1920x1080@60 / 1920x1080@60
Volume / Normalized:100% / 100%
Codecs: vp9 (303) / opus (251)
Host:r1---sn-h0jeened
Connection Speed: 40512 Kbps
Network Activity: 0 KB
Buffer Health: 35.46 s
 
Zuletzt bearbeitet:

Nureinnickname!

Captain
Dabei seit
Jan. 2010
Beiträge
3.886
googlechromekopies2p8g.jpg
Normalerweise sollten mit der 1060 dank GPU Decoder auch 8K Videos flüssig laufen.

Hardware beschleunigung in Chrome Aktivieren.
hardwarebeschleunigune3ocm.png
 
Zuletzt bearbeitet:

cbtestarossa

Admiral
Dabei seit
Okt. 2011
Beiträge
8.699
Mach mal Gegenprobe mit MPC-HC/BE oder VLC.
Normalerweise müsste das noch mal viel weniger CPU Last verursachen.

Und mit deiner CPU könnten sich auch die vielen Kerne und SSE/AVX positiv auswirken.
Richtig merken tust es erst auf langsamen CPUs wo man ohne Graka Unterstützung einpacken kann.
 
Zuletzt bearbeitet:

Nureinnickname!

Captain
Dabei seit
Jan. 2010
Beiträge
3.886
Und mit deiner CPU könnten sich auch die vielen Kerne und SSE/AVX positiv auswirken.
Richtig merken tust es erst auf langsamen CPUs wo man ohne Graka Unterstützung einpacken kann.
Nö, da ich extra in 8K getestet hab um das Auszuschließen, Siehe CPU Last ohne Hardware beschleunigung ->
gegenbeweisohnehardwaiest7.png

Hier wurde nur die Hardware Beschleunigung in Google Chrome Deaktiviert sonst nix.
 

Nureinnickname!

Captain
Dabei seit
Jan. 2010
Beiträge
3.886
Zuletzt bearbeitet:

cbtestarossa

Admiral
Dabei seit
Okt. 2011
Beiträge
8.699
Dann nimm halt ein xbeliebiges MP4 h264 FullHD File und vergleiche damit.
Wäre ja sensationell wenn der Browser weniger CPU Last verbraten würde und entspräche nicht meinen Erfahrungen.
Nicht umsonst gibt es Browser Addons die ein Video an einen externen Player schicken und dort abspielen.

Wenn ich zB im Browser eine CPU Auslastung von 40% habe dann entspricht das im MPC-HC ca 5 %.
VLC braucht etwas mehr. Und ja natürlich mit HW Unterstützung überall.
Sogar Flash war viel besser bei Youtube.
 
Zuletzt bearbeitet:
Top