1-10 sec Freezes / Crashes bei Spielen

Noxtravibur

Cadet 2nd Year
Registriert
Juli 2020
Beiträge
18
Hallo zusammen, ich habe seit ein paar Monaten ein für mich unlösbares Problem. Etwa 30 Minuten nachdem ich meinen PC und ein Spiel gestartet habe, treten etwa 1-10-sekundenlange Freezes auf, die im Extremfall in Crashes enden. Meistens kann ich danach weiterspielen, allerdings ist es mittlerweile wirklich frustrierend. Ich dachte erst, es liegt vielleicht an dem Prozessor, der durchaus mal sehr heiß werden kann, allerdings hatte ich dann einen Crash, nachdem eine Festplatten-Anschluss-Meldung kam. Deswegen bin ich nicht sicher, ob es am Prozessor oder an der/den Festplatten liegt.

Details zum Problem:
  • Video:
  • 1-10 Sekunden, Sound läuft noch kurz weiter, dann unterbrochen
  • tritt meist nicht direkt nach Start des Computers auf, nach einer Weile jedoch ununterbrochen
  • Temperaturen sind für den Prozessor okay, immer im Bereich um die 80 Grad, war allerdings schon immer so und hatte vorher nie Probleme damit
  • Task-Manager zeigt immer Einbrüche der Leistung von GPU, CPU und den Festplatten an, geht alles kurz auf etwa 20% runter.
  • Manchmal werden die Freezes von Tonabbrüchen begleitet
  • Nach sehr langen Freezes stürzt das Game manchmal ab und es gibt eine Fehlermeldung (siehe Datei-Upload)
  • Freezes treten sowohl bei Spielen auf der HDD, als auch auf der SSD auf
  • Freezes treten (meiner Erfahrung nach) nicht bei wenig anspruchsvollen Indie-Games, sondern nur bei Games wie Warzone, Battlefield etc. auf
  • manchmal treten die Freezes aber auch auf ohne überhaupt ein Game geöffnet zu haben, also alles sehr konfus
  • Manchmal bekomme ich vor dem Crash die Meldung: Datenträger F (Wählen Sie eine Aktion aus) oder das gleiche für Datenträger D (systemreserviert)
  • Im Dateianhang habe ich die Fehlermeldungen aus der Ereignisanzeige gescreenshotted


Meine Specs:
  • CPU Intel i7-7700k (übertaktet)
  • GPU Nvidia GeForce RTX 2070 (übertaktet)
  • RAM 16 GB
  • Wasserkühlung
  • SSD: Kingston SA400S37480G 0,5 TB
  • HDD: ST1000DM003-1SB10C 1 TB

Was ich bereits versucht habe:
  • AHCI Power Management in den Energieeinstellungen von HIPM/DIPM (nicht 100% sicher) auf Active gesetzt
  • Festplatte repariert mit chkdsk (nicht sicher, ob ich es 100% richtig gemacht habe)
  • Festplatte ausschalten auf Nie gesetzt
  • Übertaktung von CPU aufgehoben
  • Übertaktung von GPU aufgehoben
  • Festplattenkabel neu eingesteckt
  • Festplattentreiber aktualisiert (waren bereits auf dem neusten Stand), auch mit den dafür vorgesehenen Herstelleranwendungen
  • Herunter- und wieder Hochfahren ;)

Vielleicht sind die Kabel der Festplatte kaputt? Oder es gibt zwei Probleme, eines mit der CPU und eines mit der Festplatte?

Würde mich über Rat freuen. Danke und VG
Paul
 

Anhänge

  • ereignis4teil2.PNG
    ereignis4teil2.PNG
    20,5 KB · Aufrufe: 281
  • ereignis4.PNG
    ereignis4.PNG
    69,9 KB · Aufrufe: 284
  • ereignis3.PNG
    ereignis3.PNG
    76,7 KB · Aufrufe: 286
  • ereignis2.PNG
    ereignis2.PNG
    60,8 KB · Aufrufe: 285
  • ereignis1.PNG
    ereignis1.PNG
    49,4 KB · Aufrufe: 275
Ich würde mal den GPU-Treiber deinstallieren und neu installieren, oder eine andere (ältere/falls möglich natürlich besser neuere) Version probieren.
 
... gut daß Du die ERROR-Events gepostet hast. Wenn Du nicht 16 GB RAM hättest würde ich zuerst vermuten daß der Speicher ausgeht ... aber hier könnte die ESENT-Quelle ein Hinweis auf die Lösung geben, denn damit begann ja die Fehlerkette.
Dieses Problem hat es auch nach einem Update auf 1903 gegeben, wenn das Verzeichnis des "Kacheldaten"-Servers gelöscht wurde. Schau' doch mal ob in Deinem Benutzerverzeichnis das Verzeichnis "TileDataLayer\Database\" und dort EBK*.* Dateien mit aktuellem Zeitstempel drin liegen.
Also es sollte ein Verzeichnis "C:\Benutzer\*$<Benutzername>\AppData\Local\TileDataLayer\Database\" geben.
Falls nicht: anlegen, und zwar mit Berechtigung "Vollzugriff".
*$<Benutzername> ist natürlich durch Deinen Anmeldenamen zu ersetzen...
Good luck...
 
Wenn Du schon in diesem Forum schreibst, dann poste doch bitte mal die Screenshots von CrystalDiskInfo für die SSD und die HDD, ziehe aber bitte das Fenster soweit auf, dass alle Attribute und auch die Rohwerte vollständig sichtbar sind, also keine Scrollbalken mehr erscheinen.
 
Danke für die bisherigen Hinweise! Habe beides gemacht, Grafikkartentreiber gelöscht und neu installiert und diesen Ordner erstellt. Bisher keine Crashes, allerdings scheinen die Freezes noch vorhanden zu sein. Hatte allerdings bis eben erst einen, werde das weiter beobachten.

Hier die Screenshots.

VG

Edit: Eben wieder den ersten Crash gehabt. Dazu dieselben Fehler wie oben in den Screenshots und 10 Minuten davor auch die ESENT-Fehler.
 

Anhänge

  • crystaldiskinfo2.PNG
    crystaldiskinfo2.PNG
    76,6 KB · Aufrufe: 269
  • crystaldiskinfo1.PNG
    crystaldiskinfo1.PNG
    74,8 KB · Aufrufe: 267
Zuletzt bearbeitet:
Windows-Eingabeaufforderung als Admin: sfc /scannow und danach dism /online /cleanup-image /restorehealth
Image von der Windows-Installation machen und testweise Windows neu installieren, ob es dann auch auftritt.
 
.... hhmm. Was sagt das Event-Log zu genau diesem Zeitpunkt ?
Der Fehler ist ja bei CoD - MW aufgetreten. Das Game spuckt sicherlich auch Error-Logs aus. Ich müßte jetzt nachforschen wo diese liegen und wie man sie aktiviert (meist durch die Übergabe von Optionsparametern beim Aufruf der Startdatei), aber vielleicht kannst Du das selbst einmal herausfinden ... ?
 
CrystalDiskInfo unterstützt die A400 nicht, da musst Du nochmal mit dem SSD Tool von Kingston draufschauen. Die Werte der HDDs sind bis auf 2 Suchfehler in Ordnung.
 
Okay. Die Crashes scheinen doch aber ziemlich sicher mit der HDD zusammenzuhängen, immerhin gab es 1, 2 mal direkt vor dem Crash diese Meldung, die immer kommt, wenn ein neuer Datenträger angeschlossen wird? Oder denkt ihr, dass das nur ein "Symptom" ist?

Den Fehlercode von MW habe ich auch schon gegoogelt, es gab dann aber immer tausende verschiedene Lösungsansätze und Problembeschreibungen, die dann doch teilweise SEHR weit von meinem Problem abwichen.

Falls ich Windows neuinstalliere, sollte ich komplett neu aufsetzen oder die Benutzerdaten behalten?

Könnten die Freezes auch mit einem eventuellen Bottleneck meines Prozessors zusammenhängen? Der ist immer ganz gut ausgelastet.
 
Was ist denn bei dem Energieplan von Windows bzgl. des Ruhezustandes der HDD eingetragen? Wenn diese nach wenigen Minuten in den Ruhezustand versetzt wird und beim nächsten Zugriff erst aufwachen muss, kann das leicht über 10s dauern und leider weckt Windows auch bei Zugriffen die gar nicht auf die HDD gehen sollten, die schon mal auf und der Zugriff muss warten bis sie bereit ist.
 
Genau das war auch mein Gedanke. Den Lösungsversuch habe ich auch schon ausprobiert- bei Energiesparplan alles auf Nie gesetzt (Ruhemodus, Energie sparen, Festplatte ausschalten). Leider ohne Erfolg..
 
Es könnte noch am Unload Zustand liegen. Starte nochmal CrystalDiskInfo, gehe auf "Optionen" -> "Erweiterte Optionen" -> "AAM/APM Verwaltung", wähle oben die HDD und stellen dann unten den Schieber für APM ganz nach rechts bis daneben FEh steht, dann "Aktivieren" und das Fenster schließen. Wenn die Freeze dann weg sind, liegt es am Unloadzustand und um die Einstellung dauerhaft zu machen, wiederhole die Einstellung ggf. (wirkt nur solange die Platte Strom hat) und setze je einen Haken bei "Optionen" -> "Erweiterte Optionen" -> "AAM/APM Autoanpassung" und "Optionen" -> "Mit Windows starten", dann wird CDI jedesmal gestartet und nimmt die Einstellung automatisch vor. Aber eigentlich dauer das Aufwachen aus dem Unload nur so 1 bis 2s, andererseits hast Du eine schrottige DRAM less SSDs, die können bei mehreren parallelen Zugriffen echt lahm werden.

Tomshardware hat mal mehrere solcher DRAM less SSDs getestet und schreibt im Fazit:
Das liegt daran das die Controller die Mappingtabelle also den Flash Translation Layer (FTL) und eben nicht Userdaten im DRAM Cache ablegen, also die Information wo die Daten im NAND stehen und wo NAND frei ist um dort schreiben zu können. Die ohne DRAM Cache halten dann immer einen kleinen Teil der Mappingtabelle im interen SRAM des Controller, genug um gut in den Benchmarks abzuschneiden die ja nur über ein oder weniger GB Adressraum benchen und daher tolle Werte ins Datenblatt schreiben zu können. Aber im Alltag muss der Controller dann ständig erstmal wieder den passenden Teil aus dem NAND nachladen, was eben viel länger als ein DRAM Zugriff dauert. Auch die DRAM less TR200 fiel im Reviews bei Computerbase mit Aussetzern negativ auf.
 
@Holt Deine Lösung scheint tatsächlich zu funktionieren! Ich war allerdings in den letzten Wochen nicht sehr aktiv und werde mich nochmal melden, sollte der Fehler wieder auftreten. Falls nicht, vielen, vielen Dank für deine Hilfe!
 
Hello ;)
Ich habe genau das selbe Problem!
Andauernd! Egal was ich mache. Habe alles ausprobiert was mir eingefallen ist: (Mein SysteM: I7 7700K, Nvidia 1080 TI, ASROCK Z270 Supercarrier, 32 GB Ram

  • Windows neu installiert
  • Cod Neu Installiert
  • Neue Nvidia Treiber, alte Nvidia treiber
  • Neuen Ram!!!
  • Energiesparoptionen
  • usw.

Jetzt probiere ich mal das, was Holt geschrieben hat... teste es heute mal aus. Mal sehen. @Noxtravibur hast du bereits weitere Erfahrungen sammeln können?
 
@ravensith86

Die Lösung von Holt hat bei mir geholfen! Habe die CrystalDiskInfo jetzt so wie er es beschrieben hat immer im autostart. Das Fenster ist bei mir also immer in der Taskleiste, allerdings ist es mir das wert. Keine Crashes mehr, keine Freezes, nichts :)
 
Krass! Ich bin gespannt, ich hab das nun auch mal so gemacht....

Hast du ne Idee wie das auf Technischer Seite zusammenhängt?? Ich habe gedacht, ich habe Freezes weil irgendwas mit meiner Graka etc nicht in Ordnung ist oder so. Bin mittlerweile echt verzweifelt gewesen - zumal es nur Warzone betrifft!
 
Ne, habe nicht dieselbe Konstellation...
Das Spiel ist bei mir auf einer 1 TB Sandisk SDSSDH3 installiert.

Ich habe das Ganze ja seit Samstag im Test - und bisher nicht einen Absturz gehabt..........ich bin sehr verwundert....kann es wirklich damit zusammenhängen?

Habe am WE relativ viele Runden gezockt - bestimmt .... so um die 40 bis 50.
 
Zurück
Oben