CUPS über Netzwerk nicht erreichbar

Lucky Luke

Cadet 4th Year
Dabei seit
März 2005
Beiträge
123
Grüße an die Gemeinde!

Ich wohne in einer WG und habe einen kleinen Home-Server mit Ubuntu. Davor war es Debian. Den Rechner nutzen wir u.a. als Printserver und verwenden von daher CUPS. Mein Problem ist nur, dass das Webinterface übers Netzwerk einfach nicht erreichbar ist. Da kommt bei Firefox folgende Fehlermeldung:


Das Konfigurationstool von Samba hingegen kann man übers Netzwerk problemlos erreichen. Hier ist mal noch der Inhalt der aktuellen cupsd.conf:

Code:
#
#
#   Sample configuration file for the Common UNIX Printing System (CUPS)
#   scheduler.  See "man cupsd.conf" for a complete description of this
#   file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel warning

# Administrator user group...
SystemGroup lpadmin


# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing Off
BrowseOrder allow,deny
BrowseAllow all
BrowseAddress @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Encryption Required
  Order allow,deny
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
</Location>

# Set the default printer/job policies...
<Policy default>
  # Job-related operations must be done by the owner or an administrator...
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
#
Vielleicht habt ihr eine Idee woran es liegen könnte. Ist bestimmt irgendwas ganz Einfaches.


Mfg Lucky
 

freak01

Commander
Dabei seit
März 2002
Beiträge
2.677

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
In Config steht:

...
# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock

...

Dagegen musst unternehmen.
 

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
Listen localhost:631 musst du ändern!
Wie du es ändern willst, bleibt dir überlassen ob mit listen oder port.
Hast ja die Freiheit zu konfigurieren.
Falls du trotzdem nicht finden kannst, pack mal Suchmaschine aus, das Problem kommt ja nicht nur einmal vor.
 

Lucky Luke

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
März 2005
Beiträge
123
ich hab mal ein wenig recherchiert und bin dabei auf folgende seite gestoßen:
http://wiki.ubuntuusers.de/CUPS?highlight=cups
Bei ubuntu ist der cups-server standardmäßig nur lokal erreichbar. man muss folgende befehle ausführen um drucker für das netzwerk freizuschalten:

Code:
# Ein cupsctl ohne Parameter gibt die aktuellen Einstellungen aus:
cupsctl
# Aktiviert die automatische Druckervermittlung:
sudo cupsctl --remote-printers
# Gibt die lokalen Drucker im Netzwerk frei:
sudo cupsctl --share-printers
# Aktiviert die Möglichkeit CUPS über das Netzwerk zu Administrieren:
sudo cupsctl --remote-admin
thx an ralle & kann geschlossen werden.


mfg
 
Top