Ein erforderlicher CD-/DVD-Laufwerkgerätetreiber fehlt

Taomii

Cadet 2nd Year
Dabei seit
Okt. 2012
Beiträge
26
Hi,

Ich habe ein ziemlich nerviges Problem. Ich habe mir eine SSD gekauft und wollte jetzt darauf Windows 7 Professional 64bit neu installieren. Ich hab mir das dazugehörige ISO von Chip heruntergeladen und die Dateien auf meinen USB Stick entpackt. Den USB Stick habe ich vorher mit dem Tool "diskpart" bootfähig gemacht. Hab dann neu gestartet und vom Stick gebooted. Alles lief wie geschmiert, windows lud daten und ich konnte die Installationsprache usw. auswählen. Ich habe auf Setup starten geklickt und im nächsten Fenster tauchte der Fehler auf. Es kam eine Fehlermeldung dass ein erforderlicher CD-/DVD-Laufwerkgerätetreiber fehlt. Ich habe mir dann das ISO neu heruntergeladen und nochmals entpackt da ich dachte das irgendwelche Dateien verloren gingen, doch am Fehler änderte sich nichts.

Hatte jemand mal das selbe Problem und kann mir helfen?

Freundliche Grüsse

Taomii
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.152
Stecke den USB Stick nicht in einen USB3.0 Port. Das geht nicht. Nutze einen USB2 Port. Farblich dran zu erkennen, dass er nicht Blau ist.
 

cunhell

Lt. Commander
Dabei seit
März 2011
Beiträge
1.237
Hatte mit USB-Sticks als Installationsmedium schon die tollsten Sachen erlebt.
Fehlende Treiber und andere unerklärliche Installationsprobleme.
Zum Teil immer wieder andere Effekte bei jedem neuen Versuch
Ich habe dann das Image auf DVD gebrannt und oh wunder, die Probleme waren weg.

Das sind zumindest die Erfahrungen die ich mit USB-Sticks als Installaionsquelle gemacht habe.
Keine Ahnung was bei mir schief ging. Aber es lag zu 100% nicht am ISO-Image oder der Rechnerhardware.

Brenn das ISO auf DVD (wenn möglich) und versuch es dann von der DVD.

Cunhell
 

Taomii

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Okt. 2012
Beiträge
26
Mhm wenn ich es mit dem Microsoft App Versuche steht da das das ISO ungültig ist. Werde mir wohl morgen im Betrieb eine CD brennen.
 

Ananas

Lt. Junior Grade
Dabei seit
Dez. 2009
Beiträge
417
Stell den Sata Port des optischen Laufwerks auf IDE (kann nachher wieder geändert werden),dann müsste es gehen.
 

Dionysos808

Lt. Commander
Dabei seit
Sep. 2008
Beiträge
1.755
Es liegt womöglich daran, dass im BIOS ein CD/DVD-Laufwerk als Startmedium eingetragen ist.

So etwas hatte ich jedenfalls schon, obwohl nicht einmal ein solches Laufwerk verbaut war. Auch das Verschieben des Laufwerks nach hinten brachte keinen Erfolg, man musste es im BIOS deaktivieren.
Vielleicht sucht Windows nach 'nem passenden Laufwerk, da es ja im BIOS eingetragen ist, findet nichts und geht dann davon aus, dass es einen speziellen Treiber benötigt, den es natürlich gar nicht gibt.
 

Bennnio

Cadet 3rd Year
Dabei seit
Feb. 2013
Beiträge
33
Guten Abend,

Ich bin gerade durch Zufall auf diesen Beitrag gestoßen und dachte mir, dass ich evtl. eine Lösung für das Problem habe.

Ich hatte ein ähnliches Problem bei der Win7 Installation via USB-Stick auf einem nagelneuen Asus-Notebook, lediglich das dieses keine SSD verbaut hatte. Vielleicht liegt es aber nicht daran.
Ich hab versucht vom Stick zu booten und jedes Mal kam diese nervige Aufforderung, den Treiber extren zu laden o.ä...

Kurz googlen ergab den Tipp, keinen USB 3.0 Anschluss zu nehmen. USB 2.0 gewählt, selbes Problem.

Schliesslich bin ich zu einem weiteren Lösungsansatz gestoßen, der mir bis heute selber nicht ganz klar ist.
Ich hab herausgefunden, dass es bei Jemandem geklappt hat, nachdem er ALLE Dateien auf dem Stick mit einem Schreibschutz versehen hat.
Kam mir erst ziemlich spanisch vor, aber einen Versuch wars Wert. Alle Dateien auf dem Stick markiert, Rechtsklick, Eigenschaften, bei Schreibschutz einen Haken gesetzt, Übernehmen. (Für alle Unterordner ebenfalls)
Die Dateien, die nicht in Ordner sondern "direkt" auf dem Stick sind sollte man zur Sicherheit ein zweites Mal mit einem Schreibschutz versehen. (Irgendwelche .cfg Dateien?)

Das hat dann tatsächlich so funktioniert (USB 2.0 Port), in der Beschreibung stand, dass es etwas mit der "nicht-Beschreibbarkeit" von Original Windows-DVD's zu tun haben könnte..

Ich würde euch zu gerne die Quelle hier nennen, leider ist das schon zu lange her und ich bin gerade zu faul zu suchen.

Trotzdem viel Erfolg! Meld dich doch bitte, falls es so klappen sollte.

Gruß Bennnio
 

Schildkröte09

Vice Admiral
Dabei seit
Nov. 2009
Beiträge
6.308
@Taomii: Das ein solche Meldung kommt, ist meistens eine Ente von Windows.
Es fehlt auch garantiert kein SATA Treiber, Windows bringt alles nötige mit.

Meiner Meinung nach, kann es nur an zwei Dingen liegen:

1. Deine neue SSD ist nicht am ersten und NATIVEN SATA PORT angeklemmt, der auf dem Board zur Verfügung steht. Klemme die SSD Platte deshalb um, wenn dies nicht so ist. Die Platte darf keineswegs an einen SATA PORT eines Drittanbieters angeklemmt sein, (z.B. Marvell oder JMicron), weil dann dazu Windows tatsächlich die SATA Treiber des Drittherstellers benötigt. Wird im BIOS aber das ROM dieser SATA PORTS des Drittherstellers aktiviert, benötigt man diese SATA Treiber auch nicht mehr.

Deshalb erst mal gleich auf Nummer sicher und die SSD an einen vom Boardchipsatz unterstützten SATA PORT anklemmen (INTEL oder AMD) und dann bitte an den ersten (kann auch als SATA-0 gekennzeichnet sein).
Außerdem alle anderen SATA Platten abklemmen und nach der Installation wieder an den SATA PORTS nach der Systemplatte anklemmen.

2. Nicht alle USB Sticks bei so vielen unterschiedlichen Systemen sind geeignet, als Bootstick zu fungieren.
In erster Linie gibt es dazu die meisten Probleme mit billigen USB Sticks wie die der Marke CnMemory (Saturn + Media Markt vertriebene USB Produkte).
Probiere es mit einem anderen USB Stick anderer Fabrikate, auch wenn dein jetziger Stick nicht von CnMemory ist. Außerdem sollte der Stick unbedingt in FAT 32 formatiert sein, was ALLE Mainboards mit USB Boot Eigenschaften unterstützen, was bei NTFS nicht der Fall ist. Außerdem wäre FAT 32 zwingende Vorraussetzung für eine UEFI Installation. Das Microsoft USB Tool kann den Stick nicht in FAT 32 formatieren, sondern grundsätzlich nur in NTFS. Deshalb ist das Tool für die meisten, aber insbesondere für eine UEFI Installation nicht zu gebrauchen.

Sollte es ebenso wieder zu Problemen mit dem "neuen" Stick kommen, benutze eine externe USB Platte zur Installation. Wenn alle Stricke reißen, funzt es mit dieser.

Der Lösungstrick von @Bennnio hört sich allerdings kurios und unverständlich an. Es würde mich aber auch brennend interessieren, ob eine Installation über diesen Umweg möglich werden könnte ?!
Normalerweise erhielten zu früheren Zeiten alle Dateien, die auf eine DVD gebrannt wurden, automatisch auch das Schreibschutzattribut. Auch wenn man die Dateien später wieder auf die Platte kopierte, wurde das Schreibschutzattribut beibehalten.
Es sollte allerdings nicht ausschlaggebend für einen USB Stick sein.

Viele Grüße
 
Zuletzt bearbeitet:

Taomii

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Okt. 2012
Beiträge
26
@blubbsde auch dieses Image ist laut dem tool ungültig, werde aber noch versuchen dieses Image auf USB Stick zu entpacken.

@ananas funktioniert nicht auch wenn ich es deaktiviere oder Kabel ausstecke kommt der selbe Fehler

@Bennnio nice try funktioniert aber auch nicht

@Schildkröte09 Mhm ich hab 4x Sata II Ports und 2x SATA III Ports. HDD hab ich in den ersten Sata II Port angesteckt und die SSD an den ersten Sata III Port. Soll ich meine SSD jetzt an den zweiten Sata II anstecken? Ich habe keine Ports von drittanbietern o.ä.

Mainboard
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.152
Du kannst sie am SATAIII Port hängen. Wenn er vom Chipsatz her kommt. Und nicht von einem Zusatz SATA Controller.

Hm. Ich nutze das Windows USB Tool sehr oft. Es ging mit Win 7 Images immer. Sonst befolge mal Schildkrötes Tipp. Wenn Du den Stick selber einrichtest, dann formatiere ihn in FAT32 und nicht in NTFS. Auch eine Fehlerquelle.
 

Taomii

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Okt. 2012
Beiträge
26
Hab den Stick immer in fat32 formatiert gehabt. Das Image von der Windows Seite ist übrigens genau das gleiche einfach anders benannt. Naja danke für die vielen Vorschläge werde es morgen nochmals versuchen hab noch viele Möglichkeiten zu testen wie es aussieht.

mfg
 

Schildkröte09

Vice Admiral
Dabei seit
Nov. 2009
Beiträge
6.308
@Schildkröte09 Mhm ich hab 4x Sata II Ports und 2x SATA III Ports. HDD hab ich in den ersten Sata II Port angesteckt und die SSD an den ersten Sata III Port. Soll ich meine SSD jetzt an den zweiten Sata II anstecken? Ich habe keine Ports von drittanbietern o.ä.
SATA 3 ist prirorisiert vor SATA 2 Ports. Die SSD ist deshalb am ersten SATA 3 Port gut aufgehoben.
Allerdings kann es bei Installationen an diesen bei unterschiedlichen Mainboards zu Problemen kommen, weshalb ich dazu anraten würde, zunächst die SSD an den ersten SATA 2 Port anzuklemmen und die andere HDD unbedingt abzuklemmen. Nach der Installation kannst du die SSD wieder an einen SATA 3 Port und die HDD wieder an ihren SATA 2 Port anklemmen.

Wenn du keine SATA Ports von Drittanbietern hast, dann versuche es mal mit einem anderen Stick, oder mit einer externen USB Platte.

Besitzt dein Board ein UEFI BIOS, solltest du FAST BOOT (im BIOS unter den Bootoptionen zu finden ?), bei Installation von USB, deaktivieren. Außerdem SECURE BOOT !

Achte im UEFI BIOS außerdem auf folgende Einträge unter den Bootoptionen:

LEGACY oder CM BOOT (aktivieren, wenn nicht im UEFI Mode auf GPT Platte installiert werden soll)

UEFI BOOT (aktivieren, wenn im UEFI Mode installiert werden soll). Die Platte darf keine MBR Partitionen mehr besitzen ! Deshalb Platte putzen mit dem CLEAN Befehl von DISKPART. Warum, darauf bin ich hier schon häufiger eingegangen. Nur der CLEAN Befehl löscht Partitionen und Initialisierung der Platte ! (ganz wichtig außerdem für Windows 8 !, hat die Platte weder Partitionen noch eine Initialisierung, richtet Windows 8 automatisch auch eine Wiederherstellungspartition auf der GPT Platte ein, wenn man Windows 8 die Partitionierung überläßt, - welche äußerst wichtig für die eigene Systemsicherung und die Wiederherstellungspunkte sind). >Bleibt die Initialisierung allerdings erhalten, wird keine Wiederherstellungspartition erstellt.
 
Zuletzt bearbeitet:

Head

Cadet 3rd Year
Dabei seit
März 2013
Beiträge
33
nabend.

der threat ist zwar etwas älter aber egal,

ich wollte bei meiner freundin win7 neu installieren.

Das setup startet dann lädt er ein bischen und dann kommt "Ein erforderlicher CD DVD Laufwerkgerätetreiber fehlt" den fehler habe ich noch nie gehabt, was will der?

habe das laufwerk auch schon ausgetauscht und habe eine andere win7 dvd getestet aber immer derselbe fehler.

Mainboard Asus m2n68 und windows 7 ultimate 64 bit original dvd ohne sp? bios update habe ich schon gemacht.
 
Top