Einmal secure boot immer secure boot?

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.786
Ich kenne mich bei ASROCK Boards nicht aus. Es kann sein, das es dort einen Eintrag gibt mit UEFI + CSM oder UEFI + Legacy oder so ähnlich. Auf meinem MSI Board läßt sich UEFI + CSM oder CSM oder UEFI auswählen.

Wenn man den Secure Boot aktiviert, kann nur im UEFI Mode installiert werden. Dann ist die CSM automatisch deaktiviert. Das sollte auf allen Boards so sein. Oder aber mit aktivierter CSM kann man kein Secure Boot auswählen bzw. wird der Secure Boot automatisch deaktiviert, wenn man die CSM einstellt, egal in welcher Form.
 
Zuletzt bearbeitet:

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
Ob der Rechner mit Secure Boot nun schneller startet, mag ich bezweifeln.
Schneller oder nicht braucht man auch nicht zu diskutieren.
Secureboot ist auch keine Glaubensfrage.
Secureboot Gegner und User die an Uralter Windows Versionen 95, 98, XP und Windows 7
festhalten wird es leider immer geben.
Gegen die 3 % Linux User kann man auch nichts machen.

Secureboot zu verdammen wie es mal 2010 üblich war ist ja nun auch längst überholt.
Bei neuen Mainboards ist Uefi und Secure Boot Standard.
Genau wie man normal bei fast alles Boardherstellern die SSD bei BOOT an 1. Stelle hat und den USB Stick über das Bios Bootmenü aufruft.
Gibt na klar genug User die überhaupt keine Ahnung haben mit welcher Taste sich das Bootmenü überhaupt aufrufen lässt.
 

Anhänge

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.786
Da hast du ja Recht @Terrier. Ich starte auch mit Secure Boot.
Nur, es muss ja jedem selbst überlassen bleiben.

Viele Grüße
 
Zuletzt bearbeitet:

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
Wo findet man diese Einstellung UEFI+CSM in etwa, ist ein Asrock-Board für AMD, glaube Extreme 3.
Bootmenü bei Asrock sollte doch F8 sein laut Google und ansonsten muss man im Handbuch nachsehen, ob man was über das Bios findet.
Hier haben wir alle Windows 10 und ob sich hier ein User findet der ein Asrock Extreme 3 hat?
Google oder Bing und dann auf Bilder klicken kann auch mal helfen.
 

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
Unter Linux zeigt "ls -1 /sys/firmware/" "efi", also wurde da auch mit UEFI installiert.

Mein Problem ist irgendwas anderes und ich vermute stark, dass da eine Installationsroutine von Windows Bockmist baut, denen sind duale System wohl egal.

Code:
Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  106MB   105MB   fat32           EFI system partition          boot, esp
 2      106MB   123MB   16.8MB                  Microsoft reserved partition  msftres
 3      123MB   157GB   157GB   ntfs            Basic data partition          msftdata
 4      157GB   157GB   546MB   ntfs                                          hidden, diag
 

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
Auch wenn es kein Screen von der Datenträgerverwaltung ist, mit englischen Wörtern und Goot weiß woher ist, sieht das für mich normal aus.
16MB MSR sieht man in der Datenträgerverwaltung nicht.
Diskpart oder Linux Live oder überhaupt Linux brauchen ja Milionen Windows User auch nicht

Ab Windows 10 2004 soll ja bei einer clean Installation die 100MB Uefi Fat32 Bootpartition am Anfang der Platte sein und die Wiederherstellungspartition hinter C:
War bei 1909 ja noch anders.
Wo oder was soll jetzt denn noch dein Problem sein?
 

Anhänge

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.786
Bei mir hat Windows 10 die Wiederherstellungspartition an den Anfang gesetzt, dann kommt die EFI und die Datenpartition. Und Ende. Was ist das denn für eine 4. Partition bei dir @linuxnutzer?

startpart.png


Die Microsoft Reserved Partition wird eigentlich von Windows 10 überhaupt nicht mehr eingerichtet.
Ich wüßte nicht in welchen Fällen. Hat Windows 10 bei mir noch niemals angelegt. Ich weiß, geschrieben wird darüber.

Dann kann die 4. Partition bei dir ja nur noch die Wiederherstellungspartition von Windows sein ... Das wäre optimal, so wie es eigentlich von Microsoft vorgesehen wird.

Wenn die Wiederherstellungspartition hinter der Betriebssystempartition angeordnet ist, kann der Windows Installer die Größe der Wiederherstellungspartition im Verlauf der Installation oder des Upgrades anpassen. Wenn für künftige Updates von Windows 10 ein größeres Wiederherstellungsimage erforderlich sein sollte, kann Windows diese Partition selbstständig erweitern. Der benötigte Speicherplatz wird dann von der Betriebssystempartition abgezweigt. Die Größe der Wiederherstellungspartition ist mit jeder Windows-Version gewachsen.
Da ich mit Windows 10 2004 neu und clean installiert habe, ist die Einteilung auch von Windows 10 so automatisch vorgenommen worden.

Ich würde jedoch alles so belassen!

So sollte die Reihenfolge aussehen schon seit Windows 10 - 1803, nur das die "Healthy" immer größer wurde:

082218_figD_newlayout.jpg

Schlussendlich sollte die Reihenfolge der Partitionen der gewünschten entsprechen, wie in Abbildung zu sehen.
Viele Grüße
 
Zuletzt bearbeitet:

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
Installiert wurde auf eine leere / überschriebene HD mit 2004

Die Partitionen wurden von Windows bei der Installation angelegt

16MB MSR sieht man in der Datenträgerverwaltung nicht.
Kann das nicht Partition 2 sein?

Partition 3 sollte die Win10-Installation sein, angegeben hatte ich 150000 als Größe bei der Installation. Der Platz danach wurde für die Installation nicht partitioniert.

Unter Win dann wurde dann eine NTFS-Partition mit 200000 hinzugefügt. Der Rest blieb frei und wurde später unter Linux partitioniert.

Code:
3      123MB   157GB   157GB   ntfs            Basic data partition          msftdata
4      157GB   157GB   546MB   ntfs                                          hidden, diag
5      157GB   367GB   210GB   ntfs            Basic data partition          msftdata
6      367GB   697GB   330GB   xfs
4 ist aber wirklich interessant, Anfang 157GB, Ende 157G
Ich hatte unter Linux eine logische Partition definiert, da ich nicht wusste, dass Win eine gpt-Partitionstabelle erzeugt hatte. Komisch, dass mir das überhaupt angeboten wurde. Vielleicht wurde das aber ignoriert und 4 ist wirklich eine Wiederherstellungspartition.

Gerade läuft wieder eine Linux-Installation, da ich den grub schon wieder verlor und nun kam die Meldung bei der Linux-Installation, dass ich für Grub eine eigene Partition anlegen muss, sonst kann nicht gestartet werden. Das musste ich noch nie.
 

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
Da ich mit Windows 10 2004 neu und clean installiert habe, ist die Einteilung auch von Windows 10 so automatisch vorgenommen worden.
Genau wie ich hast du 1909 clean installiert.

Seit 2004 ist die 100MB Partition am Anfang und die Wiederherstellungs Partition ist jetzt hinter C:
wird auch überall im Web so beschrieben.
https://www.tenforums.com/windows-u...=5d625daf35904ae7972a51529a3aefdf#post1931887

4 ist aber wirklich interessant, Anfang 157GB, Ende 157G
157 GB ist doch die ganze Partition oder Platte und bei mickerigen 546 MB wird halt auch als Ende 157 GB angezeigt.
Ich weiß immer noch nicht mit welchem Tool du da arbeitest und lernen muss ich das Tool ja eigentlich auch nicht.
Wie man Linux und Windows 10 installiert im Dual-Boot und was da für Probleme auftauchen können weiß man doch wohl besser im Linux Forum.
Bei mir ist die 16MB MSR Partition mit diskpart (von Windows aus) auch nicht zu sehen.
Warum Volume 3 nun da die 100MB Partition ist und die letzte Partition sein soll?
 

Anhänge

Zuletzt bearbeitet:

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
7.786
Ich habe es soeben geschafft, mit Acronis Image 2019 die Wiederherstellungspartition auf meiner Ersatz SSD nach hinten zu verlegen, wie das eigentlich optimal dargestellt wird. Damit die Wiederherstellung weiter wachsen kann ...

system.png


So werde ich das dann auch jetzt noch mit meinem Hauptsystem vollziehen.

Viele Grüße
 

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
Hier die Partitionstabelle, nach der letzten Installation:

Number Start (sector) End (sector) Size Code Name
1 2048 206847 100.0 MiB EF00 EFI system partition
2 206848 239615 16.0 MiB 0C01 Microsoft reserved ...
3 239616 306130317 145.9 GiB 0700 Basic data partition
4 306130944 307197951 521.0 MiB 2700
5 307197952 716797951 195.3 GiB 0700 Basic data partition
6 716797952 1361330175 307.3 GiB 8300
7 1361330176 1458987007 46.6 GiB 8300
8 1458987008 1654298623 93.1 GiB 8300
9 1654298624 1750001663 45.6 GiB 8300
10 1750001664 1943361535 92.2 GiB 8300
11 1943361536 1943382015 10.0 MiB EF02
12 1943382016 1953523711 4.8 GiB 8200

Ab Partition 6 sind es Linux-Partitionen

https://askubuntu.com/questions/703443/gdisk-hex-codes
2700 Windows RE
ef00 EFI System
0c01 Microsoft reserved
ef02 BIOS boot partition

Meine Fragen sind vorerst beantwortet und was Probleme macht ist grub unter Linux, das ist aber hier logischerweise OT.
 
Zuletzt bearbeitet:

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
und ich habe etwas gegoogelt und diskpart gelernt und einen anderen Befehl "List Partition" verwendet.
16MB MSR sind da und auch die 100MB an 2. Stelle wie in der Datenträgerverwaltung.
Partitionen erstellen oder löschen möchte ich aber bei solch einem durcheinander (mal Partition 2 mal Volume 3) usw. auch nicht.
Hier die Partitionstabelle, nach der letzten Installation:

Number Start (sector) End (sector) Size Code Name
Diskpart und die ganzen Zahlen einer Partitionstabelle muss man sich doch im Jahr 2020 nicht mehr antun. was soll das? was will man damit ? woher bekommt man so was und warum?
Windows installiert man mit der Maus und ein paar klicks.
 

Anhänge

Zuletzt bearbeitet:

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
157 GB ist doch die ganze Partition oder Platte und bei mickerigen 546 MB wird halt auch als Ende 157 GB angezeigt.
Ich wollte eigentlich nur Infos zu Partition 4 geben, Fragen habe ich keine mehr. Die 4. Partition ist "2700 Windows RE" und ich denke RE steht für Recovery.

Ich vermute die Änderung von 2004 macht bei der Linux-Installation Probleme, aber das will ich natürlich hier nicht fragen.
 

Terrier

Fleet Admiral
Dabei seit
Mai 2006
Beiträge
10.700
Die 4. Partition ist "2700 Windows RE" und ich denke RE steht für Recovery.
Ja klar, da sind die Wiederherstellungsoptionen drauf die man bekommt wenn Windows nicht mehr richtig startet.
Bekommt man ja auch über einen USB Stick und den Computerreparaturoptionen.
Hilft ja nur meinst alles nichts da die Reparatur fehlschlägt.
 

Ponderosa

Lt. Commander
Dabei seit
Okt. 2016
Beiträge
1.391
@ linuxuser
Wieviele HDD/SSD hast du denn in deinem Desktop-PC?
Ich nehme an, dass es ein Desktop-PC ist, da ich oben gelesen habe, dass du glaubst, dass es ein Asrock Extreme 3 Board ist.
Bei meiner Linux Installation funktioniert z.b. WLAN nicht, wenn ich Secureboot eingeschaltet lasse.
Hab noch nicht nachgesucht, wieso das so ist, da ich Linux relativ selten nutze.
 

K-BV

Vice Admiral
Dabei seit
Aug. 2017
Beiträge
6.915
Gerade läuft wieder eine Linux-Installation, da ich den grub schon wieder verlor und nun kam die Meldung bei der Linux-Installation, dass ich für Grub eine eigene Partition anlegen muss, sonst kann nicht gestartet werden. Das musste ich noch nie.
Weil du mbr/legacy (CSM) auf gpt installierst. Mit Linux geht das, mit Windows nicht. Das erfordert dann die BIOS Grub Partition in raw.

Erstelle das Installationsmedium explizit für UEFI/gpt. Oder/Und stelle den Bootmodus auf eine "Only" Einstellung ein.

Secureboot ist völlig wurscht aber Fastboot muss zwingend abgeschaltet werden. Im BIOS und in Windows.
Ergänzung ()

Meine Fragen sind vorerst beantwortet und was Probleme macht ist grub unter Linux, das ist aber hier logischerweise OT
Nein, macht keine Probleme! Das Problem ist "hausgemacht" und mit der "glaskugel" ist das halt immer so eine Sache! ;)
 
Zuletzt bearbeitet:

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
Man sollte lieber mal auseinanderklamüsern was der TE da überhaupt alles falsch macht.
Na ja, kann schon sein. Primär sind es Probleme, die ich bei Dual-Boot mit Linux habe, aber mittlerweile ist mir klar geworden, dass die Hardware grenzwertig ist und ich zumindest unter Linux glaubte, dass UEFI für die Installation verwendet wurde, obwohl es das eventuell nicht tat, obwohl ich im Bios als 1. Start UEFI-USB-Stick verwendet hatte. Man glaubt natürlich, dass UEFI verwendet wird, wenn man es ausgewählt hat.

Das ganze Manual schreibt sehr oft von UEFI, obwohl es bei UEFI-Setup gar nicht um UEFI ging. Die meinten einfach Bios.

https://www.computerbase.de/forum/threads/uefi-einstellungen-bei-asrock-970-extreme3.1975550/ macht klar, dass das Board für UEFI grenzwertig ist.

Mich würde im Bereich von Windows 10 interessieren, wie ich herausfinde, ob wirklich UEFI für die Installation verwendet wurde? Alle anderen Kommentare bitte beim entsprechenden Thread und nichts doppelt führen.

Ich hoffe, dass ich durch die Einstellung im ACPI-Bereich und "disable CSM" UEFI erzwingen kann. Aber, ob das geklappt hat muss ich wohl unter Win 10 abfragen.
Ergänzung ()

Habe die Antwort selber gefunden:

https://www.giga.de/downloads/windo...et-ihr-heraus-welche-pc-schnittstelle-laeuft/

Windows meint, es läuft UEFI.
 
Zuletzt bearbeitet:

linuxnutzer

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2011
Beiträge
1.588
Die Spannung steigt, ob nun Grub damit klar kommt ;-) Aber das ist dann hier off topic. Unglaublich welchen Aufwand ich treiben muss, um eine SSD administrieren zu können, weil der Hersteller für eine Data-Center / Enterprise SSD keine Hersteller-Tools unter Linux anbietet. Jedenfalls habe ich bei Windows einiges dazu gelernt. Vielen Dank!
 
Top