Externe Festplatte SATA=OK USB=Fehlerhaft

Himbernuub

Cadet 4th Year
Dabei seit
Apr. 2011
Beiträge
99
Habe einen etwas komischen Fehler :/

Wenn ich meine Externe 3TB WD platte über den Sata Anschluss des Externen Gehäuse anschliese geht alles Super.Schliese ich da die Platte über den USB Port des Gehäuse an, kommt es zu Folgendes Fehler.

Ich klicke z.b Video X1 an,Startet er mir ein Video wo er mir Irgendwas aus Video x4 oder x9 zeigt.
Also wenn video X1 z.b 14:12 Min ging, dann ist das mir gestartete video auch so lang, nur halt mit irgendwelchen Video ausschnitten aus anderen Video dateien.

Habe dann zum Test die Platte in ein anderes Externes USB Gehäuse getestet mit anderen USB Kabel.
Ergebnis = selber Fehler

An 3 Win7 64Bit Rechner getestet selber fehler.

Die externen Gehäuse sind auch ein paar Jahre alt, kann es also wegen den 3TB sein, aber warum gehts dann über Sata.
Scan Disk konnte auch keine Fehler finden auf der Platte.
 

wolbe182

Captain
Dabei seit
Mai 2012
Beiträge
3.752
Das könnte an Controller des externen Gehäuses liegen, schau mal beim Hersteller ob es eine neue Firmware gibt. Oder besorg dir ein neues gehäuse.
 

derius

Lt. Commander
Dabei seit
Okt. 2012
Beiträge
1.093
kann wolbe nur zustimme - andere option gibts nicht
 

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
18.194
Bei eSATA wird das Datenkabel nur herausgeführt. Es sitzt kein Controller zwischen der HDD und dem Mainboard. Es kann also kein Controller defekt gehen oder Probleme bereiten. Warum jetzt aber augenscheinlich gleich zwei USB-Gehäuse oder deren Controller kaputt sein sollen, kann nur böser Zufall sein.

Externe Gehäuse scheinen immer miese Qualität mitzubringen. Meiner Erfahrung nach gehen sie häufig kaputt. Besonders dass bei dir nach dem Anklicken von Dateien auf eine andere gezeigt wird, kommt mir bekannt vor. Ein Medion-Gehäuse hat mir so über Firewire eine Platte komplett durchgerührt. Die HDD an sich geht noch, genau wie der USB-Controller. Nur Firewire darf man damit nicht nutzen.
 

Inzersdorfer

Vice Admiral
Dabei seit
Juli 2010
Beiträge
6.337
Der USB-SATA Controller wird eher nicht defekt sein, sondern das machen, was er soll, die durch die Festplatte emulierten 512 Byte Sektoren ein zweites mal auf 4K Sektoren emulieren, damit auch unter XP die vollen 3 TB angesprochen werden können. Da Daten via ESATA geschrieben wurden, sollte die USB Schnittstelle nicht verwendet werden, denn das der User beide Schnittstellen nutzen möchte, damit konnte ja wohl Niemand rechnen.
 
Zuletzt bearbeitet:

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
54.176
eSATA und USB ist bei externen Platten über 2TB total gefährlich. Die Platten habe ja alle intern 4k Sektoren und emulieren nach außen 512Byte Sektoren. Damit kann MBR nicht mehr anfangen und damit die auch unter älteren Systemen wie XP noch funktionieren, emulieren die USB-SATA Birdge Chips wieder 4k Sektoren. Die Platte wird also über USB wie eine Platte mit 4k Sektoren gesehen und adressiert über SATA dann aber wie eine mit 512Byte. Also entweder oder und blos nicht von intern auf extern umbauen!
 

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
18.194
Ups. Ja die Problematik mit der Umwurschtelei den Sektoren habe ich verdrängt.
Die externen Gehäuse sind auch ein paar Jahre alt...
Ging es denn schon mal oder taucht das Problem erst jetzt auf, wo du eine neue 3 TB HDD in die Gehäuse verrachtet hast? Wenn du erst jetzt eine neue 3 TB HDD mit den Gehäusen gepaart hast, auf Inzersdorfer und Holt hören. An euch beide. Die Frage hatten wir schon mal. Gibt es etwas neues dazu? Also wisst ihr von externen 3 TB HDDs, die an USB und ausgebaut laufen? Oder tut sich da nichts bei den Herstellern?
 

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Meiner bescheidenen Meinung nach hat es nichts mit 4KB/512B Sektorgrößenunterschieden zu tun.
Das ließe sich einfach feststellen, zB im HD Sentinel (Trial Version) Report, wo die aktuelle Sektorgröße unter USB bzw eSATA angezeigt wird.
In einer der beiden Situationen dürfte die Partition nicht ansprechbar sein, sondern gar nicht gefunden werden

Ich fürchte eher, die SATA-Treiber erzeugen Fehladressierung, die unter USB nicht auftritt.
Überprüfung auf Fehladressierung per HD Tune pro (Access Benchmark) siehe > hier <
Wenn dieser Fall vorliegt, ist zumindest eine Datei beschädigt worden. Wenn die Platte schon über 1,8GB befüllt ist, wurden durch unter eSATA vorgenommene Schreibvorgänge auf der Platte (neue Dateien draufkopiert) auch schon andere zerstört.
Das Symptom deutet jedenfalls darauf hin, dass Dateien, die über der 2TiB-Grenze der Platte liegen und abgespielt werden, dieser Fehladressierung unterliegen und gleich große Fragment anderer Dateien, die am Beginn der Platte liegen, statt dessen gelesen werden.
 
Zuletzt bearbeitet:

Himbernuub

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
99
Also die Platte ist 2-3 Monate alt, und ich würde auch sagen das der Fehler erst aufgetreten ist wo die 2TB Marke überschritten wurde.

Unter XP SP3 wird die platte nicht erkannt.

Also um das nochmal klar zu machen, es sind keine Dateien Zerstört auf der Platte, sie sind ,,nur" naja ,,fehlerhaft verknüpft" im Betrieb mit USB.

Habe mir jetzt ein neues Gehäuse gekauft, das von Hersteller auch mit 4TB Platten vertrieben wird.

Ich Schreib dann wie es damit geht.
 

Wilhelm14

Fleet Admiral
Dabei seit
Juli 2008
Beiträge
18.194
Unbedingt zurück melden! :)

Um welches Gehäuse handelt es sich? Ich bin auch immer noch auf der Suche nach einer externen HDD, bzw. einem Gehäuse, welches mit über 3 TB an USB und SATA (ausgebaut) läuft.
 

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Unter XP SP3 wird die platte nicht erkannt.
Natürlich. XP kennt kein GPT. Paragon hilft da weiter mit GPT-Treibern
Also um das nochmal klar zu machen, es sind keine Dateien Zerstört
Woher willst Du das wissen? Wetten, ich finde Dir zumindest EINE, die beschädigt wurde.
Viel mehr ist kaputt, wenn mit dem alten Gehäuse unter eSATA noch was draufkopiert wurde (nach Befüllung über 1,8TB)
Habe mir jetzt ein neues Gehäuse gekauft, das von Hersteller auch mit 4TB Platten vertrieben wird.
Wenn Du mein Vorpost gelesen und den Test durchgeführt hättest, wäre der nächste Schritt eigentlich:
Herausfinden, ob Gehäuse oder Treiber die Ursache sind. Wenn im neuen Gehäuse keine derartigen Symptome unter eSATA mehr auftreten, dann lag es am alten Gehäuse. Wenn nicht, dann an den Treibern, und das Problem besteht auch mit dem neuen.
Wärest Du eventuell bereit, die 4TB im alten Gehäuse nochmals mit einem Softwareprodukt zu testen, ob dieses vor Fehladressierung und Zerstörung warnt? Das könnte tausenden Usern zukünftigen Datenverlust ersparen...
 
Zuletzt bearbeitet:
Top