Linux-Live-System startet nicht: Liegt es am PC oder mir?

barmbekersurfer

Lieutenant
Registriert
Juni 2018
Beiträge
913
Moin liebe Gemeinde,

mein Selbstbau-Rechner, auf dem Windows 10 problemlos läuft, soll nun auch für Linux genutzt werden.

Verbaute Hardware:

MoBo: ASRock B450M Pro4
APU: AMD 2400G
RAM: Crucial Ballistix Sport LT DDR4-3000 DIMM CL16 Dual Kit

Derzeit installiertes BIOS: 3.50

Ich möchte zunächst ein Live-System vom USB-Stick ausprobieren. Ich habe nun schon diverse Distris runtergeladen und auf einen bootfähigen Stick kopiert. Meistens erscheint dann so etwas wie GRUB (?), wo vier bis fünf Zeilen zu sehen sind und ich beispielsweise "Mint" oder "Kubuntu" als Live-System auswählen kann.

Danach laufen einige Programmierzeilen durch, es folgt ein schwarzer Bildschirm. Nur bei den Ubuntus erscheint ein Logo für einige Sekunden, dann wird der Schirm ebenfalls schwarz. Ich muss den Reset-Knopf am Gehäuse drücken, weil nichts mehr geht.

An meinen Sticks scheint es nicht zu liegen. Wenn ich mir eine ISO auf DVD brenne, klappt es ebenfalls nicht.

Ich denke, am Programm zum Erstellen eines bootfähigen Sticks dürfte es auch nicht liegen. Ich habe Etcher, Unetbootin und Rufus ausprobiert.

Was kann ich noch probieren, um ein Linux-Live-System auf meinem Desktop zum Laufen zu bringen?
 
Ubuntu, Mint & Kubnutu sind im grunde ein und das selbe - Gleicher Unterbau und Kernel. Teste einen Rolling Release wie Manjaro KDE / Gnome mit Kernel 5.3. Damit sollte es eigentlich laufen.
 
@ghecko
Ausprobiert habe ich bis jetzt: Ubuntu, Kubuntu, Xubuntu, Mint, Manjaro XFCE. Bei den Ubuntus habe ich den neuesten Release 19.10 jeweils von den offiziellen Webseiten heruntergeladen. Die Manjaro-ISO ist von hier:
manjaro.jpg


Mint 19.2 müsste auch von der offiziellen Webseite sein:

mint.jpg


@JimPanse1984
Manjaro XFCE habe ich schon probiert. Ich kann aber gern noch mal die KDE-Variante testen. Ich werde Rufus für den Stick benutzen.
 
Gut, dass Du fragst. Ich habe erst vor einigen Tagen das BIOS geflasht, aber, bis auf das XMP-Profil und die Lüfterkurven, nichts verändert. Ich hatte beim Googeln schon den Hinweis auf "Secure Boot" gefunden, aber gleichzeitig auch gelesen, dass die Ubuntus damit zurechtkommen sollen. :confused_alt:
Ergänzung ()

Ich habe im BIOS nachgeguckt. Unter "Secure Boot Mode" habe ich zwei Auswahlmöglichkeiten:

  • Standard
  • Custom

Zurzeit ist "Custom" aktiv. Macht es Sinn, mal "Standard" auszuprobieren?
 
Zuletzt bearbeitet:
Wenn ich unter "Systemstart" gucke:

Unterpunkt "Systemstart\CDM (Kompatibilitätsunterstützung)"

  • CSM aktiviert
  • Above 4G Decoding disabled
  • PXE OpROM-Richtlinie starten Nur Legacy
  • Storage OpROM-Richtlinie starten Nur Legacy
 
@ghecko
  • PXE OpROM-Richtlinie starten Nur Legacy
  • Storage OpROM-Richtlinie starten Nur Legacy
An dieser Stelle kann ich im BIOS zwischen "Nur Legacy" und "Nur UEFI" wählen. Sollte ich mal "Nur UEFI" ausprobieren? Falls ja, bei beiden Unterpunkten?

Bei Chip habe folgendes gefunden. Ich bin am Punkt 2 hängen geblieben, was dazu passen würde:

chip.jpg


@cloudman
Ja, werde ich machen.

@Ratz_Fatz
Danke, aber die 19.10-Ubuntus habe ich bereits probiert.
 
Okay, dann gib bitte mal bei Ubuntu 19.10 ein paar weitere Parameter an. Mit "e" kannst du Parameter hinzufügen. Gehe zur Zeile "Linux". STRG+X startet dann das System.

Probier es dann mal damit aus "amd_iommu=soft pci=nocrs acpi_osi=Linux noapic"(das = findest du neben der Zurücktaste // den Unterstrich bei, meine ich, "?/ß"). Lass "nomodeset" vorerst weg.

Iommu auf Auto oder an. Amd PSP kann im Bios ausgeschaltet werden, falls vorhanden. fTPM ebenfalls, falls aktiviert. CSM kann aktiviert bleiben, bei mir verschwindet damit nur die Meldung "[drm] BIOS signature incorrect 0 0".

edit
Mit den Parameter "amd_iommu=soft pci=nocrs acpi_osi=Linux nomodeset" bekomme ich einen schwarzen Bildschirm mit dem AMD 3200G.
Wenn ich dann ca. 2 Minuten warte sehe ich dann doch den Anmeldebildschirm. Mir steht dann allerdings nur xorg zur Verfügung, kein Wayland.
 
Zuletzt bearbeitet:
@Ratz_Fatz
Vielen Dank für Deinen Post, aber ich verstehe nicht, wie ich das bewerkstelligen soll. Wenn ich Ubuntu von Live-DVD starte, kommt als erstes "Grub". Da wähle ich dann den Eintrag "Ausprobieren ohne Installation" (sinngemäß). Darauf folgt das Ubuntu-Logo mit den Wartepünktchen. Währenddessen arbeitet der DVD-Brenner wie wild und schließlich hängt sich der PC an dieser Stelle auf.

Langsam beschleicht mich das Gefühl, dass mit dem BIOS was nicht stimmt. Allerdings läuft Windows unauffällig und stabil.
 
barmbekersurfer schrieb:
Wenn ich Ubuntu von Live-DVD starte, kommt als erstes "Grub". Da wähle ich dann den Eintrag "Ausprobieren ohne Installation" (sinngemäß).


Ganz genau und an der Stelle kannst du "e" drücken.

Anschließend kannst du sogenannte Kernelparameter mitgeben.
Das hat Ratz_Fatz oben gemeint.

gestartet wird dann per Strg+x

https://wiki.ubuntu.com/Kernel/KernelBootParameters
 
barmbekersurfer schrieb:
Langsam beschleicht mich das Gefühl, dass mit dem BIOS was nicht stimmt. Allerdings läuft Windows unauffällig und stabil.
Das hatte ich bei meinen damaligen beiden 2200G und verschiedenen Mainboards auch. Es gibt reichlich Fehler, die AMD hat und hatte. Im Moment läuft ein 3200G unter Debian Testing und Ubuntu ganz gut. Fedora gab es aber ein paar Probleme(siehe hier). Vielleicht hatte AMD unter Linux etwas mehr Probleme, die Lücken "Ryzenfall..." zu schließen. Die UEFIs sind aber auch sehr anfällig, besonders die eingebaute Update-Funktion(beispielsweise von Asrock(youtube)).

Probier mal meinen Vorschlag weiter oben aus, damit sollte es eigentlich klappen. Hier gibt es auch eine gute Anleitung, wie du vorgehen musst.

Weiß jemand ob nomodeset einen Start von Wayland verhindert? Denn damit verhält sich das System noch anders und ich bekomme nur xorg.
 
Zuletzt bearbeitet:
Wenn der Grub-Bildschirm kommt, dann ist secure boot nicht das Problem. Es kann ruhig eingeschaltet bleiben. Ubuntu 19.10 ist für einen 2400G ausreichend neu.

Schau mal in den BIOS-Einstellungen nach ob irgendwo SME/TSME (Speicherverschlüsselung) aktiviert ist. Das ist leider inkompatibel zum amdgpu-Treiber für die integrierte Grafik des 2400G.
 
Auf meinem ASRock AB350M ist TSME unter Advanced / AMD CBS zu finden. Eine separate Einstellung für SME gibt es nicht, aber das ist standardmäßig bei Linux aus.

Edit: In dem von dir verlinkten Handbuch auf Seite 70 (Seite 76 des PDFs)
 
Zuletzt bearbeitet:
Zurück
Oben