Microsoft .NET Framework 4.7 läßt sich nicht installieren ?

diemaus

Banned
Dabei seit
Juli 2017
Beiträge
704
Windows 7 32 Home ,
lässt sich nicht installieren es kommt eine Fehlermeldung das Framework blockiert,
ich hatte mir Offline Installer Microsoft .NET Framework 4.7 hier von CB runter geladen und es ist doch für Windows 7 oder ist das ein schreib Fehler ?
Bitte nicht solche Vorschläge über das Windows Update Center das dauert mir zu lange und es ist zu langsam.
 
Zuletzt bearbeitet:

Jesterfox

Fleet Admiral
Dabei seit
März 2009
Beiträge
38.981
Du hast es schon übers Windows Update probiert? Kann es evtl. sein dass die Installation im Hintergrund noch aktiv ist? Schau mal im Taskmanager ob da ein "TrustedInstaller" oder was ähnliches aktiv ist.
 

diemaus

Banned
Ersteller dieses Themas
Dabei seit
Juli 2017
Beiträge
704
Lass mal Windows Update durchlaufen bis nichts mehr da ist zum updaten -_-

Kannst ja was andere währenddessen machen
ich lasse kein Windows Update durchlaufen es dauert zu lange wie schon erwähnt
MS müllt mir dann auch noch den PC zu .
Ergänzung ()

KB4019990 hast du vorher installiert? sonst geht die .net 4.7 installation nicht unter windows 7.
http://go.microsoft.com/fwlink/?LinkId=846734

-andy-
Funktioniert nicht kommt eine Meldung dass das Update nicht für meinen PC ist,
ich lasse es jetzt es macht mir zu viel Arbeit habe die Downloads wieder gelöscht weil
unbrauchbar sind .
 
Zuletzt bearbeitet:

areiland

Commodore
Dabei seit
Apr. 2010
Beiträge
4.485

AndyMutz

Commander
Dabei seit
Dez. 2007
Beiträge
2.553
ja, wenn du dein windows nicht aktuell hälst, dann brauchst du dich nicht wundern, dass sich bestimmte sachen nicht installieren lassen.

-andy-
 

hildefeuer

Captain
Dabei seit
Okt. 2009
Beiträge
3.310
für was braucht man Netframework 4.7? Dir ist klar das das nicht abwärtskompatibel ist. Du must also meist auch 3.5 zusätzlich installieren. Daran scheitern viele ältere Programme unter Win10 und auch 7 und 8, weil eine Voraussetzung Netframework ist. V4.7 wird dann nicht erkannt, Installer scheitern. Es sei denn der user weis das und installiert händisch zusätzlich v3.5 die letzte abwärtskompatible Version.
 
Zuletzt bearbeitet:

surogat

Lieutenant
Dabei seit
Mai 2015
Beiträge
672
Auch das .NET-Framework 4.7 ist abwärtskompatibel zu 1.x-2 und 3.x-4.x. Wenn das ursprünglich vorhandene -NET-Framework, in dem das Programm entwickelt wurde, nicht vorhanden ist, wird immer ersucht es auf der aktuell installierten CLR auszuführen. Notfalls wird es im Hintergrund automatisch neu kompiliert. Nur in Ausnahmefällen, wenn sich bestimmte Änderungen ergeben haben, kommt es zu Ausführungsfehlern. Oder es handelt sich um ein natives Binary. Meine vor 10 Jahren entwickelte .NET 2.0 Anwendung läuft auch ohne .NET 2.0 oder 3.5 auf der .NET 4.7 CLR.
 
Top