ProFTPD kein Zugriff auf unterordner

DreamGamer

Lt. Junior Grade
Dabei seit
Feb. 2017
Beiträge
418
Hallo, ich habe proftpd bei mir eingerichtet und eig. hat auch alles soweit funktioniert nur kann ich keine Unterordner umbenennen. Meine ProFTPD.conf ist unverändert und sieht aktuell so aus:
Code:
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes, reload proftpd after modifications, if
# it runs in daemon mode. It is not required in inetd/xinetd mode.
#

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6                on
# If set on you can experience a longer connection delay in many cases.
IdentLookups            off

ServerName            "Debian"
ServerType            standalone
DeferWelcome            off

MultilineRFC2228        on
DefaultServer            on
ShowSymlinks            on

TimeoutNoTransfer        600
TimeoutStalled            600
TimeoutIdle            1200

DisplayLogin                    welcome.msg
DisplayChdir                   .message true
ListOptions                    "-l"

DenyFilter            \*.*/

# Use this to jail all users in their homes
# DefaultRoot            ~

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell        off

# Port 21 is the standard FTP port.
Port                21

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
# PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress        1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances            30

# Set the user and group that the server normally runs at.
User                proftpd
Group                nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask                022  022
# Normally, we want files to be overwriteable.
AllowOverwrite            on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd        off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder            mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile            off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

# Logging onto /var/log/lastlog is enabled but set to off by default
#UseLastlog on

# In order to keep log file dates consistent after chroot, use timezone info
# from /etc/localtime.  If this is not set, and proftpd is configured to
# chroot (e.g. DefaultRoot or <Anonymous>), it will use the non-daylight
# savings timezone regardless of whether DST is in effect.
#SetEnv TZ :/etc/localtime

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://www.securityfocus.com/bid/11430/discuss
# It is on by default.
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.conf

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User                ftp
#   Group                nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias            anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser    on ftp
#   DirFakeGroup on ftp
#
#   RequireValidShell        off
#
#   # Limit the maximum number of anonymous logins
#   MaxClients            10
#
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin            welcome.msg
#   DisplayChdir        .message
#
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
#
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask                022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
#
# </Anonymous>

# Include other custom configuration files
Include /etc/proftpd/conf.d/
Und meine eigene Config sieht aktuell so aus:

Code:
<Global>
 RequireValidShell off
</Global>
AllowOverwrite      on
 
DefaultRoot ~ ftpuser/*
 
<Limit LOGIN>
 DenyGroup !ftpuser
</Limit>
Also der Nutzer ftp in der Gruppe ftpuser hat einen eigenen Ordner der "/var/www/" ist und hat dort diese rechte:

Code:
drwxr-xr-x  5 ftp  ftpuser  4096 Nov  2 06:59 .
drwxr-xr-x 36 root root     4096 Nov  1 23:28 ..
-rw-r--r--  1 ftp  ftpuser   220 Nov  1 23:28 .bash_logout
-rw-r--r--  1 ftp  ftpuser  3515 Nov  1 23:28 .bashrc
-rw-r--r--  1 ftp  ftpuser   420 Nov  1 23:29 index.php
-rw-r--r--  1 ftp  ftpuser   675 Nov  1 23:28 .profile
-rw-r--r--  1 ftp  ftpuser  6919 Nov  1 23:29 wp-activate.php
drwxr-xr-x  9 ftp  ftpuser  4096 Nov  1 23:31 wp-admin
-rw-r--r--  1 ftp  ftpuser   369 Nov  1 23:31 wp-blog-header.php
-rw-r--r--  1 ftp  ftpuser  2283 Nov  1 23:31 wp-comments-post.php
-rw-r--r--  1 ftp  ftpuser  3830 Nov  1 23:58 wp-config.php
-rw-r--r--  1 ftp  ftpuser  3665 Nov  1 23:31 wp-config-sample.php
drwxr-xr-x  5 ftp  ftpuser  4096 Nov  1 23:32 wp-content
-rw-r--r--  1 ftp  ftpuser  3847 Nov  1 23:32 wp-cron.php
drwxr-xr-x 20 ftp  ftpuser 12288 Nov  1 23:36 wp-includes
-rw-r--r--  1 ftp  ftpuser  2502 Nov  1 23:36 wp-links-opml.php
-rw-r--r--  1 ftp  ftpuser  3306 Nov  1 23:36 wp-load.php
-rw-r--r--  1 ftp  ftpuser 39551 Nov  1 23:36 wp-login.php
-rw-r--r--  1 ftp  ftpuser  8403 Nov  1 23:36 wp-mail.php
-rw-r--r--  1 ftp  ftpuser 18962 Nov  1 23:36 wp-settings.php
-rw-r--r--  1 ftp  ftpuser 31085 Nov  1 23:36 wp-signup.php
-rw-r--r--  1 ftp  ftpuser  4764 Nov  1 23:36 wp-trackback.php
-rw-r--r--  1 ftp  ftpuser  3068 Nov  1 23:36 xmlrpc.php
Wenn ich in einen ordner gehe sehen die Berechtigungen so aus:

Code:
drwxr-xr-x 9 ftp ftpuser  4096 Nov  1 23:31 .
drwxr-xr-x 5 ftp ftpuser  4096 Nov  2 06:59 ..
-rw-r--r-- 1 ftp ftpuser 11104 Nov  1 23:31 about.php
-rw-r--r-- 1 ftp ftpuser  4627 Nov  1 23:31 admin-ajax.php
-rw-r--r-- 1 ftp ftpuser  2626 Nov  1 23:31 admin-footer.php
-rw-r--r-- 1 ftp ftpuser   409 Nov  1 23:31 admin-functions.php
-rw-r--r-- 1 ftp ftpuser  7871 Nov  1 23:31 admin-header.php
-rw-r--r-- 1 ftp ftpuser 11419 Nov  1 23:31 admin.php
-rw-r--r-- 1 ftp ftpuser  1692 Nov  1 23:31 admin-post.php
-rw-r--r-- 1 ftp ftpuser  3672 Nov  1 23:31 async-upload.php
-rw-r--r-- 1 ftp ftpuser 10902 Nov  1 23:31 comment.php
-rw-r--r-- 1 ftp ftpuser  5611 Nov  1 23:31 credits.php
drwxr-xr-x 3 ftp ftpuser  4096 Nov  1 23:31 css
-rw-r--r-- 1 ftp ftpuser 20557 Nov  1 23:30 custom-background.php
-rw-r--r-- 1 ftp ftpuser 47470 Nov  1 23:30 custom-header.php
-rw-r--r-- 1 ftp ftpuser  9567 Nov  1 23:30 customize.php
-rw-r--r-- 1 ftp ftpuser 14137 Nov  1 23:30 edit-comments.php
-rw-r--r-- 1 ftp ftpuser 28177 Nov  1 23:30 edit-form-advanced.php
-rw-r--r-- 1 ftp ftpuser 13200 Nov  1 23:30 edit-form-blocks.php
-rw-r--r-- 1 ftp ftpuser  7518 Nov  1 23:30 edit-form-comment.php
-rw-r--r-- 1 ftp ftpuser  6140 Nov  1 23:30 edit-link-form.php
-rw-r--r-- 1 ftp ftpuser 17163 Nov  1 23:30 edit.php
-rw-r--r-- 1 ftp ftpuser  9513 Nov  1 23:30 edit-tag-form.php
-rw-r--r-- 1 ftp ftpuser 20994 Nov  1 23:30 edit-tags.php
-rw-r--r-- 1 ftp ftpuser 10927 Nov  1 23:30 export.php
-rw-r--r-- 1 ftp ftpuser  6049 Nov  1 23:30 freedoms.php
drwxr-xr-x 2 ftp ftpuser  4096 Nov  1 23:30 images
-rw-r--r-- 1 ftp ftpuser  7430 Nov  1 23:30 import.php
drwxr-xr-x 2 ftp ftpuser  4096 Nov  1 23:30 includes
-rw-r--r-- 1 ftp ftpuser  5889 Nov  1 23:30 index.php
-rw-r--r-- 1 ftp ftpuser  5907 Nov  1 23:30 install-helper.php
-rw-r--r-- 1 ftp ftpuser 16818 Nov  1 23:30 install.php
drwxr-xr-x 3 ftp ftpuser  4096 Nov  1 23:30 js
-rw-r--r-- 1 ftp ftpuser   727 Nov  1 23:30 link-add.php
-rw-r--r-- 1 ftp ftpuser  4005 Nov  1 23:30 link-manager.php
-rw-r--r-- 1 ftp ftpuser  2439 Nov  1 23:30 link-parse-opml.php
-rw-r--r-- 1 ftp ftpuser  2737 Nov  1 23:29 link.php
-rw-r--r-- 1 ftp ftpuser  1655 Nov  1 23:29 load-scripts.php
-rw-r--r-- 1 ftp ftpuser  2262 Nov  1 23:29 load-styles.php
drwxr-xr-x 2 ftp ftpuser  4096 Nov  1 23:29 maint
-rw-r--r-- 1 ftp ftpuser  3189 Nov  1 23:29 media-new.php
-rw-r--r-- 1 ftp ftpuser  5618 Nov  1 23:29 media.php
-rw-r--r-- 1 ftp ftpuser  3376 Nov  1 23:29 media-upload.php
-rw-r--r-- 1 ftp ftpuser  9693 Nov  1 23:29 menu-header.php
-rw-r--r-- 1 ftp ftpuser 14190 Nov  1 23:29 menu.php
-rw-r--r-- 1 ftp ftpuser   322 Nov  1 23:29 moderation.php
-rw-r--r-- 1 ftp ftpuser   211 Nov  1 23:29 ms-admin.php
-rw-r--r-- 1 ftp ftpuser  4031 Nov  1 23:29 ms-delete-site.php
-rw-r--r-- 1 ftp ftpuser   231 Nov  1 23:29 ms-edit.php
-rw-r--r-- 1 ftp ftpuser   238 Nov  1 23:29 ms-options.php
-rw-r--r-- 1 ftp ftpuser   230 Nov  1 23:29 ms-sites.php
-rw-r--r-- 1 ftp ftpuser   232 Nov  1 23:29 ms-themes.php
-rw-r--r-- 1 ftp ftpuser   234 Nov  1 23:29 ms-upgrade-network.php
-rw-r--r-- 1 ftp ftpuser   230 Nov  1 23:29 ms-users.php
-rw-r--r-- 1 ftp ftpuser  4657 Nov  1 23:29 my-sites.php
-rw-r--r-- 1 ftp ftpuser 43585 Nov  1 23:29 nav-menus.php
drwxr-xr-x 2 ftp ftpuser  4096 Nov  1 23:29 network
-rw-r--r-- 1 ftp ftpuser  5362 Nov  1 23:29 network.php
-rw-r--r-- 1 ftp ftpuser 15119 Nov  1 23:29 options-discussion.php
-rw-r--r-- 1 ftp ftpuser 15121 Nov  1 23:29 options-general.php
-rw-r--r-- 1 ftp ftpuser   492 Nov  1 23:29 options-head.php
-rw-r--r-- 1 ftp ftpuser  6236 Nov  1 23:29 options-media.php
-rw-r--r-- 1 ftp ftpuser 18654 Nov  1 23:29 options-permalink.php
-rw-r--r-- 1 ftp ftpuser 11918 Nov  1 23:29 options.php
-rw-r--r-- 1 ftp ftpuser  8601 Nov  1 23:29 options-reading.php
-rw-r--r-- 1 ftp ftpuser  8610 Nov  1 23:29 options-writing.php
-rw-r--r-- 1 ftp ftpuser 13248 Nov  1 23:29 plugin-editor.php
-rw-r--r-- 1 ftp ftpuser  6320 Nov  1 23:29 plugin-install.php
-rw-r--r-- 1 ftp ftpuser 24255 Nov  1 23:29 plugins.php
-rw-r--r-- 1 ftp ftpuser  2680 Nov  1 23:29 post-new.php
-rw-r--r-- 1 ftp ftpuser  9587 Nov  1 23:29 post.php
-rw-r--r-- 1 ftp ftpuser  2383 Nov  1 23:29 press-this.php
-rw-r--r-- 1 ftp ftpuser  8068 Nov  1 23:29 privacy.php
-rw-r--r-- 1 ftp ftpuser   298 Nov  1 23:29 profile.php
-rw-r--r-- 1 ftp ftpuser  5168 Nov  1 23:29 revision.php
-rw-r--r-- 1 ftp ftpuser 15808 Nov  1 23:29 setup-config.php
-rw-r--r-- 1 ftp ftpuser  5632 Nov  1 23:29 site-health-info.php
-rw-r--r-- 1 ftp ftpuser  5296 Nov  1 23:29 site-health.php
-rw-r--r-- 1 ftp ftpuser  2114 Nov  1 23:29 term.php
-rw-r--r-- 1 ftp ftpuser 14815 Nov  1 23:29 theme-editor.php
-rw-r--r-- 1 ftp ftpuser 15144 Nov  1 23:29 theme-install.php
-rw-r--r-- 1 ftp ftpuser 23293 Nov  1 23:29 themes.php
-rw-r--r-- 1 ftp ftpuser  2612 Nov  1 23:29 tools.php
-rw-r--r-- 1 ftp ftpuser 32552 Nov  1 23:29 update-core.php
-rw-r--r-- 1 ftp ftpuser 10344 Nov  1 23:29 update.php
-rw-r--r-- 1 ftp ftpuser   344 Nov  1 23:29 upgrade-functions.php
-rw-r--r-- 1 ftp ftpuser  5654 Nov  1 23:29 upgrade.php
-rw-r--r-- 1 ftp ftpuser 13668 Nov  1 23:29 upload.php
drwxr-xr-x 2 ftp ftpuser  4096 Nov  1 23:29 user
-rw-r--r-- 1 ftp ftpuser 28921 Nov  1 23:29 user-edit.php
-rw-r--r-- 1 ftp ftpuser 22280 Nov  1 23:29 user-new.php
-rw-r--r-- 1 ftp ftpuser 19716 Nov  1 23:29 users.php
-rw-r--r-- 1 ftp ftpuser 19602 Nov  1 23:29 widgets.php
Weiß einer weshalb ich keine Berechtigung habe? In FileZilla bekomme ich als Fehlermeldung:
550 Rename bookmark-template.php2: Permission denied
Eigentlich müsste ftpuser doch alle Berechtigungen haben, oder nicht?

Danke schon einmal für die Hilfe :=)

MFG DreamGamer
 

burglar225

Lt. Junior Grade
Dabei seit
Juni 2004
Beiträge
421
ftpuser ist doch hier gar kein User, sondern eine Gruppe, wenn ich das richtig sehe. Der Benutzername des Besitzers lautet hier "ftp". Bist du mit dem angemeldet? Abgesehen davon wären die Berechtigungen der Datei, die du umbenennen willst deutlich interessanter, die bitte noch nachliefern.
 

Andreas_

Commander
Dabei seit
Jan. 2017
Beiträge
2.169
Der User "ftp" aus der Gruppe "ftpuser" schon. Aber bist Du denn "ftp", wenn Du Dich verbindest?

Sorry editiert, war noch nicht ganz wach.
 
Zuletzt bearbeitet:

burglar225

Lt. Junior Grade
Dabei seit
Juni 2004
Beiträge
421
Dann kann das mit den vergebenen Berechtigungen ohnehin nicht funktionieren.
Da du leider keine Auflistung der Datei geliefert hast, nehme ich jetzt exemplarisch irgendeine andere:
-rw-r--r-- 1 ftp ftpuser 20994 Nov 1 23:30 edit-tags.php
Die Datei gehört dem Benutzer ftp und der Gruppe ftupser. Der Besitzer hat Lese- und Schreibrechte. Die Gruppe und alle anderen Benutzer des Systems haben lediglich Lesezugriff. Ich kann dir jetzt nicht sagen in welchen Gruppen der User proftp ist, allerdings kann dieser Benutzer höchstens Leserechte haben. Warum genau ist der Besitzer der Dateien ein anderer wie der Benutzer, der den Dienst ausführt?
Du hast zwei Möglichkeiten:
1. Besitzer der Dateien und Ordner ändern
chmod -R proftp:ftpuser .
2. Den ausführenden Benutzer in deiner Config zu ftp ändern.
 

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
@burglar225 ich bin mit ftpuser angemeldet. Oder was meinst du denn genau? Und wie sieht man denn die Berechtigungen zum Umbenennen ein? (Ich habe seit 2 Jahren nicht mehr mit Linux gearbeitet :=) #MerktManEtwas)
Ergänzung ()

@Andreas_ Die Original Datei habe ich unverändert gelassen ich habe leider 0 Erfahrung bisher mit ProFTPD. Aber Einloggen geht ohne Probleme mit dem Namen ftpuser und dem Password des Benutzers. Oder was meinst du genau? :=)
Ergänzung ()

@burglar225 Ich habe gar keinen Benutzer der proftp heißt das ist, die Original Config die ich unverändert gelassen habe. Ich habe trd. mal den Namen zu ftp geändert aber ich habe weiterhin keine rechte in Unterordnern. Seltsamerweise aber ja im Hauptordner dort kann ich alles machen.
 

burglar225

Lt. Junior Grade
Dabei seit
Juni 2004
Beiträge
421
Mit wem du angemeldet bist, ist irrelevant. Es zählt nur, mit welchem Benutzer der Dienst ausgeführt wird: ftp.
Die Berechtigungen sind z.B. das hier: -rw-r--r--
Das erste - bedeutet hier, dass es sich um eine Datei handelt und keinen Ordner. Anschließend folgen je drei Werte r(ead), w(rite) und (e)x(ecute). Das erste Triple steht für die Berechtigungen des Besitzers der Datei. Hier also ganz konkret der Benutzer ftp (Achtung: Das ist nicht der Benutzer, der den Dienst ausführt). Das nächste Triple aus rwx steht für die Berechtigungen der angegebenen Besitzergruppe (hier: ftpuser).
Das letzte Triple zeigt dann die Berechtigungen für alle anderen Benutzer und Gruppen, die weder der Besitzer sind, noch in der Besitzergruppe sind.
Insgesamt solltest du dich ganz dringend mit den Berechtigungen mal auseinandersetzen, bevor du solche Sachen machst. Wie du siehst ist ein zumindest grundlegendes Verständnis absolut essentiell.
Ergänzung ()

Wie gesagt: Du dokterst nur herum, ohne wirklich zu wissen, was du überhaupt tust. Das macht so an dieser Stelle keinen Sinn, da Unix-Berechtigungen für den Betrieb von Software wirklich absolut essentiell sind. Ein gewisses Verständnis sollte auf jeden Fall da sein.
Da du auch auf mehrfache nachfrage hin keine Auflistung der Berechtigungen der entsprechenden Datei geliefert hast, kann ich dir an dieser Stelle auch nicht weiterhelfen (und das werde ich auch nicht, weil einfach die absoluten Basics fehlen).
 
Zuletzt bearbeitet:

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
@burglar225 ja das sollte ich dringend mal ^^ Aber ich nutze den Server nur im Privaten Raum aktuell noch. Zuvor hatte ich z.b. diese Config Datei aus dem Tutorial von dieser Seite: https://www.thomas-krenn.com/de/wiki/FTP-Server_unter_Debian_einrichten

Dann sah es bei mir so aus:
<Anonymous ~ftpuser>
User ftp
Group ftpuser
# Users can also login with ftp
UserAlias anonymous ftpuser
# All files belong to ftp
DirFakeUser on ftp
DirFakeGroup on ftpuser
RequireValidShell off
MaxClients 2
<Directory *>
<Limit ALL>
AllowAll
</Limit>
</Directory>
</Anonymous>
Nur konnte ich damit nicht einmal im Haupt Ordner eine Datei bearbeiten, löschen oder Umbennnen. Verstehe ich einfach ProFTPD gar nicht oder weshalb habe ich dort seltsamerweise keine rechte außer zum Lesen?
 

Andreas_

Commander
Dabei seit
Jan. 2017
Beiträge
2.169
Der user "ftp" aus der verlinkten Anleitung ist für anonymen Zugriff gedacht. Warum nutzt Du keinen normalen User?

DirFakeUser can be used to hide the true user owners of files (including directories, fifos, etc.) in a directory listing. If simply turned On, DirFakeUser will display all files as being owned by user 'ftp'. Optionally, the username argument can be used to specify a specific user other than 'ftp'. "~" can be used as the argument in order to display the current user's username.
Du bekommst also angezeigt, dass er Eigentümer wäre, obwohl er es nicht ist.
 
Zuletzt bearbeitet:

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
@burglar225 Achso oh gott jetzt verstehe ich die Frage erst
Abgesehen davon wären die Berechtigungen der Datei, die du umbenennen willst deutlich interessanter, die bitte noch nachliefern.
Ich dachte du wolltest wissen, wie die Umbenennen Berechtigungen gesetzt sind und da dachte ich mir welche Berechtigung meinst du es gibt doch keine eigene zum Umbenennen die ist doch in Write mit drin. Ich glaube ich sollte echt langsam mal wieder schlafen, wenn ich das schon nicht mehr auffasse. Es gibt keine bestimmte Datei, ich habe jede Datei durch probiert. Die 2. Berechtigungs-Tabelle oben ist von dem wp-admin Ordner. Und dort habe ich versichert keine Rechte zum Umbenennen oder Bearbeiten bei jeder Datei. Ich hoffe, jetzt habe ich es richtig verstanden Entschuldigung für die Umstände ^^
 

xammu

Lt. Commander
Dabei seit
Dez. 2008
Beiträge
1.830
Solange sich nicht der Nutzer "FTP" sondern nur ein Mitglied (zb: Anwender01) der Gruppe "FTPuser" wirst du gar nichts umbenennen konnen.

Entweder du meldest dich als Nutzer "FTP" an oder änderst den Besitzer der entsprechenden Datei / Order entsprechend (zB. Anwender01) oder du befasst dich mit dem Parameter "Umask" in der Proftp Konfiguration.
 

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
@Andreas_ Aber es gibt doch nur Anonymous, oder nicht?
Ich bin jetzt einmal auf dir ProFTPD Seite gegangen und habe mich etwas durchgelassen und mal das Example von denen nachgestellt. Das wäre dann ja so:
Code:
<Anonymous ~ftpuser>
  User                ftp
  Group                ftpuser

  <Limit LOGIN>
    AllowAll
  </Limit>
 
  GroupOwner            ftp
  Umask                0644     


  <Limit WRITE>
    AllowAll
  </Limit>


  <Directory *>
    <Limit READ>
      AllowALL
    </Limit>

    <Limit WRITE>
      AllowAll
    </Limit>
  </Directory>
</Anonymous>
@xammu wie logge ich mich denn direkt über ftp ein? Entschuldigung kenne mich noch nicht so sehr mit Pro FTPD aus. Und Unmask habe ich jetzt auch drin mit den benötigten Berechtigungen. Ist denn das soweit richtig? Denn ich kann immer noch nicht schreiben und damit überall nichts.
 

Andreas_

Commander
Dabei seit
Jan. 2017
Beiträge
2.169
Anonymous ist Zugriff ohne Nutzer/Passwort. Den Abschnitt kannst Du also ganz weg lassen. Wie Du normale FTP-Nutzer anlegst:

https://rootserver-blog.de/linux-webserver-hilfe/proftpd-neuer-benutzer/
Als erstes legen wir einen neuen Systembenutzer mit useradd an. Wir könnten auch adduser benutzen, ist aber nicht so leicht steuerbar.

Unsere Syntax für useradd lautet:
useradd Benutzername -d Verzeichnis

useradd John -d /var/www/john -s /bin/false

Jetzt geben wir dem Jungen noch ein Passwort mit:

passwd John

Damit der Benutzer John auch in seinem Verzeichnis /var/www/john
bleibt, schreiben wir folgendes in die Konfigurationsdatei
/etc/proftpd/proftpd.conf:

defaultroot ~

Nach dem Speichern sollte ProFTPD neugestartet werden:

/etc/init.d/proftpd restart

Nun sollte John per FTP reinkommen …
 
Zuletzt bearbeitet:

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
@Andreas_ Das habe ich ja zuvor gehabt. Also ich habe ja oben in meiner Datei zuvor "defaultroot ~" stehen gehabt um mich mit jedem Nutzer einzuloggen. Nur hatte ich dort nur rechte Dateien zu Bearbeiten im Hauptverzeichnis. Jetzt das seltsame... Ich habe jetzt gerade defaultroot ~ wieder mit Anonymous ersetzt und jetzt kann ich selbst im Hauptverzeichnis nichts mehr bearbeiten, obwohl nichts anders ist soweit ich weiß.
Aktuell sieht es so bei mir aus:

Code:
#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes, reload proftpd after modifications, if
# it runs in daemon mode. It is not required in inetd/xinetd mode.
#

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6                on
# If set on you can experience a longer connection delay in many cases.
IdentLookups            off

ServerName            "Debian"
ServerType            standalone
DeferWelcome            off

MultilineRFC2228        on
DefaultServer            on
ShowSymlinks            on

TimeoutNoTransfer        600
TimeoutStalled            600
TimeoutIdle            1200

DisplayLogin                    welcome.msg
DisplayChdir                   .message true
ListOptions                    "-l"

DenyFilter            \*.*/

# Use this to jail all users in their homes
# DefaultRoot            ~

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell        off

# Port 21 is the standard FTP port.
Port                21

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
# PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress        1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances            30

# Set the user and group that the server normally runs at.
User                ftp
Group                nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask                022  022
# Normally, we want files to be overwriteable.
AllowOverwrite            on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd        off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder            mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile            off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

# Logging onto /var/log/lastlog is enabled but set to off by default
#UseLastlog on

# In order to keep log file dates consistent after chroot, use timezone info
# from /etc/localtime.  If this is not set, and proftpd is configured to
# chroot (e.g. DefaultRoot or <Anonymous>), it will use the non-daylight
# savings timezone regardless of whether DST is in effect.
#SetEnv TZ :/etc/localtime

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://www.securityfocus.com/bid/11430/discuss
# It is on by default.
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.conf

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User                ftp
#   Group                nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias            anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser    on ftp
#   DirFakeGroup on ftp
#
#   RequireValidShell        off
#
#   # Limit the maximum number of anonymous logins
#   MaxClients            10
#
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin            welcome.msg
#   DisplayChdir        .message
#
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
#
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask                022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
#
# </Anonymous>

# Include other custom configuration files
Include /etc/proftpd/conf.d/
Meine Datei ist immernoch gleich:
Code:
<Global>
 RequireValidShell off
</Global>
AllowOverwrite      on
 
DefaultRoot ~ ftpuser/*
 
<Limit LOGIN>
 DenyGroup !ftpuser
</Limit>
Was ist denn jetzt anders?
 

Andreas_

Commander
Dabei seit
Jan. 2017
Beiträge
2.169
Also ich habe ja oben in meiner Datei zuvor "defaultroot ~" stehen gehabt um mich mit jedem Nutzer einzuloggen. Nur hatte ich dort nur rechte Dateien zu Bearbeiten im Hauptverzeichnis.
Was meinst Du mit "rechte Dateien"

Wenn Du FTP User auf Dateien außerhalb ihres User-Verzeichnisses zugreifen lassen willst, dann musst Du das konfigurieren. Siehe Punkt 3.1
http://wiki.ubuntu-forum.de/index.php?title=ProFTPd

Vorhin stand da noch proftp in Zeile 68
 
Zuletzt bearbeitet:

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
Oh ups, da fehlt ein Komma ^^ Ich hatte nur rechte, Dateien zu bearbeiten oder welche Umzubenennen oder zu löschen. Aber nur im Hauptverzeichnis. Sobald ich in /wp-admin/ gegangen bin, hatte ich keine Rechte mehr seltsamerweise. Und den User habe ich schon probiert wieder zurückzusetzen sobald es wieder proftpd ist, ändert sich aber nichts. Also ich kann seltsamer weise nicht wieder darauf zugreifen. Ich habe zuvor sogar ein Backup der beiden Dateien gemacht und habe die Hochgeladen und ProFTPD neugestartet und selbst bei diesen habe ich jetzt auch im Hauptverzeichnis keine Rechte mehr also irgendwie macht das gerade für mich garkeinen sinn mehr da ich sonst absolut nichts geändert habe.
 

DreamGamer

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Feb. 2017
Beiträge
418
10 Stunden später und ich finde immer noch nichts. Ich bin jetzt alles abgegangen. Die Dateien die ich Gebackupt habe funktionieren nicht mehr. Und auf dem Server wurde nichts eingegeben außer "systemctl Restart proftpd.service". Kann es sein das es zuvor ein Fehler war das ich im Hauptverzeichnis etwas ändern konnte und es jetzt richtig ist und ich überall keine Rechte haben sollte? Also sozusagen das es zuvor ein Bug war?

MFG DreamGamer
 
Top