Samba als PDC - Domainbeitritt funzt nicht

frey

Ensign
Dabei seit
Juni 2002
Beiträge
225
Hallo...

ich habe folgendes Problem. Ich habe einen Samba Server als PDC eingerichet (unter SuSE 9.2). Testparm meint dass alles iO ist. Ich kann auf alle Shares usw. zugreifen, doch wenn ich von einem Windows Client der Domain beitreten will bekomm ich folgende Fehlermeldung:

Der Domänenname "ha" ist möglicherweise ein NetBIOS-Domänenname. Sollte dies der Fall sein, stellen Sie sicher, dass der Name bei WINS registriert ist.

Wenn Sie sicher sind, dass es sich nicht um einen NetBIOS-Domänennamen handelt, können folgende Information bei der Fehlersuche in der DNS-Konfiguration behilflich sein:

Der folgende Fehler ist beim Abfragen von DNS über den Ressourceneintrag der Dienstidentifizierung (SRV) aufgetreten, der zur Suche eines Domänencontrollers für die Domäne "ha" verwendet wird:

Fehler: "Der DNS-Name ist nicht vorhanden."
(Fehlercode 0x0000232B RCODE_NAME_ERROR)

Die Abfrage war für den SRV-Eintrag für _ldap._tcp.dc._msdcs.ha

Die häufigsten Ursachen dieses Fehlers sind:

- Der DNS-SRV-Eintrag wurde nicht in DNS registriert.

- Mindestens eine der folgenden Zonen enthalten keine Delegierung zu dieser untergeordneten Zone:

ha
. (die Stammzone)

Klicken Sie auf "Hilfe", um weitere Informationen über die Fehlerbehebung zu erhalten.

Was mach ich falsch?

thx in advance...

maze
 

frey

Ensign
Ersteller dieses Themas
Dabei seit
Juni 2002
Beiträge
225
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
# Date: 2004-04-06
[global]
workgroup = ha
server string = Samba %v on %L
security = user
encrypt passwords = yes
netbios name = linux
read only = no
browseable = yes
domain master = yes
prefered domain = yes
domain logons = yes
os level = 65
logon drive = Z:
logon path = \\linux\profiles\%U.pds
logon home = \\linux\profiles\%U
logon script = %u.bat


[homes]
comment = Homeverzeichnis
browseable = no
writeable = yes

[winshare]
path = /windows
comment = Windows Partitionen
read only = no
writeable = yes

[netlogon]
path = /netlogon


hier erstmal die smb.conf...was du allerdings mit der slapd meinst weiss ich nicht genau
 

dow

Lieutenant
Dabei seit
Sep. 2002
Beiträge
730
kann mich erinnern mit xp-clients an samba mehrmals probleme mit der digitalen signierung gehabt zu haben.

Könnte folgende Option in den Gruppenrichtlinien sein (bin mir aber nicht sicher mangels samba pdc hier und mangels testmöglichkeit):
Computerkonfig->Windows Einst.->Sicherheits-Einst.->Lokale Richtlinien->Sicherheitsoptionen-> "Domänenmitglied: Daten des sicheren Kanals digital verschlüsseln oder signieren (immer)" -> deaktivieren.

Alternativ könnte es auch irgendeine andere Option in diesem Verzeichnis sein, aber es war etwas mit digitaler Signierung oder Verschlüsselung, probier halt mal.
 

frey

Ensign
Ersteller dieses Themas
Dabei seit
Juni 2002
Beiträge
225
erst einmal danke für euere Hilfe...ich bin jetzt soweit, dass die domain von meinem client gefunden wird (habe den pdc explizit in die lmhosts datei eingetragen), jedoch bekomme ich die fehlermeldung dass der zugriff verweigert wurde...ich vermute dass es an irgendwelchen rechteproblemen auf meinem linux pc liegt...(könnten es die zugriffsrechte auf netlogon sein?)
 
Top