Welche Linux-Live-Versionen haben mindestens Kernel 5.2?

linuxnutzer

Commander
Dabei seit
Dez. 2011
Beiträge
2.458
Da ich, nachdem es schon funktionierte, mit Ubuntu 19.10 Probleme habe, würde ich gerne eine Live-Version eines anderen Linux probieren, Voraussetzung ist Kernel mit mindestens 5.2 bzw. Supoort für X570 Chipset.
 
z.B. Kali, Arch und Manjaro.

BFF
 
  • Gefällt mir
Reaktionen: linuxnutzer
Manjaro würde sich insofern Empfehlen, da es mit dem Kernel Manager absolut Anfänger-Freundlich ist. Du kannst 4.19, 5.2, 5.3 und 5.4 wählen und per Gui installieren bzw. deinstallieren.

Außerdem kannst du zwischen "normalem" und RT Kernel auswählen (je nachdem ob du Realtime Kernel brauchst)

Genau so wie Treiber für AMD/Nvidia etc.
 
Zuletzt bearbeitet:
Fedora 31 müsste bald released werden, das hätte dann wohl 5.3.
 
Das neuste Ubuntu (19.10) kommt auch mit Kernel 5.3.

Edit: Sry, jetzt erst gesehen, dass du was anderes als Ubuntu 19.10 suchst.
 
Vielen Dank, mein Problem hat sich erledigt, ist was ganz diffiziles. Der Brenner hat AHCI-Fehlermeldungen gebracht und es könnte mit dem ASM1061-Chip zusammenhängen, seitdem der Brenner direkt an der CPU hängt, ist das Problem weg.

Müsse unter Linux die SATA-Ports hintereinander belegt sein oder darf man da auch einen aus lassen?
 
Sprich die Hardware ist/baut „Bullshit“. 😉

Bau den Brenner aus und besorge Dir einen Externen.

BFF
 
Sprich die Hardware ist/baut „Bullshit“.

Welche denn, das X570-Board, der Brenner, der ASM1061-Chip, etc? Der Brenner an SATA-Port 3 ist problemlos, bei SATA-Port 5 gibt es Probleme. Ich vermute einfach, dass die Hardware zu neu ist und das gibt dann die Probleme unter Linux bis die Bugs behoben sind. Ist nur schwierig, da selber dahinter zu kommen, warum etwas Probleme macht, hätte nie an den Brenner gedacht, wobei es aber auch die SATA-Ports 5-6 sein können, die über den ASM1061 verbunden sind. Solange ich nicht alle Ports brauche also kein Problem, aber bald werde ich 5 Ports brauchen und da wird sich zeigen, was nun funktioniert.
 
Es gibt eigentlich keine "zu neue Hardware" fuer ein nerdiges SATA-Brenner-Laufwerk.

SATA-Port 5 macht Probleme? Zufaellig eine M2 verbaut die SATA ist?
Ich schau da jetzt nicht nach ob das sein kann.

BFF
 

Bei der Ubuntu 19.10 Installation, wenn ein Brenner angehängt ist. Keine Ahnung, ob das auch für eine HD gilt. Es ist eine NVME-M2 angehängt und das sollte sich lt. Handbuch nicht beißen. Vgl. http://download.msi.com/archive/mnu_exe/mb/E7B93v1.1.pdf Der Brenner wurde im Bios auch an Port 5 angezeigt. Vielleicht ein Problem der Installation? Darum hatte ich ja nach einem anderen Linux gefragt. Win 10 lief durch, mehr habe ich aber damit auch nicht gemacht und Win ist schon wieder gelöscht. Wie geschrieben, es funktioniert zur Zeit alles nachdem Port 3 statt Port 5 für den Brenner verwendet wurde.

Zurück zu meiner Frage, kann man SATA-Ports frei lassen und sollte das keine Probleme machen? Es wird langsam auf den neuen PC umgestellt, zur Zeit passt es.
 
Was heisst frei lassen?

So was wie SSD0 in M2, SSD1 in SATA0, HDD0 in SATA1 und Brenner in SATA5?
Ja klar geht das. Hab ich hier auch so aehnlich.

Da ich zu faul bin die Spezifikationen durchzuackern fuer das Brett.
Der ASM1061 fuer SATA5/6 hat definitiv Kernelunterstuetzung?

BFF
 
Zuletzt bearbeitet:
disk:
/dev/nvme0n1 Samsung Electronics NVMe SSD Controller SM981/PM981
/dev/sdb ST6000VN0021-1ZA
/dev/sda ST8000NM000A-2KE

cdrom:
/dev/sr0 HL-DT-ST BD-RE BH16NS40

Das sind die verbauten Geräte

So was wie SSD0 in M2, SSD1 in SATA0, HDD0 in SATA1 und Brenner in SATA5?
Ja klar geht das. Hab ich hier auch so aehnlich.

Das nahm ich auch an, bin schon gespannt auf einen ähnlichen PC, da ist der Brenner auf SATA6 und SATA5 ist frei, SATA1 SSD, SATA2-4 HD. Den PC krieg ich aber erst und dann muss ich noch aus anderen PCs was dazu bauen, dauert also.

Der ASM1061 fuer SATA5/6 hat definitiv Kernelunterstuetzung?

Tja, ich vermute schon, ich habe irgendwo einen Thread gefunden wo wer mit Ubuntu 18.04 "irgendwie" ähnliche Probleme wie ich hatte.

http://download.msi.com/archive/mnu_exe/mb/E7B93v1.1.pdf
Wenn du dir das Blockdiagramm auf S. 23 ansiehst, dann siehst, dass SATA 1-4 eine Gruppe bildet und SATA 5-6 mit den 1 NVME auch, ich vermute das ist der 2. M2. Ich habe also nichts über den ASM1061 eingeschlossen. Somit bleibt es Rätselraten warum die Installation hängt.

Hier ist was aus 2011:
https://ata.wiki.kernel.org/index.php/SATA_hardware_features
Nachdem der Chip schon damals erwähnt wurde, nehme ich an, dass da schon einige Zeit daran gearbeitet wurde, aber das sagt natürlich nichts wie sich das mit dem aktuellen X570 verträgt.
 
Das lese ich aber anders mit der Zuordnnung der M2.

1571871189307.png


Fuer mich sind nur SATA5/6 am ASMEDIA. Keine M2 dort dran.
Ob die M2_2 beeinflusst wird durch des ASMedia kann ich Dir echt nicht sagen.

BFF
Ergänzung ()

Lies mal das hier. @linuxnutzer

https://bbs.archlinux.org/viewtopic.php?pid=1855895#p1855895

Das kommt doch dicht ran an Dein Problem, oder?
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: Serana und linuxnutzer
Zitat von linuxnutzer:
Der im letzten Beitrag genannte Problem mit Asmedia oder ähnliche Probleme scheinen recht verbreitet und lange zu bestehen - libata.atapi_passthru16=0 gibt mehrere Ergebnisse bei google.
Bei den Kernel-bugs die diesen Parameter als Lösung vorschlagen steht dann als Ursache zB auch Laufwerksfirmware (oder die Fähigkeiten des SATA Chipsatzes selbst).
Der Chip selbst ist recht alt - und die Mainboardhersteller interessieren sich vielleicht nicht unbedingt für jede exotische Kombination - MS könnte die Hardware anders ansprechen und dadurch tritt bei Windows der Fehler nicht auf.
Bei Redhat steht zB auch das

  • Deaktivieren von AHCI Modus beim Controller/Port,
  • setzen auf 1.5G SATA oder
  • Deaktivieren von NCQ

Auswirkungen haben könnten = das Laufwerk dann besser funktioniert. SATA ist recht komplex.
 
  • Gefällt mir
Reaktionen: Serana und linuxnutzer
Das Problem wurde zwar schon gelöst, aber ich kann zumindest bestätigen, daß der Asmedia 1061/1062 Chip unter Linux generell Probleme macht sobald man ein DVD-Laufwerk (oder irgendwas anderes mit Silberscheiben) daran anschließt. Leider hatte ich nämlich jetzt die Tage genau dieses Problem mit "AHCI controller unavailable".

Dabei dachte ich, daß ein Board wie das Asus Sabertooth 990FX R2.0 nun wirklich so "abgehangen" sein müßte, daß es da keine Probleme mehr gibt. Insofern gehe ich mal davon aus, daß diese spezielle Unverträglichkeit auch in Zukunft erhalten bleibt.
 
  • Gefällt mir
Reaktionen: BFF
Zurück
Top