Windows 10, DVI -> HDMI, 2560x1440

Mickey Cohen

Commander
Registriert
Mai 2015
Beiträge
2.904
hallo,

habe hier folgendes setup:
2560x1440 monitor
radeon r9 380
windows 10 x64 pro 1709

ich will den monitor über ein dvi-d -> hdmi kabel anschliessen. (dvi-d an der graka, hdmi am monitor)
windows gibt mir maximal 1080p zum auswählen an.
radeon-treiber erlaubt mir nicht, benutzerdiefinierte auflösung über 1080p zu erstellen.

wie krieg ich windows dazu, 2560x1440 darstellen zu lassen?

es hat seinen grund, warum ich den dvi-port benutzen muss, also bitte kein "warum nutzt du nicht einfach den hdmi-port an der grafikkarte".

es handelt sich um ein dual-link kabel, das extra als 4k-fähig beschrieben wurde.

unter linux habe ich 2560x1440.

danke :)
 
Mickey Cohen schrieb:
es handelt sich um ein dual-link kabel, das extra als 4k-fähig beschrieben wurde.

dual Link DVI kann keine 4k bei 60 Hz ...

Weiterhin wenn es nicht anders unter Windows erkannt wird und du die Auflösung nicht Manuell hochschalten kannst dann wars das fast schon.

Ausser mit einer passenden Monitor *.inf File die Windows halt sagt was der Monitor kann.
 
wollte ich auch mal machen und habe dann überall gelesen, dass fast alle DVI -> HDMI kabel von DVI seite nicht dual link geschaltet sind, dementsprechend auch nur maximal 1080p@60 können.
ist wohl reines glück, ob das kabel das kann oder nicht.

EDIT: wobei, wenn es bei dir unter linux geht, dann sollte es eigentlich nicht am kabel liegen, würde ich mal vermuten.

-andy-
 
Zuletzt bearbeitet:
In Windows (W10) macht man das hier:
20180205_112519.jpg
Dann da:
20180205_112448_001.jpg

Der AMD Treiber ist dabei gar nicht involviert...

4K ist auch nicht 1440p sondern 2160p jedenfalls laut Wiki 4K2K.
 
Zuletzt bearbeitet:
lösch dich.

und dann lern lesen.

jetz mal ernsthaft, geht aus meinem post nicht hervor, dass in der liste mit den auflösung 2560 x 1440 NICHT vorhanden ist???

mir schrieb:
windows gibt mir maximal 1080p zum auswählen an.
 
Hi!

Wenn die Windows die Auflösung in den Anzeigeanstellungen nicht anbietet, dann ist sie zunächst auch mal nicht möglich.

Prinzipiell kann die Grafikkarte die Auflösung, aber ich kenne es so, dass oft die DVI-D Ausgänge Single Link sind und die DVI-I Ausgänge Dual Link. Und Dual Link brauchst du für die Auflösung. Hast du mehrere DVI-Ausgänge? Dann wäre es der, mit den vier kleinen Löcher bei dem länglichen Schlitz. Wenn dann dein Adapter, Kabel und Monitor die Auflösung mitmachen, dann sollte es gehen.

Also eine R9 380 kann die Auflösung. Jetzt musst du nach deinem Monitor schauen. HDMI bis 1.2a kann nur Full HD, wäre aber Quatsch, wenn dein Monitor mit seiner Auflösung nur den Standard könnte. Warum per HDMI anschließen? DVI-Eingang hat der Monitor nicht?

Was ich ehrlich gesagt nicht verstehe, ist warum es unter Linux funktioniert.

Gruß
MoJo77
 
Ein ähnliches Problem hatte ich gestern.
AMD Karte mit 2 DVI Anschlüssen. 2 baugleiche 1440p Monitore. Beide über DVI-D angeschlossen. Einer lief mit 1440p beim zweiten wurde mir nur 1080p angeboten. Bin dann auf einen Displayport ausgewichen. Riecht nach Bug. ;-)
 
um das nochmal klarzustellen: es ist kein hardwarefehler, das problem ist windows.

windows muss die info ja irgendwo herkriegen, welche auflösungen es anbietet. also muss ich wohl das manipulieren. wo und wie mache ich das? registry?
 
Mickey Cohen schrieb:
lösch dich.
und dann lern lesen.
jetz mal ernsthaft, geht aus meinem post nicht hervor, dass in der liste mit den auflösung 2560 x 1440 NICHT vorhanden ist???
Lösch dich selbst.
Bei Windows liest Windows das aus wenn du ein Device steckst. Stecken, Starten, Einstellen wie auf den Bildern ... Standardvorgang ohne große Geheimnisse. Der Monitor sagt also gerade zu Windows: 1080p ist Ende der Fahnenstange. Evtl. hat dein Monitorhersteller ein *.inf für seine Displays auf der Homepage? Dann dieses in Windows laden. Windows nimmt gerne Standard VGA oder Generic *.inf.
 
Hier sind ja echt teils wilde Antworten...
Ich vermute, dass das Kabel indirekt Schuld ist, also nicht unbedingt Windows ausreichend "glaubhaft" machen kann, dass es die 2560x1440 stemmen kann.
Oder es ist tatsächlich mal ein fehlender Monitortreiber.

Wie dem auch sein, ich würde es mit einer benutzerdefinierten Auflösung versuchen.
Dazu gehst du unter die Anzeigeeinstellungen (da wo du die Auflösung nicht auswählen kannst).
Dann gibt es unterhalb der Auflösung einen Punkt "Adaptereigenschaften anzeigen".
Klicke dort auf "Alle Modi auflisten". Gibt es dort 2560x1440? Vermute leider, dass es Windows auch nicht besser als der Readeon-Treiber hinbekommt, aber manchmal passieren ja noch Wunder..
Falls nicht, müsstest du es wohl mit einem externen Tool versuchen, wie dem Custom Resolution Utility.
Alles nochmal nachzulesen hier (auf Englisch).

Viel Erfolg

Edit:
@benneque:
Das hab ich mir auch gedacht, vielleicht bietet Windows nur Auflösungen an, die mit 60Hz laufen und Linux eben alles verfügbare.
Aber das wäre nur ne grobe Vermutung..
 
Zuletzt bearbeitet:
Sind es unter Linux auch wirklich 60Hz? Am Besten direkt das Info Menü vom Monitor befragen.
 
Zuletzt bearbeitet:
nochmal extra nachgeschaut:

also die graka ünterstützt via DVI 2560x1600 @ 60 Hz

unter linux klappt es, dort habe ich 2560x1440 @59.95 Hz

selbst DVI single link geht bis 1920 x1200@ 60 Hz offiziell mit.

wenn also wirklich alles schiefläuft, dann müsste mir windows wenigstens 1920 x 1200 @ 60 Hz anbieten. tatsächlich lässt es mich maximal 1920 x 1080 @ 60 Hz wählen.

es liegt also definitiv an der software, sei es nun OS oder der AMD-Treiber. Zumal es ja unter linux klappt.

zum thema monitor-treiber: ich habe auf der herstellerseite nachgesehen (Hannspree, Monitor ist ein Hanns-G HQ272) und der einzige download, den ich finden konnte, war das support-handbuch. nehm ich ihnen nicht übel, wenn die anderen hirnis ihre jobs vernünftig gemacht hätten bräuchte es auch keinen treiber.

@ shadowrid0r

sry, dass ich so ausfallend geworden bin, aber ich kam mir durch deinen ersten post dezent verarscht vor, wenn ich das doch extra so hinschreibe.

soweit mal danke an alle, werde jetzt mas das CRU-Tool versuchen.


edit: grade kommt mir noch die idee, dass AMD ja auch das soundsignal über DVI durschschleift. (der monitor hat integrierte böxchen). vll. geht dadurch etwas bandbreite drauf, werde versuchen das mal auszustellen.
 
Zuletzt bearbeitet:
Nein das Soundsignal geht über andere Ports raus ... das klaut keine Bandbreite

Was mich interresieren würde was für eine AMD Karte ... weil viele meinen das machen neuere Karten nicht mehr ?
 
Zuletzt bearbeitet:
heute erst getestet, da kommt definitiv ein tonsignal durch den dvi-port. ist eine r9 380, wie im eingangspost geschildert ;)

hast aber insofern recht, als dass das deaktivieren nix bringt
 
Mickey Cohen schrieb:
nochmal extra nachgeschaut:
Selbst DVI single link geht bis 1920 x1200@ 60 Hz offiziell mit.

wenn also wirklich alles schiefläuft, dann müsste mir windows wenigstens 1920 x 1200 @ 60 Hz anbieten. tatsächlich lässt es mich maximal 1920 x 1080 @ 60 Hz wählen.
Welche anderen Auflösungen werden dir noch angeboten ? Möglicherweise nur 16:9 Auflösungen ?
 
Zurück
Oben