wireless ipw2200 unter SUSE 10

corallus

Cadet 2nd Year
Dabei seit
Feb. 2006
Beiträge
21
Hallo

Ich tu mich ein wenig schwer, mein Wireless in Funktion zu bringen. Ist ein Inspirion 6000 Schlepptop und nun mit SUSE 10 bestückt. Die Funkkarte ist eine ipw2200. Hab auch schon mit Hilfe aus dem Netzt ein Firmwareupdate und dergleichen gemacht, doch genützt hat es nichts. Ich komme irgendwie nicht zum Ziel. Mit Kompillieren kenne ich mich noch nicht aus. Ich hoffe, dies ist auch nicht nötig..

Wäre froh, wenn mich jemand durch den Softwarejungel begleiten könnte.

Danke im Voraus und Gruss
Swen
 

DatenMetzgerX

Cadet 3rd Year
Dabei seit
Dez. 2005
Beiträge
58
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

Viel spass, habe meine ipw2100 nie zum laufen gebracht bis...

Ich ubuntu genommen habe :)

Sonst musst du den ganzen Kernel neu kompilieren (wenn ich das damals richtig verstanden habe ^^)
 

corallus

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Feb. 2006
Beiträge
21
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

Merci für eure Antworten.

So schnell möchte ich nicht aufgeben, doch wenns nicht klappt, dann probier ich mal ubuntu. Oder warte auf die nächste Suse-Version (10.1) und hoffe, das Problem wird dort behoben sein..

Habe den Thread studiert und folgendes festegestellt: Wireless funktioniert, wenn ich per kinternet manuell starte. Habe auch die Firmware 2.3 und Treiber 1.0.6 installiert. Nützt nichts, muss trotzdem jedesmal manuell starten. Habe ich etwas falsch installiert oder gibt es allenfalls noch andere Möglichkeiten?

Werde mich jedoch unter linuxclub.de probieren schlauer zu machen.

Bacchisio, war dir das Ernst mit "dmesg", da kommen ja unmengen von Infos raus. Gibt es da keine "Light-version"..?
 

davidbaumann

Commodore
Dabei seit
Aug. 2004
Beiträge
4.864
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

tail -f /var/log/messages

Probier auch mal dmesg | less

David
 

Bacchisio

Lieutenant
Dabei seit
Sep. 2004
Beiträge
517
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

das mit dmesg war ernst gemeint :)

eigentlich war die idee dass du die relevanten Teilen rausfilterst , könnte man auch so machen :

dmesg | grep ipw
 

corallus

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Feb. 2006
Beiträge
21
Bin relativ neu auf dem Gebiet und kenne die Befehle noch kaum.

Ich hoffe, ihr versteht diese Inhalte besser als ich. ;)

tail -f /var/log/messages
Feb 15 10:15:57 linux kernel: ipw2200: failed to send CARD_DISABLE command
Feb 15 10:16:04 linux hcid[7301]: Can't set scan mode on hci0: Connection timed out (110)
Feb 15 10:16:10 linux dhcpcd[5298]: terminating on signal 15
Feb 15 10:16:10 linux dhcpcd-hook: Skipping 'ifdown $INTERFACE -o dhcp' call
Feb 15 10:16:22 linux kernel: eth1: no IPv6 routers present
Feb 15 10:16:46 linux ifup-wireless: command 'iwconfig eth1 mode Master' returned
Feb 15 10:16:46 linux ifup-wireless: Error for wireless request "Set Mode" (8B06) :
Feb 15 10:16:46 linux ifup-wireless: SET failed on device eth1 ; Invalid argument.
Feb 15 10:17:23 linux modify_resolvconf: Service dhcpcd modified /etc/resolv.conf. See info block in this file
Feb 15 10:19:08 linux su: (to root) corallus on /dev/pts/0

dmesg | grep ipw
ipw2200: module not supported by Novell, setting U taint flag.
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.6
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Radio Frequency Kill Switch is On:
ipw2200: failed to send SCAN_ABORT command
ipw2200: failed to send CARD_DISABLE command

dmesg | grep ieee
ieee80211_crypt: module not supported by Novell, setting U taint flag.
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: module not supported by Novell, setting U taint flag.
ieee80211: 802.11 data/management/control stack, 1.0.3
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ieee1394: Initialized config rom entry `ip1394'
ieee1394: Host added: ID:BUS[0-00:1023] GUID[384fc0003c695c30]
ieee80211_crypt_wep: module not supported by Novell, setting U taint flag.
ieee80211_crypt: registered algorithm 'WEP'

modinfo ipw2200
filename: /lib/modules/2.6.13-15.8-default/extra/ipw2200.ko
description: Intel(R) PRO/Wireless 2200/2915 Network Driver
version: 1.0.6
author: Copyright(c) 2003-2004 Intel Corporation
license: GPL
vermagic: 2.6.13-15.8-default 586 REGPARM gcc-4.0
depends: ieee80211,firmware_class

So schwierig kann es doch eigentlich nicht sein. Schalte den Laptop auf, dann mit FN-Taste WiFi einschalten, bei Kinternet den Key eingeben und es läuft! Gibt es nichts, das einem genau diese Schritte abnimmt? ;)
Hm, werde mal schön weiter googlen..
 
Zuletzt von einem Moderator bearbeitet:

Bacchisio

Lieutenant
Dabei seit
Sep. 2004
Beiträge
517
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

du könntest folgendes versuchen (wenn du es nicht schon so gemacht hast) :

- im yast die wlan karten entfernen

- diese ftp Quelle hinzufügen :
ftp://ftp.gwdg.de/pub/suse/i386/10.0/inst-source-extra/suse/i586/

und das Paket "kernel-default-nongpl-2.6.13-15.i586.rpm" installieren und neustarten. Danach im yast neu konfigurieren.
 
Zuletzt bearbeitet:

corallus

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Feb. 2006
Beiträge
21
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

Danke, das habe ich nun getan. Es bleibt aber alles beim Alten. Wenn ich via Root einlogge wird Kinternet automatisch geladen (Beim normalen Einloggen noch nicht. Weiss nicht, wie ich das hinkriegte, werde ich jedoch noch rausfinden..). Dann muss ich "nur" noch drahtlose Verbindungen anzeigen, mein Heimnetzwerk anklicken und dann auf "Verbinden" drücken (ohne Key-Neueingabe). Ich denke, damit kann ich leben..

Ist wohl ein Einstellungsfehler von mir, dass ich dies alles manuell machen muss, und kein SW-Fehler auf Seiten von SUSE oder sonst wem. Mal tüfteln und probieren, bis alles automatisch geht beim Aufstarten..

Für weitere Tips bin ich dankbar und ansonsten schon mal besten Dank für die Tips bis hierhin.
 

Bacchisio

Lieutenant
Dabei seit
Sep. 2004
Beiträge
517
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

man könnte noch das versuchen:

alias wlan0 ipw2200
options ipw2200 ifname=wlan0

in die /etc/modprobe.conf eintragen

danach neustarten und hoffen dass es klappt :)
 

corallus

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Feb. 2006
Beiträge
21
AW: brauche hilfe: wireless ipw2200 unter SUSE 10

Hehe, der ging hinten raus, denn nach dieser Eintragung und Neustart ging gar nichts mehr mit dem Netz.

Ich begnüg mich mit der aktuellen Situation und hoffe, dass dann die neue Version (SUSE 10.1) besser sein wird..

Danke und Gruss
 

corallus

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Feb. 2006
Beiträge
21
Ja, via Forum ist es aufwändig, doch immer noch besser als ohne Hilfe ;)

Ich werde es in 2 Wochen nochmals vesuchen, doch zuerst sollte ich mich wieder anderen Dingen zuwenden. Habe eben in kürze wichtige Abschlussprüfungen zu bestreiten und sollte mich noch ein wenig darauf vorbereiten..

Werde dann allfällige Netzwerk-Erfolge hier melden..
 
Top