allgemeine Installation Drucker nicht mehr möglich

Galaxysnoopy

Newbie
Registriert
Sep. 2016
Beiträge
5
Hallo liebe Gemeinde,

ich habe seit längerem einen Samsung 365W Netzwerkdrucker, dieser funktioniert soweit einwandfrei.
Da ich nur ab und an etwas drucke, fiel es mir gestern Abend auf.

Als ich das Dokument absetzen sollte, kam keine Fehlermeldung, nur der Spooleintrag war vorhanden aber der Drucker empfing über WLAN nichts. Nach mehrmaligem Versuchen, neu einbinden im Router, fiel mir bei der Neu-Installation mehrerer Treiber-Pakete des Herstellers auf, dass er zwar immer den Drucker fand, aber dann beim letztendlichen Verbinden fehlschlug ("kann keine Verbindung herstellen"). Der Drucker ist aber 100% da, ich kann ihn auch im Netzwerk per interner Website aufrufen.

Nun das eigentliche Problem: Wenn ich manuell einen Drucker hinzufügen will, sehe ich schon, dass mir die Auswahl wie LPT, COM und USB etc fehlen. Dieses Problem habe ich bisher nur bei einem anderen im Netz gefunden, dort gab es aber keine abschließende Hilfe.

Kurz zusammengefasst was ich herausgefunden habe bzw. probiert habe:
  • ich habe Windows 10 (Personal, Build 21H2, 19044.1682)
  • im Netz gefunden, dass es so diverse Druckprobleme seit dem Update KB5006670 gibt
(Windows 10: Update KB5006670 behindert den Druckvorgang etc..)
  • dieses habe ich lt. Konsolencheck aber wohl nicht mehr aktiv, wurde wohl schon durchs neuste überschrieben(?)
  • scf /scannow bereits durchgeführt, ebenso MS eigenes Repair Tool.
  • Spoolservices laufen anscheinend alle, auch schon alle DLLs durchsucht, oder neu gestartet.
  • Avira und Firewall komplett deaktiviert
  • mehrfach versucht alle Treiber zu deinstallieren und "sauber" neu aufzuspielen, Drucker wird dann zwar angezeigt, aber er ist nicht "wirklich" auswählbar bzw. auch nicht als Standard auswählbar.
  • auch Anschluss über USB und Netzwerkkabel führt im besten Fall nur dazu, dass der Drucker angezeigt wird, aber nicht wirklich von Windows aus ansprechbar ist.
  • mein System ist aller Vorraussicht nach sauber, mache regelmäßige Scans auch per Windows eigenem Check, Malwarebytes etc. (aktiver Scanner ist aber nur der Avira) und es sind sonst keine Auffälligkeiten sichtbar.

Ich denke mittlerweile dass ich nicht dieses wie im Netz häufig auftrende Problem mit dem Drucker habe. Was mich wundert ist, dass ich unter manueller Eingabe diese Standard-Ports nicht hinzufügen kann (sie werden gar nicht erst angezeigt). Wenn ich z.B. einen eigenen Anschlusstypen dann hinzufügen will, will er eine *.INF Datei haben. Ggf. kann man die Schnittstelle ja "reparieren"? Aber auch als Informatiker ist Netzwerk und/oder Drucker nicht so meine Glanzparade was die Tiefen angeht :)

Im Netz gab es dazu ebenso einen Registry Versuch unter HKLM\SYSTEM\ControlSet001\Control\Print\Monitors, dass man sich dort die Anschlüsse über den Schlüssel Driver die localspl.dll laden muss. Der Eintrag war bei mir nicht vorhanden (dachte ggf. an "mysteriösem Verschwinden" durch irgendein Windows Update), die brachte aber auch nichts nach Neustart.

Bin grad ein wenig am Verzweifeln. Kennt sich jemand mit dem Kern der Druckersteuerung aus? Wie gesagt, man kann ihn hinzufügen, er ist auch in Ordnung und druckt über USB als Plug & Play auf einem Firmen-Notebook wunderbar.

Ich vermute dass Windows irgendwo ne Macke hat, oder es doch noch an einem der Windows Updates Probleme liegt?

Im Netz war teils noch davon die Rede, dass man sich ggf. z.B. die Win32spl.dll und weitere tauschen sollte (alte Versionen):
Auszug:
So nun noch ein verzweifelter versuch die Drucker zum drucken zu bewegen
Anscheint muss man noch zwei weitere Dateien austauschen.
1. win32spl.dll wie schon erwähnt
2. localspl.dll
3. spoolsv.exe


Gemacht habe ich das noch nicht da ich eine Quelle bräuchte aber auch bei Windows nichts wirklich finde.

Ich bin noch dankbar für jede Hilfestellung :) Aktuell scheint es so, als wenn ich ja überhaupt keinen Druck mehr richtig angeschlossen bekomme :(

Viele Grüße
Marc
 
Versuch mal den Drucker per usb Kabel zu installieren, oder installieren lassen von Windows
 
Hi und willkommen im Forum...

Hoffentlich ist durch das manuelle Eingreifen in die Registry nun dort nichts "zerschossen".

Wurde denn auch das in diesem deskmodder-Artikel erwähnte Update KB5007253 installiert, dass diesen Remote-Fehler aus der PrintNightmare-Problematik (u. a. mit KB5006670) behebt?​
 
Hi, zur ersten Antwort: ja ich habe "alle" möglichen Wege ausprobiert, den Drucker zum Laufen zu bekommen. Er läd ein wenig im Hintergrund, fügt ihn dann hinzu. Aber erst ist dann nur noch wie ein Pseudo-Gerät (sieht gut aus, aber klappt nicht in letzer Konsequenz 🧐

Zur zweiten: Ich denke nicht, dass dadurch jetzt was zerschossen ist. Ich bin - wenn ich da schon rumfummel - wirklich sehr bedacht und schaue nur das Thema/den Hinweis 3x mal an um einigermaßen abzuschätzen was das bedeutet. Das ganze System selbst läuft auch immer noch einwandfrei.

Ja, in der Tat hatte ich genau das auch gefunden, bei MS unter der Auflistung meines Rechnertyps das eigentlich adäquate gedownloaded (x64 Maschine 64 Bit Windows Home und das korrekte Build), aber leider meint der Installer dann, dass genau dieses nicht zu meinem System passt.
2021-11 Kumulatives Update für Windows 10 Version 21H1 für x64-basierte Systeme (KB5007253)

Hat da jemand evtl. noch ne Meinung zu? Kann es ein anderes sein, welches erst gar nicht danach aussieht (also eine andere Variante aus dem Katalog?).
 
1652114714253.png


Ich habe mal die letzten beiden "größeren" Updates deinstalliert, allerdings brachte das keinen Erfolg. Wenn ich versuche, den Drucker mit einem der Treiberpakete von Samsung (gibt ja explizit für 360er Serie oder wahlweise den Universal-Driver 3.0), kommen solche Meldung. Es geht bei mir wohl um "die Anschlüsse" zu der Windows anscheinend keinen Draht (mehr) hat. Sagt das jemandem was bzw. kann man das heilen, ich hoffe!! :(

Beim anderen Treiber (Universal 3.0) kommt übrigens nur die nichtssagende Meldung bei "weiter", "kann keine Verbindung herstellen", was vermutlich intern derselbe Fehler ist wie hier das Bild zeigt.

Bei der Suche nach 0x00000704 kommt man übrigens auf z.B.:
1652115275014.png


Schlau geworden bin ich da allerdings nicht drauf. Hoffe jemand hat da mehr Expertise.
 

Anhänge

  • 1652115011126.png
    1652115011126.png
    52 KB · Aufrufe: 155
Zuletzt bearbeitet:
Erkennt WIN keine (neuen) WLAN-Geräte oder kann man keinerlei Drucker, etwa PDF-Drucker, hinzufügen?

Galaxysnoopy schrieb:
Da ich nur ab und an etwas drucke, fiel es mir gestern Abend auf.
Meine einfache Antwort bei so wirrem Verhalten von WIN wäre eine Systemsicherung. Wenn man hat bleibe zu fragen wie alt.
→ ich vermute, du druckst nicht so sehr selten, dass du nicht bereits bei diesen Unglücksupdates was bemerkt hättest. Deshalb sagt mein Gefühl: die waren es nicht.

CN8
 
Ich erstelle immer wieder mal ein Abbild bzw. einen Wiederherstellungspunkt. Leider sind die aktuell leider alle weg.

Ich habe grade versucht einen PDF Druckertreiber zu installieren:
1652123209604.png


Ich denke dass dann doch mal eine Neuinstallation ansteht :( Wollte es vermeiden, aber nützt ja nichts. Muss auch zugeben dass mein System tatsächlich bereits einige Jahre - vielleicht >3 - (stabil) läuft. Aber irgendwann ist es dann mal wieder soweit..

Es sei denn jemand hat noch eine Idee, oben kommen in der Exception ja auch direkt die Ports.
 
Hallo liebe Gemeinde, wollte kurz nen abschließendes Update geben. Nachdem ich auf dem ToDo Zettel nen Neuaufsetzen hatte, wollte ich noch eines ausprobieren. Da ich mit 2 Tools Sicherungen auf einem NAS ablege, und eines davon "live scrollbar" als Dateisystem ist, wollte ich mir 1, 2 Stellen in der REG mit einem Viewer anschauen, und siehe da, es viel wie Schuppen aus....

1652852152953.png


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

Wenn man an diesen Stellen die DLLs als Driver (wieder) unterordnet, ist in der Auflistung der Druckerverbindung wieder alles sauber da und auch ein Installieren klappt wieder reibungslos, der Drucker mag mich wieder :)

Warum genau diese Einträge (gelbe Schlüssel wie "Local Port" etc.) bei mir vor kurzem ins Nirvana sind, entzieht sich meinem Verständnis. Ob es mit einem Update zu tun hat, in Verbindung meiner individuelle Konfiguration.. muss nicht sein. Oder ein unbedachter Klick im Avira "Optimizer" Tool. Der ist jetzt eh von der Platte weil der mir mit sowas zu sehr genervt hat, Panda Dome läuft sehr neutral im Hintergrund.

Wenn jemand so ein ähnliches Problem hat, und Details benötigt, gerne.

Einen schönen Tag!
Marc
 
  • Gefällt mir
Reaktionen: Terrier
Zurück
Oben