Bootdateien verloren?

MichiFlyer

Lieutenant
Dabei seit
Dez. 2009
Beiträge
739
Hallo liebe Community,

ich habe auf meiner Festplatte(siehe Signatur) 2 Betriebssysteme auf 2 verschiedenen Partitionen installiert gehabt. Dies waren auf "C:\" Windows xp und danach auf "F:\" Windows 7. Nachdem ich heute alle Dateien die ich noch von meinem Stammsystem Windows xp brauchte auf Windows 7 gesichert hatte. Entschloss ich mich die Partition via diesem Programm im DOS zu löschen und den neu entstandenen Speicher gleich danach der F:\ Partition zuzuteilen, somit war/ist dann 100% der Festplattenkapazatät Windows 7(F:\) zugewiesen. Jetzt nach 2 1/2 Stunden war das Programm fertig und als ich neustartete kam der Bootfehler, dass kein OS installiert. TOLL! Dann habe ich die Windows 7 DVD eingelegt und die Geschichte mit bootrec eingegeben und es wurde in etwa wie folgt angezeigt:

bootrec /fixmbr
Erfolgreich...

bootrec /fixboot
Die Datei wurde nicht gefunden

bootrec /rebuildbcd
Es wurde eine Windows Installation gefunden - C:\(Da war mein xp drauf, das aber jetzt weg ist...^^) Wollen sie diese zum Bootmenü anheften Ja(J), Nein(N), ALLE(A): J
Die Datei wurde nicht gefunden.

So toll, bei der Systemreparatur kommt auch nichts raus. Es wird angeblich immer die fehlende "Partitionstabelle" wiederhergestellt und es wird keine Windows 7 Installation gefunden. Ich habe nochmal mein Partitionsprogramm gestartet und es wird alles wunderbar angezeigt. F: NTFS, 299GB Speicher, 70GB verbraucht und dann habe ich eine Funktion entdeckt, wo man die HDD durchsuchen und alle DATEIEN einsehen kann und ich habe natürlich nach Boot Dateien gesucht und folgendes habe ich gefunden:

F:\Windows\boot\PCAT\de-DE\bootmgr.exe.mui
F:\Windows\boot\PCAT\de-DE\memtest.exe.mui
F:\Windows\boot\PCAT\de-DE\bootmgr
F:\Windows\boot\PCAT\de-DE\memtest.exe
F:\Windows\boot\EFI\de-DE\memtext.efi.mui
F:\Windows\boot\EFI\de-DE\bootmgr.efi.mui
F:\Windows\boot\EFI\de-DE\bootmgfw.efi.mui
F:\Windows\boot\bootmgfw.efi
F:\Windows\boot\bootmgr.efi
F:\Windows\boot\memtest.efi
F:\Windows\boot\DVD\PCAT\de-DE\bootfix.bin
F:\Windows\boot\DVD\PCAT\BCD
F:\Windows\boot\DVD\PCAT\boot.sdi
F:\Windows\boot\DVD\PCAT\etfsboot.com
F:\Windows\boot\DVD\EFI\BCD
F:\Windows\boot\DVD\EFI\boot.sdi
F:\Windows\bootstat.dat
F:\Windows\system32\bcdboot.exe
F:\Windows\system32\bcdedit.exe
F:\Windows\system32\bcdprov.dll
F:\Windows\system32\boot.sdi
F:\Windows\system32\bootcfg.exe
F:\Windows\system32\BootMan.exe
F:\Windows\system32\bootres.dll
F:\Windows\system32\BOOTVID.DLL

Ich habe keine Ahnung, ob das nützlich ist. Aber ich weiß auch wirklich nicht, wo ich suchen sollte. Wenn ihr für mich andere relavante, nützliche Pfade habt nennt sie mir bitte. :rolleyes::(

Gruß Game Michi
 

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
Ja da ging es aber um die HDD und hier geht es um das Betriebssystem...^^ :(
 
M

miac

Gast
Bei deiner Vorgehensweise mit dem Löschen der Partitionen kann es leider zu den geschilderten Problemen kommen.

Meine Fragen:
Wie war die Platte aufgeteilt:
1. Partition C:
2. Partition F:
3. Partition ...
4. Partition ...

War der Systemlaufwerksbuchstabe von Windows 7 schon F: als Du noch zwei Betriebssysteme hattest und Windows 7 gebootet war?
 

6shop

Banned
Dabei seit
Juni 2009
Beiträge
6.820
einfachste lösung: daten sichern. platte formatieren und win7 neuaufsetzen, und zwar auf C:
 

Robo32

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
21.552
Gut dass sich der bootloader auf "C" befand...

Link^^
 

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
Zitat von miac:
Bei deiner Vorgehensweise mit dem Löschen der Partitionen kann es leider zu den geschilderten Problemen kommen.

Meine Fragen:
Wie war die Platte aufgeteilt:
1. Partition C:
2. Partition F:
3. Partition ...
4. Partition ...

War der Systemlaufwerksbuchstabe von Windows 7 schon F: als Du noch zwei Betriebssysteme hattest und Windows 7 gebootet war?

Zuerst war auf C:\ Windows xp installiert. 2 Wochen später installierte ich auf einer neuen Partition F:\ Windows 7(insg. 2 Partitionen) und wie gesagt habe ich alle wichtigen Dateien heute auf die Windows 7 Partition geschmissen und wollte dann C:\ löschen, was ich auch gemacht habe. Danach habe ich den neu entstandenen Speicher(etwa 60GB) der F:\ Partition zugeteilt und das war's... Und ja F:\ war schon immer Windows 7!

Game Michi
Ergänzung ()

Zitat von Robo32:
Gut dass sich der bootloader auf "C" befand...

Link^^

Ich habe oben bereits geschrieben, dass ich die Reparaturfunktionen versucht habe - erfolglos.
 

Fairy Ultra

Commander
Dabei seit
Sep. 2005
Beiträge
2.848
ich hatte letztens ein ähnliches Problem:

Lösung:
1.
Windows 7 dvd nehmen und auf die richtige Partition installieren klicken (quasi wie überschreiben)
nach dem ersten Punkt der Installation ('dateien wurden kopiert') installation abbrechen.

2.
dann über die dvd über die reparaturoptionen korrigieren (normalerweise popt da was von alleine das was gefunden wurde und repariert wird)

3.
über die windows 7 dvd danach nochmal die automatische reparatur laufen lassen (manchmal sogar 2.mal)

danach sollte es bootfähig sein.
damit hab ich ein windows ohne irgendeine bootpartition zum laufen gebracht.
 
Zuletzt bearbeitet:

Robo32

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
21.552
Versuch es ruhig noch öfter...
 
M

miac

Gast
Es sieht so aus, das entweder die Partitionstabelle nicht mehr stimmt (erster Eintrag leer, 2ter Eintrag deine Windows 7 Partition) oder die Windwos Reparatur deiner Installation den falschen Laufwerksbuchstaben zuteilt.

Ich muß nochmal was nachschlagen...
 

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
Zitat von Robo32:

Nach 10+ Malen vergeht meine Hoffnung auch langsam... ^^ :D
Ergänzung ()

Zitat von miac:
Es sieht so aus, das entweder die Partitionstabelle nicht mehr stimmt (erster Eintrag leer, 2ter Eintrag deine Windows 7 Partition) oder die Windwos Reparatur deiner Installation den falschen Laufwerksbuchstaben zuteilt.

Ich muß nochmal was nachschlagen...

Ja die Partitionstabelle wird bei der "Reparaturoption" immer berichtigt und neuerstellt und es wird immer die Partition C:\ korrigiert. - Aber funktionieren tut es immer noch nicht. Ich habe gerade was von DiskPart gelesen. Ich probier das mal...^^
Vielen Dank jetzt schonmal für deine/eure Hilfe. Ich bin mit den Nerven echt am Ende...^^
 
Zuletzt bearbeitet:
M

miac

Gast
Ich fürchte, was Du brauchst ist bcdedit. Da muß Du die Partitionseinstellungen des Bootsystems und den Laufwerksbuchstaben ändern.

Es gibt die Möglichkeit, einen generalizierten BCD Store zu erstellen (mußt Du aber nicht):

http://www.multibooters.co.uk/cloning.html

Damit umgeht man die Zuweisungen. Kannst das ja mal versuchen.
 
Zuletzt bearbeitet: (mußt Du aber nicht)

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
Hmm, das ist mir zu schwierig...^^
Aber ich habe gerade einen Fortschritt erzielt, aber immer noch kein Ziel.
Ich habe mir mal gerade von DiskPart meine Festplatten und Partitionen anzeigen lassen.
Festplatte 0 = 298GB So weit so gut.
Partition 0 = 298GB Auch sehr gut.
Aber mir wurde wieder die Partition als C:\ angezeigt...^^
Jetzt habe ich den Fokus auf Partition 0 gesetzt und als "active" markiert.
Dann habe wieder die bootrec Geschichte eingegeben.
bootrec \fixmbr
Erfolgreich, wie vorher auch
bootrec \fixboot
Erfolgreich!!! lol, mich hat's vom Sessel gehaun...^^ xD
bootrec \ScanOS
C:\Windows (Immer noch dieses C:\...^^)

So, da ich endlich jetzt auch fixboot geschafft habe, gleich mal neugestartet und jetzt kommt, sobald er anfangen will das OS zu laden:
ERROR LOADING WINDOWS.
Files not found.


Was muss ich jetzt noch verändern, damit es läuft? Die Bootsektoren scheinen ja jetzt da zu sein. Ich denke ich muss mit DiskPart meine alte F:\ Partition, die jetzt C:\ heißt, wieder auf F:\ umbenennen, oder? Dann dürfte er doch die "Files" wieder finden, oder? :D

Gruß Game Michi
 

Robo32

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
21.552
Aus sicht von Win7 war es schon immer auf "C".
 

Inzersdorfer

Vice Admiral
Dabei seit
Juli 2010
Beiträge
6.953
•W7 MBR/Bootsector reparieren: (@schildkröte09)
Die HD muß am 1.Sataport hängen, DVD/CD-Sata-LW bitte an den letzten Port !
Die automatische Bootreparatur mit der W7 DVD 3x durchlaufen laßen.
Funtioniert in W7 besser als die nachfolgenden händischen Befehle !
In der Wiederherstellungskonsole
1. bootrec /fixmbr
2. bootrec /fixboot
3. bootrec /RebuildBcd (nur wenn auf gleicher partition Bootmgr und Verzeichnis Boot liegen)

Als Ergänzung:
•W7 Partition auf ACTIVE setzen: (@schildkröte09)
Vorgehen mit DISKPART in der Eingabeaufforderung :
Eingabeaufforderung aus dem Windows 7 Setup starten.
DISKPART eingeben und nachfolgend folgende Befehle:
LIST DISK
SELECT DISK datenträgernummer (schau in die Liste und identifiziere deine Windows 7 Systemplatte anhand der Datenträgernummer und gebe sie hinter select disk ein).
LIST PART (zeigt jetzt alle Partitionen der Festplatte an)
SELECT PART partnummer (identifiziere die Windows 7 Partition und wähle sie hinter select part aus)
ACTIVE (aktiviert nun die Windows 7 Partition)
EXIT (verläßt DISKPART)
PC Neustart von der Windows 7 Setup DVD und
1. die automatische Bootreparatur starten die mindestens 3 mal durchlaufen gelassen werden muss ! ODER
2. die manuelle Reparatur über die Eingabeaufforderung mit den obigen 3 Befehlen.
Außerdem ist darauf zu achten, das sich NUR die Systemplatte angeklemmt am ersten SATA PORT am System befindet. Alle weiteren Platten bleiben abgeklemmt !
 
Zuletzt bearbeitet:
M

miac

Gast
Wenn das vorige nicht geklappt hat und du noch Lust hast, poste mal die Einträge (als Bild oder so), die bcdedit /enum ausgibt.
 

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
Bisher ist alles erfolgslos. Bei der automatischen Reparatur kommt jetzt der Fehler:
Das Systemvolume des Datenträgers ist beschädigt.
CHKDSK wurde gestartet
Keine Fehler
Habe dan CHKDSK selber ausgeführt. Keine Fehler.^^

Bei dem Partitionsmanager habe ich jetzt aufeinmal eine namenslose Partition mit 226GB Speicher, der belegt ist...^^ Aber das liegt wohl darn, dass mein Systemvolume wirklich fehlerhaft ist.
Das Aktivieren von meiner PArtition ist erfolgreich gewesen, jedoch hat die manuelle und die automatische Reparatur nicht geklappt.

Bei bcdedit /enum kommt
Die Startkonfigurationsdatei konnte nicht geöffnet werden.
Die Datei wurde nicht gefunden.


Oh man...^^ Mir bleibt da nur zu sagen: Micromurks Windoof, Windoof, Windoof...
Ergänzung ()

Ich habe auf meiner 200GB Ersatzplate mein Windows 7 Backup mit den Standardprogrammen... Aber gibt es vlt. nicht noch eine andere Möglichkeit?
Mir macht es nicht Spaß wieder nach einem Monat 6 Stunden lang neuzuinstallieren und konfigurieren...^^
 
Zuletzt bearbeitet:
M

miac

Gast
Okay, dein BCDStore ist nicht mehr da (war wahrscheinlich auf deiner XP Partition).

Stelle bitte sicher, das F: dein Systemlaufwerk ist, indem du unter F: den Windows Order findest.

Dann führe von der Rettungscd folgendes aus:

bcdedit /createstore f:\boot\bcd.temp
bcdedit.exe /store f:\boot\bcd.temp /create {bootmgr} /d "Windows Boot Manager"
bcdedit.exe /import f:\boot\bcd.temp

Danach sollte der Store wieder da sein.

Danach bitte nochmal bcdedit /enum ausführen
 

Fairy Ultra

Commander
Dabei seit
Sep. 2005
Beiträge
2.848
hast du mal probiert was ich dir geschrieben habe?
Damit habe ich laufwerke komplett ohne bootsektor zum laufen gebracht.
 

MichiFlyer

Lieutenant
Ersteller dieses Themas
Dabei seit
Dez. 2009
Beiträge
739
.
 
Zuletzt bearbeitet:
Top