BSOD beim Booten von Windows XP

cebolla

Cadet 1st Year
Dabei seit
Nov. 2006
Beiträge
15
Hola und Guten Morgen!

Habe ein ziemlich diffiziles Problem bei einer frischen XP-Installation - hoffe, man kann mir hier helfen...

Windows XP ist neu installiert auf einer nagelneuen WD-Raptor 74GB-Platte, die ich folgendermassen partitioniert habe:

C: Win_Boot primär 5MB
D: Win_Vista logisch 18
E: Win_XP logisch 14
F Win_XP_Test logisch 5
G Win_CD_Images logisch 12
H VirtualPC_Images logisch 11

Die Installation auf E: läuft auch normal durch, ich kann alles konfigurieren, was man eben bei der Erstinstallation macht inkl. Einrichten mehrerer Benutzer. Doch dann, beim ersten Reboot passiert es dann; ich bekomme, ca. 3 sek nach Erscheinen des XP-Bootscreens, einen BSOD. Dieser verschwindet sofort wieder und das System bootet neu (bis zu eben diesem Punkt).

Was ich aber nach mehreren dieser Durchgänge lesen konnte, ist, dass der Fehler "PAGE_FAULT_IN_NONPAGED_AREA" von der Datei ntfs.sys verursacht wurde. Also ein Speicher-Problem.

Das Dumme ist nur, dass ich meine beiden Speicherriegel (GEIL DDR-2-800, 2048mb-Kit, die Orangefarbenen) einzeln, paarweise, in allen Bänken durchprobiert habe und das jedesmal gleich abläuft. Was mich vermuten lässt, dass es _nicht_ die Speicherriegel sind, es sei denn, beide sind zur gleichen Zeit kaputtgegangen (?). Die GEIL-Speicher sind als kompatibel/erfolgreich getestet im Asus P5W DH Deluxe-Sammelthread aufgeführt.

Die Festplatte habe ich mit den Diagnose-Tools von WD durchgeprüft und auch dort keinen Fehler gefunden.

Das BIOS ist mit 16.02 auf dem neuesten Stand und auf die Default-Werte (ausser Sprache) zurückgesetzt.

Hardwaremässig ist auch sonst alles abgeklemmt/ausgebaut, was nicht unbedingt nötig ist; es laufen nur ein CD-Laufwerk, Floppy, eine Festplatte und Grafikkarte. Im übrigen ist meine Hardware-Kombination (s.u.) in letzter Zeit ziemlich häufig hier im Forum vertreten (und, wie ich vermuten darf, erfolgreich am Laufen), was mich ja prinzipiell hoffen lässt.

Wie kann ich nun definitiv feststellen, dass es (nicht) die Speicherriegel sind, oder eine andere Hardware-Komponente?

Kann es - trotz fehlerfreier Überprüfung - doch die Festplatte sein? Falls ja, wie muss ich vorgehen, um CHKDSK per Floppy auf der Festplatte auszuführen (hab' ich bisher nicht hinbekommen :freak:)?

Für sachdienliche Hinweise und/oder (problem-)bewusstseinserweiternde Links/Tipps im Voraus vielen Dank!

cebolla


--
Asus P5W DH Deluxe; Intel Core 2 duo 2400 MHz E6600; GEIL DDR-2-800 (2048mb-Kit); WD Raptor 74GB; MSI NX7900GTO
 

jodd

Stammgast
Teammitglied
Dabei seit
Dez. 2005
Beiträge
29.685
probier doch mal eine live cd (knoppix o.ä.), wenn die läuft kannst du ausschließen das es an der hardware liegt.
 

cebolla

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
15
Hola jodd,

danke für Deine Antwort!


Ja, das vergass ich zu erwähnen: Habe ich natürlich ausprobiert. Weniger, um auszuschliessen, ob die Hardware defekt ist, eher um zu schauen, ob ich mit der Knoppix-CD irgendwelche Tools an der Hand habe, um dem Fehler auf die Spur zu kommen.

Um es kurz zu machen: Knoppix 3.7 läuft ohne Probleme durch, nützliche Tools habe ich allerdings keine gefunden (ich weiss, v3.7 ist recht alt, habe mir heute nacht die DVD-Version 4.05 heruntergeladen und muss sie noch brennen). _Gibt_ es bei dieser Version irgendwelche Tools, die mir weiterhelfen könnten?

Wenn es denn nicht die Hardware sein sollte, was kann denn dann die Ursache für den Absturz sein, bei einem in der Tat _frischest_ aufgesetzten Windows, bei dem ich noch nicht einmal die Chance hatte, etwas zu verkonfigurieren?!


Saludos,
cebolla
 
Zuletzt bearbeitet: (Rechtschreibfehler ;-))

Mueli

Admiral
Dabei seit
Aug. 2005
Beiträge
7.533
Google mal nach der Insert-CD, gibt auch eine UBCD mit inkludierter Insert, auch die c't hatte schon ein paar Diagnose-CDs im Lieferumfang, evtl. kennst Du jmd. mit einem ABO.
 

cebolla

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
15
Hola und buenos días miteinander,


vielen Dank erstmal für den Tip mit der Insert-CD. Habe ich mir auch brav gebrannt, allerdings hat sich mir der Nutzen der CD mit ihren Tools für _meinen_ Fall nicht ganz erschlossen; mir geht es nicht so sehr um Datensicherung/ -rettung, sondern vielmehr darum, die Ursache für meinen BSOD zu finden. Sollte das allerdings mit diser Insert-CD möglich sein, bitte ich um Nachsicht und entsprechende Aufklärung.

Dafür habe ich die Festplatte nochmals neu aufgesetzt; alles gelöscht, neu partitioniert, XP installiert (wenn auch seltsamerweise mit ein paar Abschmierereien die ich so nicht von einer XP-Installation kenne), und siehe da; nach ein paar gut durchgelaufenen Programm-Installationen verabschiedet sich Windows nach einer solchen (PartitionMagic 8), und beim Reboot erscheint derselbe BSOD wieder, wie gehabt :-(

Dann habe ich all das auf einer anderen Platte gemacht (eine Samsung SP2504C, die ich eigentlich später in einem RAID-1 verwenden wollte), und auf dieser Platte hat sich XP seitdem nicht einmal auf og. Weise verabschiedet.

Erstere Festplatte (die WD Raptor) habe ich mit diversen Tools (XP-Wiederherstellungskonsole, chkdsk, Testdisk etc.) überprüft, mit dem Ergebnis, dass einmal die Konsole beim ersten Zugriff auf die Festplatte abgestürzt ist, beim zweiten Mal chkdsk mich mit der Meldung "Der Datenträger scheint mindestens ein nicht behebbares Problem zu haben" beglückt und TestDisk diverse Fehler findet, die ich zwar mit den Testdisk-eigenen Befehlen reparieren kann (inkl. neu geschriebener Partitionstabelle, bei Bedarf kann ich den Inhalt der TESTDISK.LOG posten), allerdings mit der Folge, dass ich bei dem abermaligen Versuch, mit der Wiederherstellungskonsole auf die Raptor-Platte zuzugreifen, die Meldung bekomme, dass nun gar keine Partition mehr gefunden werden kann... So kam ich also auch nicht in die Verlegenheit, fixboot oder fixmbr oder ähnliches auszuprobieren.

Um die ganze Sache noch mehr zu verwirren, habe ich versucht, mit der Samsung-Platte als Bootplatte auf die Raptor-Platte zuzugreifen, mit der Folge, dass das auf der Samsung-Platte installierte Win XP (was sonst tadellos läuft) mit dem gleichen (!) BSOD abschmiert wie die Raptor. Hänge ich diese wieder ab, startet das Samsung-Windows wieder problemlos.

Wer mir bis hierher folgen konnte, dem danke ich herzlich und möchte ihn gnädigst um den Versuch bitten, mir folgende, evtl. etwas wirre Fragen zu beantworten:

- Darf ich aus alldem schliessen, dass die Raptor-Platte hinüber ist? Ich bin mir nicht sicher, da lt. einem Test mit den WD eigenen 'Data Lifeguard Tools' kein Fehler festzustellen ist. PartitionMagic 8 zeigt allerdings, wie zu erwarten, derer gar so viele an, dass es ihm _zu_viel wird und die Fehlersuche einfach abbricht. Ich möchte jedoch vermeiden, dass ich das Ding einschicke, Wochen darauf warte und mit dem Kommentar "Der fehlt nix" wiederbekomme...

- Kann es sein, dass der BSOD des Samsung-Windows daher rührt, dass ich das XP auf der Raptor-Platte mit speziellen Treibern für den AHCI-Modus eingerichtet habe, das Samsung-Windows aber nicht (Habe vor dem Booten der Samsung-Platte den AHCI-Modus im BIOS allerdings wieder deaktiviert, und, wie gesagt, alleine fährt sie ja anstandslos hoch)?

- Ist es möglich, dass evtl. auch das Mainboard (die SATA-Anschlüsse?) einen Defekt hat? Wie kann ich das feststellen/ausschliessen?

- Können o.g. Probleme daher rühren, dass ich nur einen (egal welchen, habe beide getestet) von zweien 1GB-Speicherriegeln eingesetzt habe (die ja als Kit verkauft werden)?

- Sollte das alles doch irgendwie zu dilettantisch vorgetragen worden sein, nehme mich doch bitte einer an die Hand und gehe das ganze, für eine zielführende Diagnose/Therapie notwendige Prozedere mit mir Punkt für Punkt durch.

EDIT:
Habe mir die Raptor-Platte jetzt unter Knoppix 5 angeschaut - die XP-Partition zeigt einen belegten Speicherplatz von ca. 2GB an, der WINDOWS-Ordner allerdings ist leer (0 kb Grösse). Wie ist das möglich? Kann man das mit irgendwelchen Tools ausser den o.g. wieder irgendwie hinbiegen?


Muchas gracias & saludos,
cebolla
 
Zuletzt bearbeitet: (Rechtschreibfehler ;-))

Mueli

Admiral
Dabei seit
Aug. 2005
Beiträge
7.533
Der Sinn mit einer CD wie der INSERT oder einer Knoppix zu testen besteht erst einmal darin zu sehen, ob ein OS gebooted werden kann und wenn man dann noch eine Weile damit arbeitet, ob auch unter ihnen ein Absturz kommt, was dann auf einen Hardware-Defekt der bis zu dem Zeitpunkt getesteten/verwendeten Komponenten (also ausschließlich der Disks) schließen läßt.
Es werden unter den Bedingungen keine Windows-Treiber verwendet und man kann diese dann ebenso ausschließen (Windows dann eigentlich komplett).
Die Tests unter der INSERT (UBCD), wie die Smartmontools könnten dann eine Beteiligung der Festplatten ausschließen und der Memory-Test (evtl. auch mit jedem einzelnen DIMM) würde dann auch die Speicher auf Herz und Nieren testen können.
Fehler lassen sich immer am besten im Ausschlußverfahren eingrenzen!
 

cebolla

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
15
Hola Mueli,


danke für Deine Antwort!

Der Sinn mit einer CD wie der INSERT (...) was dann auf einen Hardware-Defekt der bis zu dem Zeitpunkt getesteten/verwendeten Komponenten (also ausschließlich der Disks) schließen läßt.
Ja, ist klar. Ich habe allerdings in der Tat einmal diese Insert-CD, die neueste Knoppix-DVD und auch die Ubuntu-DVD der neuen C't erfolgreich booten können, ohne Fehler. Richtig lange habe ich allerdings nicht damit 'gearbeitet' - eher nur so herumgespielt. Ich kann also nicht mit absoluter Sicherheit behaupten, dass alle dabei beteiligten Komponenten fehlerfrei sind, möchte es aber annehmen. Allerdings habe ich unter letzterer Ubuntu-Version zuerst den MemTest auf beiden Riegeln komplett durchlaufen lassen, ohne Fehlermeldung. Darf ich dann davon ausgehen, dass man diese als Übeltäter schon einmal ausschliessen darf? Und, wie schon erwähnt, der Fehler tritt ja nur auf der WD-Platte auf.

Diese 'Smartmontools' habe ich auf der Insert-CD wohl übersehen - das sollte ich dann wohl mal nachholen.


Saludos,
cebolla
 

cebolla

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
15
Hola Kuhni,

Ersteres ja. Ich kann aber den Vista-Bootsektor nicht zerschossen haben, den gab's noch gar nicht. XP ist wirklich das allererste, was bei mir auf die Platte kam...

Speicherfehler (ich rede vom RAM) habe ich mittlerweile ja ausgeschlossen, die laufen ja ohne Probleme mit diversen Linux-live-CD's und auch mit der anderen Festplatte (Samsung).

Saludos,
cebolla
 
Top