Grafikkarte (Code 43) - Windows 7 Ultimate 64 bit

€_I)H89

Newbie
Dabei seit
Mai 2004
Beiträge
7
Hallo an alle,

um den Fehler eventuell eingrenzen zu können hole ich ein wenig aus.

Zunächst einmal habe ich einen etwas in die Jahre gekommen Desktop PC mit folgender Hardware:

- ASrock ALiveXFire-eSATA2

- AMD Athlon 64 X2 Dual Core Processor 5600+

- MSI NX 8600 GT (GeForce) 256 MB RAM

- Corsair ~ 4 GB RAM

- 1 HDD SATA Seagate 250 GB

- 1 HDD SATA Western Digital 1 TB


Seit Jahren habe ich auf der kleineren Festplatte Windows XP Professional installiert Alles funktioniert fehlerlos,
die Grafikkarte macht keine Probleme. Spiele - auch wenn sie in die Jahre gekommen sind - laufen tadellos, sogar ein anspruchsvolles 3D-CAD Simulationsprogramm läuft echt gut.

Wie das nun mal so ist musste ich das CAD Programm aktualisieren, jedoch unterstützt dies kein XP mehr.
Also habe ich mir eine neue Festplatte (die größere der beiden) und Windows 7 Ultimate 64 bit OEM zugelegt.

Nach der Windows-Installation habe ich die Treiber der Hardware bei den entsprechenden Herstellern für Betriebssystem ausgewählt, heruntergeladen und installiert.

Nach dem Installationsmarathon und ständigen Neustarts des Systems wollte ich dann wieder an die Arbeit gehen und startete das CAD-Programm.
Jedoch flackerte nur kurz der Bildschirm und wurde anschließend schwarz, woraufhin mein Monitor schrieb, dass er kein Signal erhalten würde.
Der Rechner reagierte gar nicht mehr und ich habe ihn über reset neu gestaret.

Nach einem Blick in den Gerätemanager konnte ich sehen, dass die Grafikkarte einen Fehler aufwies. Unter deren Eigenschaften stand:
"Dieses Gerät wurde angehalten, weil es Fehler gemeldet hat. (Code 43)".

Anschließend habe ich den Treiber deinstalliert und nach einem Neustart war der Fehler weg. Erneut habe ich einen Treiber des Herstellers installiert, diesesmal jedoch einen älteren. Das ergab das gleiche Problem. Auch Treiber-Neuinstallationen des Mainboards blieben ohne Erfolg.

Wenn ich jedoch die Festplatte mit Windows XP anschließe ist es so, dass ich alles machen kann. Keine Probleme, kein Bildschirmflackern, Spiele und CAD-Programme laufen problemlos.
Stare ich die Windows 7 Festplatte treten wieder die Probleme auf. Sogar bei Windows-Spielen wie Schach 3D.

Auch wenn ein Youtube-Video gespielt werden soll, wird dies nur sehr langsam und ruckelnd abgespielt.
Zudem kommen die merkwürdigsten Geräusche aus den Lautsprechern.


Da - im Gegensatz zu Windows 7 - unter XP alles wunderbar funktioniert, habe ich Hardware-Schäden somit für mich ausgeschlossen. Ich schiebe es auf Software-Probleme, also Treiber o.ä. .
Ich habe mir sämtliche "Live Updater" besorgt, bezahlt und durchlaufen lassen, deren Treiberupdates installiert - ohne Erfgolg.
Zwischenzeitlich geht der Rechner sogar soweit, dass es zum Systemstopp mit "Bluescreen" und der Fehlermeldung
"nvlddmkm.sys", was scheinbar auf Grafiktreiber zu schiben ist. Allerding können diese so alt oder so neu sein wie sie wollen. Das wird bei allen angezeigt.

Tatsächlich ist so, dass der Rechner ohne jeglichem Grafiktreiber viel besser läuft als mit einem.
Jedoch kann ich dann das CAD-Programm vergessen.

Meine Bitte ist es mir ggf. sagen zu können, ob die Hardware mit Windows 7 nicht kompatibel ist, oder ob es tatsächlich an Treibern oder so liegt.

Ich bitte inständig um eure Hilfe und bin für jeden Tipp dankbar.

Vielen Dank im Vorraus

Mit freundlichen Grüßen

Dominik
 

Emissary1978

Lieutenant
Dabei seit
Aug. 2004
Beiträge
853
Installiere dein Windows neu und nimm einfach die aktuellsten Treiber von der nvidia seite. Ich halte es für Schwachsinn für einen Treiber updater Geld zu bezahlen.
 

€_I)H89

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2004
Beiträge
7
Danke für den Hinweis. Tatsächlich war das mehr als schwachsinnig sich an solche Treiber Updater zu wenden.
Jedoch habe ich vergessen in den Text mit rein zu schreiben, dass ich Windows 7 bereits neu installiert habe. Und wie gesagt, auch der aktuellste Treiber vermag nicht zum Erfolg führen.
 

joerghalm

Lieutenant
Dabei seit
Aug. 2011
Beiträge
983
Code 43 bedeutet entweder der falsche Treiber oder die Grafikkarte an sich ist defekt was aber auszuschließen ist da sie bei XP funktioniert.
Ergänzung ()

Also probiers mal mit dem GeForce-Treiber 332.21
Ergänzung ()

Wenn du Hilfe zur Treiberdeinstallation brauchst einfach noch mal laut schreien!
 

Emissary1978

Lieutenant
Dabei seit
Aug. 2004
Beiträge
853
Die Grafikkarte muss mit Windows 7 auf jeden Fall gehen denn ich habe die in meinem Laptop drin mit Windows 8.1
 

€_I)H89

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2004
Beiträge
7
Ich habe den Grafiktreiber installiert, jedoch auch abermals ohne Erfolg...im Gerätemanager wird wiedererwartzend die Grafikkarte mit einem gelben Ausrufezeichen angezeigt und auch wieder mit dem Fehler "CODE 43" deklariert...(siehe Bilddateien)CODE 43.jpgCODE 43_2.jpg

Ich werde das Gefühl nicht los, dass das mit dem Mainboard zusammenhängt...gibt es da irgendwelche Erfahrungen bezüglich meines Problems?
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.664
Zuletzt bearbeitet:

€_I)H89

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2004
Beiträge
7
Mit dem Treiber fährt der Rechner nicht mehr hoch. Man sieht kurzzeitig das Windows 7 Logo und anschließend nur schwarzen Bildschirm.
Über den abgesicherten Modus musste ich den Treiber wieder deinstallieren, dann fuhr der Rechner wenigstens wieder normal hoch.
Versuche es mit dem älteren Treiber davon, also mit dem 191.07...

Sagt das irgendwas aus, dass der Rechner mit dem speziell für die MSI Grafikkarte veröffentlichten Treiber das Betriebssystem nicht richtig hochgefahren wird?
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.664
Hast Du vorher neu installiert und dann erst den Treiber genommen? Wenn Du soviele getestet hast, ist sehr viel Müll drauf der mitgeladen wird und deshalb kommt es zu den Problemen.
 

€_I)H89

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2004
Beiträge
7
mir wurde einst "CC Cleaner" empfohlen. Mit dem Programm deinstalliere ich vorher immer erst einen Treiber, und behebe Registrierungsfehler...danach nehme ich einen Neustar vor und installiere den "neuen" Treiber...
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.664
Ein Allheilmittel ist das aber nicht, neu installieren hilft evtl besser. Versuch macht Klug, ich würde es machen oder mir direkt eine andere Karte besorgen, die neuere Treiber mitbringt, viel Können muss sie ja nicht sonst hättest Du ja bereits vorher was anderes gekauft. Das Problem wirrd bestimmt auch am Chipsatz liegen, neue AMD Chiptreiber und alte Geforcekarten haben oft Probleme. Habe hier recht oft das Problem. Wenn ich nicht aufpasse und Windowsupdate neue Grafiktreiber installiert, muss ich ein Image zurückholen damit es wieder funktioniert.
 

€_I)H89

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2004
Beiträge
7
Einen Teilerfolg konnte ich verbuchen. Die Fehlermeldung "CODE 43" ist verschwunden. Allerdings funktioniert sonst immer ncoh kein Programm und ein Bluescreen kam auch schon wieder mit dem Felher "nvlddmkm.sys"...

Eine neuere Grafikkarte wird sicher die Lösung sein...Das wirft jedoch die Frage auf, verträgt sich eine PCI 2.0 16x mit meinem Asrock - ALiveXFire-eSATA2 Mainboard?
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.664
Teste es doch einfach, der Aufwand ist ja nicht so groß.
 
Top