Heimnetzwerk mit Windows 10 und diversen Linux Geräten - Dateifreigabe funktioniert nicht

MrTony

Lieutenant
Registriert
Feb. 2015
Beiträge
601
Hallo miteinander.

Mein Heimnetzwerk sieht so aus

Ich habe einen zentralen Router Fritzbox 7430 (wird allerdings bald ausgetauscht).

Mein Desktop PC (Windows 10) direkt per Ethernet verbunden
Mein RaspberryPi4 (Ubuntu Mate) direkt per Ethernet verbunden

Diverse Laptops mit Windows 10 und Ubunut per WLAN

Diverse Smartphones und Tablets mit Android und iOS per WLAN

Der Raspberry Pi 4 soll als hausinterner Server verwendet werden.

Ich wollte heute einige Dateien auf dem Raspberry Pi freigeben und habe mich dafür an diesen Guide gehalten:

https://wiki.ubuntuusers.de/Heimnetzwerk/
https://wiki.ubuntuusers.de/Samba_Server/net_usershare/
https://wiki.ubuntuusers.de/Samba_Server_GNOME/

Im Prinzip habe ich SAMA installiert und noch die Erweiterung caja-share, damit ich das auch über den Dateimanager bequem machen kann.

Ich habe auf dem Raspberry mittels caja-share nun einen Ordner freigegeben mit allen Zugriffsrechten zum testen.
Allerdings kann ich den leider von meinem Windows 10 Rechner aus nicht sehen.
Habe bereits Samba 1.0 auf Windows 10 nachinstalliert sowohl Client als auch Server.

Kann vom Windows 10 PC den Raspberry auch problemlos anpingen.

Kann mir jemand sagen, wie ich solche Dateifreigaben in einem kleinen Heimnetzwerk mit Linux und Windows richtig einrichte?

VG
Tony
 
Netzwerkfreigaben unter Windows "sehen" (in der Netzwerkumgebung) läuft mehr schlecht als recht & seit Windows 10 graduell immer schlechter.
Versuch mal den Direktzugriff auf das Gerät im Windows Explorer. Also wenn dein RPi die IP 192.168.178.210 hat, dann bspw:

\\192.168.178.210\
 
  • Gefällt mir
Reaktionen: MrTony
t-6 schrieb:
Netzwerkfreigaben unter Windows "sehen" (in der Netzwerkumgebung) läuft mehr schlecht als recht & seit Windows 10 graduell immer schlechter.
So ein Quatsch, ich mach das permanent zu Hause wie in der Firma und hab keine Probleme. Anders wird ein Schuhn daraus, seit Win 10 läuft es deutlich unproblematischer. ;)
MrTony schrieb:
Ich habe auf dem Raspberry mittels caja-share nun einen Ordner freigegeben mit allen Zugriffsrechten zum testen.
Allerdings kann ich den leider von meinem Windows 10 Rechner aus nicht sehen.
Habe bereits Samba 1.0 auf Windows 10 nachinstalliert sowohl Client als auch Server.
1.0 brauchst Du nicht mehr, lass es bitte weg (Sicherheitsrisiko). Kannst Du die IP auf dem Windows so auflösen, wie es t-6 geraten hat?
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: ekin06 und MrTony
t-6 schrieb:
Versuch mal den Direktzugriff auf das Gerät im Windows Explorer. Also wenn dein RPi die IP 192.168.178.210 hat, dann bspw:
\\192.168.178.210\

PHuV schrieb:
Kannst Du die IP auf dem Windows so auflösen, wie es t-6 geraten hat?

Teilerfolg. Ich sehe sofort den freigegebenen Ordner im Explorer.
Allerdings kommt ein Dialogfeld " Netzwerkanmeldefinformationen eingeben".
Ich bin etwas überfragt, was hier erwartet wird, da ich auf dem Raspberry kein Passwort oder sonstiges eingestellt habe, eigentlich sollte es für alle Nutzer offen zugänglich sein.

Einfach Enter oder meine Windows Anmeldeinformationen eingeben geht auch nicht - Zugriff verweigert.
 
So ein Quatsch, ich mach das permanent zu Hause wie in der Firma und hab keine Probleme. Anders wird ein Schuhn daraus, seit Win 10 läuft es deutlich unproblematischer.
Naja, was soll ich sagen? Mein Win10 ist frisch aufgesetzt & in der Netzwerkumgebung taucht mein Synology NAS nicht auf. Dasselbe Verhalten beobachte ich nicht nur auf Arbeit, sondern auch bei Kunden. Windows 10 --> unzuverlässige Erkennung von Geräten in der Netzwerkumgebung.
Auf das Gedödel mit den verantwortlichen Diensten haben wir kein Bock, so dass wir die Verknüpfung zu den relevanten Shares direkt auf den Desktop pushen.
 
  • Gefällt mir
Reaktionen: MrTony
PHuV schrieb:
So ein Quatsch, ich mach das permanent zu Hause wie in der Firma und hab keine Probleme. Anders wird ein Schuhn daraus, seit Win 10 läuft es deutlich unproblematischer.
Kannst du in dem Fall erklären, was man falsch macht, wenn eine out of the box Windows 10 Installation keine anderen Geräte im Netzwerk sieht? Das scheint nämlich trotz allem ein gängiges Problem zu sein.
Ergänzung ()

@MrTony Die Anmeldeinformationen des Pi Users oder für den Share anonymen Zugang aktivieren, damit keine Anmeldung nötig ist.
 
  • Gefällt mir
Reaktionen: MrTony
Sykehouse schrieb:
Kannst du in dem Fall erklären, was man falsch macht, wenn eine out of the box Windows 10 Installation keine anderen Geräte im Netzwerk sieht? Das scheint nämlich trotz allem ein gängiges Problem zu sein.
Definiere "sehen". Und bei mir mit meinen Freigaben klappts auch mit einem neuen Windows sofort. :confused_alt: Daher kann ich Euer Problem so erst mal nicht nachvollziehen. Ich mache genau das \\IP. \\Rechnername, das klappt nicht immer sofort, ist ja auch klar, wenn es keinen DNS im Heimnetz gibt. Da braucht Windows eine Weile, um die beteiligten Rechnernamen zu ermitteln, aber das sind Minuten.
 
Mit "sehen" meine ich anzeigen in der Netzwerkumgebung. Das direkte Eingeben einer IP oder eines Hostnamens klappt bei mir auch problemlos.
 
Die Entdeckung von Diensten ("Discovery") bei Windows / Linux Mischumgebungen ist immer kompliziert und ändert sich je nach Sicherheitslücke (Samba SMBv1) und Windowsversion.

Avahi / MDNS ist nur bei Linux/OS X verbreitet.
Win kann / konnte (?) SSDP / UPnP - keine Ahnung ob da Samba-Shares gemeldet werden können

aktuell scheint wohl : WSD zu sein , siehe auch wsdd@github
 
MrTony schrieb:
Teilerfolg. Ich sehe sofort den freigegebenen Ordner im Explorer.
Allerdings kommt ein Dialogfeld " Netzwerkanmeldefinformationen eingeben".
Ich bin etwas überfragt, was hier erwartet wird, da ich auf dem Raspberry kein Passwort oder sonstiges eingestellt habe, eigentlich sollte es für alle Nutzer offen zugänglich sein.

Einfach Enter oder meine Windows Anmeldeinformationen eingeben geht auch nicht - Zugriff verweigert.
Hast du denn auch wie im ubuntuusers-Wikiartikel angegeben, einen extra Samba-Benutzer auf dem Raspi angelegt? Ich wette: nein ;)

Also auf dem Rapi:
sudo smbpasswd -a BENUTZERNAME ---> BENUTZERNAME durch den von dir gewünschten Namen ersetzen, logischerweise.
damit legst du in der Samba-Benutzerverwaltung einen Benutzer an, der nicht mit den Benutzerkonten des Betriebssystems zusammenhängt ---> kannst also den gleichen Namen und das gleiche Passwort wie für den normalen Benutzer des Betriebssystems nehmen.
Dann greifst du wieder wie o.g. mit dem Windowsrechner auf die Freigabe zu und gibst die Netzwerkanmeldeinformationen ein, die du für den Samba-benutzer eingerichtet hast. Und dann funktioniert es.

Es ist auch nicht kompliziert. Man muss es nur richtig machen ;) :daumen:
 
Sykehouse schrieb:
@screwdriver0815 Das macht doch caja-share im Hintergrund, aber eben für den angemeldeten Systembenutzer.
Sicher?? Dann würde es ja funktionieren - tut es aber nicht.

In Gnome 2 Zeiten hat caja-share (damals noch nautilus-share oder wie es auch immer hieß...) nie funktioniert, ohne dass man manuell (wie im ubuntuusers-Wiki beschrieben) einen Samba-Benutzer angelegt hat. Und ich würde mich wundern, wenn es jetzt funktionieren würde, ehrlich gesagt.
 
Sykehouse schrieb:
@screwdriver0815 Das macht doch caja-share im Hintergrund, aber eben für den angemeldeten Systembenutzer.
screwdriver0815 schrieb:
Sicher?? Dann würde es ja funktionieren - tut es aber nicht.

Es gibt bei caja-share eine Option den Share auch für "Gäste" freizugeben. Ich nehme an, das entspricht dem anonymen Zugang. Seit ich das aktiviert habe, kann ich problemlos ohne Passwort auf den Share zugreifen und auch ohne einen Nutzer einzurichten.

Ohne die Option hätte ich wohl, wie screwdriver sagte, einen Samba User anlegen müssen.
 
Hi Zusammen ich möchte in dem Zusammenhang nochmal was fragen.
Und zwar habe ich in den letzten Tagen ja meinen diversen Geräten feste IP-Adressen zugewiesen, Shares eingerichtet und mit eurer Hilfe (Danke nochmal) lief das auch alles Problemlos auch zwischen Windows und Linux.

Heute wollte ich wieder auf den Share auf dem Raspberry zugreifen und es hat nicht funktioniert. Er wollte plötzlich wieder Nutzernamen und Passwort haben ?!

Was mir auch aufgefallen ist, ist dass die IP Adressen nicht mehr gestimmt haben.
Auf meinem Windows 10 PC habe ich zum Beispiel eine ganz andere IP, als ich manuell konfiguriert hatte (siehe Bild). Ich kann mir das nicht erklären, ich habe am Router nichts geändert und die Konfiguration ist, wie man ja auch sieht, nach wie vor die gleiche 🤨 🤨 🤨
 

Anhänge

  • ipv4.jpg
    ipv4.jpg
    203,6 KB · Aufrufe: 324
Warum überhaupt fixe IPs auf den Geräten (insbesondere dem Windows Client) vergeben? DHCP Reservierungen auf dem Router konfigurieren ist bequemer und selbst mit dynamischen IPs ist DNS dein Freund.

169er IPs vergibt sich Windows selbst, wenn per DHCP keine kommt oder keine fixe konfiguriert ist. Stell das mal zurück auf "automatisch beziehen" und schau was passiert.
 
Sykehouse schrieb:
Warum überhaupt fixe IPs auf den Geräten (insbesondere dem Windows Client) vergeben? DHCP Reservierungen auf dem Router konfigurieren ist bequemer und selbst mit dynamischen IPs ist DNS dein Freund.

Wie oben schon gesagt ist die Netzwerkerkennung zwischen Windows und Linux ja manchmal tückisch. Bei festen IPs (Die bei maximal 10 Geräten im Netz ja leicht überschaubar sind) kann ich wie @t-6 ja schon beschrieben hat ganz einfach über die IP auf den Rechner zugreifen. Und das gilt ja nicht nur für Dateifreigaben, sondern auch für Sachen wir SQL Server etc.

Sykehouse schrieb:
169er IPs vergibt sich Windows selbst, wenn per DHCP keine kommt oder keine fixe konfiguriert ist. Stell das mal zurück auf "automatisch beziehen" und schau was passiert.

Ich werde es mal versuchen, aber was mich ja gerade so überrascht ist, dass eine automatisch konfiguriert wurde, OBWOHL eine fixe konfiguriert ist?


UPDATE:
Ich wollte gerade mal die Variante mit DHCP auf dem Router testen, als ich am Router folgendes sehe(Bild)
ipv4.jpg


Es handelt sich dabei definitiv um besagten Windows PC.
Wie kann das bitte sein, dass der PC laut Router 192.168.0.3 hat (wie er auch habe sollte)
Laut ipconfig auf dem PC aber 169.254.0.228

🤨 🤨 🤨
 
Zuletzt bearbeitet:
MrTony schrieb:
Wie oben schon gesagt ist die Netzwerkerkennung zwischen Windows und Linux ja manchmal tückisch
Hmm also ich habe ja nur ein primitives Netzwerk aus zwei bis drei freigegebenen Ordnern, jeweils auf einem Windows- oder einem Linuxrechner. Jedoch klappt die Erkennung per Rechnername immer völlig reibungslos. Ich habe mir diese Hampelei mit den festen IPs einfach aus Faulheit erspart und hatte bisher nie Probleme mit den Rechnernamen.
Immer jeweils im Explorer oder im Dolphin (KDE) in die Adresszeile \\Rechnername\freigebener-Ordner\ eingegeben, diesen Pfad als Lesezeichen oder Schnellzugriff gespeichert, Passwort gespeichert (ich habe keine anonymen Zugriffe konfiguriert) und das funzt.

Vielleicht ist einfacher und primitiver doch irgendwie besser... ;) :D
 
Die Auflösung des Hostnamens in die IP Adresse hat auch nichts mit der Windows Netzwerkerkennung zu tun, die funktioniert über den Router.
 
Zurück
Oben