MicroSD wird plötzlich als unformatiert angezeigt

Tim90

Cadet 3rd Year
Dabei seit
Feb. 2010
Beiträge
37
Hallo Leute,

Ich besitze eine MicroSD-Karte, die ich je nach Gerät über einen SD- bzw. USB-Adapter an verschiedenen PCs benutze.

Im Laufe des Tages erschien beim Anschließen mittels USB-Adapter ein Fenster mit "Sie müssen den Datenträger in Laufwerk X:\ formatieren, bevor sie ihn benutzen können.", jedoch öffnete sich direkt danach das Fenster und ich konnte an meine Daten ran.

Seit ich meinen PC eben aus dem Standby-Modus geweckt habe, klappt es nicht mehr. Die gleiche Meldung wie oben erscheint, gefolgt von einem weiteren Fenster: "Der Pfad ist nicht verfügbar. Auf dem Datenträger befindet sich kein erkanntes Dateisystem. Stellen sie sicher, dass alle benötigten Dateisysteme geladen sind [...]."

Habe direkt mit Acronis ein Abbild mit der Methode Sektor-für-Sektor hergestellt. Habe versucht, es mithilfe der Anleitung mit Testdisk zu analysieren. Soweit ich das verstehe, findet es nichts.

Komme nach Analysis/Quick Search/Deep Search hier an [siehe Anhang].

Die Karte hat eine Größe von 4GB, schließe daher mal auf FAT, sicher bin ich mir aber nicht. Verstehe leider wenig davon. Die Daten darauf sind mir unheimlich wichtig, mein letztes Backup liegt aber zu lange zurück (wird mir aber nie wieder passieren). Hoffe auf eure Hilfe und auf eine Lösung.

Grüße,
Tim90
 

Anhänge

Janz

Fleet Admiral
Dabei seit
Juni 2004
Beiträge
13.313
Die Karte zickt schon und du kommst nicht auf die Idee nen neues Backup zu machen? Besonders bei 4GB wos schnell geht? Format wird entweder FAT oder FAT32 sein, haste dich mal gründlich durch die TestDisk Anleitung hier gehangelt? Die Größe wird ja noch korrekt erkannt, daher ist noch nicht alle Hoffnung verloren. Mach ne Kopie von dem Image und erstell mal in dem Image ne neue Partition die 4GB groß ist (lieber in dem Image als direkt auf der SD, kommt ja aufs gleiche raus) und dann scannst du nochmal nach Dateien. Hatte ich neulich selber,dass das Programm (in meinem Fall R-Studio) die alten Daten nur gesehen hat nachdem ich die alten Partitionen manuell gelöscht hatte und neu erstellt hatte, warum auch immer...
 
Zuletzt bearbeitet:

Tim90

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
37
Die Karte zickt schon und du kommst nicht auf die Idee nen neues Backup zu machen? Besonders bei 4GB wos schnell geht?
Ich habe meine hellen Momente, doch die sind selten geworden...

Format wird entweder FAT oder FAT32 sein, haste dich mal gründlich durch die TestDisk Anleitung hier gehangelt?
Mit "Deeper Search" wird während des Suchvorgangs das Bild im Anhang angezeigt. Also Fat32 schätze ich? Durch die Anleitung habe ich mich gehangelt, nur komme ich bei meinen Analysisen immer an den Punkt, dass nichts gefunden wurde. Wie es dann noch weitergehen soll, habe ich trotz Anleitung nicht verstanden.

Die Größe wird ja noch korrekt erkannt, daher ist noch nicht alle Hoffnung verloren. Mach ne Kopie von dem Image und erstell mal in dem Image ne neue Partition die 4GB groß ist (lieber in dem Image als direkt auf der SD, kommt ja aufs gleiche raus) und dann scannst du nochmal nach Dateien.
So, hab eine Kopie gemacht. Erstelle ich die neue Partition mit Windows-Bordmitteln?

ScreenShot:
https://www.computerbase.de/forum/attachments/271615/
 
Zuletzt bearbeitet:

myblade

Ensign
Dabei seit
Juli 2009
Beiträge
236
kartenhersteller? cnmemory? gibt da so ein paar kandidaten, die gerne sehr oft sehr schnell den geist aufgeben
 

Janz

Fleet Admiral
Dabei seit
Juni 2004
Beiträge
13.313
Mounte das Image mit Acronis und dann entweder über die Datenträgerverwaltung (Systemsteuerung,Verwaltung,Datenträgerverwaltung) oder über die Kommandozeile mit Diskpart und dann versuchs nochmal mit Testdisk oder nem anderen Wiederherstellungsprogramm.
@myblade: haha cnmemory :D jaja da machts klick, wobei testdisk ja zumindest noch die korrekte Größe erkennt. Komplett hinüber ist se anscheinend noch nicht ganz
 

Janz

Fleet Admiral
Dabei seit
Juni 2004
Beiträge
13.313
Machts nicht besser, besonders weil Intensokarten gerne gefälscht werden. Aber auch die Originalkarten sind nicht wirklich gut
 

Tim90

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
37
Mounte das Image mit Acronis und dann entweder über die Datenträgerverwaltung (Systemsteuerung,Verwaltung,Datenträgerverwaltung) oder über die Kommandozeile mit Diskpart und dann versuchs nochmal mit Testdisk oder nem anderen Wiederherstellungsprogramm.
Komisch. In der Datenträgerverwaltung erscheint sie als RAW-Partition, unter Rechtsklick->Eigenschaften auf das Laufwerk steht neben "Dateisystem" aber nichts.

Direkt partitionieren kann ich den Datenträger in der Datenträgerverwaltung nicht; einzige Optionen wären Volume verkleinern, löschen, formatieren. :confused_alt:

EDIT: Hab auf einer Kopie des Images das Laufwerk formatiert und Recuva drüberlaufen lassen; es findet einige Dateien, aber leider nur spezifische (wav, mp3), die mir eigentlich schnuppe sind. Viel wichtiger sind mir meine .gp*-Dateien. Aber immerhin schon mal ein gutes Zeichen dafür, das diese auch noch zu retten sind...
 

Anhänge

Zuletzt bearbeitet:

Janz

Fleet Admiral
Dabei seit
Juni 2004
Beiträge
13.313
Ja ist klar,dass sie als RAW angezeigt wird. Hast ja ne 1:1 Kopie von der Karte gemacht die ebenfalls kein gültiges Dateisystem mehr hat. Volume löschen und dann neu erstellen mit FAT(32). Dann erneut scannen wie schon vorher gesagt. Da es das gemountete Image ist wird das auch über die GUI funktionieren. Bei normalen SD-Karten/USB-Sticks muss man das zwangsläufig mit diskpart machen
 

Tim90

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
37
Ok, fand's nur komisch, dass das Dateisystem in den Eigenschaften widerum nicht angezeigt wird.

Hab meinen letzten Post editiert, Recuva findet auf dem formatierten Image nur die "populären" Formate .mp3, .wav, .pdf... hoffe mal, dass die anderen Dateien nicht ganz verloren sind, nur weil Recuva sie nicht findet.

EDIT: Endlich, Restoration zeigt mir einiges mehr als Recuva (vielleicht sogar zuviel... :p). Werd mich jetzt mal an's Wiederherstellen und Sortieren setzen... vielen Dank für deine Hilfe und Geduld, Janz, hast mir den Tag gerettet :D Sollte noch was sein, melde ich mich natürlich wieder... aber schaut auf jeden Fall gut aus... ich sag schon mal gute Nacht :)

WICHTIG
EDIT2: Habe mit einer neueren Version von Restoration (die mehrere Dateien gleichzeitig wiederherstellen kann) alle verlorenen Dateien wiederhergestellt - dachte ich. Die Namen stimmen, die Dateiendungen stimmen, sogar die Größen stimmen - aber KEINE Datei lässt sich richtig öffnen. Wenige funktionieren, die sind dann aber unter falschem Namen wiederhergestellt.

Fällt jemandem noch etwas ein? Oder sollte ich auf ein Wunder hoffen? :( Die Dateien, die sich mit Recuva wiederherstellen ließen, waren einwandfrei. Aber Recuva kann eben nur viel zu wenige finden/wiederherstellen...
 
Zuletzt bearbeitet:
F

Fiona

Gast
Du hättest auch mal Testdisk ,ot Rechtsklick und als Administrator ausführen können.
Diagnose wäre;
Bestätige mal in Testdisk bis zur Festplattenanzeige durch.
Wähle deinen Stick aus.
Bestätige weiter, bis du das Menü Analyse siehst .
Bestätige aber nicht bei Analyse sondern bei Advanced!
Teile mit, ob deine Partition angezeigt wird.
Verlasse das Menüs mit bestätigen bei Proceed.
Bestätige bei Boot und gehe auf Rebuild BS.
Hinterher zeigt Testdisk dir das Ergebnis an.
Wenn Testdisk zu lange sucht (mehr als einige Minuten, teile es mit.
Hinterher solltest du das Menü List sehen.
Gehe mal da drauf und teile mit, ob deine Daten oder wieder eine Meldung angezeigt wird.
Gehe dort erstmal nicht auf das Menü Write, um keine Änderungen vorzunehmen.

Auch ist unter Advanced das Menü Undelete.
Wenn Testdisk nicht ausreicht, kannst du auch PhotoRec im Testdisk-Ordner testen.
Gehe dor am besten auf File Opt und drücke s um alle Dateirypen abzuwählen.
Markiere dann nur die Dateitypen die du benötigst.
Führe einen vollen scan aus.

Teile es mal mit.

Viele Grüße

Fiona
 

Tim90

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
37
Habe die nächsten Schritte mit dem formatierten Image gemacht, da Testdisk beim unformatierten ja nichts findet.

Du hättest auch mal Testdisk ,ot Rechtsklick und als Administrator ausführen können.
Diagnose wäre;
Bestätige mal in Testdisk bis zur Festplattenanzeige durch.
Wähle deinen Stick aus.
Bestätige weiter, bis du das Menü Analyse siehst .
Bestätige aber nicht bei Analyse sondern bei Advanced!
Teile mit, ob deine Partition angezeigt wird.
Verlasse das Menüs mit bestätigen bei Proceed.
Bestätige bei Boot und gehe auf Rebuild BS.
Hinterher zeigt Testdisk dir das Ergebnis an.
Wenn Testdisk zu lange sucht (mehr als einige Minuten, teile es mit.
Hinterher solltest du das Menü List sehen.
Gehe mal da drauf und teile mit, ob deine Daten oder wieder eine Meldung angezeigt wird.
Gehe dort erstmal nicht auf das Menü Write, um keine Änderungen vorzunehmen.
Ok, hab's jetzt als Admin ausgeführt.
Eine Sache vorweg: Hab alles zweimal ausprobiert, d.h. bin alles einmal durchgegangen, habe das Image zurückgesetzt, wieder (mit selben Einstellungen) formatiert, nochmal TestDisk.
Beim ersten Mal erschien unter "Advanced" die (einzige) formatierte Partition, beim zweiten Mal das Bild unten.
Testdisk sucht in Boot -> Rebuild BS sehr kurz, zeigt mir aber auch nur wenige Dateien an.
Unter List sind auch Ordner dabei gewesen, einige Dateien/Ordner waren rot markiert. Habe testhalber mal eine Datei mit TestDisk wiederhergestellt, kommt aber dasselbe bei raus wie mit Restoration - richtiger Name, richtige Endung, Größe ok, lässt sich nicht öffnen.

Auch ist unter Advanced das Menü Undelete.
Wenn Testdisk nicht ausreicht, kannst du auch PhotoRec im Testdisk-Ordner testen.
Gehe dor am besten auf File Opt und drücke s um alle Dateirypen abzuwählen.
Markiere dann nur die Dateitypen die du benötigst.
Führe einen vollen scan aus.
Bei Undelete erscheint "No file found, filesystem may be damaged.".

Werde es jetzt mal mit PhotoRec versuchen und das Ergebnis in diesen Beitrag editieren.

Neuster Stand der Dinge

Mit PhotoRec scheint es nun endgültig geklappt zu haben... rund 1100 Dateien mit der gesuchten Endung sind gefunden worden, leider ohne Namen, aber per Stichprobe scheint es so, als würden alle funktionieren.

Vielen, vielen Dank für eure Hilfe. :) Mach mich jetzt an's Umbenennen... *Kaffee aufsetz*
 

Anhänge

Zuletzt bearbeitet:
F

Fiona

Gast
Dein Bild ist immer noch als Drive (Laufwerk) und nicht als Disk.
Die Größe ist kleiner als 4 GB.
Hattest du Testdisk als Admin ausgeführt?
Kannst du deine Speicherkarte nicht als Disk auswählen?
 
Zuletzt bearbeitet:

_TK_

Lieutenant
Dabei seit
Jan. 2009
Beiträge
707
Vorsicht beim Verwenden von Micro-SDs!

Normale FLASH-Speicher (USB-Stöpsel, gute SD-Karten, CF-Karten usw.) haben separate FLASH-Speicherchips. Im Fall eines Falles kann ein Datenrettungsunternehmen immernoch die Rohdaten vom FLASH-Speicher auslesen, und diese dann wieder zusammensetzen. Bei Micro-SD ist dieser Weg grundsätzlich versperrt, d.h. wenn sie kaputt sind, sind die Daten für immer weg.
 

Tim90

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Feb. 2010
Beiträge
37
@Fiona
Lohnt es sich noch, darüber zu sprechen? Habe mit Photorec alles wichtige retten können.
Ich GLAUBE, dass das Image des Sticks nie als Disk angezeigt wurde.
Es KANN auch sein, dass ich Testdisk beim zweiten Mal nicht als Admin ausgeführt habe.
Es liegt leider schon ein paar Tage zurück... und zu der Zeit hatte ich vor Aufregung auch noch Schlafmangel. :schaf:

Tut mir Leid, dass ich erst wieder so spät antworte, war mit dem Beschriften der zahllosen Dateien beschäftigt und nahm an, das Thema sei auch für die anderen Beteiligten aus der Welt.^^

@_TK_
Werde ich mir auf alle Fälle merken. Beim nächsten Mal nehme ich einen USB-Stick... und klatsche mir einen "Backup!"-PostIt an den Monitor! :D
 
F

Fiona

Gast
Wenn du genügend Daten zurückbekommen und sortiert hast, ist es Ok. :)

LG

Fiona
 
Top