.mov Datei nicht zu Ende geschrieben von Digicam - Datenrettung?

Schlumpf2000

Cadet 2nd Year
Dabei seit
Jan. 2012
Beiträge
22
Hallo Leute,

Ich habe im Urlaub ein Video vom ersten Surfversuchs meines Sohnes gedreht. Dummerweise ist mir gegen Ende die Kamera (Casio Exilim S10) entglitten und auf den Steg. Akkudeckel auf, Batterie raus. Das Video wird nicht angezeigt. Habe ein zweites direkt danach gemacht zum Test, dieses wurde problemlos gespeichert.

Am Rechner werden beide .mov Dateien angezeigt. Die erste mit 0 Byte, die zweite normal. Das erste Video ist aber offensichtlich dennoch auf der Karte, da der benötigte Speicherplatz auf der SD-Karte als belegt ausgewiesen wird (siehe Screenshot). Ich nehme an das die Datei nicht zu Ende geschrieben wurde. Seit dem Vorfall wurde die Speicherkarte nicht weiter beschrieben.

Hat jemand einen Tipp wie ich das Video dennoch auslesen kann?

Viele Grüße,
Klaus

08-09-2013 08-54-55.jpg
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
Danke für den Tipp. Leider hat Recuva die Datei nicht gefunden, nur ein paar ältere, bereits gelöschte Fotos und Videos wiederhergestellt.
 

Simpson474

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
12.674
Mach zunächst ein 1:1 Backup mit Win32DiskImager und anschließend kannst du mal probieren, ob "chkdsk" (Windows Datenträgerüberprüfung) irgendetwas findet. Außerdem kannst du Photorec aus dem TestDisk Paket einmal probieren.
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
Phototec von Testdisk hat nur alte gelöschte Fotos und Videos gefunden.

Chkdsk hingegen hat was gefunden, Screenshot anbei. Habe für die Analyse das gezogene Image auf eine leere SD Karte wiederhersgestellt für die Windows Datenträgerüberprüfung. Es wurde ein FOUND.000 Ordner angelegt mit einer Datiel FILE000.CHK. Die Größe passt zum gesuchten Video. Habe die Datei um .mov erweitert, aber die Datei lässt sich mit VLC nicht abspielen. Kann man da was machen, um sie abspielbar zu machen?
08-09-2013 12-03-39.jpg
 

Simpson474

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
12.674
Wahrscheinlich schreibt die Kamera den Dateiheader am Ende der Aufzeichnung: deshalb wird auch nichts von Photorec gefunden. Ohne den Header müsstest du ein Reparaturprogramm für QuickTime *.mov Dateien finden, möglichweise kann das den Header rekonstruieren. Ansonsten könnte es auch funktionieren, den Dateiheader einer funktionierenden Videoaufnahme an den Beginn der defekten Datei zu kopieren.
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
Ja, das klingt plausibel.
Ich werde mal gucken., ob ich ein Programm finde, welches .mov Header rekonstruieren kann. Vielleicht kennt ja sogar jemand ein passendes Programm - bin für jeden Tipp dankbar!
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
So, habe diese Woche mal eine ganze Reihe von Programmen getestet. Leider hat keins die Datei wieder herstellen können. Weder Digital Media Converter Pro, noch MP4Cam2AVI und nicht Remo Repair MOV. Der Support vom letzteren hat mir angeboten die Datei einzusenden, man werde sie sich ansehen und ich kann dann die Datei im Fall einer Wiederherstellung zum Preis der Software bekommen. Irgendwie recht merkwürdig das ganze, 69$ kostet die Software.

Alternativ kann ich www.mp4repair.org ausprobiert, dort bekomme ich eine Vorschau der Datei von 3 Bildern aus dem Video die einwandfrei sind und auch der Ton dazu passt. Kostenpunkt hier 113$. Ziemlich viel Geld um einen Header zu reparieren, zumal es nur für eine einzige Datei ist.

Kennst vielleicht jemand eine Software die das kann und somit zumindest dauerhaft nutzbar ist oder eine günstigere Alternative um den Header der .mov Datei zu rekonstruieren?
 

Simpson474

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
12.674
Du könntest noch probieren (beide Dateien zunächst sichern, falls etwas schiefgeht), z.B. 1MB vom Anfang einer funktionierenden Datei mit den gleichen Aufnahmeeinstellungen in die defekte Datei zu kopieren (z.B. mit HxD).
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
Hi Simpson,
Danke für Deinen erneuten Support. Habe HxD mal installiert und es probiert 1024kB am Anfang des Codes abzurechnen und in die andere Datei einzufügen. Leider ließ sie sich dann immer noch nicht wiedergeben. Da die funktionierende Videodatei nur knapp 2MB groß ist, habe ich im zweiten Versuch einfach die erste Hälfte des Codes mit der gleichen Menge Code in der Zieldatei ersetz. Leider auch ohne brauchbares Ergebnis..
Hat HxD eine Fuktion wie ich das vielleicht so machen kann, wie Du es Dir gedacht hast?
 

Simpson474

Fleet Admiral
Dabei seit
Sep. 2006
Beiträge
12.674
So wie du es beschreibst, klingt es eigentlich richtig. Hier einmal, wie ich es machen würde:
  • Funktionierende Datei in HxD öffnen, STRG+E, Start-Offset 0, End-Offset 100000, OK, STRG+C
  • Defekte Datei öffnen, STRG+B, speichern und schließen.
Statt mit 100000 kannst du auch mal 20000, 40000 und 80000 probieren (wenn man mit dem kleinsten Wert beginnt, so braucht man die Datei nicht nach jeden Versuch wiederherzustellen, da beim nächsten Versuch sowieso noch mehr Daten am Anfang überschrieben werden). Wenn das nicht funktioniert, dann kommt man wohl mit so einfachen Mitteln nicht weiter.
 

Schlumpf2000

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Jan. 2012
Beiträge
22
Hallo,

Kurze Rückmeldung zum Thema. Habe bei www.mp4repair.org knapp 40 EUR bezahlt. Video funktioniert zu 98% wieder, aber hat manchmal Aussetzer wenn man vorspult. Insgesamt bin ich recht zufrieden mit der Lösung. Das ist mehr als ich mir zuletzt erhofft hatte...

Danke für eure Tipps zu dem Thema :)
 
Top