nvidia treiber und videowiedergabe

dahum

Lt. Commander
Dabei seit
Juli 2005
Beiträge
1.381
Habe ein kleines Problem, bin gerade von einer ATI auf eine 8800GTS umgestiegen, mit Zwischenstation 6100LE.
Sowohl auf der ATI als auch auf der kleinen Nvidia (mit Orginaltreiber vom letzten Jahr) lief alles wie erwartet, aber jetzt habe ich die GTS mit dem neusten XP-Treiber 162.18 installiert und einige Videoprobleme.

Da ich das CCCP (Combined Comunity Codec Package) installiert habe, haben bisher der Haali Media Splitter und ffdshow das decodieren übernommen. Nun bekomme ich Bildfehler bei allen DivX, h.264, mp4 und Xvid Dateien, wenn bei ffdshow der libavcodec oder divx/xvid als decoder eingestellt ist. Dann ist das Videobild diagonal geteilt, und sägezahnartig ineinander verschoben.
Wenn ich entsprechend die Formate auf disabled stelle, sind alle DivX, h264 und mp4 Files wieder ok, bei den Xvid laufen einige normal, andere haben weiterhin diesen Bildfehler. Worin sich diese xvid Dateien unterscheiden, ist mir schleierhaft, sind identischer Codec, Auflösung, Bitrate, Framezahl etc.
Außerdem konnte ich vorher mov Dateien über den Media Player Classic abspielen, jetzt funktionieren einige, andere lassen ihn abstürzen.

Wenn ich die Dateien über Virtual Dub abspiele, das sowohl den Splitter als auch ffdshow umgeht, gibt es keine Bildfehler.
Gibts irgend einen Zusammenhang zwischen den Treibern und dem CCCP, irgendeine Inkompatibilität mit den Direct Show Filtern oder dem Splitter, weiß da jemand was? Ich hatte mir gerade alles perfect mit Hilfe des CCCP als HD PC eingerichtet, und das ärgert ich mich wieder ordentlich.
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
Hi,

warscheinlich liegt bei dir ein Codec-Konflickt vor. Lade dir GSpot runter und prüfe deine Codec's unter System -> List Codec ..., alles was rot ist muss deinstalliert werden.
Wie du Codec's deinstallierst kannst du hier sehen.

Einfach neu installieren bringt gar nichts!
Erst wenn der Konfilckt beseitigt ist, kann neu installiert werden.

Du kannst dir den VLC media player installieren und probieren ob die Videos richtig laufen. Der VLC bringt seine eigenen Codecs mit.

Probiere auch mal einen älteren GraKa-Treiber zu installieren ... das hat schon Wunder bewirkt.
 

dahum

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
1.381
Bei GSpot ist alles grün, ich hatte ja vorher auch keine Konflikte. Habe jetzt mal auf gut Glück Xvid deinstalliert, und seitdem laufen alle Xvids, und alle Programme sagen mir: verwendendeter Codec: -
Virtual Dub zeigt als Decoder nun DivX an, wusste gar nicht, dass das geht.

Immerhin spielt jetzt fast alles, aber es müssen doch noch andere Leute die Kombination von Xvid, ffdshow und den neusten Treibern haben.
 

herja

Commodore
Dabei seit
Mai 2004
Beiträge
4.113
Hi,

naja, kein Codeckonflickt ist ja erstmal sehr schön.
Ja, Xvid-Dateien können auch mit den DivX-Codec abgespielt werden.
Wenn du ffdshow installiert hast, brauchst du auch keinen Xvid oder/und DivX-Codec extra installieren. Xvid und DivX werden bereits von ffdshow mitgebracht. In ffdshow kannst du auch auswählen welches Progi mit welchem Codec zusammen arbeiten soll.
Welche Version von ffdshow benutzt du den? Ich habe hier die deutsche Vers., evt hilft dir das ja schon. (http://www.ffdshow.info/)
 

Metzlor

Lt. Commander
Dabei seit
Juni 2006
Beiträge
1.101
1. Macht der VLC auch Probleme? Dieser verwendet nicht die Windows codec, wenn dieser funktioniert, dann liegt es an den Codecs.

2. Startet ein Programm unten in der Taskleiste wenn du ein Video startest? Hatte ich mal bei einem Codec Pack, dies deinstalliert und es tat wieder.

3. Von Codec Packs halte ich persönlich gar nichts, meißt sind ältere Codecs drin und sehr oft verursachen sie probleme! Also Codec PAck deinstallen und einzeln die neuesten benötigten Codecs ziehen, bzw. den VLC Player ^^, der spielt bis auf mov und flash fast alles ab!

4. Mal in den Nvidia Treibern schauen, ob Hardware beschleunigung aktiviert ist, mal testweise deaktivieren bzw. aktivieren ...
 

dahum

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
1.381
Gut, habe noch mal alle Kombinationen durchprobiert, und die neuste Xvid Version installiert, ffdshow ist vom 14.02.07.

1. VLC macht nur dann Probleme, wenn ich ffdshow auf libavcodec einstelle. Dann zeigt er kein Bild mehr an. Auf Xvid oder disabled gestellt gibts keine Probleme.

2. Nein, nur die Anzeigen, wenn der Haali Mediasplitter und/oder ffshow das decodieren übernimmt. Beide kann ich abstellen, aber auch dann werden Xvids nur richtig dargestellt, wenn der Xvid Codec deinstalliert ist.

3. Das CCCP installiert ja keine Codecs, sondern nur ein paar Programme, die zusammen das Decodieren übernehmen können, unabhängig von sonst installierten Codecs. Man kann außerdem leicht einstellen, ob ffshow die integrierten Codecs benutzten soll, oder die Windowsstandarts. Man kann auch das ganze CCCP komplett abschalten. Trotzdem funktionieren Xvids nur, wenn Windows sie über DivX decodiert. Und der ffshow interne Codec libavocodec funktioniert überhaupt nicht mehr.

4. wo? Ich finde in diesen dämlichen Treibern überhaupt nichts mehr.

Das also ist das Problem, der Xvid Codec geht nicht mehr, und ffshow mit seinen Codecs geht nicht mehr, beides muss am Nvidia Treiber liegen. Beides kann ich umgehen bzw. abschalten, aber mich ärgert das ganze, weil ffdshow quasi playerunabhängig Videos on the fly bearbeitet, z.B. die Größe festlegt und diverse Postprozessing Effekte hinzufügt. Nun bin ich wieder auf die einzelnen Player angewiesen, von denen jeder andere Features bietet und Dateien abspielt, aber keiner alle zusammen.
 

Arkos

Cadet 3rd Year
Dabei seit
Sep. 2004
Beiträge
52
doch doch...das bekommt man schon hin.


Es ärgert ja, dass man meistens bei verschiedenen Formaten verschiedene Player benötigt.


Ich werde hier zwei Varianten beschreiben.


1. VLC Player ohne dass vorhandene Zuordnungen verändert werden. Trotzdem kann man getrost über das Kontextmenu einen Film abspielen.

2. Eki-Pack und VD-Codec-Pack arbeiten mit dem alten MediaPlayerClassic. Und das funktioniert tadellos. Für alle Formate.

....................................................................................................................


1. VLC-Media Player

...

Also mit VLC gibt's dieses Problem schon mal nicht mehr.

Wenn man aber gerene den VLC so installieren will, dass vorhandene Format-Verknüpfungen nicht verändert werden, dann sollte man den VLC sfolgendermassen installieren.

Hier http://www.videolan.org/vlc/ den neusten VLC Player (VideoLanClient) runterladen und installieren.

Wenn man an den bisherigen EInstellungen nichts verändern will, dann kann man dies so installieren.

> Benutzerdefinierte Installation wählen.

> File Type associations deaktivieren. (Keine neue Zuordnung für VLC) (Daneben aber Desktop und StartleistenVerknüpfung aktivieren, sowie ActiveX Plugins und Mozilla usw.

> Wichtig ist aber die Einstellung "Context Menus"

So könnt ihr danach im Explorer immer via rechter Maustaste auf jeden Film > "Play" wählen, ddamit der Film anstatt mit dem verknüpften Prtogramm eben mit dem VLC abgespielt wird. (Der Vorteil daran ist, dass man eben nichts an den bisherigen Einstellungen verändert.)


....................................................................................................................


2. MediaPlayerClassic mit allen Codecs. Danach spielt MPC alles ab.

...

Downloadlinks und Installationsanleitung.


VD-Codec Pack

http://www.codec-archiv.de/win/vdcod/VDCodecPack0.9[Codec-Download.de].exe

Hier ist der neuste VD-CodecPack http://www.boncarmaz.com/telecharger_logiciels.php?download=104


Eki-CodecPack

http://www.codec-archiv.de/win/sonst_cp/EkiPack_1.9[Codec-Download.de].exe

Media Player Classic 6.4.9.0 Deutsch

http://sourceforge.net/project/showfiles.php?group_id=82303&package_id=84486&release_id=403230


PS. Die Downloads von den französischen Seiten benötigen Rerferee. Es funktionieren keine Downloadbeschleuniger. Einige Firewalls wie Symantec und Sygate könnten den DL blockieren. Es käme dann einfach nichts. In diesem Fall für den DL die Firewall kurz auf alle Erlauben einstellen. (Dies ist eben weil gewisse Verschleierungseinstellungen der Firewall diese DL's nicht zulassen. Aber an den DL's ist alles in Ordnung.)


Installationsanleitung


Zuerst andere CodecPacks, wie Tsunami Codec Pack und ACE-Mega-Codec Pack und deinstallieren über Systemsteuerung > Software. Aber nicht andere Player deinstallieren, sondern nur CodecPacks.


Danach ...


> VD-Codecpack mit allen Features installieren

> Eki-Codec Pack mit allen Features installieren und den Media Player Classic aktivieren. (Auch in der Installation. Damit werden alle Formate später mit dem MediaPlayer Classic abgespielt.)

> Nun die Datei "mplayerc_2kxp_6490_DE.zip" doppelklicken und die Datei "Mplayerc.exe" (ist der MediaPlayer Classic 6.4.9.0 Deutsch) in das Installationsverzeichnis "C:\Programme\EkiPack\mpc" entpacken die vorhandene Datei überschreiben. (Der installierte MPC ist französisch. Deshalb überschreiben wir diesen mit dem Deutschen.)

(Ihr könnt auch den deutschen MPC ins Verzeichnis "C:\Programme\VDCodecPack3.6" hineinkopieren. Dann kopiert ihr vom Originalen französischen den Namen und löscht dann den französichen Player oder benennt ihn um. Nun benennt ihr den deutschen Player mit dem französischen Namen. So wird dann auch sicher nie der französiscvhe Player geöffnet.


Nun könnt Ihr alle Film-Formate im PC abspielen. Auch DirectSound, AC3, DTS, Avi, Xvid usw. einfach alles. Sogar QuickTime und RealPlayerFormate können damit abgespielt werden.


Wenn ihr ein Format wieder mit einem anderen Player abspielen wollt, könnt ihr das entweder über die Optionen des MediaPlayerClassic > Optionen machen oder aber per Explorer > Extras > OrdnerOptionen > Dateitypen die entsprechende Dateiendung suchen und dann entweder löschen oder unter erweitert den bevorzugten Player einsetzen. (Das Gleiche kann man dann auch via > Datei > öffnen mit > durchsuchen > usw.)


Aber bei Problemen empfiehlt es sich eher, via Arbeitsplatz (Explorer) > Extras > OrdnerOptionen > Dateitypen die entsprechende Dateiendung ganz zu löschen, und dann im bevorzugten MediaPlayer > Optionen > Formate > das entsprechende Format wieder zu aktivieren.


(Wichtig! Immer nach Änderungen zuerst Programme neu starten, damit die Änderungen übernommen werden können.(Zum Beispiel beim Dateiendungen löschen im Explorer (Arbeitsplatz (Explorer) > Extras > OrdnerOptionen > Dateitypen))


Funktionieren tut's jedenfalls super....


PS. Wenn ihr das StartBild des MPC wechseln wollt, dann geht das so... > MediaPlayerClassic > Ansicht > Optionen > Logo > Internes Logo benutzen > OK

PS. Wenn ihr zusätzliche, also nicht direkt im Film enthaltene Untertitel zu *.avis abspielen wollt, müssen diese ja gleich heissen wie der Film. (Film.avi und Film.srt z.Bsp.) Der VLC erkennt sogar viele verschiedene Untertiteldateien, die auch im gleichen Film jeder einzeln angewählt werden kann. Beim MPC muss man aber eine DX8 oder DX9 Grafikkarte haben und die Filter auch so einstellen. Das geht aber einfach wieder über die > Optionen > Wiedergabe > Ausgabe > * und ** lesen und ggf. ändern. Oder einfach so lassen und bei zus. Untertiteln einfach den VLC benutzen. Aber es ist eh einfach.

Praktisch ist einfach, dass nach der Installation des MCP's, wie ich vorgeschlagen habe, sämtliche Formate per Doppelklick direkt über den MPC abgespielt werden. Das funktioniert immer.

An den Filtereinstellungen würde ich nichts machen, sonst kommt es eben vor, dass die Bildquali sich eher verschlechtert oder der Film gar nicht mehr abgespielt wird. (Störungen). (PS. Ich benutze auch für Divx den xVid Codec. Aber auch der fdshow bringt das locker ohne Probleme.

So... genug geschrieben... für nene älteren Beitrag soweiso... Aber helfen tut's sicher. Ich kann's jedenfalls nur empfehlen.

Ich habe übrigens auch bebilderte Anleitungen erstellt. Wenn die jemand braucht, dann einfach ne PN an mich.
 
Zuletzt bearbeitet:
Top