SSD lässt sich nicht formatieren, selbst in verschiedenen Rechnern

Raycrate

Lt. Junior Grade
Dabei seit
Nov. 2013
Beiträge
498
Hallo liebe CB - Community,

ich bin ratlos und komme nicht weiter, deswegen bitte ich nun hier um Hilfe. Folgendes Problem:

Ein Bekannter bat mich um Hilfe, da sein Rechner nicht mehr startete. Er will jedoch sowieso einen neuen haben und nur noch ein paar Teile wieder verwenden. Unter anderem die Samsung 850 Evo 1TB, um die es geht ( Daten sind egal, muss nichts gesichert werden).

Ich nehme mal an, dass ein Windows Update irgendwas zerschossen hat und deswegen Windows nicht mehr bootet von der SSD. Der Rest vom alten Rechner läuft noch. Aber egal, ich habe die SSD rausgenommen, neue Teile besorgt und wollte gerade Windows frisch installieren auf dem neuen Rechner auf die besagte SSD, allerdings weigert sich Windows und sagt es ist eine GPT - Partition. Eine zweite Partition mit 845mb ist mit OEM gekennzeichnet und auch hier weigert sich Windows drauf installiert zu werden. Ich kann sie aber auch nicht löschen oder formatieren.

Ich habe die SSD also in ein externes Dock SATA-USB an meinen Rechner angeschlossen und versucht sie in der Datenträgerverwaltung zu finden, aber da sehe ich sie nicht. In Diskpart ebensowenig. Nach paar Minuten fängt er an sie einzulesen aber dann hängt sich die Datenträgerverwaltung auf und Diskpart geht auch nicht mehr, bis ich das SATA-USB Dock abziehe. Selbst Rechner herunterfahren ist vorher nicht mehr möglich. Aber im Bios beim neuen PC und auch bei meinem PC im Gerätemanager ist sie aufgeführt.

Meine Frage: Wie kann ich die SSD formatieren und alle Partitionen löschen, um anschließend frisch Windows darauf installieren zu können? Bin für alle Tipps Dankbar.

Falls ihr weitere Infos braucht zum System oder so fragt gerne.

Danke vorab^^
 

NameHere

Commander
Dabei seit
Sep. 2013
Beiträge
2.191
Partitionen löschen geht nicht bei der Installation?
 

wern001

Lt. Commander
Dabei seit
Mai 2017
Beiträge
1.565
Also normal kann man die Partionen beim Installieren löschen.
Sollte es weder dort noch in einem anderen PC funktionieren tippe ich eher darauf das die SSD defekt ist.
 

Bob.Dig

Lt. Commander
Dabei seit
Dez. 2006
Beiträge
1.628
Teilweise kann man im UEFI ein Secure Erase machen. Auch sollte der Diskpart clean Befehl das lösen oder schon bei der Win Install, wie @NameHere schon schrieb, sollte ein Löschen eigentlich möglich sein.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
Ne beim Windows install weigert er sich sie zu löschen und bringt eine Fehlermeldung. Das mit dem UEFI Secure Erase schaue ich mir mal an, danke.
 

Nickel

Admiral
Dabei seit
Aug. 2005
Beiträge
9.501
Das sollte aber eigtl. funktionieren an dieser Stelle die Partitionen zu löschen.
Du kannt aber an dieser Stelle auch mit der Tastatur "Shift u. F10" die Eingabeaufforderung
aufrufen, dann dann mit "diskpart" die SSD "cleanen".
Eingabeaufforderung wieder beenden und im Setup dann auf aktualisieren klicken.
Übrigens, dann keine Partitionen selbst anlegen und auch nichts formatieren.
Die Windows 10 Installation macht das alles automatisch,
einfach auf "Weiter" oder auf "Neu" gehen.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
@Nickel ok das mit Shift u. F10 versuche ich gleich mal, danke
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.930
Baue die SSD in den Rechner, boote Dein Windowsinstallationsmedium und drücke dabei mehrfach die Tastenkombination Shift+F10 um eine Eingabeaufforderung zu öffnen, dort gib dann folgende Befehle ein:

  • diskpart
  • list disk
  • select disk x (x steht für die Nummer des Laufwerks aus list disk, die richtige Platte sollte an der Kapazität zu erkennen sein, sonst andere Platten besser vorher abklemmen um Datenverlust zu vermeiden, vor einer Windowsinstallation sowieso, damit der Bootloader nicht dort landet)
  • detail disk (nur um sicher zu gehen die richtige Platte ausgewählt zu haben)
  • clean (clean löscht alle Partitionierungsinformationen, clean all überschreibt alles mit 00 und dauert entsprechend länger, man kann danach auch nichts mehr wiederherstellen)
  • exit
Überlasse danach dem Installer die Initialisierung der SSD, der wählt entsprechen dem BIOS/UEFI bzw. bei UEFI der Einstellung zum UEFi Modus dann die korrekte Partitionierungsart (MBR oder GPT) aus.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
ich versuche es gleich und werde berichten, danke
 

Nickel

Admiral
Dabei seit
Aug. 2005
Beiträge
9.501
Ja, hatten wir ja auch bereits schon, nur nicht so ausführlich wie es Holt nun wiederholen musste.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
So, alles gemacht wie beschrieben und hat geklappt bis zur Eingabe von "clean", hier kommt jetzt die Meldung: "Fehler in Diskpart: Ein nicht vorhandenes Gerät wurde angegeben. Weitere Informationen finden Sie im Systemereignisprotokoll."

Wenn ich bei der Windows install versuche das Volume zu löschen, kommt übrigens der Fehler 0x800701b1. Falls das was hilft...

Sagt bloß die SSD ist echt hinüber, das hätte ich ja nie gedacht :-(

Ich glaube dass irgendwie ein Win 10 Update den Boot Sektor geschrottet hat. Die SSD wurde auch von einer alten HDD geklont, vielleicht ist da was schief gelaufen und rächt sich jetzt. Man findet ja einige mit ähnlichen Problemen, nur hat keine Lösung die ich gefunden hatte bei mir bisher funktioniert...
 

Jokeboy

Rear Admiral
Dabei seit
Okt. 2007
Beiträge
5.883
Hatte ich auch einmal: eine SSD im Rechner der ein paar Wochen auf dem trockenen lag (kein Strom) wurde auf einmal nicht mehr erkannt. Kein Tool oder sonstiges konnte den anbinden aber im BIOS wurde er noch erkannt.

Habe dann das gute alte Knoppix gestartet und Gparted genutzt und siehe da - der kanns. Aber leider musste ich damals die Festplatte formatieren damit sie wieder ging, zu meinem Glück war die SSD nur für Spiele da.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
OK ich teste die genannten Vorschläge durch und melde mich wieder, schonmal vielen Dank für eure Hilfe bisher!!

Edit:
Ok also gerade mal nen Gparted Live Stick gebootet, hier wird die SSD nicht mal aufgelistet...
Erstelle jetzt nen Stick mit Samsung Magician.
 
Zuletzt bearbeitet:

Bob.Dig

Lt. Commander
Dabei seit
Dez. 2006
Beiträge
1.628
Was zeigt denn eigentlich das neuste Magician so an. Kannst ja mal Screenshots hier einstellen, wenn du nicht weiter kommst. Encrypted Drive und Drive Details fände ich interessant.
Möglichst keine Adapter benutzen sondern direkt an den SATA-Anschlüssen des Chipsatzes anschließen.
 
Zuletzt bearbeitet:

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
Leute, ich habs geschafft. Samsung Magician war die Lösung. Vielen vielen Dank!!!

Der Ablauf war wie folgt (für die Nachwelt mal festhalten falls es jemandem hilft in Zukunft) :

  • Mit Magician nen bootbaren Stick erstellt
  • Stick in den neuen Rechner mit der defekten SSD und vom Stick gebootet.
  • SSD gewählt wo der Secure Erase laufen soll
  • Magician hats beim 1. Anlauf nicht geschafft -> SSD war in einem Frozen State und ich sollte das Power Kabel der SSD im laufenden Betrieb für paar Sekunden abziehen Oo^^
  • Anschließend zweiter Versuch lief durch, dauerte ca. 30sec
  • Jetzt klappts mit der Windows Installation, alle Partitionen waren weg, als wäre die SSD neu!!


Nochmals tausend Dank :-)
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.930
So, alles gemacht wie beschrieben und hat geklappt bis zur Eingabe von "clean", hier kommt jetzt die Meldung: "Fehler in Diskpart: Ein nicht vorhandenes Gerät wurde angegeben.
Hast Du das wie in Post #8 beschrieben wirklich mit der SSD im Rechner statt über USB gemacht? Über USB kann es sein, dass die SSD mehr Strom zieht als der Port liefert und dann dreht der den Saft ab und außerdem kann es sein, dass irgendeine Sicherheitssoftware das Beschreiben vom Sektor 0 bei USB Speichermedien verhindert damit sich dort keine Schadsoftware einnisten kann.
 

Raycrate

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2013
Beiträge
498
@Holt ja habe es während der Windows install versucht mit Shift und F10 wie von euch beschrieben ;-)
 

Holt

Fleet Admiral
Dabei seit
Mai 2010
Beiträge
55.930
Und wirklich mit der SSD an einem SATA Port? Was für ein Board ist das denn, eigentlich sollte CLEAN funktionieren, dabei werden ja nur die ersten letzten 1024k oder so reichen mit 00 überschrieben, damit alle Partitionierungsinformationen weg sind und die Platte danach wieder wie neu wirkt.
 
Top