Treiber Windows 10 AMD System

Tong Kyr

Cadet 4th Year
Dabei seit
Sep. 2017
Beiträge
65
Hallo zusammen,

ich werde gleich meine Festplatte formatieren und Windows 10 neu installieren, da ich Soundprobleme mit meiner Onboard Soundkarte habe (Empfehlung aus dem Forum).
Die Treiber will/ habe ich von den Herstellerseiten runtergeladen. Leider werde ich da von einer Flut von Möglichkeiten nahezu erschlagen.

Runtergeladen habe ich mir folgendes.
AMD Seite:
Adrenalin edition 18.12.1.1
AMD Ryzen Master
AMD Chipset driver 18.10_1018

MSI Seite:
Realtek PCIlan W10
Realtek nahimic audio (6.0.1.8470) [308MB]
Realtek nahimic UAD audio [34MB]
weiteres funktioniert grad nicht, da die Seite aktuell spinnt.

Meine Hardware:
MSI X470 Gaming plus
Sapphire RX 580 nitro+

Meine Frage ist nun, welche Treiberpakete ich nun wirklich benötige?

Es gibt ja alleine auf der Sapphireseite für die Graka Adrenalin, Crimson und Crimson minimalsetup. Soweit ich das rausgelesen habe ist dem Kind nur ein anderer Name gegeben worden mit leichten veränderungen.
Die Treiber sollten meines Wissens in Windows 10 automatisch aktuell gehalten werden. Daher wären die AMD Chipset driver 18.10_1018 eigentlich überflüssig zu installieren!?

Danke für die Antworten.

Grüße

Tong Kyr
 

shadowrid0r

Lt. Commander
Dabei seit
Juni 2008
Beiträge
1.742
Wenn der HD Sound Stecker für das Frontpanel steckt nehme ich Realtek HD Treiber...
Wenn der AC97 Soundstecker für das Frontpanel steckt nimmt man normal den Realtek AC97 Treiber...
Von der Realtek Seite.
Was für Soundprobleme hast du genau?
 

Bullermann

Ensign
Dabei seit
Jan. 2008
Beiträge
149
Na wenn dein Tonproblem mal nicht an Windows 10: Version 1809 im Zusammenhang mit jüngeren Realtek HD Audio Treiben liegt. Hatte 2 Wochen den Fehler gesucht. Trat meist nach Kaltstart auf.
 

Lord Maiki

Lieutenant
Dabei seit
Feb. 2011
Beiträge
533
Es soll nur wichtig sein das der AMD Chipsatztreiber vor dem Grafikkartentreiber installiert wird (der ist meist älter).
Der Netzwerktreiber ist normalerweise das erste was installiert wird.
Den AMD Chipsatztreiber brauchst du normallerweise nicht. Windows bringt die wichtigsten eigene (allgemeine) Treiber mit. Die von AMD sind oftmals schneller. Sorgen aber bei einigen auch für Probleme. Allerdings hatte ich schon ein paar mal das ein spezieller Treiber nur durch den Chipsatzteiber vom Mainboardhersteller mitgeliefert wird. Deswegen nehme ich den vom Mainboardhersteller.
Bei der Grafikkarte hatte ich bisher den von amd (Hersteller) verwendet. Die sind meist aktueller. Das steht sogar bei Saphire

Für Systeme mit Microsoft Windows wird empfohlen die neuesten offiziellen Treiber für Ihr AMD Grafikprodukt zu verwenden. Klicken Sie auf den Download-Link und es sollte eine Browsermeldung erscheinen. Wählen Sie dort 'Run'.
Unter downloadlink befindet sich der reine Treiber (minimalsetup). Der Rest ist halt zum Anpassen des Treibers (+ zusätzliche Funktion) und wird halt seltener aktuallisiert (das ist dann diese Adrenalin, Crimson, Catalyst, ... Bezeichnung).
Der AMD Ryzen Master selber ist eine Erweiterung des Treiberpaktes um noch weitere Funktionen.
Ergänzung ()

Bei den offiziellen Treibern gibt es 2 Versionen von AMD. Einer mit Zertifizierung vom MS, der dann auch von Windows installiert wird, und ein meist neuerer mit Anpassung gerade herausgekommenen Spielen. Die Zertifizierung vom MS findet nur bei wenigen Treiberversionen statt. Der ist halt für typische Bürorechner gedacht. Da spielen die Anpassungen für die neusten Spiele keine Rolle.
 
Zuletzt bearbeitet:

Questionmark

Lt. Commander
Dabei seit
Feb. 2015
Beiträge
1.595
Und nochmal: Windows aktualisiert nie korrekt und schon gar nicht aktuell!

In diesem Fall:

1. AMD Chipset
2. Realtek Audio (AC97 Treiber sind nur für alte Chipsätze, das hat mit dem Chip zu tun, nicht mit dem Anschluss),
wichtig ist die Version, ich nutze immer noch die R281, zwar nicht die aktuellste, aber funktioniert alles tadellos, auch der Realtek Audio Manager
3. Grafik

Alle Treiber immer vom Hersteller beziehen, Boardhersteller sind nie ganz auf dem Laufenden,

Wenn gewünscht, danach noch Tools wie Ryzen Master oder RGB Software, den Rest immer weglassen.
 

Tong Kyr

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Sep. 2017
Beiträge
65
Danke für die Antworten!

System ist installiert.

Das bei meinem 5.1 System der Center und Subwoofer nicht, bzw. nur sehr leise funktioniert haben. Beim testen in der Soundsystemeinstellung knartze der Center. Anfänglich war der Sound/ Klang super, wurde aber nach kurzer Zeit merklich leiser und das Knarzen trat auf.
Soundproblem

Na wenn dein Tonproblem mal nicht an Windows 10: Version 1809 im Zusammenhang mit jüngeren Realtek HD Audio Treiben liegt. Hatte 2 Wochen den Fehler gesucht. Trat meist nach Kaltstart auf.
Welches Fehler hattest Du und wie hast Du ihn behoben?

@ Lord Maiki: Ich bin deiner Empfehlung gefolg. Danke dafür.

Realtek Audio Treiber: Damit sind die "Realtek nahimic audio (6.0.1.8470) [308MB]" gemeint von der Herstellerseite vom Board gemeint?
 

Wishbringer

Commander
Dabei seit
Juli 2002
Beiträge
3.036
Ich denke mal, dass der TE eher die Probleme sieht, welche Realtek er runterladen soll.

Bei Windows 10 gibt es zwei Arten von Treibern (auch bei Realtek selbst).
HDA (High Definition Audio) = das sind die klassischen Soundtreiber für Win XP bis Win 10, belegen meist so um die 300 MB und sind am weitesten verbreitet und auch jahre-(jahrzehnte)lang getestet und optimiert
UAD (Universal Audio Driver) = sind ganz neue Treiber für Windows 10 und nur Windows 10. Sind kleiner (ca. 30 MB) und entgegen den HDA kriegt man sie seltener von Realtek selbst, tauchen meist als "angepasste" Versionen bei den MB-Herstellern auf = passt irgendwie nicht zum Begriff "Universal"

Ich hab bei mir beide ausprobiert und bin bei den HDA geblieben, da die UAD Knackser und sonstige Störgeräusche bei Einstellungen oberhalb von 48.000 Hz und Samplingraten von 192.000 erzeugt haben.
 

Bullermann

Ensign
Dabei seit
Jan. 2008
Beiträge
149
Welches Fehler hattest Du und wie hast Du ihn behoben?
Nach dem Upgrade auf Win 1809 plötzlich Tom verzehrt, Pegel nur knapp die Hälfe von normal. Jeden Tag fast gefummelt. Dann lief es 1-2 Tage dann war er wieder da der Fehler. Da Fehler nicht gefunden und es auch mal Zeit für ein Neuinstall war halt neu installiert. Ein Tag später das selbe ohne das ich einen Treiber installiert hatte. Der letzte offizielle Realtek HD R282 Treiber löste dann das Problem. Jeder neuere Treiber löste früher oder später, meist nach Kaltstart den Fehler wieder aus.
 

tywebb

Cadet 3rd Year
Dabei seit
Jan. 2012
Beiträge
45
Hallo !

Hier kannst Du Dir immer direkt die neuesten treiber von Realtek herunterladen

https://www.realtek.com/en/component/zoo/advanced-search/74?Itemid=276

Du hast den ALC892, gehste drauf und dort gibt's dann das aktuellste.

P.S. Jetzt kommt sicher die nächste Frage weil dort steht Driver only aber es gibt verschiedene Mögklichkeiten. Den Unterschied kenne ich jetzt auch nicht, ich lade immer das größte Paket ;-). Da kannst Du ja experimentieren.
 

Tong Kyr

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Sep. 2017
Beiträge
65
Danke Wishbringer. Genau das meinte ich.
Da ich immer eine separate Soundkarte hatte, habe ich mich nie mit der Onboardvariante auseinander gesetzt.


Die HDA´s sind dann die Realtek nahimic audio (6.0.1.8470) [308MB] von der Mainboardherstellerseite?
Auf CB werden auch Treiber angeboten. Da gibts beispielsweise Realtek HD Audio-Treiber 6.0.1.8467 für Windows 10 64bit [112MB] und Realtek HD Audio-Treiber 6.0.1.8186 (R2.82) WHQL für alle Windows Versionen.

Ergänzung ()

@ tywebb: Danke. Aber nein, die Frage habe ich mir jetzt ausnahmsweise nicht gestellt. :)
 
Zuletzt bearbeitet:

Ash1983

Lt. Junior Grade
Dabei seit
Apr. 2012
Beiträge
333

CrEaToXx

Lt. Junior Grade
Dabei seit
Nov. 2018
Beiträge
363
Beim Chipsetdriver rate ich zu MSI, da aktueller. Ich meine der AMD ist vom 18.11, der MSI(Webseite nicht CD) vom 27.11 oder so. Hat mich auch etwas googeling Nerverei gekostet, das raus zu finden. MSI basiert ihr built immer auf dem aktuellsten built AMDs. Der generelle Rat bezüglich Chipset sagt: unabhängig vom Provider, nur neu installieren, wenn es Probleme mit dem bereits installierten gibt, oder in irgendeiner "offiziellen" Form zu einem Update geraten wird.

Ansonsten würde ich ganz sicher nich zwei Audiotreiber parallel installieren. Auch hier sollte der Treiber deines Mainboardherstellers verwendet werden, da MSI Nahimic und AMD den ganz normalen Realtek HD benutzt.

Edit: Ryzen Master brauchst du nicht, bzw. ist der äquivalenten MSI Software unterlegen.
 

Wishbringer

Commander
Dabei seit
Juli 2002
Beiträge
3.036

shadowrid0r

Lt. Commander
Dabei seit
Juni 2008
Beiträge
1.742
Zuletzt bearbeitet:

Wishbringer

Commander
Dabei seit
Juli 2002
Beiträge
3.036
Beim Chipsetdriver rate ich zu MSI, da aktueller. Ich meine der AMD ist vom 18.11, der MSI(Webseite nicht CD) vom 27.11 oder so...
Also bei den Raid-Treibern stimmt das nicht.
Versions-Nr. MSI = 9.2.0.70
Versions-Nr. AMD = 9.2.0.87

Bei Chipsatz
MSI = 18.10.30
AMD = 18.10.1810

Übrigens, die Chipsatztreiber für den X470 liegen gerade mal bei 60 MB.
Das Paket, das MSI mit ca. 700 MB anbietet, beinhaltet auch die Grafiktreiber für APUs.
Wenn man dann noch für die RX580 die neusten 18.12.1.1 runterlädt hat man alles doppelt gemoppelt.

Auf Datumsangaben verlasse ich mich nicht.
Es ist egal, wann eine Zip-Datei erstellt oder hochgeladen wurde. Es kommt auf den Inhalt an.
 

Questionmark

Lt. Commander
Dabei seit
Feb. 2015
Beiträge
1.595
@ shadowrid0r: Das ist meinte ich auch nicht, aktuelle Cases haben den alten Anschluss ja gar nicht mehr! Es gibt Non-HD Chips, wie die alten ALC6xx Serie Chips, die im Prinzip keine HDA Chips sind.
 

Tong Kyr

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Sep. 2017
Beiträge
65
Also das Frontpanel ist mit dem HD Audio Stecker angeschlossen. Der andere ist bei mir nicht vorhanden.

Die Realtektreiber habe ich gleich wieder deinstalliert, da ich die einzelnen Boxen nicht separat konfigurieren konnte. Dazu kam noch, dass beim 5.1 ich anstatt 2 Rearlautsprecher 2 seitliche hatte.

Ich habe die Nahimic´s drauf gezogen und aktuell funktioniert alles wie ich es wollte. Bis auf dass der Center etwas leiser ist als die restlichen Lautspecher.

Vielen Dank für Eure Unterstützung.
 
Top