TrueCrypted Harddisk nicht mehr zu öffnen

SlevinSeven

Cadet 2nd Year
Dabei seit
Nov. 2010
Beiträge
21
Hey alle miteinander,

ich streite mich seit mehreren Tagen mit folgender Problematik herum.
Ich habe vor einiger Zeit eine komplette Festplatte (extern) mit TrueCrypt 7.0 a verschlüsselt. Nun musste ich vor ein paar Tagen wegen eines Fehlers im Windows System mein Betriebssystem neu aufsetzen.

Doch als ich die externe Festplatte mit dem erneut installierten TrueCrypt entschlüsseln wollte, fällt mir zunächst auf, dass die Festplatte nicht mehr im Arbeitsplatz zu sehen ist - was sie vorher war. Außerdem ist anzumerken, dass sie in Systemsteuerung/Verwaltung/Computerverwaltung - als "nicht zugeordnet" und ergo ohne Laufwerksbuchstaben angezeigt wird. Sie wird bei dem "Hardware sicher entfernen" Interface als "an Standort 0"
eingestuft.

Wähle ich die Platte dennoch mit Truecrypt auf und gebe das 100% richtige pw ein, kommt nur: "Incorrect password or not a TrueCrypt volume."

Gibt es für mich irgendeine Möglichkeit die Daten noch zu retten?
Bitte um Hilfe, danke schon mal im Voraus.

Hier noch ein paar Daten:

Windows XP, 32 bit SP 3

Festplatte:

IDE Festplatte mit 320 GB von fantec (3,5 zoll, ergo mit eigener Stromversorgung)
angezeigt als "WDC WD 3200JS-00PDB0"

Mfg Slevin Seven
 
Mach mal einen Screen von der Truecrypt Device Auswahl beim Mounten.

Gruß mokabo
 
Das die Platte in der Computerverwaltung als "nicht zugeordnet" gelistet ist, ist normal.

Gehe ich recht in der Annahme, dass die Platte in der TrueCrypt Programmoberfläche unter "Datenträger..." korrekt aufgelistet ist und auch richtig ausgewählt wurde?
Evtl. sind die Platten dort in einer anderen Reihenfolge gelistet als vor der Neuinstallation und du hast aus gewohnheit versehentlich ein falsches Laufwerk eingebunden.

Ansonsten solltest du den Volume Header wiederherstellen, weil der evtl. kaputt ist.
Den hast du ja hoffentlich vorher gesichert!
 
Hier der Screen. Und ja, es sollte wohl korrekt ausgewählt worden sein. Den Header hatte ich auf meinem Rechner vor der Formatierung und konnte ihn nicht retten.

Gibts es dennoch eine Möglichkeit für mich daran zu kommen?

MfG SlevinSeven
 

Anhänge

  • asd.jpg
    asd.jpg
    108 KB · Aufrufe: 189
So wie es hier aussieht, ist die Partitionierung der HDD nicht mehr vorhanden. Du hast jetzt zwei Möglichkeiten: entweder du versuchst eine neue Partition mit dem gleichen Betriebssystem wie damals zu erstellen (ohne Formatierung, ansonsten ist alles verloren) oder du versuchst mein TestCrypt-Tool (siehe hier).
 
Ich habe in den Foren gelesen, dass bei den True Crypt Versionen ab 6 und höher der Header am Ende der Verschlüsselung zu finden ist. Kann ich den bei meinem nicht auch ausfindig machen und wenn ja, wie ? Und wenn ich ihn hab was bringt er mir dann ?

MfG und danke für die umfangreiche Hilfe.
SlevinSeven
 
Genau das macht mein Tool - es sucht nach dem Backup-Header am Ende und gibt die Partitionsdaten aus, die nötig sind um die richtige Partition erneut erstellen zu können.
 
Tool geladen, viel probiert aber es funktioniert nicht. Egal wie ich es ausführe, es steht kurz in der cmd Konsole und verschwindet dann wieder. Aber ich muss den Befehl ja im Programm selbst ausführen und das geht nicht weil es ja immer wieder auf cmd zurückspringt und der damit logischerweiße nichts anfangen kann.

Was kann ich da machen?

MfG SlevinSeven
 
Kommen irgendwelche Meldungen vom Programm? Hast du die Parameter auch so angegeben/berechnet wie im anderen Thread beschrieben (also zunächst die Anzahl der Sektoren der HDD ermittlen) und dann die letzten 20000 Sektoren gescannt?
 
Ich kann mit dem Begriff Parameter bezüglich der Konsole nichts anfangen. Aber nachdem ich den Pfad angegeben habe erscheint dann auch die auszuwählenden Festplatten incl. Sektorenanzahl. Außerdem gibt wie im Bilderbuch das Programm an, in welcher Form ich die Befehle angeben muss. Jedoch ist das die cmd Konsole dann und nicht dein Programm, was es ja sein sollte, weil sich das kurz nach öffnen wieder von selbst schließt.

Konsole sagt mir dann:

"Der Befehl "TestCrypt.exe" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

MfG SlevinSeven
 
Bin leider immer noch nicht weiter. Wie kann ich das Programm erfolgreich Starten und die Befehle im Programm selbst dann ausführen?

MfG Slevin Seven
 
Am besten wäre es, wenn du noch ein bisschen warten könntest. Ich arbeite im Moment an einer GUI-Version von dem Tool, da die Bedienung doch nicht ganz einfach ist und zu vielen Fragen und Problemen führt. Ich kann dir innerhalb der nächsten Tage mal erste Versionen zukommen lassen.
 
Konsole ist nach wie vor nicht in der Lage, das Programm zu nutzen s. o.
Wie kann ich das ändern oder anderswie ausführen?

Screen verdeutlicht vielleicht die Problematik, denn anstatt "Eingabeaufforderung" sollte die Konsole ja den Pfad zum TestCrypt Programm aufweißen, doch wenn ich das prog in cmd reinziehe, geht die Bezeichnung sofort wieder weg.

MfG Slevin Seven
 

Anhänge

  • asdfasdf2.GIF
    asdfasdf2.GIF
    7,4 KB · Aufrufe: 104
Die GUI-Version hat bei dir ja Daten gefunden, oder? Weder die GUI-Version noch die Kommandozeilenversion von TestCrypt können momentan Partitionen erstellen, von daher solltest du das normale TestDisk verwenden.
 
Habe paritioniert, jedoch mit der Xp Computerverwaltung was mich einen Schritt weiter gebracht hat, jedoch siehe Anhang, seh ich mich nun mit einem neuen Problem konfrontiert... wie soll ich weiter vorgehen ?
Ergänzung ()

Wo kann ich bei Test Disk den Backup hadder eingeben ?
 

Anhänge

  • 73.GIF
    73.GIF
    43,3 KB · Aufrufe: 116
Zuletzt bearbeitet:
Bei TestDisk kannst du eine Partition exakt an den Grenzen erstellen, die dir von TestCrypt angegeben wurden. Allerdings sieht das gar nicht so schlecht aus - wurde das Volume einfach so gemountet oder hast du einen gesicherten Backup-Header eingespielt? Wenn es einfach so gemountet wurde, so solltest du jetzt mit Datenrettungsprogrammen (z.B. GetDataBack oder Recuva) auf der eingebundenen Partition arbeiten können.
 
Nachdem ich durch Windows das Teil partitioniert hatte, hat nach der 3tten passworteingabe true cryp reagiert und den backupheader gesonstwast und wollte dran, aber dann kam die Meldung (siehe anhang), die mich am Zugriff hindert. Ich hab praktisch extern keinen Header oder sonst iwelche Daten aus den Analyseprogrammen eingegeben.

Was ist nun der nächste Schritt?

Wäre es vielleicht möglich, wenn ich mit dem richtigen Dateisystem partitioniere, dass das Teil wieder läuft, weil das ist ja die Fehlermeldung
 
Zuletzt bearbeitet:
Zurück
Top