Antergos - AMD Ryzen 2700U GPU Performance

Dabei seit
Dez. 2007
Beiträge
1.565
#1
Hallo Zusammen,

Mit dem erscheinen des Thinkpad A485 habe ich mir gedacht, dass ich Linux mal wieder eine Chance gebe auf dem Laptop um es zum arbeiten zu nutzen. Soweit so gut nach ein paar kleinen Anpassungen hat es, dann soweit ohne Probleme funktioniert mit Suspend usw.

Mein Problem zurzeit ist, dass wenn ich unter Linux Antergos mit Gnome 3 Arbeiten möchte es extrem mühsam ist, wenn man viel Text auf dem Bildschirm hat Samsung Ultrawide 34 Zolle 3440x1440 oder Dell 27 2560x1440 wo beide über HDMI angeschlossen sind. Arbeite als Softwareentwickler und somit Atom Editor oder ein anderer Editor mit viel Text immer offen. Das Verschieben der Fenster Ruckelt sehr sowie das Switchen auf andere Arbeitsplätze.

Woran kann das liegen, dass es zu Rucklern kommt? Was kann ich dagegen unternehmen? Bei meinem MacBookPro habe ich keine Probleme und kann die Fenster hin und herschieben wie ich möchte. Bei dem Thinkpad gestaltet sich dies aber extrem Mühsam.

Ich habe keine Speziellen Treiber installiert. Muss, sollte man das für die neuen APU's von Ryzen? Im ArchWiki wurde ich leider nicht richtig fündig was dies anging oder meistens waren es meines erachtens nach Veraltet Einträge. Da doch vor allem der Offene Radeon Treiber unter Linux extreme fortschritte gemacht hat.

Würde mich über eine Hilfestellung freuen. Auch bin ich mir nicht so sicher, was ich euch an Daten liefern soll um dieses Problem anzugehen / erkennen.

Solved: https://www.computerbase.de/forum/t...-2700u-gpu-performance.1848049/#post-22158984
 
Zuletzt bearbeitet:
Dabei seit
Juli 2008
Beiträge
3.604
#2
Mein Problem zurzeit ist, dass wenn ich unter Linux Antergos mit Gnome 3 Arbeiten möchte es extrem mühsam ist, wenn man viel Text auf dem Bildschirm hat Samsung Ultrawide 34 Zolle 3440x1440 oder Dell 27 2560x1440 wo beide über HDMI angeschlossen sind.
Es ist sehr schwer nachzuvollziehen, was genau nun dein Problem ist.
Fenster ruckeln beim Verschieben?
 
Dabei seit
Juli 2002
Beiträge
2.744
#3
Ist denn AMDGPU bei Deiner Linux-Distro per default installiert?

Antergos Forum
 

surtic

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
1.565
#5
Es ist sehr schwer nachzuvollziehen, was genau nun dein Problem ist.
Fenster ruckeln beim Verschieben?
Ja genau das Verschieben von Fenstern ist extrem Ruckelig oder auch das Switchen auf einen anderen Arbeitsplatz.

Ist denn AMDGPU bei Deiner Linux-Distro per default installiert?

Antergos Forum
Muss ich nachher gleich noch nachschauen. Ich selber habe aber bezüglich Treiber nix Installiert. Ist, denn der Treiber nun nicht direkt im Kernel?

Welchen Kernel verwendest Du? Seit 4.15 ist AMDGPU im Kernel, ab 4.18 ist der auch brauchbar.
Der neuste 4.20
 
Dabei seit
Nov. 2004
Beiträge
8
#7
Hatte ähnliches Problem vor paar Monaten, allerdings Intel-i3 mit GPU.
Damals behoben durch Änderung der KDE-Einstellung (ich benutze KDE):
"Anzeige und Monitor" -> Compositor -> Ausgabemodul: von "OpenGL 2.0/3.1" auf "XRender"
 

surtic

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
1.565
#8
Ist denn AMDGPU bei Deiner Linux-Distro per default installiert?

Antergos Forum
Also so wie ich das sehe hab ich den nicht installiert, dass Packet xf86-video-amdgpu inst nicht installiert. Soll ich, denn über diesen Treiber gehen oder über den vom Kernel / Mesa oder verwechsle ich da was?

das hört sich an, als ob keine 3d beschleunigung aktiv ist und der desktop über die cpu berechnet wird. was sagt denn die ausgabe von "glxinfo"?
glxinfo -B // oder willst du einen anderen Output?
Code:
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD RAVEN (DRM 3.27.0, 4.20.0-arch1-1-ARCH, LLVM 7.0.0) (0x15dd)
    Version: 18.3.1
    Accelerated: yes
    Video memory: 1024MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 4.5
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 734 MB, largest block: 734 MB
    VBO free aux. memory - total: 3058 MB, largest block: 3058 MB
    Texture free memory - total: 734 MB, largest block: 734 MB
    Texture free aux. memory - total: 3058 MB, largest block: 3058 MB
    Renderbuffer free memory - total: 734 MB, largest block: 734 MB
    Renderbuffer free aux. memory - total: 3058 MB, largest block: 3058 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 1024 MB
    Total available memory: 4096 MB
    Currently available dedicated video memory: 734 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RAVEN (DRM 3.27.0, 4.20.0-arch1-1-ARCH, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 18.3.1
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Hatte ähnliches Problem vor paar Monaten, allerdings Intel-i3 mit GPU.
Damals behoben durch Änderung der KDE-Einstellung (ich benutze KDE):
"Anzeige und Monitor" -> Compositor -> Ausgabemodul: von "OpenGL 2.0/3.1" auf "XRender"

Hm bei Gnome habe ich keine solche Option. Muss mal nachschauen ob das irgend wo anders ist.
 

surtic

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
1.565
#11
@Forlorn Ausgeschaltet, neugestartet und leider nichts gebracht.

Das Problem hab ich auch einfach auf dem Normalen Laptop Bildschirm. Oder ist das irgend ein anderes Problem? Ne Art Freesync wo die Hz einstellung des Bildschirms nicht stimmt?
Ergänzung ()

@Forlorn Hm ne ich glaube es hat doch gewirkt. Hab den Laptop an den Bildschirm angeschlossen und viele Fenster mit Text aufgemacht und ich kann die Fenster nun sehr schnell hin und her schieben ohne, dass es zu so eine komischen Stottern Verzögern kommt.
 
Zuletzt bearbeitet:
Top