Probleme mit FPS

marqoxr

Cadet 3rd Year
Registriert
Dez. 2021
Beiträge
51
Hallo, ich war jetzt schon in etlichen Foren unterwegs und beschreibe mein Problem bestimmt jeden Monat 1x. Ich bin jetzt hier um alles komplett genau zu erklären.

Ich habe in jedem Spiel extreme Framespikes, bei welchen die Frametime auch gerne mal auf 70ms springt. Das ganze ist wirklich immer nur sehr kurz und manchmal echt überhaupt nicht stark und manchmal eben stärker.

Außerdem besteht das Problem, wenn die FPS meist von z. B. 150 auf 120 fallen, ist das sofort bemerkbar und fühlt sich sofort extrem schwammig und unruhig an.

Mein PC ist neu, ich hatte ähnliche Probleme auch auf meinem alten PC. Monitore wurden ebenfalls ausgetauscht.

Als erstes würde ich gerne mal mein Setup auflisten:

PC:
  • GeForce RTX 3080 ASUS Strix OC V2
  • AMD Ryzen 9 5900X
  • ASUS ROG Strix X570-E Gaming
  • G.Skill Trident Z NEO 32GB
  • Corsair iCUE H150i RGB PRO XT AiO
  • Lian Li PC-O11 Dynamic

Monitore:
ASUS TUF Gaming VG27AQ (27" 165 Hz | Hauptmonitor)
iiyama G-MASTER Red Eagle GB2760HSU-B1 (27" 144 Hz)
iiyama G-MASTER Red Eagle GB2760HSU-B1 (27" 144 HZ)

Gestern hatte mich ein Kollege angesprochen, ob ich nicht mal Fortnite mit ihm spielen möchte. Bin eigentlich kein Fan von diesem Spiel, aber dachte mir dann halt "okay machen wir mal". In Fortnite fing es dann erst richtig an, ich bekomme diese oben beschriebenen Framespikes mehr als denn je. Ist das normal?

In Minecraft läuft alles perfekt, immer schöne 160 FPS. Wenn ich jetzt allerdings einen Shader rein mache und meine FPS mal auf 130, 110, 80, 150, 140 droppen, fängt es richtig an. Das Spiel sieht extrem abgehakt, unflüssig und wirklich unerträglich aus. Was ich sehr komisch finde, weil Kollegen von mir auch ohne Probleme mit Shader spielen.

Ich erfülle gerade ein ganz schönen Klischee "Für was braucht er diesen PC? Für Fortnite oder Minecraft hä?". So ist es aber nicht. Ich habe diese Spiele mal aufgezählt, weil es dort am schlimmsten ist, natürlich spiele ich auch andere Sachen.

Meine NVIDIA Systemsteuerung-Einstellungen:

G-Sync ON (Vollbildmodus aktivieren)
V-Sync ON

Ich habe V-Sync nur im Treiber aktiviert, da ich oft höre, dass man G-Sync unbedingt mit eingeschaltetem V-Sync benutzen sollte, da sonst Tearing auftreten kann. Und das ist auch der Fall bei mir, wenn ich nur G-Sync an habe, bekomme ich genügend Tearing, da bräuchte ich gar keinen G-Sync Monitor. Das ganze ist nur schön, wenn ich V-Sync zusätzlich an habe.

FPS Limiter ist auch aktiviert, 3 FPS unter der Hz-Zahl, also 162 FPS. Ich habe das ganze auch schon ohne Framelimiter getestet, allerdings die gleichen Probleme. Auch ohne G-Sync wurde schon gespielt, da wird nur noch mehr alles unflüssig, schwammig und in meinem Fall unspielbar.

Ich hoffe, dass ich einen guten Eindruck in mein Problem geben konnte. Ich "kämpfe" mit diesem Problem jetzt leider schon fast zwei Jahre.

Danke, dass ihr euch alles bis hier hin durchgelesen habt. Wirklich ein großes Dank! :)
 
Tritt das auch auf, wenn du nur einen Monitor nutzt? Es gibt immer mal wieder Threads bei denen es zu merkwürdigen Rucklern kommt, wenn man Monitore mit verschiedenen Hz mischt. Als Versuch kannst du auch mal den 165 Hz Monitor mit 144 Hz betreiben.
 
Vielen Dank für die Antwort. Tritt auch mit einem Monitor auf. Habe ich schon öfters getestet. Betreibe den Monitor seit gestern auch erst wieder mit 165 Hz. Die ganze Zeit davor mit 144 Hz. Ich dachte mir nämlich, dass das vielleicht hilft. Trotzdem ein großes Danke. :)
 
FPS-Probleme können an den aktivierten Mitigations in Windows liegen.

Schau mal in der Windowsregistry ob folgende Werte eingetragen sind bevor teures Geld in die Hände genommen wird. Schreib die alten Werte vor Änderung auf. Nach der Abänderung den PC neu starten um es anzuwenden.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"FeatureSettings"=dword:00000000
"FeatureSettingsOverride"=dword:00000003
"FeatureSettingsOverrideMask"=dword:00000003
 
KlausBärbel schrieb:
Schau mal in der Windowsregistry ob folgende Werte eingetragen sind bevor teures Geld in die Hände genommen wird.
Habe mal einen Screenshot gemacht. Einfach ein Rechtsklick auf die drei? Und dann auf "ändern" und bei Wert dann die eintragen, die du zu den drei geschickt hast?
 

Anhänge

  • Screenshot 2022-04-09 124652.png
    Screenshot 2022-04-09 124652.png
    40,7 KB · Aufrufe: 179
Bevor du in der Registry rumspielst, würde ich mich mal informieren was die entsprechenden Registry Keys bewirken. Nicht einfach blind jeder Empfehlung folgen. Nur so am Rande.
Ergänzung ()

PS: Der Tipp kann gut, harmlos oder schlecht sein, will ich gar nicht bewerten. Ist eher grundsätzlich gemeint ;)
 
  • Gefällt mir
Reaktionen: VoAlgdH
Stormfirebird schrieb:
Hast du schon ohne CPPC und CPPC preferred cores getestet?
Muss ehrlich sagen, dass ich davon noch nichts gehört habe und gar nicht weiß, was das genau ist. Kann mir vorstellen, dass das eine BIOS-Einstellung ist?
 
marqoxr schrieb:
dass das eine BIOS-Einstellung ist?
Jop, das sagt dem Betriebssystem welche die besten Kerne sind, allerdings werden die damit teilweiße zu sehr belastet und das kann für Ruckler sorgen. Muss nicht daran liegen, aber probiers aus.
 
Habe das mal eben eigestellt und in den meisten Spielen getestet, allerdings leider keine Änderung. Trotzdem danke!

Ich finde es halt wirklich sehr komisch, dass es sich so sehr schwammig anfühlt, wenn die FPS fallen. Ich meine es geht ja hier nicht um 60 FPS fallen, sondern auch mal um 10 FPS.

Ich habe auch oft gehört, dass es helfen soll, wenn man z. B. die Frames begrenzt, auf die Anzahl, was man immer erreicht. Ändert leider nichts, da ich selbst mit konstanten 100 FPS dann auch Framespikes bekomme. Außerdem fühlen sich diese 100 FPS dann nicht wirklich smooth an.

Und das was am meisten komisch ist, der PC ist ja komplett neu. Ich hatte das gleiche ja bereits bei meinem alten PC.
 
Stormfirebird schrieb:
CPU-Z Screenshots vom memory und SPD Tab mit den belegten Slots bitte
Hier sind die Screenshots. Kann schon sein, dass ich ein bisschen empfindlich bin. Aber nochmal zum Beispiel vom Anfang:
Ich spiele viele Spiele, aber am meisten stört mich, dass z. B. Fortnite und Minecraft mit Shader nicht läuft. Nicht weil ich diese Spiele oft spiele, sondern nur weil ich es extrem komisch finde.
 

Anhänge

  • Screenshot 2022-04-09 140213.png
    Screenshot 2022-04-09 140213.png
    24,9 KB · Aufrufe: 169
  • Screenshot 2022-04-09 140241.png
    Screenshot 2022-04-09 140241.png
    28,8 KB · Aufrufe: 169
  • Screenshot 2022-04-09 140304.png
    Screenshot 2022-04-09 140304.png
    29,1 KB · Aufrufe: 166
  • Screenshot 2022-04-09 140718.png
    Screenshot 2022-04-09 140718.png
    36,6 KB · Aufrufe: 162
Sieht gut aus. Hast du mal explizit geschaut wie die Auslastung der Graka, Takt etc bei der Drops ausschaut?
Was läuft an Software im Hintergrund? Icue oder ähnliches installiert?
 
Muss ich mal genauer im Auge behalten. Icue ist installiert, wegen den Corsair Lüftern im Gehäuse. Ist auch im Hintergrund offen.
 
Den unteren Punkt auf Disabled setzen oder? Bei dem oberen Punkt kann ich nämlich nur zwischen „Enable Firmware TPM“ und „Enable Discrete TPM“ auswählen.

Habe nämlich gerade im Internet gelesen, dass es bei aktiviertem oft bei AMD zu Problemen kommt.
 

Anhänge

  • 58A30F57-2B8B-4173-B80B-3E63DCF08E34.jpeg
    58A30F57-2B8B-4173-B80B-3E63DCF08E34.jpeg
    1,1 MB · Aufrufe: 178
Das obere auf discrete TPM. Da du keines hast sollte es damit deaktiviert sein. Kannst du in Windows überprüfen wenn du tpm.msc aufrufst, bzw. es gibt einen cmd Befehl dafür, aber den müsste ich erst raussuchen.
 
Stormfirebird schrieb:
Das obere auf discrete TPM
Habe ich eingestellt, jetzt wird folgendes unter "tpm.msc" angezeigt.
 

Anhänge

  • Screenshot 2022-04-09 152118.png
    Screenshot 2022-04-09 152118.png
    59,9 KB · Aufrufe: 171
Dann stell ich den unteren Punkt mal auf aus. Den oberen dann trotzdem mal so lassen wie er gerade ist?
 
Zurück
Oben