Ubuntu benutzt den nVidia Treiber nicht

Lobo666

Lieutenant
Dabei seit
Nov. 2008
Beiträge
546
Hallo, ich hoffe ihr könnt mir helfen...

Ich installiere gerade Ubuntu 10.10 an dem alten PC meiner Mutter. In diesem ist eine nVidia Ti4200 mit 64mb verbaut.

Jetzt habe ich mal den aktuellen Linuxtreiber (185) über das Ubuntu Service Center Installiert, aber dieser wird wohl leider nicht verwendet.

Im Menü "Zusätzliche Treiber" steht der Treiber zwar drin und dort steht "Dieser Treiber ist aktiviert und in Benutzung" aber es lassen sich keine visuellen Effekte einstellen (nur um die Treiberfunktion zu testen). Desweiteren sagt das Program Nvidia X Server Settings "You do not apear to be using the Nvidia X driver, please edit your configuration file....".

Ich hab schon gegoogelt, aber bei diversen Youtube Videos wurde nicht darauf hingewiesen, dass man nach der Installation über das Software center noch etwas anderes machen muss.

Könnt ihr bitte einem Linux Einsteiger helfen?
 

rony12

Commodore
Dabei seit
Jan. 2007
Beiträge
4.333
nun... ich kenn mich da jetzt auch nicht aus....

aber zu allerserst unterstützt der treiber garnicht mehr die TI4200 - der letzte ist glaub ich der 97....

hinzukommt, dass ab ubuntu 10.10 die x.org version hochgesetzt wurde, und diese nur von den neuen nvidia treibern supportet wird- da deine karte aber keinen support in den neuen treibern hat, fällt sie raus.

bitte korregieren wenn ich totalen blödsinn schreibe :)

ubuntu 10.04 sollte aber gehen
 

Lobo666

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
546
Hmmm, ich dachte der Softwareservice bietet mir nur Treiber an die auch zu meiner Hardware passen...

Im SS wird auch noch ein Treiber "für ältere nvidia Karten" angeboten. Der heißt "Version 96". Wäre das denn dann der Richtige?
 

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
96e Version wäre zwar richtig, wird aber laut versch. Quelle nicht funktionieren. Verwende also 10.04.
 

Lobo666

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
546
Na gut, das mache ich dann. Wird dieses Problem denn wohl in Zukunft noch gelöst? Dann könnte ich das ja im Auge behalten und später updaten.

Danke für die Hilfe!
 

tcsh

Ensign
Dabei seit
Juni 2010
Beiträge
170
Da gibt es Tricks, damit der nvidia-driver auch mit X-Servern laufen kann, für die er eigentlich nicht gedacht ist, da gibt es extra eine ignoreABI Funktion.
Jedoch ein derart alter Treiber und ein derart neuer X-Server, das wird wohl ein Glückspiel. :freak:

Normalerweise ist diese ignoreABI Funktion zum Beispiel dafür da, wenn der X-Server für den nvidia-driver gerade mal eine Version zu neu ist. Aber das ist ja ein uralt Treiber für eine uralt Grafikkarte.

Vor vielen Jahren musste ich auch mal eine weile den X-Server zu Fuß so starten:
Code:
startx -- -ignoreABI
Mit meiner guten alten Geforce3! :freaky:
 
Zuletzt bearbeitet:

xXNeXoNXx

Lt. Junior Grade
Dabei seit
Mai 2008
Beiträge
455
Ich würde an deiner Stelle einfach den Weg des geringsten Widerstandes wählen und 10.04 installieren. Das ist zum einen eine LTS, also längerer Support und zum anderen wird dir der Unterschied glaube ich gar nicht auffalen.
 

mensch183

Captain
Dabei seit
Jan. 2008
Beiträge
3.666
Deine Mama will vermutlich keine 3D-Anwendungen auf der alten Hardwarecht verwenden. Dann versuche nicht weiter, den uralten, unsupporteten binary-only Treiber von Nvidia auf dem Rechner zum Laufen zu bringen. NVidia unterstützt seine älteren Grafikarten heute nicht mehr - unter Linux genausowenig wie unter Windows.

Nimm den Nouveau-Treiber! Bietet dir Ubuntu den Nouveau-Treiber nicht sowieso als Voreinstellung für deine Grafikarte an? Wenn ich deine Ausführungen richtig verstehe, hast du ja bereits eine funktionierende grafische Oberfläche. Dann gibts keinen Grund mit anderen Treibern rumzumurksen.
 

Lobo666

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
546
Leider stürzten aber z.B. YOutube Videos im Vollbild ohne den nvidia Treiber ab.

Das zweite Problem das ich derzeit habe ist, dass der Installer von 10.04 und 10.10 bei der Installation abstürzt. Bei 10.04 ist die Installation dadurch nicht abgeschlossen und der PC bootet nicht. Bei 10.10 stürzt der Installer zwar auch ab - aber sehr spät. Das System lässt sich danach booten. Leider konnte ich gestern nicht probieren ob es mit der Alternate CD klappt, da der PC nach dem Booten von dieser auf keine Taststureingabe reagiert (scheiß USB Tastatur - und eine PS/2 hatte ich nicht zur Hand).

Deshalb muss ich nun erstmal bei 10.10 bleiben (ohne nvidia Treiber) und anfang nächsten Jahres muss ein neuer PC her.
 

mensch183

Captain
Dabei seit
Jan. 2008
Beiträge
3.666
Leider stürzten aber z.B. YOutube Videos im Vollbild ohne den nvidia Treiber ab.
Was genau stürzt da ab? Der Browser mit dem Flash-Plugin oder der X-Server? Wenns nur der Browser ist, läßt sich das Problem vielleicht lösen.

Eine weitere Alternative wäre der Vesa-Server. Nouveau ist ja noch sehr neu und kräftig in Entwicklung.

Achja:
Hast du mal einen Speichertest oder sowas laufen lassen? Ich verwende kein Ubuntu, wundere mich aber über deine Berichte zu den abstürzenden Installern. Klingt nicht normal. ;)
 
Zuletzt bearbeitet:

Lobo666

Lieutenant
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
546
Das Flash Plugin stürzt ab.

Memtest habe ich nicht laufen lassen, vor allem weil ich ja immer nur recht kurz bei meinen Eltern bin, und Memtest brauch ja ne Menge Zeit. Müsste ich aber vieleicht mal bei Zeiten machen...
 

mensch183

Captain
Dabei seit
Jan. 2008
Beiträge
3.666
Für das abstürzende Flash-Plugin kann der X-Server zu 99.9999% Wahrscheinlichkeit nichts. Behalte den Nouveau-Treiber, wenn es sonst keine Probleme gibt.

zu Flash: Hast die aktuelle Version des Plugins? "about:plugins" in Firefox zeigt die Version. Ich habe kA, welche Version Ubuntu mitliefert. Die wahrscheinliche Lösung für dein Problem findest du hier: http://ubuntu-ky.ubuntuforums.org/showthread.php?p=9962663
Also das File /etc/adobe/mms.cfg anlegen und dort folgendes reinschreiben:
OverrideGPUValidation = 1


Wenns nicht geht, kannst du alternativ mal die "square"-Previews von http://labs.adobe.com/downloads/flashplayer10.html ausprobieren.
 
Zuletzt bearbeitet:
Top