Ubuntu Bootzeit sehr lang

cryeR

Ensign
Dabei seit
Dez. 2006
Beiträge
233
Hallo, habe Ubuntu 10 neu installiert (Netbook-> Atom 1.6Ghz ,5600rpm, 2GB)
Der Startvorgang hat sich jedoch stark erhöht, teilweise 5Minuten.
Wenn ich jedoch ENTER während des schwarzen Bildschirm gedrückt halte (nach grub) leuchtet die Festplattenlampe auf und man hört sie auch rödeln.
Dann ist die Startzeit ca 1 Minute.
Bei Windows verhält es sich ähnlich, das aufhellende Logo mit Ladebalken erscheint nur schleppent ( 2 Sekunden pro Bild) , erst wenn es voll erschienen ist wird auch hier die Festplatte erst aktiv.
Bootzeit bei Windows kann ich jedoch nicht mit gedrückten ENTER beeinflussen , vorher war die Bootzeit unter einer Minute , jetzt sind es ca. 2,5 Minuten.
Habe diesen komischen Bug seit dem ich von Ubuntu 9 auf 10 (komplett neu installation) gewechselt bin.
 
M

MC BigMac

Gast
nutz Netbook Remix, Lubuntu, XFCE Desktop dann sollte der Atom rennen ohne Probleme, Windows zu nutzen ist beim Atom auch nicht immer das beste.
 

Vektor

Lt. Commander
Dabei seit
Nov. 2004
Beiträge
1.622
Installiere mal bitte bootchart und hänge (wenn bei Ubuntu nötig) in der grub.conf an die root zeile init=/sbin/bootchartd an. (oder den Pfad wo bootchartd halt liegt). Dann rebootest du mal (ohne enter) und führst anschliessend als Benutzer den Befehl bootchart (ohne 'd') aus. Das erzeugt ein png im aktuellen Verzeichnis. Daran kann man dann erkennen was so lange braucht. (Kannst das hier auch posten wenn du damit nichts anfangen kannst ;) ).
Und die boot.log (ohne enter, bzw. mit enter) wäre ganz interessant so ist das leider Rätselraten :(

nutz Netbook Remix, Lubuntu, XFCE Desktop dann sollte der Atom rennen ohne Probleme, Windows zu nutzen ist beim Atom auch nicht immer das beste.
Den Tip finde ich nicht optimal. Das Problem ist nicht die Version sondern die Bootzeit "mit/ohne Enter". Das wird auch mit den anderen Versionen nicht anders sein, weil die auch auf 10.04 aufbauen. Und es scheitert ja scheinbar nicht an der Desktopumgebung sondern beim booten des Kernels!
 

cryeR

Ensign
Ersteller dieses Themas
Dabei seit
Dez. 2006
Beiträge
233
bootchart
/.
/etc
/etc/init
/etc/init.d
/etc/init.d/bootchart
/etc/init/bootchart.conf
/lib
/lib/bootchart
/lib/bootchart/collector
/lib/bootchart/gather
/usr
/usr/share
/usr/share/doc
/usr/share/doc/bootchart
/usr/share/doc/bootchart/changelog.Debian.gz
/usr/share/doc/bootchart/copyright
/usr/share/initramfs-tools
/usr/share/initramfs-tools/hooks
/usr/share/initramfs-tools/hooks/bootchart
/usr/share/initramfs-tools/scripts
/usr/share/initramfs-tools/scripts/init-top
/usr/share/initramfs-tools/scripts/init-top/bootchart
/var
/var/log
/var/log/bootchart
grub
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
set saved_entry=${prev_saved_entry}
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z ${boot_once} ]; then
saved_entry=${chosen}
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
fi
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
set locale_dir=($root)/boot/grub/locale
set lang=de
insmod gettext
if [ ${recordfail} = 1 ]; then
set timeout=-1
else
set timeout=2
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Home Edition (on /dev/sda1)" {
insmod fat
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4409-1dfa
drivemap -s (hd0) ${root}
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, mit Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
linux /boot/vmlinuz-2.6.32-21-generic root=UUID=7f9f0839-4afa-40c2-a092-6cb2eae0a77a ro quiet splash
initrd /boot/initrd.img-2.6.32-21-generic

}
menuentry 'Ubuntu, mit Linux 2.6.32-21-generic (Wiederherstellungsmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
echo 'Linux 2.6.32-21-generic wird geladen …'
linux /boot/vmlinuz-2.6.32-21-generic root=UUID=7f9f0839-4afa-40c2-a092-6cb2eae0a77a ro single
echo 'Initiale Ramdisk wird geladen …'
initrd /boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set 7f9f0839-4afa-40c2-a092-6cb2eae0a77a
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
wo füg ich das ein ?
 

enteon

Commander
Dabei seit
Apr. 2009
Beiträge
2.092
nirgends!
wenn das nicht gerade dein eigener PC ausgespuckt hat stimmt das vorne und hinten nicht, da du z.B. komplett andere dateisystem UUIDs hast, also das ellenlange zahlen und buchstaben gewustel.

du musst das was wichtig ist in deine eigene /boot/grub/grub.conf (vorausgesetzt du hast auch grub2) übernehmen. aber auch NUR das.

praktisch wäre es vielleicht noch zu erwähnen was du damit eigentlich erreichen willst. weil irgend etwas, das wohl nicht sowieso schon bei dir steht, erkenne ich nicht. eventuell das 'recordfail'?
 
Zuletzt bearbeitet:

cryeR

Ensign
Ersteller dieses Themas
Dabei seit
Dez. 2006
Beiträge
233
Das Problem hat sich anscheinend nach der Installation von bootchart selbst gelöst.
Vielen Dank !
 
Top