Umstellung auf Windows 11 - Secure Boot Modus scheitert

stau

Lt. Junior Grade
Registriert
Juni 2015
Beiträge
267
Hallo,
Beider Umstellung auf Windows 11meines auf aktuellem Update-Stand befindlichen Rechners fehlt der Secure Boot Modus.
Der Rechner ist im UEFI-Modus. Mein BIOS auf dem Gigabyte-Mainboard Z390 UD stammt von AMI mit Version 2.8.

Im Register Favoriten stand der Secure Boot Modus auf "Customer". Von dort aus soll man andere Variablen einstellen können, ich sehe jedoch keine. Daraufhin habe ich den Modus "Standard" eingestellt. Nach Sichern und Neustart bleibt das Ergebnis jedoch das gleiche. Die Umstellung auf Windows 11 scheitert am fehlenden Secure Boot Modus.

Ich hoffe, dass mir jemand mitteilen kann, wo ich an welcher Schraube drehen kann.
 
Secure Boot ist für win11 nicht erforderlich.

Erforderlich ist, das der UEFI Mode mit GPT genutzt wird und nicht der alte legacy oder CSM Mode mit MBR. Und es ist fTPM (AMD) bzw PTT (Intel) erforderlich.
Und natürlich eine CPU, die von win11 unterstützt wird, ist auch erforderlich.

Ansonsten lass mal unter win10 das Programm WhyNotWin11 drüber laufen, poste davon ein Screenshot und wir können mal gucken, was noch fehlt.
 
  • Gefällt mir
Reaktionen: coasterblog
@stau - ist deine Festplatte verschlüsselt?
 
Vielleicht fehlt ein BIOS-Passwort, ohne das "Secure Boot" (und div. weitere Sicherheitseinstellungen) wenig Sinn macht.
 
Hallo,
Zunächst Danke für die vielen Antworten.

@bisy
Das erstaunt mich, denn es wird ja vin MS gerade darauf hingewiesen, dass Secure Boot aktivert sein muss.
WhyNotWin11 zeigt Ergebnisse, die zum Teil mit meinen BIOS-Einstellungen nicht übereinstimmen.
Der Boot Modus steht auf Legacy, obwohl mir UEFI angezeigt wird.
Secure Boot ist deaktiviert oder nicht erkannt.
TPM2 ist ok
Der Partitionstyp GPT wird nicht erkannt. Ich weiß, dass durch eine Umstllung im Normalall Windows neu installiert wird und damit eine Datenneuinstallation erforderlich würde. Das will ich auf keinen Fall. Da bleibe ich lieber noch 10 Jahre bei Win10.

@cyberpirate
Zusätzlich: Die übrigen UEFI-Einstellungen entsprechen den Erfordernissen, die die PC-Integrationsprüfung verlangt.

@wickedgonewild
Selbstverständlich nicht.

@eCy
Ich habe (noch) kein BIOS-Passwort festgelegt. Wenn ich Dich richtig verstehe, ist das aber nicht der Grund für die Unmöglichkeit der Umstellung.

@floklo4
Deine Screenshots sehen etwas anders aus als bei mir.
Meine BIOS-Version ist 2.8. Du hast 3.1 installiert. Ich hatte, bevor ich mich an die Arbeit herangewagt hatte, schon nach einer Update-Möglichkeit gesucht, aber nicht gefunden. Vielleicht kannst Du mir die nennen?

Ich hatte Secure Boot nicht im Boot-Register gefunden, sondern nur bei den Favoriten. Da will ich gern nochmals nachschauen. Leider überlagert der gelbe Hintergrund die Secure Boot Einstellung.
Im nächsten Screenshot sehe ich die Einstellung User, so wie sie bei mir zuerst auch stand. Bei mir fehlete darunter die wichtige Auswahl von Secure Boot Enabled. Auch da schau ich anschließen noch einmal nach.

Über Eure Antworten würde ich mich freuen.
 
stau schrieb:
Das erstaunt mich, denn es wird ja vin MS gerade darauf hingewiesen, dass Secure Boot aktivert sein muss.
nein das genau sagen sie nicht, Secure Boot ist bei win11 keine Pflicht.
Microsoft weist darauf hin, das TPM/PTT und eine UEFI Installation mit GPT Pflicht ist.

stau schrieb:
Der Boot Modus steht auf Legacy, obwohl mir UEFI angezeigt wird.
Und genau das ist dein Problem, Windows ist bei dir im falschen Modus installiert.
Bei dir ist sicherlich im UEFI bei den Bootoptionen CSM aktiviert.
Windows wurde bei dir im CSM mode mit MBR installiert.
Win11 will aber den UEFI Mode mit GPT.

Und nur im UEFI Mode gibt es dann auch TPM/PTT und Secure Boot.
Der CSM Mode kann das nicht.

Du musst entweder Windows 10/11 gleich richtig mit deaktivierten CSM/Legacy und aktivierten fTPM/PTT und wenn du willst aktivem Secure Boot neu installieren.

Oder du wandelst dein Systemlaufwerk von MBR in GPT um mit dem Windows eigenen Programm mbr2gpt, danach kannst du auch UEFI alles umstellen. (Daten vorher sichern)

Ergänzung ()

stau schrieb:
Meine BIOS-Version ist 2.8.
ein Update auf die aktuellste Version wäre nach dem umwandeln oder vor der neu Installation ratsam
 
Zuletzt bearbeitet:
stau schrieb:
Ich habe (noch) kein BIOS-Passwort festgelegt. Wenn ich Dich richtig verstehe, ist das aber nicht der Grund für die Unmöglichkeit der Umstellung.
öhmm - nicht umgekehrt?

Wenn du Secure Boot aktivierst, aber kein BIOS-Passwort vergeben hast, könnte jeder wieder Secure Boot deaktivieren, so dass die Aktivierung wenig Sinn macht. Vielleicht will dich der BIOS-Hersteller davor bewahren, dich dadurch sicher zu fühlen, ohne dass es so ist.
 
stau schrieb:
obwohl mir UEFI angezeigt wird
ja du hast ein UEFI, aber man kann da Windows im UEFI Mode mit der GPT Partitionstabelle installieren oder man kann Windows im alten CSM/Legacy Mode mit der MBR Partitionstabelle installieren.

Besonders wenn man Windows Systeme von alten PCs auf neue übernimmt, geht da nur der CSM/legacy Mode.
Man muss dann erstmal alles umwandeln oder neu installieren.
 
Hallo Bisy,

Danke für Deine ausführliche Erklärung.
Aber was passiert bei der Umstellung von MBR auf GPT? Ist das einer kompletten Neuinstallation gleichzusetzen, nach der man bei Adam und Eva anfangend die Userprogramme neu aufsetzen muss?
 
stau schrieb:
Ist das einer kompletten Neuinstallation gleichzusetzen
nein, da wird wirklich nur das Datensystem umgewandelt, die Daten darauf bleiben im Normalfall alle erhalten.
aktuell wird bei dir halt die MBR Partitionstabelle genutzt, es wird aber die GPT Partitionstabelle benötigt, und da muss von dem einen auf das andere umgewandelt werden.
https://de.wikipedia.org/wiki/Master_Boot_Record
https://de.wikipedia.org/wiki/GUID_Partition_Table

Für win11 wird halt fürs Systemlaufwerk GPT benötigt und nur wenn wenn man dann im UEFI den UEFI Mode aktiviert, bzw CSM deaktiviert geht auch Secure Boot und fTPM/PTT

stau schrieb:
nach der man bei Adam und Eva anfangend die Userprogramme neu aufsetzen muss?
im Normalfall bleibt da alles so wie es ist und es muss nichts neu installiert werden.

Eine Datensicherung ist aber immer ratsam
Ergänzung ()

https://docs.microsoft.com/de-de/windows/deployment/mbr-to-gpt
 
Ich habe mir jetzt einen Boot-USB Stick mit Acronis Media Builder erstellt.
Dann wollte ich mbr2gpt.exe aus windows\system32 starten. Das gelingt weder normal noch mit der Option "Als Administrator", als der ich angemeldet bin.
Ich bin ein derartiger Laie, dass ich fragen muss, wozu ich einen Boot-Stick benötige, wenn doch mit diesem Minitool ohne Datenverlust auf GPT umgestellt werden kann.
 
Was für einen Bootstick genau? Brauchst Du nicht wenn Du es unter Win machen willst:

MBR2GPT. EXE konvertiert eine Festplatte aus dem Master Boot Record (MBR) in eine GUID-Partitionstabelle (GPT), ohne Daten auf dem Datenträger zu ändern oder zu löschen. Das Programm kann über eine Befehlszeile in Windows Preinstallation Environment (Windows PE) ausgeführt werden, mit der Option /allowFullOS aber auch im vollständigen Windows 10-Betriebssystem (OS).
 
stau schrieb:
Ich habe mir jetzt einen Boot-USB Stick mit Acronis Media Builder erstellt
Warum so?
Laut Video sollst du ein win10 install Stick erstellen und davon booten, das Erstellen des Sticks macht man mit dem win10 Media Creation Tool
 
cyberpirate schrieb:
MBR2GPT. EXE konvertiert eine Festplatte aus dem Master Boot Record (MBR) in eine GUID-Partitionstabelle (GPT), ohne Daten auf dem Datenträger zu ändern oder zu löschen
Ich hab da auch so gemacht ....fuktionierte soweit ohne problem.....nur irgendwie braucht win10 nun ca.30 sekunden windows logo (hdd licht bleibt solange finster) um dann doch in die gänge zu kommen....Ursach unbekannt .....boot alanlyse mit dem windows tool zeigt keine auffälligeiten

Mein xubuntu auf der selben sdd(m2) startet in <5 Sekunden ........wurde aber nachträglich installiet.....win10 kam vom alten rechner
 
Nowareeng schrieb:
Ich hab da auch so gemacht ....fuktionierte soweit ohne problem.....nur irgendwie braucht win10 nun ca.30 sekunden
Den Hinweis nicht beachtet?
Wichtig

Nachdem der Datenträger in den Partitionsstil GPT konvertiert wurde, muss er zum Starten im UEFI-Modus neu konfiguriert werden.
Wenn noch Legacy-Boot aktiviert ist, bzw. beides (und "Legacy first"), dann sucht das BIOS wohl zuerst vergeblich nach einer Legacy-Installation.
 
Zurück
Oben